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About This Guide

®
This guide introduces eiStream Imaging for Windows  and shows 
you how to get started by performing some common tasks.

In this Chapter
Purpose .............................................................................viii

Prerequisites ......................................................................viii

Related Information...........................................................viii

Support .............................................................................. ix



About This Guide
Purpose
This document is written for users of the Imaging for Windows 
application. It provides general information about imaging 
concepts, describes the features of Imaging for Windows, explains 
how to install the software, and shows you how to perform several 
imaging tasks.

This guide is not intended to provide instructions for any 
operating systems, programming languages, Web server, or 
database products. For information about these products, refer to 
the documentation provided with the product.

Prerequisites
To use this product, you need to be familiar with the Microsoft® 
Windows environment. If you are using a printer, a scanner, or a 
TWAIN-compliant device, you should also know how to connect 
and operate it.

If you plan to access documents residing on a WMS Imaging 
Server (1.x) or in a WMS Imaging and Workflow (WMS) 
environment, you should be familiar with navigating document 
databases in those environments.

Related Information
For information about the application and how to perform 
additional tasks, refer to the online help.

The Release Notes (Readme.txt) provide important information 
including last-minute changes to the documentation.

For updated product information and general information about 
Imaging for Windows, visit our Web site at:

www.eiStream.com

Proceed to WMS|Kofile or eiStream WMS. Under products, 
select eiStream Imaging for Windows.
viii
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About This Guide
Support
Should you have questions regarding Imaging for Windows, or 

problems with your system after installation, consult your customer 
support representative.

For technical support, visit our Web site at:

www.eiStream.com

Proceed to WMS|Kofile or eiStream WMS. Under products, 
select eiStream Imaging for Windows, and then click the Support 
link. 

The Support area includes technical bulletins, current 
documentation, and other relevant information. To request a 
patch, send an e-mail to Technical Support.
ix
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Introducing Imaging for Windows®

This chapter discusses basic imaging concepts and describes the 

functions available with Imaging for Windows.

In this Chapter
Basic Imaging Concepts.......................................................2

Imaging for Windows ..........................................................6

Flow ..................................................................................12



Chapter 1
Basic Imaging Concepts
The following section discusses some basic concepts and 
terminology to help you better understand Imaging for 
Windows.

What is Imaging?
Imaging can be described as using computer software to create, 
modify, and process electronic images. Typical imaging operations 
include:

■ Scanning text, photographs, or drawings and saving the results 
in an image file.

■ Displaying images using techniques such as thumbnail 
representations, magnification, rotation, and size to fit.

■ Sending image documents by e-mail or fax.

■ Adding annotations to images.

■ Performing electronic “cleanup” of images to make them easier 
to view.

Types of Images
An image is an electronic representation of a text document, a 
photograph, a line drawing, or other graphical entity. You can 
create an image by scanning a printed page, a photograph, or 
drawing; by saving a fax; or by creating an image with a drawing 
or graphic-design program.

After a page of text is scanned and saved, it takes on the properties 
of an image file, and can no longer be opened with a word 
processor or text editor.
2



Introducing Imaging for Windows®
Image File Formats
Images are saved as image files, which use file name extensions 
such as .tif, .bmp, and .jpg. The extension indicates the format 
used to store the image.

Some formats, such as BMP and JFIF (commonly referred to as 
JPG), contain just one image per file.

Other formats, such as TIFF, are similar to a book; they contain 
one or more pages, and each page holds a single image.
3



Chapter 1
Because image files are standard Windows files, you can use 
Windows commands to perform operations such as:

■ Organizing files into folders

■ Attaching an image file to an e-mail message

■ Copying, renaming, or deleting files

■ Printing or faxing files

Image Documents
An image document is a collection of one or more images that are 
logically related. A simple image document might be a blank 
form, scanned and saved in an image file format.

Another image document could be a collection of faxes, memos, 
and photographs that are scanned to a multi-page image file.
4



Introducing Imaging for Windows®
Image documents can also be found in WMS Imaging Server (1.x) 
and WMS Imaging and Workflow installations. In these 
environments, an image document can be a collection of images 
stored in different multi-page image files, and located on different 
servers. The links to different image files/servers and the 
mechanism for retrieving the images are invisible to the user, who 
sees only a single image document. 
5



Chapter 1
Imaging for Windows
With Imaging for Windows, you can perform a variety of imaging 
operations by making selections from menus or by clicking on tool 
buttons. 

Many options present dialog boxes. If you are not sure about 
which values or properties to set, accept the default values. These 
values were chosen to give satisfactory results in a variety of 
situations. As you experiment with the different options and 
property settings, you can create results that suit your preferences.

Developers can use Imaging’s 
ActiveX controls and COM 
object to write custom 
applications.

Imaging for Windows consists of the Imaging application, the 
Preview applet, ActiveX controls, and a COM object. The 
Imaging application is described in the following section.

Imaging Application
This section briefly describes what you can do with the Imaging 
application. For more detailed information, including how to 
perform specific tasks, refer to the on-line Help while you are 
using the application.

Display Images

The Imaging application reads and displays the following types of 
image files:

Image File Type Extension

TIFF files .tif, .tiff, .jfx

Bitmap Image .bmp

GIF file .gif

Image Bookmark File .ibk

JPG-JFIF file .jpg, .jpe, .jpeg
6



Introducing Imaging for Windows®
You can display a single image in the window, display thumbnail 
views of the images contained in a multi-page image document, 
or display an image page and thumbnails together.

PCX/DCX Document .pcx, .dcx

WIFF Document .wif

XIF Document .xif

Image File Type Extension
7



Chapter 1
Imaging Server Documents

You can save server documents 
to a local or redirected drive, in 
TIFF format.

You can view documents residing on a WMS Imaging Server (1.x) 
or in a WMS Imaging and Workflow environment. To do so, you 
must configure server access during installation. Dialog boxes help 
you navigate between servers and databases, and provide various 
search options to find documents.

Convert Image Files

Using Imaging for Windows, you can save a displayed image in 
one of the following formats:

■ TIFF

■ BMP

■ JPG-JFIF

In some cases, converting from one image format to another 
causes the original image to permanently lose certain attributes. 
For example, saving an LZW compressed image in a JPG-JFIF file 
subjects it to JPEG compression, which may degrade the image 
quality. 

Change Image Display

You can change the image display by zooming to increase or 
decrease the size of the image, by sizing the image for best fit, or 
sizing it to fit the height or width of a window. You can also rotate 
an image left, right, or 180 degrees. Rotating an image is useful if 
you scanned landscape images using a scanner’s sheet feeder, or if 
you fed a stack of documents into the scanner’s document feeder 
backwards (180 degrees from the desired orientation).

Thumbnail images can be made larger to display more detail, or 
smaller to fit more of them in the window. You can also drag and 
drop thumbnails to change the order of pages in the image 
document.
8
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Scan Images

For best results, save scanned 
documents in TIFF format.

You can create image documents by scanning forms, memos, 
pictures, or other paper documents to an image file. 

Imaging for Windows supports TWAIN-compatible devices such 
as scanners and digital cameras.

Annotate Images

You can add a variety of markups to an image by using annotation 
features, and save the annotations with the image. Some types of 
annotations are:

■ Freehand or straight-line markings

■ Highlighter 

■ Hollow and filled rectangles

■ Hollow, filled, and auto polygons

■ Attach-a-note text

■ Text or Text from a file

■ Image to text (OCR)

■ Customizable rubber stamps such as “Received” or an image 
such as your company logo

■ Hyperlinks

■ Initials

Several of these annotations have properties that you can set, such 
as color, line width, and font.

A hyperlink is a special type of annotation that you can link to a 
file, a URL (Uniform Resource Locator) on the World Wide 
Web, or to a page in an image document.
9
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The document Hq.tif is included in the Samples folder of this 
product. This example of an annotated document page includes 
hyperlinks to other pages within the document. Click on text 
within the rectangles drawn on the map to jump to the 
photographs on pages 2 and 3 of the document. Click on the 
designated area of the street address on the map to jump to the 
eiStream home page on the World Wide Web.

When the annotation icon 
appears next to a thumbnail’s 
page number, it means the 
page contains one or more 
annotations.
10



Introducing Imaging for Windows®
Create a Contact Sheet

You can create a contact sheet that contains a thumbnail rendition 
of each page of an image document, similar to a photographic 
contact sheet that displays images of each negative on a roll of film. 
Before you create the contact sheet, you can globally set the 
thumbnail size — larger to display more detail, or smaller, to fit 
more thumbnails onto the contact sheet. Each thumbnail contains 
a hyperlink to its source file and page.

Image Processing

During scanning and faxing, documents can pick up small speckles 
of dust that degrade the image. The Remove Speckles option 
electronically processes the document to remove these.

Using the Straighten Page option, you can straighten an image 
that is crooked in relation to the background page. After you draw 
a reference line on the displayed document, the application rotates 
the image to the correct orientation.

You can specify a portion of the image to crop or let the program 
automatically crop the edges of a displayed image for you.
11



Chapter 1
Flow
Flow is a component of Imaging for Windows. It is designed to 
automatically capture, process, and output information while you 
perform other tasks.

A flow is a set of directions for processing images. You create a 
flow interactively, adding tools to the flow one at a time. When 
you add a tool, you can define settings and choose options for it. 
When you finish building a flow, you save it as a file with a .flo 
extension.

You can run the same .flo file repeatedly, for predictable results, 
or modify it with the Flow Editor. You can also save a flow to run 
on another PC with Imaging for Windows installed. 
12
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Capture
Flow’s tools can capture:

■ Images scanned to your system — you can select the type of 
document to scan, or you can define scanner parameters such 
as resolution, paper size, and color.

■ Fax messages received via a MAPI (Microsoft’s Message 
Application Program Interface) inbox — you define which 
faxes to process, and specify what to do with the fax after it is 
read.

■ Image files from folders on local or redirected drives — Flow 
captures new documents that appear in designated folders. This 
is useful if you have a fax application that places incoming faxes 
into a particular folder, or if you are using WMS Imaging Scan 
Station to create documents in a designated folder.

Process
Flow tools can perform various processes on your captured 
documents: 

■ Convert images to TIFF, BMP, or JPG-JFIF (*.jpg) file formats

■ Apply compression to image files

■ Invoke a user-defined program

■ Perform image enhancement such as Despeckle, Straighten 
Page, Crop, Rotate, and Invert

■ Delete pages from a document

■ Display the image, image thumbnails, or both

■ Prompt a user for input

■ Convert images to text (OCR)

You can define or modify settings and options for these processes 
when you click on a tool in the Flow interface.
13
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Output
You can define or modify settings and options for each output tool 
when you click on the tool in the Flow interface. Flow’s output 
tools let you send documents to several destinations: 

■ A specified folder name and location

■ An outbound fax or e-mail, using a MAPI-compliant mailbox

■ WMS Imaging (1.x) or WMS Imaging and Workflow (WMS) 
servers

■ Microsoft Exchange folders

■ A printer

You can also open a predefined application, or invoke another 
flow as an output task.

Flow routes your documents to a location you specify. Optionally, 
you can have Flow automatically route your documents to a 
destination, based on words found in the document. To use this 
feature, you must first create a word list that associates certain 
words with folders, locations, or recipients, depending on the 
output tool you are using. 

Note: The automatic routing feature is not available for the Run 
Program or Printer output tools.
14
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Installing the Software

This chapter specifies system requirements and describes how to 

install and remove Imaging for Windows®. 

In this Chapter
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Chapter 2
System Requirements
Before you install Imaging for Windows, check to see if your 
system configuration and software meet the following 
requirements.

Hardware
■ Personal Computer based on an Intel Pentium® or equivalent 

processor, 166 Mhz or faster

■ 32 MB of RAM or more for Windows 98
64 MB or more for Windows XP, Windows 2000 and 
Windows NT 4.0

■ A minimum of 30 MB of hard disk space above what is 
required by the operating system that Imaging for Windows is 
being installed on

■ VGA or SVGA monitor

■ VGA controller with 1 MB or more of memory 

■ CD ROM drive (to install the software)

■ TWAIN-compliant device (optional)

■ Fax/modem card (optional)

Software
■ Microsoft Windows XP

Or:

■ Microsoft Windows 2000

Or:

■ Microsoft Windows NT 4.0 (with Service Pack 6a or greater)

Or:

■ Microsoft Windows 98 Second Edition
16



Installing the Software
Installation Overview
When you insert the Installation CD into your computer’s 
CD-ROM drive, the installation program starts automatically and 
displays the Imaging for Windows Installation window. 

Note: If the installation program does not start automatically, 
click the Start button and then click Run. On the Run 
dialog box, enter the drive letter of your CD-ROM drive, a 
colon and backslash, and then install.exe.
For example, if your CD-ROM drive letter is E, enter
E:\install.exe.
17



Chapter 2
You can select from the following options:

Install Imaging for Windows — Installs Imaging for Windows. 
Refer to the section “Installing Imaging for Windows” for 
instructions.

Install Imaging 1.x Server Access— Installs the components 
required to access documents residing on a WMS Imaging Server 
(1.x). Refer to the section “Installing Imaging 1.x Server Access” 
for instructions.

View Release Notes — Opens the Readme.txt file, which 
contains the latest information about Imaging for Windows. It is 
important that you read this file before you install the software.

After you select an installation option, and the software has been 
copied to your system, the Imaging for Windows Installation 
screen reappears. You can select another option or exit the 
installation program.
18
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Installing Imaging for Windows
This section describes how to install Imaging for Windows. If you 
are installing this application under Windows XP, Windows 2000 
or Windows NT, you must be logged on as an administrator.

1 Click Install Imaging for Windows. After a brief 
initialization, the Welcome screen appears.

2 Click Next. The Software License Agreement screen appears.

3 Read the license agreement. If you agree to the terms, click 
Yes to continue. The Choose Destination Location dialog box 
appears. Otherwise, click No to exit the installation procedure.

4 In the Choose Destination Location dialog box, accept the 
default location displayed under Destination Folder and click 
Next.
Or:
Click Browse to display the Choose Folder dialog box. Select 
a folder from the list or type in a new name and then click OK. 
Alternatively, click Network in the Choose Folder dialog box 
to display a list of shared network folders. Select a folder and 
then click OK.

If you typed the name of a folder that does not exist, a 
confirmation dialog box appears. Click Yes to create the 
folder.

The Select Program Folder dialog box appears.

5 Designate a folder where the program icons will be installed. 
Accept the default name (Imaging) or enter the name of a 
different folder. 

6 Click Next. The setup program begins copying files to your 
system while a message box displays the progress.

The Setup Complete dialog box appears.

7 Click Finish to complete the installation and return to the 
Imaging for Windows Installation screen.

Note: If you install a later version of your operating system, you 
must reinstall Imaging for Windows.
19
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Installing Imaging 1.x Server Access
This section describes how to configure access to WMS Imaging 
Server (1.x). Before you continue, obtain the IP address and port 
number of your image domain name server.

1 From the Imaging for Windows Installation screen, click 
Install Imaging 1.x Server Access. After a brief 
initialization, the Welcome screen appears.

2 Click Next. The Imaging 1.x Server Configuration dialog box 
appears.

3 Type the IP address and port number of the image domain 
name server. Use the format:
nnn.nnn.nnn.nnn/pppp
where nnn represents numbers in the IP address of the server 
and pppp is the port number (default is 4010). 

4 Click Next. After the software is copied to your system, the 
Setup Complete dialog box appears.

5 Click Finish. The Imaging for Windows Installation screen 
reappears.

Note: If you cannot see any image databases when you 
search for documents on WMS Imaging Server (1.x), 
check to see if your configuration information is 
correct. Then, verify that a server volume 
configuration file resides on your Imaging server, and 
that it contains the correct entries. The name of this 
file is typically oix.vols for UNIX installations, and 
vols.dat for NT installations.
20
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Uninstalling Imaging Components
You can remove most components of Imaging for Windows in the 
same manner as you remove other applications. In Windows XP, 
Windows 2000 and Windows NT 4.0 environments, you must log 
on as an administrator to uninstall the software.

1 Open the Windows Control Panel by clicking on the Start 
button, and then pointing to Settings, Control Panel.

2 Double-click the Add/Remove Programs icon. The Add/
Remove Programs Properties dialog box appears.

3 Click on the Install/Uninstall tab in Windows NT 4.0 or 
Windows 98 to display a list of currently installed software.

4 Select the Imaging component you want to remove.
■ Imaging for Windows — removes Imaging for Windows. If 

you remove this component, Imaging Server Access will not 
work.

■ Imaging for Windows Server Access — removes Imaging 
Server Access.

5 Click Add/Remove in Windows NT 4.0 or Windows 98, or 
Change/Remove in Windows 2000 or Windows XP. The 
Confirm File Deletion dialog box appears.

6 Click Yes to confirm that you want to remove the program.

Note: On Windows 2000 systems, the uninstall program will 
attempt to reinstall the version of Imaging for Windows 
that came with the operating system. You may see the 
prompt asking for the location of the software. Mount 
your Windows 2000 CD to continue the installation, or 
press Cancel to terminate the process. If you terminate 
the installation, you may be left without an image viewer.
21
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Using the Imaging Application

This chapter guides you through some basic operations with the 

Imaging application. For additional information, refer to the 
on-line Help.

In this Chapter
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Enhancing a Document .....................................................35
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Before You Begin
Before you perform the following exercises, start Imaging for 
Windows:

Although some operations can modify the sample image files 
installed with this program, the original versions of these files are 
available on your installation CD.

Finding an Image Document
You can assign properties — such as Author, Keywords, 
Comments, Title, and Subject — to image documents in TIFF 
format. When you want to find documents on local or redirected 
drives, specify one or more of these properties as search criteria. 
For information about finding documents on Imaging servers, 
refer to Chapter 4.

Setting Properties
Perform the following steps to assign a property to an image 
document.

1 On the File menu, click Open.

2 Navigate to the folder where you installed Imaging for 
Windows. The default location is:
C:\Program Files\Imaging

3 Open the Samples folder.

4 Select the document Frost.tif and then click Open.

5 On the File menu, click Properties. A tabbed dialog box 
appears.

6 Click the Summary tab. The Property fields are displayed (they 
should be blank).

Click the Start button, and then point to Programs, Imaging, 
and Imaging.
24



Using the Imaging Application
This is where you type property values for your image docu-
ments. You may wish to standardize the values you enter so 
that your documents are organized in a more useful way. For 
example, descriptive Keyword entries could be “Invoices”, 
“Deposits”, “Inventory”, and so on. For this exercise, you will 
type an arbitrary value just to see how the procedure works.

7 In the Subject field, type Sample image and then click OK. 
(These fields are not case sensitive; be sure to include the space 
between the two words, however.)

8 On the File menu, click Save to add the property value to the 
document.

9 On the File menu, click Close to close the document.
25
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Finding Specified Properties
The following steps describe how to find image documents that 
have the property value you specified.

1 On the File menu, click Open. The Open dialog box appears.

2 Click the Find button. The Find: Image Files dialog box 
appears.
26



Using the Imaging Application
3 In the Subject field, type Sample image.

4 Type the path to your Imaging folder, and select the Include 
subfolders box. 

5 Click Find Now. The lower pane of the dialog box displays 
the names of documents with the Subject property value 
“Sample image.”

Notice that two documents met the search criteria — the 
document whose Subject property you set, and another sample 
document.
27
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Displaying an Image Document
This section describes how to open an image document, change 
the display attributes, display and resize thumbnails, and create a 
contact sheet.

Opening the Document
1 On the File menu, click Open. The Open dialog box appears.

2 Navigate to the folder where you installed Imaging for 
Windows. The default location is:
C:\Program Files\Imaging

3 Open the Samples folder.

4 Select Chapter1.tif and then click Open. The image of a 
text document appears.

Changing the Display
1 Change the size of the display window in the vertical and 

horizontal directions to suit your preference.

2 On the Zoom menu, choose different options to resize the 
document to fit in the display window. When you change the 
size of the document, its height to width ratio is maintained.

On the Tools menu, click 
Magnifier if you want to 
enlarge only a portion of the 
document page.

a Click Fit to Height to view the full height of the document 
page.

b Click Fit to Width to display the full width of the page.

c Click Best Fit. This is often the optimum setting because it 
displays the entire image in the window. 

d Click Pixel to Pixel. If the entire page does not fit into the 
display window, scroll bars appear along the right side and/
or bottom.

3 On the View menu, click Page and Thumbnails. Thumbnails 
of pages in the document are displayed in a window next to the 
page view. The selected thumbnail has a border around it.
28



Using the Imaging Application
4 Position the pointer over the splitter bar separating the 
Thumbnail and Page windows and picture. When the pointer 
changes shape, hold down the left mouse button and then drag 
the bar left or right to resize each window.
29
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Displaying and Changing Thumbnails
1 On the View menu, click Thumbnails. Only the thumbnails 

are displayed.

2 On the Tools menu, click Options, Thumbnail Size. The 
Thumbnail Size dialog box appears.

3 Place the pointer over the handle in the lower right corner of 
the thumbnail, hold down the left mouse button, and then drag 
the handle diagonally to increase or decrease the size of the 
thumbnail.

4 Click OK to apply the new size to the displayed thumbnails.
30



Using the Imaging Application
Creating a Contact Sheet
1 On the File menu, click Open. The Open dialog box appears.

2 Navigate to the folder where you installed Imaging for 
Windows. The default location is:
C:\Program Files\Imaging

3 Open the Samples folder.

4 Select Chapter1.tif and then click Open. The image of a 
text document appears.

5 On the Tools menu, click Create Contact Sheet. The Create 
Contact Sheet dialog box appears.

6 Type a filename (contact) and location (Samples folder) to 
create the file, and then click Save. 

7 On the File menu, click Open, and then double-click on 
contact.tif to view the file you created. Click on a 
thumbnail to view the original page.

8 Click the Back button  to return to the contact sheet.

You can choose to have your 
contact sheet automatically 
open after you create it. 
On the Tools menu, click 
Options, and then Contact 
Sheet. On the dialog box, select 
the Open contact sheet after 
saving box.
31
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Annotating a Document
This section describes how to add annotations to a document, 
change annotation properties, and save the annotated document.

Applying a Rubber Stamp
1 On the File menu, click Open.

2 Navigate to the folder where you installed Imaging for 
Windows. The default location is:
C:\Program Files\Imaging

3 Click the Samples folder.

4 Select the image document Frost.tif and then click Open. 
The image document appears.

Instead of selecting from the 
menu, you can click on a tool in 
the Annotation toolbar.

Rubber Stamp

5 On the Annotation menu, click Rubber Stamps. The Rubber 
Stamp Properties dialog box appears.
32



Using the Imaging Application
6 In the Stamps list, click Received, and then click the Edit 
button. The Edit Text Rubber Stamp Properties dialog box 
appears.

7 Click the Font button. The Rubber Stamp Font Properties 
dialog box appears.

8 In the Color list, click Red and then click OK three times to 
close each dialog box. The pointer changes to a rubber stamp 
icon.
33
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9 Position the rubber stamp at the top of the document, and then 
press the left mouse button once. The stamp annotation is
applied to the document. You can move the stamp by placing 
the pointer inside the dotted outline, holding down the left 
mouse button, and dragging the stamp to a different location.

10 Click outside of the dotted outline to anchor the stamp.

Adding a Highlight
Keep the document Frost.tif open to apply a highlight 
annotation.

Highlighter
1 On the Annotation menu, click Highlighter. The pointer 

changes to a marker and crosshair.

2 Position the crosshair slightly above and to the left of a 
paragraph you want to highlight. Hold the left mouse button 
down and drag the pointer across and down to the end of the 
paragraph. Release the button to apply the highlight.

Changing Highlight Properties

To change the default prop-
erties for an annotation, right 
click on the tool in the 
Annotation toolbar or check 
the Set As Default pick in the 
Annotation Properties dialog 
box.

1 Place the pointer on the highlight and press the right mouse 
button. The shortcut menu appears.

2 Click Properties. The Highlighter Properties dialog box 
appears.

3 Choose a color, such as light blue, that allows the text to show 
through. Click OK to apply the new color.
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Enhancing a Document
This section shows how to enhance a document page by 
despeckling and straightening it.

Removing Speckles From a Document
1 On the File menu, click Open.

2 Navigate to the folder where you installed Imaging for 
Windows (C:\Program Files\Imaging)
and then click the Samples folder.

3 Select the document Crooked.tif and then click Open. The 
image document appears.
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4 On the Zoom menu, click Best Fit.

5 On the Tools menu, click Remove Speckles. The application 
removes small speckles introduced during the scanning or 
faxing process.

Keep this document open to perform the next task.

Straightening the Page
1 On the Tools menu, click Straighten Page. The Straighten 

Page dialog box appears.

2 Move the dialog box to the side or bottom of the page, so you 
can draw a reference line in the top portion of the page.

3 Create a reference line that is slanted in exactly the same way as 
the text. To do so, position the pointer between two lines of 
text and press the left mouse button. While holding the button 
down, drag the pointer to the right, parallel to the text above 
and below the line. Release the mouse button when the 
reference line you have drawn is positioned correctly. Refer to 
the following screen shot.

4 Click OK in the Straighten Page dialog box. The page rotates 
until the reference line you drew is parallel with the top and 
bottom edges of the window. 
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Finding Imaging Server Documents

This chapter describes how to find documents residing on WMS 

Imaging Server (1.x) or a WMS Imaging and Workflow server.

In this Chapter
Finding Server Documents .................................................38

1.x Documents ..................................................................39

WMS Imaging Documents .................................................44
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Finding Server Documents
Before you begin your document search, start Imaging for 
Windows:

Perform the following steps to access a document residing on a 
WMS Imaging Server (1.x) or in a WMS Imaging and Workflow 
environment.

1 On the File menu, click Find Imaging Server Documents. The 
Find dialog box appears.

2 From the Show list box, select either 1.x Documents or WMS 
Imaging Documents.

Click the Start button, and then point to Programs, 
Imaging, and Imaging.

Note: Depending on your configuration, you may already 
be logged on to a server, or will be prompted to do so 
before proceeding with a search.

Note: The tabs displayed in the Find Image Document 
dialog box are different for 1.x Documents and WMS 
Imaging Documents.
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3 Refer to the sections 1.x Documents or WMS Imaging 
Documents, depending on the type of document you chose.

1.x Documents

You can browse for 1.x 
Documents.
On the File menu, click Open. In 
the Look for list, click 1.x Files 
and Documents.

You can search for 1.x Documents by using the options provided 
on the Name & Location, Date Modified, and Keywords tabs. 
The following procedures describe how to use these options.

Name and Location Tab

Use wildcard characters to 
identify a range of documents, 
or when you cannot remember 
the exact document name.
– An asterisk (*) represents a 
group of characters.
– A question mark (?) 
represents one character in a 
specified position.

This tab contains server and database information.

1 In the Named text box, type a full or partial document name. 
Use wildcard characters if you wish.
Or:
Leave the text box blank to retrieve all documents.
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2 From the Look in list, select a database.
Or:
Type a database name string. The string must include the name 
of the server and the database (refer to sample entry in the 
Find: Image dialog box). 
Or:
Click Browse to open the Browse dialog box, and then 
navigate to a database.

If the search is taking too long, 
click Stop to end the operation. 
The documents found up to 
this point are displayed.

3 Click Find Now to initiate the search. A list of documents 
matching your search criteria is displayed in the lower portion 
of the Find Image Document dialog box.
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To sort a column of data in 
ascending or descending order, 
alternately click on the column 
heading.

Note: Although your search returns a list of all documents 
that meet the specified criteria, you cannot open 
them unless you have access rights.
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Date Modified Tab

This tab enables you to specify date modified criteria for your 
document search. 

1 Click All Documents and then click Find Now.
Or:
Click Find All Documents Modified and then follow the 
remaining steps.

2 Click Between, and then specify a range of dates in which a 
document was modified. 

Or:

Click During the Previous, and specify the number of days or 
months to search back.

3 Click Find Now to initiate the search. A list of documents 
matching your search criteria is returned.
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Keywords Tab

This tab enables you to search for documents using keywords that 
were previously associated with the document. 

1 Type a single keyword into either text box. You can use 
wildcard characters if you wish.
Or:
Type a single keyword into each text box and then choose 
AND or OR. 

■ AND returns documents with both specified keywords.
■ OR returns documents with either specified keyword.

2 Click Find Now to initiate the search. A list of documents 
matching your search criteria is returned.
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WMS Imaging Documents
You can search for WMS Imaging Documents using options 
provided on the Name & Location and Field tabs. The following 
procedures describe how to use these options. 

Name and Location Tab

This tab contains a text box for document name and options to 
specify where to search.

Use the percent (%) wildcard 
character to represent an 
unspecified group of 
characters, and the underscore 
( _ ) to replace
one character in a specified 
position.

1 In the Named text box, type a full or partial document name. 
Use wildcard characters if you wish.
Or:
Leave the text box blank to retrieve all documents.

2 Select either option:
■ Search Domain Only
■ Search Domain and Archive

3 Click Find Now to initiate the search. A list of documents 
matching your search criteria is returned.
44



Finding Imaging Server Documents
Field Tab

This tab enables you to search by specifying Class and Index field 
values.

1 In the Class list box, select the class of documents you wish to 
search.
Or:
Select All Classes. 

2 In the Field Value field, adjacent to an entry in the Index Field, 
type a value. You can specify a complete value or a partial value 
combined with wildcard values (% or _ ). 

To sort a column of data in 
ascending or descending order, 
alternately click on the column 
heading.

3 Click Find Now to initiate the search. A list of documents 
matching your search criteria is returned.
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Creating a Flow

You can create a flow by using the Flow Wizard or the Flow 

Editor. This chapter walks you through each method. For more 
information about running a flow, performing Flow tasks, 
choosing options, and setting properties, refer to the online Help.

In this Chapter
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Before You Begin
Before you perform the following exercises, start Flow:

Using the Flow Wizard
The easiest way to create a flow is by using the Flow Wizard. After 
you provide some basic information in a few dialog boxes, the 
Wizard adds one or more process options, provides default values, 
and creates a flow.

The following procedure describes how to create a flow that scans 
and processes a document, and then saves it to a folder.

1 In the Flow Editor dialog box, click Flow Wizard and then 
click OK. The Create New Flow dialog box appears and 
describes what you can do with the Flow Wizard. 

2 Click Next to continue. The Create New Flow dialog box 
displays Capture From and Output To options.

Click the Start button, and then point to Programs, 
Imaging, and Flow. The Flow Editor dialog box appears.
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3 Under Capture From, click Scanner; under Output To, click 
Folder. Click Next to proceed. The Create New Flow dialog 
box now displays Scan Settings and Options.

If you have a flatbed scanner, 
and are scanning more than 
one page, select the Prompt for 
more pages box.
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4 Under Scan Settings, click Text only from the Original 
Document box, and then select the check box if your scanner 
has an automatic document feeder (ADF).

5 Click Next. The Create New Flow dialog box is updated and 
displays document name and location options.

6 Under Name document, click Name and then type newdoc. 

7 Under Save document in, click Folder to accept the default 
location for the new file. Click Finish to create the flow.

The Flow Editor main window appears, and displays a 
graphical representation of the flow you just created. Notice 
that the Wizard added the processes — Convert File and 
Enhance — that are appropriate to your input and output 
selections.
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8 From the File menu, click Save. The Save As dialog box 
appears. Type a name and location for the flow file.

9 To test your flow, click Run Now on the File menu, and send a 
fax to your inbox.

You can change the behavior of your flow by stopping the 
Flow and using the Flow Editor to change settings. 
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Using the Flow Editor
The Flow Editor gives you more flexibility than the Flow Wizard. 
You create a flow interactively by choosing tools from the 
Capture, Process, and Output menus. As you select each tool, the 
Flow Editor creates a diagram in the upper pane (called the Chart 
pane) of the Flow Editor main window. The lower pane (called 
the Options pane) displays settings for options. 

Use the sample flows, included 
in the Flows folder of this 
application, as a starting point 
for creating your own flows.

The following example creates a flow that captures an unread fax 
from your mailbox, converts and enhances the image, and then 
prints it.

1 In the Flow Editor dialog box, click Empty Flow and then 
click OK. A blank Flow Editor screen appears.

2 On the Capture menu, click Inbox. The Inbox tool appears in 
the Chart pane of the window, while Inbox choices and 
options are displayed in the Options pane.
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3 Accept the default option to delete image after processing.

4 From the Process menu, click Convert File. The Convert File 
tool appears in the Chart pane of the window, and image 
conversion and compression options are displayed in the 
Options pane.

5 Under Convert image to, click TIFF Document; under 
Compress images for, click Good quality and small file size.

6 On the Process menu, click Enhance. The Enhance tool is 
added to the Flow diagram. The Options pane of the window 
contains enhancement options, a list box of selections 
associated with the highlighted option, and thumbnails that 
show how a sample image looks before and after it is enhanced.
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7 Under Enhancement, click the Straighten and Remove Dirt 
Specks check boxes. Set Sensitivity to Medium.

To see how these enhancements affect the Before image, click 
Refresh to display the After image.

8 On the Output menu, click Printer. The Printer tool is added 
to the Flow. Print options are displayed in the Options pane. 
Set the options appropriate for your configuration, or accept 
the default values.
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9 On the File menu, click Save. The Save As dialog box appears. 
Type a name and location for the Flow file.

10 To test your flow, click Run Now on the File menu, and send a 
fax to your inbox.

You can change the behavior of your flow by stopping the 
Flow and using the Flow Editor to change settings. 
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