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Hello and a warm welcome to Melodyne!

Many thanks for purchasing Melodyne and welcome to the program. Melodyne
offers a new, musical and intuitive way of working with audio data that we're
confident you'll enjoy. This user manual explains the individual functions of
Melodyne as well as the underlying concept. Please take the time to read it
through carefully.

You will find the latest news, interesting tips and tricks and useful FAQs on our
web site, www.celemony.com along with background reports from the development
department, tutorials and practical examples. It's well worth a visit!

Our software is constantly being further developed and improved. Please always
make sure that you are working with the latest version of Melodyne. (The
,Updates" function in the ,Help“ menu checks via Internet to see whether or not
a later version exists). You can always find the latest version in the myCelemony
area of our website: www.celemony.com/mycelemony.

If you have any questions concerning Melodyne, first please read the

relevant pages in this handbook and consult our FAQ pages to see whether
we've already answered the same question there: www.celemony.com/faq.

If any questions remain, please contact support@celemony.com and we will be
happy to help you further.

We hope you enjoy working with Melodyne!
All at Celemony
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What is Melodyne?

What is Melodyne?

By and large, Melodyne behaves like an audio sequencer or digital audio
workstation (DAW): you record audio files or load them from the hard disk, arrange
them into tracks, edit them, save the edited project to your hard disk and can then
export individual edited tracks or the main L/R mix of the entire arrangement in
the form of an audio file to your hard disk.

But despite these superficial similarities, Melodyne is very different from such
applications, the reason being this: Melodyne analyses the audio files you record
or load in order to identify key aspects of their musical content. In other words,
instead of simply displaying the audio data in an editing window like conventional
sequencer or editor, Melodyne actually investigates the musical significance of
that data. The upshot, in the case of monophonic audio material, is that Melodyne
is capable of recognizing the notes that have been played or sung, pinpointing the
beginning and end of each note, classifying the nature of the transitions between
individual notes, assessing the rhythmic relationship between notes, and much
else besides: to Melodyne, a vocal track is not simply a succession of digital
sampling values but real music, the aspects of which it recognizes, is capable of
quantifying and — if the word isn’t too fanciful — can be said to understand.

A unique process of analysis and the program’s consequent ability to appreciate
the musical aspects of the material form the foundation upon which an elaborate
structure of editing functions (themselves unique) has been erected. You can, for
example, correct the pitch of out-of-tune notes — whether sung or played — with
a single mouse-click; transpose a melody or instrumental solo into a different key
or register without depriving it of its natural sound character; copy the melody —
and only the melody — of one audio recording to another; increase the intensity of
the vibrato applied to individual syllables, whilst removing altogether any
unwanted wavering of pitch; adjust the volume of individual notes; increase the
playback speed of the recording (without altering the pitch) or reduce it to a
standstill, if you like; lengthen individual notes to give them their correct note
values or alter the tempo of entire passages; refashion creatively the rhythmic
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pattern of recordings and exploit a wealth of possibilities that go way beyond mere
slicing for the creation of new loops With Melodyne Studio, it is even possible to
edit polyphonic material in an extraordinarily flexible and fascinating way. You can
do all this and more with Melodyne — quickly, easily, in a way that imposes
astonishingly modest demands on the resources of your system and (most
importantly) achieve results for the unique sound quality of which Melodyne is
world famous.

This introduction is designed to give you the basic information needed for working
with the program. You will find more detailed and continually updated information
(should you require it) on our web site: www.celemony.com. Please bear in mind,
however, that some of the functions described (such as the time-stretching of
polyphonic audio material) are only available with the studio edition. Here are the
main points of difference between the two programs:

Melodyne cre8 studio

Tracks 8 unlimited

Max resolution 24 bits / 96 kHz  32-bit / 192 kHz
Stereo yes (new) yes

Stretching for polyphonic material no yes

Tip: for your first experiments with Melodyne, we recommend the interactive
‘Experience Tour’, which you can open from the program’s Help menu. In the
Experience Tour, we give you a quick roundup of the most important of Melodyne’s
functions. It's interactive, too, so you can participate and try everything out for
yourself.

To help you hit the ground running, Melodyne comes with an integrated reverb
effect and a small but pleasant sounding software synthesizer called Podolski with
which you can try out the Audio-to-MIDI functions of Melodyne straight away
without further installation. Podolski was kindly provided by Urs Heckmann
(www.u-he.com). Other synthesizers and effects can be used as well, of course.

Please read this introduction through at least once to familiarize yourself with
Melodyne; it would be decidedly annoying (would it not?) to realize too late, when
the production was already in the can, that there was an easier or better way of
doing something than the one you used, and that you could have obtained better
results with far less effort had you known about it.
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What is Melodyne?

Try whatever comes to mind; experiment as much as you like; no harm can come
of it: Melodyne has a multi-level Undo function that allows you to backtrack if the
changes you make don’t turn out the way you want. Besides which, none of the
changes made in the course of editing has the slightest impact upon the original
file on your hard disk.

We begin this Introduction with some quick tips on Installation before getting
down to the nitty-gritty: the key functions of the program.

We hope you will enjoy working with Melodyne and that it will help you to attain
your musical objectives.

Melodyne cre8/studio user manual 9



01 Installation and activation

O1 Installation and activation

01-01 Installation

To install Melodyne, launch the installation program, which either you will find on
your Melodyne CD or you will have downloaded from the Celemony web site (it
may be necessary to unpack the installation program with a double-click). Simply
follow the onscreen instructions for the installation. Once the installation program
has stored the files on the hard disk, you can launch Melodyne with a double-
click.

The Melodyne installation program offers you a number of options because
Melodyne works with various different plug-in interfaces. Not all the possible
components form part of the standard installation. In addition to Melodyne itself
and ReWire support, the Melodyne Bridge plug-ins for the VST, RTAS and AU
interfaces (the last-named only on the Mac) form part of the standard installation.
Support for DXi (PC only) does not form part of the standard installation; please
activate this option by hand if you need it.

Prior to the installation, the installation program checks to see what components
are already installed. You could, for example, install Melodyne on its own and run
it at first without plug-in support. The desired plug-ins or other options can be
added in the course of a second installation without damaging the original
installation or the activation.

Under Windows, a de-installation program is available, which you can use to
uninstall the components you do not need. To do this, proceed as follows:

1. from the Start menu, open the Control Panel;

2. double-click on "Add or Remove Programs";

3. from the list of installed programs, choose Melodyne and click "Remove".

For further information about installation and the files that are stored in the
course of it, consult our FAQ at www.celemony.com/faq.

Note: Melodyne is continuously being improved. During online activation, a check
is made to see whether a later version is available than the version installed.
Afterwards, please check from time to time to see whether a newer version is
available than the one currently installed on your computer. One easy way to do
this is by choosing "Check for Updates" in the Help menu. Alternatively, you can
do this by visiting www.celemony.com/mycelemony. Via Melodyne's Help menu or
the Celemony web site, you can also contact Support or consult our FAQ. If the
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01-02 Melodyne plugin - free or at a bargain price

computer you use for music is not connected to the Internet, here's how to

discover whether or not an update is available for your Melodyne:

- find which version of Melodyne you are using; this is displayed at start-up but
can also be discovered by selecting the "About..." item in the menu;

- visit the download area of the Celemony web site and check to see whether a
newer version is available; all the current versions are listed there; if there is a
newer version, log in to your myCelemony account (see below) and download the
relevant installation program.

01-02 Melodyne plugin - free or at a bargain price
Melodyne plugin is a practical edition of Melodyne that you can use directly from
within your sequencer as a (VST, AU or RTAS) plug-in. In this way, you can correct
vocals quickly and without complications as well as editing other instruments with
the most important Melodyne tools.

As a registered user of Melodyne studio 3, you receive upon request a Melodyne
plugin licence free of charge, whilst as a registered user of cre8, you can purchase
Melodyne plugin at an especially favourable price (see below).

If you are a user of Melodyne studio 3, here's how to obtain and install your free

copy of Melodyne plugin:

- register and activate your copy of Melodyne, if you have not already done so. In
the process, you will create a myCelemony account at www.celemony.com;

- log in to your myCelemony account (www.celemony.com/mycelemony) and
navigate to the options for your registered Melodyne studio 3;

- click the option for requesting the plug-in. The myCelemony server will then
provide you with a serial number and create a new product entry in your
myCelemony account for Melodyne plugin;

- download the latest Melodyne plugin installation program for your platform from
myCelemony (use the download link next to the plug-in's name) and perform the
installation. The plug-in is independent of your Melodyne studio and can if
desired be installed on a different computer. Once the installation is complete,
Melodyne plugin must be activated; to do this, load the plug-in into your host
and follow the onscreen instructions given by the activation assistant.

If you are a user of Melodyne cre8, here's how to obtain your copy of Melodyne

plugin at a bargain price and install it:

- register and activate your copy of Melodyne, if you have not already done so. In
the process, you will create a myCelemony account at www.celemony.com;
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01 Installation and activation

- purchase the Loyalty Offer for Melodyne plugin from your local music dealer or
our Web Shop. You will obtain a serial number for the plug-in;

- log in to your account at myCelemony using a browser and navigate to the
options of your registered Melodyne;

- alongside the corresponding option, enter the serial number of your Melodyne
plugin. The myCelemony server will then create a new product entry for the plug-
in on your myCelemony account;

- download the latest Melodyne plugin installation program for your platform from
myCelemony (use the download link next to the plug-in's name) and perform the
installation. The plug-in is independent of your Melodyne and can if desired be
installed on a different computer. Once the installation is complete, Melodyne
plugin must be activated; to do this, load the plug-in into your host and follow
the onscreen instructions given by the activation assistant.

01-03 Activation and myCelemony

Before you can use Melodyne on your computer, you must register at myCelemony
as a user and activate Melodyne. This procedure usually only takes a few minutes
and need only be performed once.

"Registering" means opening a user account in the myCelemony section of the

Celemony web site. This happens in conjunction with the activation of Melodyne

(see below). You can then access this account from any computer hooked up to

the Internet by entering your user name and password

(www.celemony.com/mycelemony). Your myCelemony account consists of a

customer profile and a hierarchically arranged product display. There you can:

- see all the Celemony products you have activated as well as their activation
status;

- download the latest installation programs for your products as well as the
corresponding updates;

- in some cases, download other Celemony products at a favourable price or else
free of charge;

- choose which type of Celemony newsletter you wish to receive and edit your
other user data.
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01-03 Activation and myCelemony
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"Activation" is the process of authorizing the use of your copy of Melodyne on a

particular computer. You have to activate Melodyne before you can use it for any

length of time. We distinguish three ways of activating Melodyne:

- online activation, whereby Melodyne establishes a direct link with the
myCelemony server and therefore requires your music computer to be hooked up

to the Internet;

- offline activation, which is done by exporting and importing small files, and only
requires you to have access to the Internet from a computer (office, Internet

café, ...);

- iLok, which involves the use of an iLok copy protection dongle from Pace and
requires you to own an iLok dongle and be capable of accessing the Internet

from any computer (office, Internet café,...).

An activation assistant integrated into
Melodyne offers you all the above-mentioned
options and guides you through all the

necessary steps for registration and activation.
The assistant runs automatically the first time
you launch Melodyne and can be opened later

through the 'License' entry in the 'Window'
menu. When you first launch Melodyne after
the installation, you see the Welcome page of
the assistant:

Activation Assistant

Welcome

Welcome to the Melodyne Activation Assistant, which will help you register and
activate your copy of the program.

© 1 would like to activate Melodyne on this computer online or offline and register
with myCelemany (if | have not done so already).

© 1would like to use an iLok dongle. For this purpose, my Melodyne license must
be transferred to my iLok account. If a Melodyne license is already stored on my
iLok dongle, all | have to da is insert it in one of the computer's free USB ports.

(€ Back ) (continue )
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01 Installation and activation

Choose whether you wish to activate the program or transfer a license to your iLok
dongle. Next, click "Continue". If you already have an iLok with a valid Melodyne
license, insert the iLok dongle in a free USB port on your computer to use
Melodyne. As soon as Melodyne finds a valid license on the iLok, the assistant
informs you of this. You can then close the window and work with Melodyne.

01-04 Online or Offline Activation

This makes it possible to activate Melodyne on a particular computer. A single
Melodyne serial number can be activated on a maximum of two computers at the
same time. After selecting this option, click "Continue". The assistant will then
display the activation page, where you must first enter your serial number. You will
find this either in the printed Melodyne User Manual or in the e-mail that
confirmed your purchase from our Web Shop. Now choose whether you wish to
perform the activation online or offline or else activate Melodyne temporarily to
start off with (see below). When you have made your choice, click "Continue".

Online Activation

If you have not yet registered your Melodyne serial number, the assistant will
launch your web browser, find the myCelemony web site and open the customer
profile page. On the Mac, you will be asked in the course of the activation to enter
the administrator password for your computer; under Windows, you must log on to
an administrator account in order to activate Melodyne. This is necessary so that
Melodyne can store the license file from myCelemony in the root area of your
computer.

Note: If you already have a myCelemony account, you do not have to open a
second one (and should avoid doing so, in the interests of clarity). Instead click
the link on the customer profile page that takes you to the Login page for
myCelemony, where you can then log in by entering your user name and password.
This will ensure that your new Melodyne is registered in your existing myCelemony
account.

On the myCelemony customer profile page, enter the requisite data and confirm
by clicking "Continue Activation". On the confirmation page that follows, you will
be requested by myCelemony to return to the activation assistant within Melodyne
where you should click "Continue". Melodyne will then download the activation
data from the myCelemony server and conclude the activation process.
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01-04 Online or Offline Activation

If you have already registered Melodyne and wish to conduct a second or new
activation (for your laptop, for example, or after changing your hard disk), after
entering your serial number, select "Activate Online" and click "Continue".
Melodyne will then communicate automatically with the myCelemony server and
conduct the activation itself.

Offline Activation

Offline activation involves 3 steps:

1. exporting an activation request file from the activation assistant

2. transferring this file to a computer that is capable of connecting to the Internet
and uploading the file to myCelemony

3. downloading the activation file and dragging it to the activation assistant and
dropping it.

If you have opted for offline activation, the "Export request file" page will appear:

Activation Assistant

Export request file

Meladyne serial number:  XKXX-XXXX-KXXX

To activate Melodyne offline, you must first export from Melodyne a request file
containing the necessary data and later import an activation file that will activate
Melodyne with lasting effect on your computer.

Drag the request file from the field below to your hard disk or straight to a portable
storage medium (e.g. a USB flash drive)

Copy the request file with a simple “drag & drop"

Find a computer that is connected to the Internet and visit the myCelemony web site
(www.celemony.com/mycelemony). To register your copy of Melodyne, you must
upload the request file and then download your personal activation file. You will find
detailed instructions as to how to do this at myCelemony.

Simply drag your personal activation file onto any page of this activation assistant.
That completes the activation process.

Export the file by drag 'n' drop to your hard disk and transfer it (for example, using
a USB flash drive) to a computer with Internet access. The request file is a small
HTML file with a local web page that should open your browser when you double-
click on it. If it fails to do so, open the file manually from your browser (the
relevant command should be called "Open Page" or something similar). On the
local web page displayed, you will see a button. Click on this to establish the
connection with myCelemony and transfer the data required for the activation.
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01 Installation and activation

Then enter the necessary data in the customer profile of your new myCelemony
account and confirm your entries by clicking "Continue Activation".

If you already have a myCelemony account, you do not need to open a new one
and doing so will only cause confusion. Instead, click the link on the Customer
Profile page that takes you to the Log In page, and then log in using your existing
user name and password. Your new Melodyne will then be registered to your
existing myCelemony account.

As soon as the data has been transferred to the myCelemony server and processed,
myCelemony will offer you the activation file to download. Clicking the link will
commence the download. Where exactly the downloaded file is stored on your
computer depends upon your browser settings. Please check these, if you cannot
find the file after downloading it.

Take this file to your music computer and launch Melodyne. When the activation
assistant appears, simply drag 'n' drop the activation file into its window. You will be
asked again for the administrator
password of your computer,
whereupon the assistant's status
Melodyne serial numbers  X00CXHOC0X page will appear to confirm that

[ Actvared soundbans | | the activation has been
successful.

Activation Assistant

Melodyne is activated on this computer

Once you see this page, you know the
process of activation has been
concluded. You can now close the
assistant and work with Melodyne
without restriction.

01-05 Temporary Activation

If you cannot decide right away which form of activation to use, Melodyne allows
you time to think about it: after the first installation, you can use the software for
ten days after entering the serial number, which makes it possible to begin work
immediately. Temporary activation is only possible after the first installation of
Melodyne on a computer.
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01-06 iLok Activation

After selecting this option, click "Continue". The assistant will then inform you
that Melodyne has been activated for a period of ten days. You can now close the
assistant and use Melodyne. We recommend, however, that you undertake the
definitive activation as soon as possible. Otherwise, the temporary activation
period is liable to expire at precisely the wrong moment...

01-06 iLok Activation

You can also activate Melodyne using an iLok USB copy-protection dongle manu-
factured by Pace (www.pace.com). When this solution is chosen, your Melodyne
license is transferred to an iLok dongle, making it possible to use the software on a
variety of computers — provided, obviously, Melodyne has been installed on each of
them and you insert the dongle into a USB port each time you wish to run it. This
allows you, in effect, to carry your copy of Melodyne about with you if you work
regularly in a number of different studios. One iLok is capable of storing many
different licenses, including those of other manufacturers, so you do not need a
different dongle for each item of software you have chosen to activate in this way.

To use the iLok activation system, you need:

- an iLok copy protection dongle (which you can purchase from your local music
store; Celemony does not sell iLok dongles);

- to open an iLok account at www.ilock.com (unless you already have one);

- to transfer your Melodyne license to your iLok account (this is done via the
myCelemony website, which the assistant will open for you;

- to transfer your Melodyne license from your iLok account to your iLok dongle
(this is done at www.ilok.com, where you will find the necessary instructions).

Note: if you opt for iLok activation, you will no longer be entitled to a computer-
specific activation from Celemony.

When, from the activation assistant's welcome page, you select "iLok activation
and click on the "Continue" button, a new page opens in the assistant for
requesting an iLok license. First enter your serial number. You will find this either
in the printed Melodyne User Manual or in the e-mail that was sent to you
confirming your purchase from our Web Shop. You can transfer your license to
your iLok account either online from your music computer or offline from another
computer with Internet access. Choose the desired option and click "Continue".
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Requesting the transfer of your iLok license online
Melodyne will launch your Internet browser, open the myCelemony web site and
connect you with the customer profile page.

Note: If you already have a myCelemony account, you do not need to open a
second one and doing so will only cause confusion. Instead click the
corresponding link on the customer profile page in order to reach the login page of
myCelemony. Now log in using your user name and password. This will ensure that
your new Melodyne is registered in your existing myCelemony account.

On the myCelemony customer profile page, enter the necessary data and confirm
your entries by clicking "Continue Activation". This will take you to a page on which
you must enter the name of your iLok account ("iLok User ID"). Make sure you enter
this correctly (the name is case-sensitive) otherwise the license transfer will fail.
Now click the "Transfer" button. The myCelemony server will connect to the server of
www.ilok.com to check whether an account with the name you have entered really
does exist. If so, it will transfer your Melodyne license to this account. Once the
transfer has been initiated, you can close the myCelemony page.

Requesting an iLok license transfer offline

The offline transfer of a license involves two additional steps:

1. exporting a request file from the activation assistant;

2. transferring this file to a computer that is capable of connecting to the Internet
and uploading the data to myCelemony.

When you opt for an offline activation, the first page to appear is the one for
exporting the request file.Export the request file by drag 'n' drop to your hard disk
and transport the file (for example, using a USB flash drive) to a computer that
does have access to the Internet.

The request file is a small HTML file with a local web page that should open your
browser automatically when you double-click on it. If this fails to happen, open the
file manually using the browser's "Open Page" command, or something similar. On the
local web page that is displayed, you will see a button. Click this in order to establish
the connection with myCelemony and transfer the data needed for the activation.

Note: If you already have a myCelemony account, you do not need to open another
account (and to do so with merely cause confusion). Instead click the link on the
Customer Profile page that takes you to the Log In page, and log in using your
user name and password.
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On the Customer Profile page of myCelemony, enter the requisite data and confirm
you entry with a click on "Continue Activation". This will take you to a page where
you must enter the name of your iLok account ("iLok User ID"). Take care to enter
this correctly (it is case-sensitive) otherwise the license transfer will fail. Then
click on the Transfer key. The myCelemony server will then connect to the server at
www.iLok.com to see firstly whether or not an account with the given name exists,
and, if so, to transfer the license to it. Once this transfer is complete, you can
close the myCelemony web site.

Transferring the license from your iLok account to your dongle

Navigate to the iLok web site (www.ilok.com) and log in. Your Melodyne license
should by now be on your account. Following the instructions given on the iLok
site, transfer the license to your iLok dongle. Once the transfer has been
completed, you can close your browser. From now on, simply by inserting the
dongle into a spare USB port, you will be able to activate Melodyne on any
computer you like — provided of course that it meets Melodyne's system
requirements and that Melodyne (the actual program) has first been installed on
it. If not, you must install the application in the normal way; the iLok only holds
the license, not the program itself!

Note that if you are using Melodyne on several different computers, your
preferences (audio driver selection, keyboard shortcuts, program behaviour etc.)
on each computer will be independent. In other words, they are stored on the
computer itself not the iLok dongle. If you've assigned a whole series of keyboard
shortcuts to various functions on one computer and wish to transfer them to
another, you can do this by copying the Preferences file, which you will find at the
following location, to the same location on the target computer:

Mac: /[your user namel/Library/Preferences/Melodyne Preferences

Windows XP: C:\Program Files\Celemony\Melodyne 3.x\Melodyne.pref

Windows Vista: C:\Users\[your user name]\AppData\Roaming\Celemony Software
GmbH\Melodyne.pref

01-07 Activating an MSL title

The activation assistant is also used to activate the sound banks of the Melodyne
Sound Library (MSL) from Celemony. To activate your MSL, please proceed as
follows.
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From the "Window" menu, select "License" to open the activation assistant. You
will see the status page confirming that Melodyne has been successfully activated.
Click the "Activate Sound Bank" button. The sound bank activation page appears
from which you can choose whether you wish to activate an MSL or a Liquid sound
bank (see below). Select the option for MSL and click "Continue". The MSL
activation page will appear. Here you must first enter the serial number of your
MSL title. You will find this in the User Manual of your MSL. Now choose whether
you wish to activate the MSL title online or offline. The rest of the procedure is
similar to the one you used to activate Melodyne itself, so read the passage above
marked "Online Activation" or "Offline Activation" as appropriate.

An MSL activation applies to all the products registered on your myCelemony
account that are capable of reading MSL sound banks. That is why it makes sense
to use a single myCelemony account to register all your Celemony products. The
same applies to offline registration. You cannot, and should not try to, open a new
myCelemony account for an MSL title. The MSL should be registered to the same
account as your copy of Melodyne.

Once the activation is successful, Activation Assistan

the activated MSL title will be Melodyne is activated on this computer

displayed on the status page of Melodyne serial number: | YO0 |

the activation assistant: o coraoare
MSL the voice 1V Lx || KHOCXHHH-KHXX

Double-clicking the entry for an activated sound bank has two possible effects:

- if Melodyne does not yet know where the sound bank is stored, a file select box
opens, which you can use to localize the sound bank;

- if Melodyne already knows where the sound bank is stored, double-clicking
opens the Melody Manager window from which you can access the sound bank's
samples.
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01-08 Activating a Liquid sound bank from Ueberschall
The activation assistant is also used to activate the sound banks of the Liquid
series from Ueberschall. The activation in this case has nothing to do with
myCelemony but is handled by Ueberschall itself. To activate your Liquid sound
bank, please proceed as follows.

From the "Window" menu, select "License" to open the activation assistant. You

will see the status page confirming that Melodyne has been successfully activated.

Click the "Activate Sound Bank" button. From the page that appears, you can

choose whether you wish to activate an MSL or a Liquid sound bank. Select the

option for Liquid and click "Continue". The Liquid activation page appears:

- click the "Add" button to select and register a Liquid sound bank;

- copy the challenge code displayed;

- click the "Web Page" button to access the Ueberschall web site. From there, navi-
gate to the User Area and click the link for the activation of a Liquid sound bank:

- enter your challenge code to obtain the response code for your computer;

- copy the response code into the corresponding field on the assistant page
displayed above.

The activation is now complete and you can close the assistant.

Double-clicking the entry for an activated sound bank has two possible effects:

- if Melodyne does not yet know where the sound bank is stored, a file select box
opens, which you can use to localize the sound bank;

- if Melodyne already knows where the sound bank is stored, double-clicking
opens the Melody Manager window from which you can access the sound bank's
samples.

01-09 Deactivation

If you are selling your computer or no longer wish to use it for making music, you
should deactivate Melodyne. (Obviously this is only possible if Melodyne has been
activated on the computer, not if you are using an iLok to activate it.). Once you
have deactivated Melodyne, your myCelemony account can be credited with a new
activation. Deactivation is performed using the activation assistant. Please note
that you will not be able to launch Melodyne again after the deactivation! You can,
however, get started again with a deactivated computer by activating Melodyne a
second time on it. This assumes that another activation is available on your
myCelemony account
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Online Deactivation

In the case of online deactivation, a new activation is automatically credited to
your myCelemony account. From the "Window" menu, select "License" to open the
activation assistant. You will see the status page confirming that Melodyne has
been successfully activated. Click the "Deactivate Melodyne" button. The
deactivation page appears. Select there the online deactivation option and click
"Continue". Now you must enter the administrator password for your computer and
confirm a security question. After a short pause, a dialog box will inform you that
the deactivation has been successful. When you close this dialog box, you will
automatically quit Melodyne. Your myCelemony account will also automatically be
credited with one activation.

Offline Deactivation

When you select offline deactivation, you must upload the data from a small
HTML credit file from any computer connected to the Internet to myCelemony;
only then can your myCelemony account be credited with an activation credit, so
please do not forget this important step.

From the "Window" menu, select "License" to open the activation assistant. You
will see the status page confirming that Melodyne has been successfully activated.
Click the "Deactivate Melodyne" button. The deactivation page appears. Select
there the offline deactivation option and click "Continue". First you must enter the
administrator password for your computer and confirm a security question. The
page for the export of the credit file will then appear:

The assistant page shown here allows

Activation Assistant you, for example, to drag the credit
Export credit file file directly to a USB flash drive,
Melodme serial umber: | X000H0GOCXA0K | which you can then take to a computer
Melodyne has been successfully deactivated on this computer. The assistant has
already placed the credit file "MelodyneDeactivationCredit.txt" on your desktop. You that does offer Internet access. At the
can however also drag the credit file from this field onto your hard disk or a portable
storage medium (e.g. a USB flash drive) same tl me as the EXpOrt Cred |t page

appears, the file is placed on the
desktop of your computer. It is not

Copy the credit file with a simple "drag & drop"

Find a computer that s connected to the Internet, go to the myCelemony web site absolutely necessary to use the drag
(www.celemony.com/mycelemony) and upload your credit file. You will find detailed ) ;

instructions as to how to do this at myCelemony. lnl drop Optlon, o) donlt Worry If you
lease note: Your account will not be credited with a new activation until you have . .
e e e have accidentally closed the assistant

window. You will in any case find the
credit file you need on the desktop of
o) your computer.

To upload the data and obtain an
activation credit, proceed as follows:
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- transfer the credit file to a computer that has access to the Internet;

- double-click the credit file; this is a small HTLM file with a local web page that
should open your browser when you double-click on it; if it fails to do so, open
the file manually from your browser (the relevant command should be called
"Open Page" or something of that kind). On the local web page displayed, you
will see a button. Click this in order to establish a connection with myCelemony
and upload the data. Once the data has been transferred to the server, you will
be credited with one activation. You will see it indicated beside the relevant
product entry in the overview.

01-10 No Internet?

If you have no access to the Internet, you can request an activation by post from
Celemony. Proceed as described above under "Offline Activation" and export the
request file for the activation. Burn the file onto a CD and sent us the CD. You will
then receive back from us an activation file on CD, which you will then be able to
import exactly as though you had downloaded it from myCelemony. Please do not
forget to send us your address! Our address is:

Celemony Software GmbH

Valleystrasse 25

81371 Munich

Germany

01-11 Background Information on Activation

Celemony has taken pains to make the activation process as simple and as
transparent as possible for users. In the following section, we would like to answer
some of the questions you might perhaps want to put to us.

What does Celemony do with the personal data | had to enter in order to open an
account at myCelemony?

Your data is treated as confidential and is not passed on to any third party. It is
used by Celemony for the management of your myCelemony account as well as
making it possible for us to send you, if you wish, an e-mail newsletter that takes
your nationality into account.

What data is transferred to my myCelemony server in the course of activation?

The data exchanged is the same regardless of whether you opt for online or offline
activation. The following data is transferred to the myCelemony server in the
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course of activation:

- the edition of Melodyne to which the activation relates (i.e. essential, uno,
plugin, cre8 or studio)

- the version number of the software (so that the server can keep you informed
about updates)

- an automatically generated computer serial number — which serves as a
‘fingerprint' to identify your computer (formerly known as a 'User ID'; depending
upon the equipment of the computer, there could be several of these)

- the name of your computer; this is displayed by myCelemony to make it easier
for you to keep track.

The files described above are transferred automatically in the case of online

registration. In the case of offline activation, this is included in the request file to

be uploaded to the myCelemony web page. This is a simple HTML file, the
contents of which can be inspected in any text editor. The contents of the HTML
file are transferred to myCelemony as soon as you establish a connection with the
server using the button in the browser.

What data does the myCelemony server send back for the activation?
myCelemony sends an encoded file back. You receive an activation code that
allows your Melodyne software to run without restriction on your computer. The
contents of this file too can — in the case of offline registration — be opened and
inspected in a text editor. Since it is encoded, however, it contains nothing you
can read.

How long and under what circumstances does the activation on a given computer

remain valid?

The activation for a particular computer is based upon its 'fingerprint', which is

generated for the computer at the time of the activation request and transferred to

the myCelemony server. As long as this 'fingerprint' does not change, the

activation for your software will also remain effective. The 'fingerprint' and

activation are therefore unaffected when:

- you update the operating system or install a new one;

- change hardware components such as your hard disk or monitor (with the
exception of your network card);

- update your Melodyne software (provided it is a free update);

- reinstall your Melodyne software.

What needs to be borne in mind for a successful iLok activation?

If you are using, or wish to use, an iLok from Pace for the activation of Melodyne,
you need to be aware above all of the following points:-
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- once you have opted for iLok activation, you can no longer request any computer-
specific activations from myCelemony. Your iLok, in other words, becomes the
exclusive 'key' affording you access to Melodyne.

- Celemony can accept no liability in the case of loss or damage for a license that
has been transferred to an iLok. Please make sure that your iLok is suitably
insured. You will find information about this, too, at www.ilok.com.

If you have any further questions concerning activation, please consult our FAQ at
www.celemony.com (which you can also access from inside the program using the
Help menu). If you have any problems with the activation, consult our support at
registration@celemony.com. Please contact us if you purchased your Melodyne
second hand, so that we can change the registration for you.

01-12 Choice of audio drivers

Under Mac OS X, Melodyne automatically uses the Core Audio drivers and the
integrated audio hardware of the Mac. If you have connected other audio hardware
to the computer, you can select it using the Preferences dialog

Under Windows,, a small window appears from which you can select a driver. The
default is DirectX, since this audio interface is present in most PCs. DirectX
drivers, however, are seldom optimised for delay-free audio playback. If you have
other audio hardware available that is equipped with ASIO drivers, we recommend
that you use this rather than your DirectX device.

If problems occur, check to see whether a buffer size smaller than the default
functions with your system (if the buffer size is too small, the result may be little
clicks or playback interruptions). Smaller buffers mean less latency and audibly
increase the speed at which Melodyne responds to your actions at the controls.
You will find more information about these setting options in the section dealing
with Preferences.
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Notation
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Quantization Grid
Switch and Selector
R N o | o Al 2ol Activates or de-activa-
' | tes Quantization Grid;
selects quantization
factor / grid size

4 108.0
4[] Autostretch

Zoom Buttons
Increase / decrease the
vertical (y axis) and
horizontal (x axis)
resolution of the
display

Zoom/Scroll Bars
With the scroll bars, you can zoom and move
forwards or backwards in time.
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Locator

left

Time Ruler
The time in bars and
beats or seconds

Editor Display

The Edit pane of a
Melodyne uno
window plotting
Time (x axis) against
Pitch (y axis)

|- Melodyne.mar -

The Tools
Melodyne's tool box
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Notation —

The Stave icon
toggles the Notation
display on and off

Blob

With monophonic
audio material,
Melodyne is capable
of identifying and
displaying the
individual notes
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melody — for the
pitch, refer to the left-
hand margin

Note Ruler

When Scale Snap
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click on the tonic to
identify the tonality
and the [Shift] key
to toggle between
major and minor
modes
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Pitch Snap
The menu for enabling and disabling
the Pitch Snap function
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Melodyne cre8/studio user manual 29



01 What is Melodyne?

and/or saving of arrangements, audio files

[’ " Melodyne Edit Definition View Navigation MIDI Window Help
New Arrangement 28N
Open... 380 -
Open Recent > File menu
Vet N T Commands for the creation, loading
Import Audio File... 380

Insert Empty Tracks... %+

Remove Selected Track #=

Save Arrangement %S

Save Arrangement As... {885

Save Audio... H%E

Save Audio to MIDL...

Revert to Saved
—

and MIDI files as well as for opening the
'Melody Manager' file browser and inser-
ting and removing tracks

Melodyne's multi-level Undo functi-
on, the standard Copy, Cut and
Paste commands, numerous selec-
tion- and Melodyne-specific com-
mands as well as access to the
Correct Pitch and Quantize Time

,,!’, File [ Definiti View  Navigati MIDI  Window Help
Undo Changing Note Pitch 4
Redo {38z
Undo History > .
Revert to Audio File » Edit menu
Cut ®X
Copy #®C
Paste LA
Delete
Paste Special >
Select 2
Edit Pitch >
Edit Formant >
Edit Amplitude >
Edit Notes Time > macros
Edit Note Separations »
Change Tempo (Autostretch) »
Define Tempo >
Variable Tempo Editing Mode  "\C38)
Correct Pitch kP
Quantize Time T
S —
B ' Melodyne File Edit B[ 0 View Navigation MIDI Window Help
—
Correct Detection ¢¥D
Save MDD from Current Edit State S

30

Reset Detection to Melodic Mode
Reset Detection to Percussive Mode
Reset Detection to Polyphonic Mode

Redetect Audio File
Select Detection Parameter Set...

Apply Arrangement Tempo and Tone Scale to all MDDs

©Open MDD Editor...
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Main tool

At the beginning of a In the middle of a note: At the end of a note:
note: alter position (if alter pitch (if the Alt alter length (if the Alt key
the Alt key is held: key is held: in steps of is held: without snapping)
without snapping) a cent instead of a

semitone)

Above / below a note: create a note separation (where none
‘-I-' exists); otherwise, delete (double-click) or move one. If the Alt
key is held, segments can be created or reunited; the latter
presupposes, of course, that they once belonged together.

Pitch tool

At the beginning or middle or a note: At the end of a note: control
double-click quantize pitch to the nearest the pitch transition to the
suitable semitone (blue frame) next note. Double-click:

transistion on or off

'\IN Sub-tools (for pitch modulation — i.e. vibrato — or drift:
These tools are not context-sensitive: double-clicking on a
TI, note removes the vibrato or drift altogether or restores it.

Formant tool

At the beginning or middle of a note: alter At the end of a note: control
formants (bear in mind that this is only formant transition to the
possible if the ‘melodic’ playback algorithm next note

has been selected). Double-click: restore
formant bgams to their original positions
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Amplitude tool

At the beginning and middle of a note: alter At the end of a note: control
amplitude. Double click: mute or else unmute amplitude transition to next
notes (toggle) note

Time tool
At the beginning or middle of a note: alter At the end of a note: alter
position of note (if the Alt key is held: without length (if the Alt key is
snapping). Double-click: quantize to the next held: without snapping)

suitable time unit (silhouette in the blue frame)

Sub-tool: tool to govern the starting speed of notes

Note separation tool

Above / below a note: create a note separation (where

none exists); otherwise, delete (double-click) or move

one. If the Alt key is held, segments can be created or
reunited; the latter presupposes, of course, that they "]E'
once belonged together.

R L
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02 General

Before we begin to examine the editing possibilities of Melodyne, we would like
briefly to discuss the structure of the program as well as making a few preliminary
remarks concerning the user interface and file handling.

Keyboard shortcuts: Melodyne is available for both the PC and the Mac, and the
keyboard shortcuts for both versions are essentially the same. However, where in
this manual, you see the word ‘{Command]’ (i.e. in square brackets), Mac users
should understand this to mean the Apple key and PC users the Ctrl key. There are
no other complications; ‘[Alt]’ means the Alt key and ‘[Shift]’ the Shift key on
both platforms.

The ideal material for working with Melodyne is monophonic (in the sense of
comprising a single unaccompanied melodic line rather than containing chords).
The human voice, obviously, is monophonic, as are all members of the woodwind
and brass families. It is with this type of material that Melodyne offers you the
widest range of editing options.

Percussion instruments of all kinds, drum loops and speech also constitute
suitable material; Melodyne automatically inserts breaks between hits and
syllables, which therefore retain their character even after the material has been
stretched or compressed. You are therefore not confined to melodies but can edit
rhythmic or noise-like material - though not with quite the same degree of freedom
as you can melodic material.

Users of Melodyne studio can also edit material in which multiple notes sound
simultaneously, which (for the sake of brevity) we will call ‘polyphonic’, such as
guitar and piano recordings. Not only can the program be used to stretch,
compress or transpose such material but the results exhibit the unique excellence
(in terms of sound quality) for which Melodyne is famous. Melodyne studio can
even be used to edit tracks on which several musicians are playing simultaneously
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and even complete mixes - no matter how complex the arrangement. This offers
you the ultimate in freedom when arranging or editing audio.

With Melodyne, you can open and edit audio files in the following formats:

— WAV, AIFF, SND or Sound Designer |l (the latter only on the Mac)

— 8- to 24-bit (Melodyne cre8) or to 32-bit (Melodyne studio) resolution sampling
rates of 22.05, 44.1, 48, 88.2 or 96 kHz (Melodyne cre8) and 192 kHz
(Melodyne studio)

— mono or stereo

Melodyne offers two main windows: the Arrange window, in which the tracks are
displayed in a manner similar to that of an audio sequencer, and the Editor, which
opens automatically when you load a single audio file and which is reserved for
the functions that make Melodyne unique. To open the Arrange window, pull down
the Window menu and select Show Arrangement.

[Whenever, incidentally, you have to make a sequence of selections, whether from
menus or dialog boxes, for brevity, we will write the names of the items to be
selected in italics, linking successive items with the symbol ‘>". The procedure for
opening the Editor, for example, is: Window > Show Editor.]
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This is how audio is
displayed in Melodyne

Note that all audio editing in Melodyne is performed in real time and non-
destructively. The standard file type when saving is an arrangement (as is the case
with most sequencers) — the suffix being “.mar”. When you are editing a single
audio file (as if working with a sample editor) and want to save the edited version
as a new audio file, select Save Audio... from the File menu. (If you are still
working on an audio file but want to save it with a view to opening it again later to
continue work, you can of course save the individual file initially as an
arrangement and only later export it). For more information on Melodyne’s export
options, see section 05-07 Saving Audio.
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In the main display, notes are represented by blobs the vertical extent of which is
indicative of their amplitude at each instant; as a result, each blob displays the
amplitude envelope of the note to which it refers (i.e. the way the volume changes
over time). The average pitch of the note over the course of its duration (where
this has been identified) can be discovered by referring to the Note ruler in the
left hand margin — as is intuitively obvious, the higher the vertical position on the
screen, the higher the pitch — whilst the precise pitch at any one point in time is
indicated by the thin continuous line (the ‘Pitch Curve’) threaded through the
blobs. In addition to the blobs, Melodyne is capable of displaying notes on a stave
in the conventional manner: select View > Show Score Notes. or click the stave
icon in the top left-hand corner of the Editor or Arrange window (to the left of the
Bar/Time Ruler) to toggle the display on and off.

Notes can also be el E

displayed in = = .
conventional notation E : I i

After selecting one or multiple blobs, you can delete them (using the delete key,

[DEL] or [BACKSPACE] on the Mac), or else cut or copy them with a view to

pasting them into the same or some other document (you will find all three

commands in the Edit menu). The first of a sequence of notes inserted in this way

will appear at the current cursor position (the cursor being the vertical red line

that moves from left to right across the screen as the audio plays back) with the
others following at the expected intervals.

The copying of blobs from one document to another is realized ‘intelligently’: if
the ‘key snap’ function is activated in the recipient document, the new notes will
adapt to the selected tonality and mode; if the Autostretch box in the Transport
Bar is checked, the blobs will be stretched or squeezed to suit the selected tempo;
if in the original there are minor deviations from the set tempo — a note falls, for
example, a semiquaver (16™ note) before the beat in 4/4 time — these will be
respected when the notes are copied to a different document, provided the
quantization factor in both documents is the same (i.e. 1/4).

If, on the other hand, you want the note in question to fall on the beat, change the
quantization factor (to the right of the Bar/Time Ruler) to 1/16 in the receiving
document prior to pasting. You can, of course, always correct the position of a
pasted note manually — just like that of any other note.
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Melodyne's transport controls doubtless have a familiar look to them, being
identical to those offered by conventional sequencing applications (not to mention
cassette and video recorders!). You can also use the space bar ([Spacel) of your
computer keyboard to pause or resume playback of the entire audio file as well as
[Alt]+[Spacel], if only part of the file has been selected, to play back that part only.
It is also possible to step through the audio recording on the selected track or of
the Editor in either direction hopping from blob to blob as though they were
stepping stones using the left and right arrows ([<-] and [->]) of your computer
keyboard — auditioning (i.e. listening to) each blob as it is selected.

In the Transport panel, in [6) Transport Bar

addition to the Start, Stop, ® Cycle 0001.01.01.000 0001.01.01.000 4 1200
Fast Forward and Rewind g::: ::';u: 20030101000 4 [JAutostretch
buttons, you will see a s K| 4| [N|[0] D | O |pax @

Record button (you can

record directly with

Melodyne) and a Cycle button, which, when depressed, causes Melodyne to loop
between the left and right locators like a conventional sequencer. When depressed
(i.e. in their down position), the transport buttons are gray; when released, white.

You can position the left and right cycle locators by clicking and dragging in the
lower (darker gray) deck of the Bar/Time ruler: either click at the start of the
desired loop and drag the mouse to the right (to mark the end) or click at the end
of the desired loop and drag the mouse pointer to the right (to mark the
beginning).

Melodyne’s Bar / Time ruler

e showing the left and right

locators and the cursor

If no blobs are selected, double-clicking anywhere in the lower deck of the ruler
will cause the left and right locators to move to the beginning and end of the
recording - or rather (to be more precise) to the grid lines just to the left of the
beginning, and right of the end, of it. If blobs are selected, the locators will move
to the beginning and end of the selected notes (without snapping if the Alt key is
held). The locators otherwise always snap to the nearest grid lines, though they
can be moved to intermediate positions if the Alt key is held.

By dragging the gray ‘1’ marker, you can realign the ruler with the audio data: the
ruler will move, in other words, whilst the audio data stays put.
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To position the cursor, click in the upper part of the ruler; to commence playback
from the new cursor position, press the space bar. To combine both operations,
double-click in the upper part of the ruler, and playback will commence
immediately from the new cursor position. By clicking in the top part of the ruler
and dragging the mouse to the left or right, you can scrub through the
arrangement or the file in the Editor in order to scrutinize different parts of it,
freezing the playback on a single cycle of the waveform if you wish so that the
music comes to a complete standstill — an impressive example of the power of
Melodyne's Local Sound Synthesis!

Where only part of the audio file is displayed in the Editor or Arrangement window,
you can see what lies to the right or left of the area displayed, or above or below it,
by holding the [Command] key and dragging the display in the desired direction
using the hand that appears in place of the mouse pointer.

If you hold down the [Alt] key at the same time, the hand becomes a magnifying
glass, and functions as a zoom tool. Melodyne’s zoom tool, however, works
differently to those of other programs:

— to zoom the display horizontally and vertically at the same time, drag the pointer
diagonally towards the top left (to zoom out) or bottom right (to zoom in) of the
Editor

— to zoom either horizontally or vertically (but not both), drag the pointer sideways
(left to zoom out; right to zoom in) or vertically (upwards to zoom out;
downwards to zoom in)

Melodyne also offers you horizontal and vertical scroll bars, which can also be
used to alter the display resolution: drag the middle of the sliders to scroll the
display and the sides of the sliders to zoom in or out. You will see in the slider a
miniaturized representation of the pitches or note positions; material that lies

= outside the pitch range at the selected zoom resolution (or that would do if you
scrolled there) is grayed out.
W The vertical and horizontal Zoom / Scroll sliders
- Drag the centre of the slider to move the

display window and the sides to increase W m

or decrease the display resolution
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03 Loading and editing audio
- the Main tool and Macros

We would now like to show you the basic functions of Melodyne, so you need at
this point to load an audio file; please use the file “vocal.wav”, which you will find
in the “Audio Files” sub-folder of the “Manual” folder. You can, of course, choose
some other file if you prefer, but make sure it is one with a single melodic line,
such as an unaccompanied solo on a monophonic instrument such as a saxophone
or flute or something of that nature, as it is upon this type of material that
Melodyne’'s editing functions can most usefully be demonstrated.

’ @ Melodyne I8 Edit Definition View Navigation MIDI Window Help

New Arrangement BN

Open... ' ®O

Open Recent >

Melody Manager... g 4]

Import Audio File... {4380

Insert Empty Tracks... H+ P

Open an audio file with “Open”

Remove Selected Track L or “Import Audio File”
Save Arrangement E

Save Arrangement As... {35

Save Audio... #®E

Save Audio to MIDI...

Close Arrangement 3w

T —

03-01 Analysis and note blobs

Once you have selected a file from the Open dialog and clicked OK, Melodyne will
open and analyze the file. This analysis is a background process that is essential
to the unique editing functions offered by Melodyne; loading a small file into a
fast computer, you may scarcely be aware that it is taking place, but if the
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necessary processing requires more time, a progress bar (a rectangle that is
gradually filled, from left to right, with the system highlight color as the operation
proceeds) will appear to give you some idea of how long the process can be
expected to take.

Melodyne stores the analysis data in a separate analysis file in the same folder as
the source file and with the same name (except that the
filename extension is “.mdd"”); this obviates the need for
Melodyne to analyze the file a second time when you reload it
the next day. Melodyne creates an analysis file for each new
audio file you load. (For more detailed information about MDD

MDD files and their editing for the purposes of analysis correction,
see section 05-03 The Analysis and playback of audio by

Melodyne)

audio.wav.mdd

Once the process of analysis is complete, the Editor opens, replete with
Melodyne’s famous blobs displaying the exact pitch center and amplitude
envelope of each note. You can now begin editing the file. If the material loaded is
purely melodic, the blobs will be displayed in the Editor at various heights
depending upon their pitch, which you can read from the Note ruler in the left-
hand margin. If, on the other hand, the material has been identified as
noise/percussive or polyphonic, the blobs will be displayed at the same height, in
the same way as notes of the same pitch are displayed.

To load additional files into the same arrangement, select File > Import Audio File
(the Arrangement window opens with the imported file now displayed on the next
free track). Incidentally, any time you wish to open the arrangement window from
the editor, either select Window > Show Arrangement or use the shortcut:
[Command]+[Shift]+[Al.

03-02 Editing pitch

Move the mouse pointer in the Editor to the center of one of the blobs. You will
notice that the appearance of the pointer changes as it transforms into the Edit
Pitch tool: click on a blob and drag it to the rectangle above; when you release the
mouse button, you will find that you have raised the pitch of the note one
semitone, as effortlessly as if the note were MIDI and you were using a sequencer.
Using this drag ‘n’ drop method, you can transpose notes upwards or downwards
by any number of semitones. Melodyne’s scrub mode is activated as you are
moving the note, which means that if you move the tool to the right or left as you
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In the left hand margin, you can see
the names of the notes

are dragging a note, you can hear the waveform at the points
through which it passes. [If you find this distracting, select
Edit > Preferences > Other and uncheck Monitor Note Pitch
on Editing.]

You aren’t, of course, obliged to move notes one at a time:
you can select an entire phrase and transpose it upwards or
downwards in the same way by rubber-banding multiple
notes or holding the Shift key as you select them. When you
then move one of the blobs, all the others follow the
movement.

If you click in the center of a blob,
you can drag it any number of semitones up or down

Tip: when you have loaded a really long file, the blobs may

be too small to be easily manipulated; in this case, click on

the horizontal and vertical zoom icons in the bottom right-

hand corner of the screen to increase the display resolution.

Another way of zooming the display is to hold the

[Command] and [ALT] keys and drag the pointer —which has now taken on the
aspect of a magnifying glass— upwards (to decrease the vertical resolution),
downwards (to increase the vertical resolution), to the left (to decrease the
horizontal resolution) or to the right (to increase the horizontal resolution).

When you transpose a note or series of notes over some interval larger than a
semitone — a fifth, say — you will notice that the characteristic timbre of the
source, be it a voice or instrument, is preserved: instead of the dreaded
‘Chipmunk’ or ‘Darth Vader’ effects of conventional transposition tools, you get
something that sounds remarkably similar to the same voice singing, or the same
instrument playing, in a different register.
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If you are familiar with the acoustic principles at work here, you will have guessed
why this is so: when it transposes the sound of a voice or instrument, Melodyne
leaves the formants (its acoustic fingerprint, if you like) where they are, thereby
obtaining a far more realistic effect than conventional pitch shifters, which simply
increase or decrease the frequency of the entire waveform, moving the formants
into the bargain.

Note: it can happen on rare occasions that the sound characteristics of a
recording prevent Melodyne correctly identifying the intended pitch of a note,
usually confusing it with the same note an octave higher or lower. You cannot hear
the error, of course; Melodyne hasn’t changed the sound of your audio yet in any
way. We are talking simply about the way it is displayed. In such cases, there is an
easy way of ensuring that Melodyne identifies and displays the note correctly in
future; but we will come to it later.

Melodyne's blobs indicate the exact pitch of each note. Not the intended pitch but
the actual pitch. This means that if notes are not precisely in tune, as if often the
case when the sound source is the human voice or one of those instruments (such
as the violin) that are not always easy to play precisely in tune, you will notice that
the blobs are often some way from the dead center of the shaded horizontal ‘lanes’
that calibrate the display. If, for example, instead of a G, you sing or play a note
halfway in pitch between G and G#, that is precisely where Melodyne will display
it: on the line between G and G#.

.JI', J(AL
. U This note can’t seem to decide
i whether it's an A# or a B

If you want to correct the pitch of such a note manually (and here, we are talking
about changing the sound of the note, not simply the way it is displayed), you
have to hold the [Alt] key and drag it to the center of the desired lane (G). This is
Melodyne’s manual fine-tuning function, which allows you to move notes through
intervals smaller than a tone (called ‘microtrones’ or ‘fractional tones’). If you were
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to do the same thing without holding the [Alt] key, the note would move through
an entire semitone, which in this case is obviously no good; (instead of being on
the borderline between G and G#, it would end up on the border between G and
Gh!).

So, to recap: if the note is in tune but just happens to be the wrong note, such as
when you play an F instead of an E on the piano, all you do is click and drag with
the Edit Pitch tool. If, on the other hand, the note is out of tune (i.e. it falls
between two notes), you must hold the [Alt] key and drag it carefully to the center
of the desired lane. This is how you correct wrong, or out of tune, notes manually
using Melodyne. Easy, isn't it? But don't go away, because it's about to get even
easier...

03-03 Automatic pitch correction

Melodyne can correct pitch automatically! You can, for example, correct the
intonation of an entire track in seconds; causing every note that was slightly out
of tune to ‘snap’ to the correct pitch, or, if you prefer, closer to the correct pitch.
Here’s how: commence playback (so that you can hear what happens), click
somewhere in the background of the Editor (to deselect all notes) and choose
Edit > Correct Pitch.

Correct Pitch

Correct Pitch Center

T 100% ==

@

The Correct Pitch dialog
Correct Pitch Drift opens, displaying two slider

@ 100 % % controls (or ‘trackbars’)

@
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The upper trackbar is used to specify the extent to which the ‘pitch center’ of
errant notes — in the case of a note to which vibrato has been applied, this would
be the axis about which the oscillation occurs — should be moved closer to what
is assumed to be the intended pitch. The default setting (100%), you will observe,
leaves all blobs bang in the center of their various lanes, whilst more moderate
settings improve the intonation without imposing what might seem an overly
‘mechanical’ perfection. Move the slider and experiment until you find the
balance that feels most satisfying musically.

Melodyne makes an important distinction between vibrato, which is usually
intentional, and drift, which is not. When a string player or classical guitarist, for
example, shakes his left wrist whilst playing, he does so in order to impart vibrato
(a rapid fluctuation in the pitch of the note that gives the sound greater fullness
and vibrancy). When Melodyne corrects the pitch of out-of-tune notes, therefore, it
is careful to do so without removing the vibrato, which is an important element of
musical expression.

When singers drift out of tune on long notes, on the other hand, this is seldom
intentional but usually the result of poor breathing technique or inattention. For
this reason, Melodyne offers you the possibility of correcting any unintentional
drifting from the correct pitch without removing the vibrato. (You can, of course,
remove the vibrato too, if you wish, or tone it down, but we will deal with that
later.)

Pitch drift covers the case not only of singers (or instrumentalists) gradually going
sharp or flat on long notes but also of performers with a tendency to err in both
directions in the course of a single note. “How is this different from vibrato?”, you
might ask. The answer is that vibrato is rapid — good orchestral violinists favor a
rate of around 6 or 7 Hz — and cyclical, whereas the type of aimless wandering
Melodyne’s Correct Pitch Drift function is designed to eliminate is far slower and
irregular in terms of frequency and amplitude.

With the 100% setting, the axis of
each blob lies perfectly in the
centre of the lane
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The two pitch correction parameters, Correct Pitch Center and Correct Pitch Drift,
are completely independent: i.e. you can set a different intensity (from 0-100%)
for each parameter. If and when you are satisfied with the results, exit with OK; if,
on the other hand, you would prefer to leave things as they were before you
opened the Correct Pitch dialog, exit with Cancel.

Note: if no notes are selected at the time you open the Correct Pitch dialog,
Melodyne understands you to mean ‘correct the pitch of all the notes’ — otherwise
your action in opening the dialog would be pointless; if, on the other hand, one or
more notes are selected, they and only they will be affected by whatever changes
you make. This applies to the Editor and the Arrangement window. As well as
selecting notes by rubber-banding them (as described above), you can use the
Select submenu to select only the notes between the two locators (Edit >

Select > Select Notes between Locators), only those notes not currently selected
(... > Invert Selection) or only notes of the same pitch as the note selected

(... > Select Same Notes), and so on.

03-04 Pitch Snap

Now that you know how notes can be moved semitone-wise manually as well as
fine-tuned or (if you prefer) corrected in pitch automatically and freed from
unwanted pitch drift, we would like to show you a practical help function for the
editing of pitch: the Pitch Snap function. Look for a moment at the left hand side
of the editing area or (to be precise) the lower edge of the window. The snapping
of note blobs in the editor to the nearest semitone can be disabled in the same
way that you can disable snapping to the vertical (time) grid lines. There is,
therefore, a menu at the bottom left of the note ruler offering the options No Pitch
Snap, Note Snap and Scale Snap.

A C#
= The menu for enabling
and disabling the Pitch -
Snap function
Monew | 4 r B
No Pitch Snap
Note Snap L.; A The Scale Snap function
Scale 5 is now active and the
R = Note ruler can be used to
No Pitch Snap F select the tonality and
Note Snap . the mode
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When you activate the Scale Snap function, the vertical list of notes in the left-
hand margin (which we call the ‘Note ruler’) lights up to indicate that the function
is active and Melodyne displays the key identified in the course of its analysis.

If the key is F# minor, we describe F# as the ‘tonality’ and ‘minor’ as the mode; to
select the key of F# minor, click F# (to select the tonality); then [Shift]-click to
select the mode — you will notice that repeatedly [Shift]-clicking toggles between
the major and minor modes. The difference would be important, say, in the case
of a note closer to A# than to B: in F# minor, it would snap to the B; in F# major,
to the A#.

Besides being useful for the correction of wayward intonation, the Key Snap
function can be used to change the mode of a melody — from major to minor or
minor to major — as well as for the generation of harmonies: to double the melody
at the third or tenth, for example — a harmonic technique known as the
‘thickened line’ — you would simply make a copy of the part, activate the key
snap function (remembering to set the correct key) and then drag the new part up
a third. Without the Key Snap function, this wouldn’t work properly, as you would
either have major thirds the whole time or minor thirds the whole time, whereas
the musical effect you are aiming for requires the superposition of major thirds on
certain degrees of the scale [in the major: the tonic, subdominant and dominant]
and minor thirds on the rest.

Note: It is possible to select other modes besides the major and minor as well as
define modes of your own (see Section 05-04).

Now that you have mastered the basic pitch editing functions of Melodyne, it
should be pointed out that these only work as described for monophonic audio
material (we're talking here about the number of parts not the number of
speakers); with monophonic material, there are no chords, so if more than one
performer is involved, they are by definition singing or playing in unison. The
problem with material composed of two or more parts is that Melodyne has no way
of isolating the individual notes that make up each chord, in the case of
homophonic material, or, in the case polyphonic material, of assigning notes
correctly to the various parts; so the set of functions available for editing the pitch
are rather more limited.

Before we move on to consider Melodyne’s other tools for the editing of pitch, we
will briefly introduce you to a number of other fundamental and no less
fascinating functions: this time for editing the tempo and timing of audio
recordings.
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03-05 Any tempo you like

We turn now to the general playback tempo of the audio file: in Melodyne, this is
variable — a fact that will hardly astound you in the light of what you have seen
already. The sound quality that Melodyne is able to achieve whilst implementing
the most extreme degrees of time-compression and —stretching does, however,
astound even hard-bitten audio professionals and further vindicates the
technological approach adopted by Celemony.

In the Transport Window (which you can open from the Window menu or else using
the shortcut [Shiftl+[Command]+[T]), you will find Melodyne’s tempo parameter.

8] Transport Bar

™ cyele 0001.01.01.000 4 120.0
Civunchin oo030101000 ©0001.01.01.000 -,

] Punch Out

B[ e[ w]n|][O] D> [0 |0« 120.0
| Autostretr

In the course of its analysis of the recording, Melodyne seeks to identify not only
the pitch of each note but also the rhythm and tempo of the music; when the
analysis and loading of the first audio file is complete, Melodyne’s tempo
parameter will very often be correct; in the event, however, that further
adjustments are needed, they are easily made.

The tempo displayed here is incorrect

As you can see from the Bar/Time ruler, Melodyne has not interpreted the rhythm
of the loop correctly, and as a result it appears to extend over two and a half bars
instead of only two. Never mind; in Melodyne such things are fixed easily and
intuitively. First make sure that Autostretch checkbox is not selected in the
Transport Bar.
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Now click on the Tempo box and drag the pointer in the vertical plane; you will
notice that the calibration of the Bar/Time ruler as well as the chequered pattern
of the background display in the Editor expands and contracts depending upon
whether you drag the mouse upwards or downwards. The “1” marker serves as a
point of reference. What we need to do in this case is alter the tempo so that the
grid lines will match the audio data.

Kl :

Now the bar/time ruler indicates the true length of the loop

What we have just done, it should be noted, has nothing whatever to do with time-
stretching: we haven’t yet changed the tempo of the loop; all we have done is
correct Melodyne’s reading of the tempo, so that the display now matches the
data. Having performed that task (which, as we have remarked, is seldom
necessary, as Melodyne usually gets the tempo right automatically), we can
proceed, if we wish, to the actual business of time-stretching. To switch to time-
stretching mode, check the Autostretch box.

120.0 bpm
o Transport Bar
8o 0001.01.01.000 1 120.0 bpm
“ U meioime 00010101000 5 gl !Amnﬁtrﬂt.‘h
Bk @ [®[H][0] b [0 |gwo:
“lcick )

The Autostretch box

Now, as you increase or decrease the indicated tempo, the extent and position of
the notes moves along with the grid and you can hear the playback tempo
changing. This makes it possible to use Melodyne as a simple tool for modifying
the tempo (and therefore the length) of samples and loops: just load the file;
stretch or contract it to arrive at the desired tempo (or length) and export the
edited version using the Save Audio... command; the tempo of the saved file will
be the tempo displayed in the Tempo pane at the moment the file was saved.
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If you alter the tempo whilst the Autostretch box is checked, the tempo of the
audio itself will be altered. If, on the other hand, the Autostretch box is cleared,
the only effect will be upon the alignment of the background display. If you paste
blobs from another document whilst the Autostretch box is checked, their tempo
will be adjusted to that of the current arrangement. The same applies to already
detected audio files inserted by drag ‘n’ drop. New files loaded into the
arrangement with /mport Audio file... initially have their original tempo.

03-06 Editing timing
Melodyne allows you to adjust not only the overall tempo but also the timing (i.e.
the position and length) of individual notes.

Since Melodyne allows you to modify the pitch of individual notes, it must
obviously know where one note ends and the next begins. If the Arrow tool is
selected in Melodyne’s Editor or Always Show Note Separations is checked in the
View menu, this information is displayed in the form of thin vertical lines.

You may have noticed when you were editing the pitch of notes that the
appearance of the Main tool (an arrow in most areas of the screen) changes as it
approaches and passes over a blob: in the center of a note, it takes the form of the
Edit Pitch tool, whereas when you move it to the beginning or end of a note, it
changes shape again to become the Edit Time tool.

By clicking with this tool at the beginning of a note and dragging the pointer to
the right or left, you can move the beginning of that note, with the result that as
the note is lengthened, the one that precedes it is shortened, and by the same
amount.

One use for this type of function, obviously, is tidying up the timing of sloppy
performances; hesitation attributable to memory lapses or defective technique can
be removed from recordings simply by lengthening or shortening notes as
appropriate.
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f The thin vertical lines indicate
| the boundaries between notes

We move the beginning of a note
to the left...

... or to the right; the lengths of
the two notes are complementary:
shorten the one and you lengthen
the other

Being able to stretch and squeeze notes at will has creative implications as well:
you can make either minor or radical changes to the rhythm simply by cutting and
deleting here, compressing there, and filling the resulting gaps by pasting from
the clipboard or stretching the notes on either side. With commands like Cut,
Copy, Delete and Paste in the Edit menu, and the standard shortcuts used by word
processors, Melodyne makes audio files as easy to edit as text.

As you will doubtless have noticed in the course of your own experiments, the
default behavior of the program is to quantize note lengths: in other words, the
Edit Time tool normally increases or decreases note lengths in a series of discrete
steps rather than continuously. The minimum amount by which you can increase
or decrease the length of a note depends inter alia upon the display resolution: a
quarter of the distance between the grid lines if the resolution is reasonably high;
less if the display is more cramped. Since the grid lines are generally spaced at
crotchet (quarter-note) intervals, this means you can normally only increase or
decrease the length of notes by so many semiquavers (sixteenth notes) at a time;
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if you need still higher sensitivity, you can reduce the quantize factor (increasing
the density of the mesh) or override the quantization altogether by holding down
the [Alt] key in the normal way.

With a switch in the upper right-hand corner of the editing area, you can change

or deactivate the grid. You can also deactivate the grid temporarily by holding the
Alt key.

Clicking on this

button toggles the
quantization on = v 1/4
and off 14T
1/BT
e To ch. th tizati
o change the quantization
;:;g o factor (as indi?ated !Jy the
mesh of the grid), click and
17327 | hold (or drag) this button to
Seconds | gpen the Quantization list box

To change the quantization factor (as indicated by the mesh of the grid), click and
hold (or drag) this button to open the Quantization list box

Note that what is happening here is that the quantization factor is determining the
amount you can add to, or subtract from, the length of a note; this is not the same
thing as saying that note endings must coincide with, or lie a specific distance
from, grid lines. If the blobs are adrift from the grid lines to begin with, they will
remain adrift, unless and until you decide to fine-tune their position by [Alt]-
dragging them to the appropriate grid line.

Note: the grid is zoom dependent, in the sense that as you zoom the display
outwards, a point may be reached at which it is no longer possible to display the
quantization factor selected. If you zoom right, the effective grid could have up to
four times the resolution of the grid displayed.
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03-07 Note separators

When you move the Arrow tool to a note separation, it changes shape to become
the Note Separation tool. You can use this to move the boundary between notes
freely to the right or left; by ‘freely’, | mean ‘independently of the current
quantization factor’; the boundary does not, in other words, snap to the nearest
grid line.

The Arrow also becomes the Note Separation tool, when you place it just above or
below a note; if you now double-click, the note will be split at that point and a
new note separator created. This in itself will make no difference to the sound, but
allows you, for example, to change the pitch of the first part of the note (the part
to the left of the newly created separator) without changing that of the second
part, or vice versa. Suppose, for example, you wish to introduce an échappée or a
cambiata (or any other ornament for that matter) that isn’t contained in the
original performance.

The note to be split

Now split the note (we’ll say it's a minim) with the Note Separation tool to create
two crotchets (quarter notes). The note that follows is a major second lower, so the
melodic tendency is downward.

A ] The original minim has
AMATANINE been split into two

W v U \'l_ crotchets
i ]

Now you can drag the second half in the middle with the Edit Pitch tool and
transpose it independently of the first.
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& “ 'n'l E L E,‘ Here we have introduced
- | an échappée

Note: when you create a division within a note, Melodyne calculates the average
pitch of each of the two parts separately and then tries to select the most
appropriate split point. This may cause the newly created separator to appear
slightly to the right or left of the point at which you clicked. You can, however,
override the split point chosen by dragging the separator to the exact position you
want.

If you double-click an existing note separator, it will disappear. If you hold the
[Alt] key and move the pointer to a note separator, it will become the Segment
Separation tool; in this case, if you double-click on the note separator, it will
become a segment separator, which is denoted by a pair of square brackets placed
back to back.

“What is a segment separator?” you are probably asking. Good question.
Unfortunately, we can’t answer it quite yet, because there are one or two other
things that have to be explained first.

Note: whenever you select the Arrow tool, the note separators will be displayed
(even if Always Show Note Separations is unchecked in the View menu).

03-08 Lengthening and moving notes

So far, we have been dealing with contiguous notes, and we have seen that since
by default neither gaps nor overlapping are permitted, the end of one note and the
start of the next are by definition the same thing: if you shorten the first note
(bringing the note ending forward in time), you automatically bring the start of the
following note forward in time by the same distance (and to the same place), and
since the ending of the second note remains unchanged, its length (obviously) is
increased.
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For notes that stand in isolation, on the other hand, different rules apply: if you
drag the start of an isolated note to the left, the note simply moves, rather than
stretching.

[==1]

i

E

i
Dragging the start of an
isolated note or one with no
immediate successor moves
it without altering its length
Fray Dragging the end of a note

stretches or compresses it.
As it changes from moving
notes to resizing them, the
appearance of the mouse
pointer also changes

Pause for a moment to practice moving and resizing notes; if there are no isolated
notes in your file, delete a few notes to give yourself more room in which to work.
For the time being switch off the quantization. Once the use of the tools has
become second nature, move on to the next paragraph.

If you select two or more adjacent notes, they behave as one: if you drag the start
of the group, the entire group moves; if you drag the end of the group to the right,
all members of the group are stretched.

Note: When stretching a note inside the selection all the selected notes that lie
before the note you have taken hold of are to a certain extent grouped together
and stretched proportionately. Also the selection behind the note taken hold of is
treated as a connected group in the same way and proportionately compressed.
(The behavior described applies when you take hold of the back of the note; if, in
other words, the Stretch Notes tool is active. If you take hold of the front of the
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note, the entire group is moved in the same way, regardless of which note you take
hold of). If the Bar Snap function is active, the position of the note boundary
taken hold of is quantized.

03-09 The behavior of contiguous notes and note
segments
As we have mentioned, and as you have doubtless observed in the course of your
own experiments, contiguous notes in Melodyne remain contiguous: no gap is
created when you shorten a note; instead, the following note begins earlier and is
lengthened to take up the slack. In this way, the legato effect is maintained; but
there is another reason for this that will become clearer if you look again at the
Pitch Curve that Melodyne displays after analyzing monophonic material.

Contiguous notes in Melodyne
uno are not treated as
independent entities; the nature
of the transitions between them
are always respected

With the human voice and most instruments other than keyboard and percussion
instruments, the start of a note is dependent upon what went before: the note at
the beginning of each phrase is liable to have a sharper and cleaner attack than
the notes that follow, which tend to melt into each other — often with a more or
less pronounced portamento (a gliding from note to note) between them.
Depending upon the nature of the audio file you have loaded, this may be obvious
from a glance at the Pitch Curve. To Melodyne, no note is ‘an island entire unto
itself” unless it really is isolated to begin with; otherwise, as you move and resize
notes in Melodyne, care is taken to ensure that the transitions retain their true
musical character.

Most of the time, this is what you want: to be able to tidy up the rhythm of a

performance without a gap appearing whenever a note needs to be shortened; but
there may be contexts in which you really would prefer to modify the ending or
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beginning of a note without this affecting the notes around it; in other words, to
be able to treat each note as an independent entity. This is where the Segment
Separation tool, to which we alluded earlier, comes into its own. Segment
separation works like this:

— If you double-click with the Segment Separation tool or the Note Separation
tools whilst holding the Alt key on an existing note separation, you turn it into a
segment separation, the symbol for which is a square bracket that is slightly
thicker than a normal note separator. The result is to detach the note in question
from those on either side, allowing you to move it without this affecting them.

— Double-clicking on a segment separator changes it back into a normal note
separator. But take care: this is only possible in places where the adjacent
note(sections) were touching before the segment separation. If this was not the
case previously, the segment separator between them cannot be removed.

You can create segments in another way: select
a blob (or several); then cut and paste it into the
same place. This will also sever its connection
with the adjacent blobs and create a new
segment. You can now move the blob(s) without
dragging the adjacent blobs at the same time.

Segment separations
hetween notes

03-10 Automatic timing correction

As with the correction of pitch, Melodyne offers the possibility of correcting timing
errors automatically; this means that, instead of laboriously correcting each note
in turn, you can just leave it to the program to make musically intelligent
adjustments to the timing of all or selected notes.

If you have read the sections above dealing with adjusting the length and position
of notes, you will probably have guessed what this involves: the beginnings of
notes snap to the nearest grid line, whereupon Melodyne makes whatever further
adjustments are necessary to preserve the naturalness — in terms of pitch, timbre
and volume — of the transitions between them.
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Try out the function now. Select a few notes the timing of which needs improving
or click in the background of the Editor to cancel the current selection and choose
Edit > Quantize Time

Q Time

e e e = | e =) The Quantize Time dialog
(e J(vav](ys | (a7 [1ns ] (116 7] (1732 | (132 7) [eRY opens, displaying the
Select Groove Reference
group in the upper pane

% bl % and the Quantize Intensity
= 80% = === slider (with its default

oy setting of 80%).

(==

You could, if you wanted, exit immediately with OK, effectively correcting all the
timing irregularities in the file or selection with two mouse-clicks, but for the time
being experiment with different settings and try to develop a sense of the musical
implications. If you watch the blobs as you move the Quantize Timing slider, you
will notice that the extent to which they move, stretch or contract in order to
conform more closely to the grid lines is dependent upon the position of the slider.

Now let’s turn our attention to the top pane of the Quantize Time dialog; beneath
the words ‘Select Groove Reference’, is a row of push buttons.

As you can see, the default option is ‘None’, in which case Melodyne makes an
intelligent guess (based upon its prior analysis of the audio material) as to where
each note is supposed to begin and how long it is supposed to last; usually, you
will find, it gets it spot-on and most of the notes end up in their intended places
and with the correct note values, but occasionally you will need to correct one or
two notes by hand, using the Edit Time tool.

If, on the other hand, you prefer to set the quantization factor (the fineness of the
mesh) by hand, click the appropriate push button; you will observe the effects at
once: grid lines appear at the intervals you have specified and the beginnings and
ends of all selected notes adjust accordingly. In addition, it is also possible to
synchro-quantize tracks by selecting from the list box on the right of the panel,
the track you wish to serve as a model. Experiment awhile with the quantization
functions, as the musical implications of the various options are more easily
understood by listening.
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If you have ever used a MIDI sequencer, you will doubtless have done much the
same thing with MIDI data; but here, there is one important difference: Melodyne
quantizes intelligently, not mechanically, so you are not obliged to set the
quantization factor to the smallest note value of the piece; the fact that you have
set the quantization factor to 1/4 T does not mean that smaller note values will
automatically be rounded up and that all note beginnings and endings will snap to
the nearest grid line (or move whatever percentage of the way is stipulated by the
Quantize Timing slider); instead Melodyne tries to interpret the underlying rhythm
and rhythmic emphasis; this is something far more sophisticated and tolerant of
musical expression than the Procrustean bed inflicted on it by conventional
quantization algorithms.

03-11 Creative re-quantization: an example

Melodyne’s Quantize Time functions are further proof of the musical intelligence
of the program. They offer not only powerful editing functions for the swift
correction of timing problems but also a wealth of creative possibilities. To give
you an idea of just some of them, we will show how the rhythm of a tabla loop can
be radically transformed with a few mouse-clicks.

— At this point, please load the file “tablaloop.wav”, which you will find in the
“Audio Files” subfolder of the folder “Manual”. You will see the following two-
bar loop displayed in the Editor. The original tempo is 104 BPM.

[

= P Pe I by
, w&%ﬁ_ wJ@L.%- el oo

— Begin playback of the tabla loop and open the Quantize Time dialog from the

Edit menu.

— Click the 1/8 push button in the Groove JR—— W
Reference group and set the Quantize Timing Cecltr e oy
control to 100% (not that this makes much E=="RToni e

difference here, as the performance is
reasonably tight to begin with).

— —E
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— Now push the 1/16 T (semiquaver triplets)
button and the tabla loop will begin to ‘swing’,
though in a somewhat stilted fashion at first:
move the Quantize Timing slider to somewhere
between 30% and 60% for a pleasantly
understated swing.

— Another interesting perspective is offered by the
setting 1/4 T (crotchet triplets) with the
Quantize Timing slider moved all the way to the
right (100%)...

Guamize Time.

e e e )
(e | (o] (o ) [uow ) (v | ) 130 ] (s ) e |
| Cuareee e |
E== ST s
[ cament ) = )

Guamize Time

[ - v

e by

100 %

... now the rhythmic emphasis is transformed and the entire feel of the loop

changes.

— Now let’s see what happens when we change the
time signature. Exit the Quantize Time window
with Cancel to return to the original rhythm.
Change the time signature to 5/4, make sure the

Autostretch check box is cleared (we don’t want Bk &)

to change the playback speed) and alter the
tempo definition from 104 to 130 BPM.

5 130.0
4 ] Aurostretch

.000

Melodyne cre8/studio user manual 59



03 Loading and editing audio

Now the background of the Editor shows the loop extending over two bars of five
beats each. The notes, naturally, do not correspond with the grid.

- Now open the Quantize Time dialog; push the . m“' _ .
1/4 button in the Select Groove Reference 8 () o )] ] o)) (e
grpup box and move the Quanhze Intensity 5 —
slider all the way to the right (100%).

) e

Finally, the loop really is in 5/4 time and the notes coincide with the grid lines.

03-12 Copying and pasting notes

Selected notes can be copied and pasted. You can only copy part of a melody to a
place within a melody where there is enough space. If you wish to insert notes into
the middle of a continuous melody, you have to make room for it by splitting the
melody (using the Note Separation tool) and moving the following notes out of the
way. Only then can you insert the new notes.

This is not the case if you are replacing notes directly. If, for example, you copy a
note, select a second note that is in fact shorter, and then click paste, the pasted
note simply shrinks to fit the hole left by the note it is replacing. The same applies
when replacing one series of notes with another.

If quantization is inactive, the first note will be pasted at the cursor position and
the others will follow at the same intervals as in the passage from which they have
been copied. Otherwise, the exact position to which notes are pasted depends not
only upon the position of the cursor but also upon the quantization factor, which is
indicated by the blue box at the right-hand end of the Bar/Time ruler. If, for
example, Bar (1/1) is selected, notes will be pasted to the same positions in the
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bar in which the cursor is currently located, as they occupied in the bar from
which they were copied.

Note: you can learn more about copying and pasting notes and the effect of the
Autostretch function in this context from §06-04 Arranging by copying and
pasting.

When a melody has been put together by copying and pasting more than once, it
will consist of the same number of segments (see the section on note separation
and segments above). You can move the beginning and end of the segment
boundaries, if there is enough room respectively before the beginning and after
the end of the segment. If you extend the boundaries of the segment in this way,
part of the recording will be audible that was previously defined as not belonging
to the note. This is useful, for example, when you have copied and pasted a vocal
line but not the intake of breath that preceded it, but decide, after all, that you'd
like the intake of breath to be heard prior to the pasted line as well. In such cases,
you just drag to the left the segment boundary at the start of the pasted line until
the intake of breath becomes visible (and therefore audible).
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04 Other tools

In the preceding chapters, we encountered Melodyne’s Main tool, the aspect of
which, you will remember, depends upon its position relative to the nearest blob.
Positioned in the middle of a note, it becomes the Edit Pitch tool; positioned at
the beginning or end, it becomes the Edit Time tool; positioned above or beneath
a blob or else above the note separator between blobs, it becomes the Note
Separation tool. With this multi-function tool alone, you have what is obviously a
very powerful set of editing options; but these are by no means all that Melodyne
has to offer. In this chapter, we will be looking at the other tools, which offer
additional ways of editing audio data. These are also accessed by right-clicking (or
Ctrl-clicking on the Mac).

04-01 Tools for editing pitch

The first tool in the series should have a familiar enough look to it: it's the Edit
Pitch tool we met earlier. There, however, it was a context-sensitive form of the
Main tool: it appeared as you moved the arrow over the center of a note and
disappeared just as rapidly when you moved it away. But whereas the Main tool
may be more useful if you are planning to edit the timing as well as the pitch of a
note, the dedicated Edit Pitch tool offers a wider range of functions for correcting
intonation problems.
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When this tool is active, at the semitone nearest to each blob, you will see a blue
box containing an outline of the same blob. This ‘ghost’ blob indicates where the
real blob would be if the note to which it refers were perfectly in tune. To correct
the tuning of a note, simply double-click on the blob with the Edit Pitch tool and
it will snap to the position indicated by the outline (i.e. the ghost blob). To
quantize the pitch of multiple notes in this way, select them and double-click any
note in the selection.

As with the Main tool, Melodyne’s scrub mode is activated as you are moving the
note, which means that if you move the tool to the right or left as you are dragging
a note, you can hear the waveform at the points through which it passes. [If you
find this distracting, select Edit > Preferences > Other and uncheck Monitor Note
Pitch on Editing.]

Next to the toolbar, you will see a read-out of the exact pitch (to the nearest cent)
and frequency of the selected note: you can see, for example, that your A (a’) is
14 cents (hundreds of a semitone) flat and oscillating at 436 Hz instead of the
440 required by concert pitch.

A4 =14 ct 436 Hz

The name of the note and the number of cents (if any) adrift of concert pitch are
displayed in text boxes, allowing you to type in the desired values; you may find
this easier than fiddling around with the mouse.

When the Edit Pitch tool is active, there is another easy way of generating a
thickened line, (i.e. a second part moving (almost) parallel to the first at some
interval such as a third, sixth or tenth) or with further editing harmony parts that
move independently (e.g. in contrary or oblique motion to the melody) . Simply
select the notes to which you wish to add harmonies, and hold [Shift]+[Alt] as you
drag them upwards or downwards the required number of semitones. What
happens when you do this is that the selected notes are copied to a parallel track
and then transposed by the desired amount. When you do this, slight pitch and
timing variations are introduced to make it sound like two people singing in
harmony, rather than a copy, and to prevent comb filter effects. If, however, you
would prefer an exact copy (as you might if you were copying percussive material)
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select Edit > Paste Special > Copy and Paste Selection to a Parallel Track (or drag
the notes with [Shift]+[Alt] in the Arrangement window). When this procedure is
used, no random pitch or timing variations are introduced. When the Tone Scale
snap function is active, you can a create a thickened line that alternates between
major or minor intervals as necessary to conform with the selected key.

As you move the Edit Pitch tool to the end of a note, its shape changes and it
becomes the Pitch Transitions tool.

When singing or playing the violin in particular, musicians often glide from one
note to the next. This is called portamento. Melodyne indicates a portamento
transition by means of a blue line linking the two notes affected. If this ‘transition’
is deactivated, the pitch curve from this note to the next is ‘cut through’ and is
not adjusted when adjacent notes are transposed.

If ever, for creative reasons or after altering the pitch of a note, you wish to
introduce a portamento, double-click the end of the first of the two notes or
activate with the first note manually the ‘Transition’ checkbox and drag the blue
line that appears linking them upwards (for a slower portamento) or downwards
(for a faster one). Transitions between the adjacent notes of an entire selection
can be created and edited simultaneously in the same way; first make the
selection, then create and/or edit the transition between any pair and similar
transitions will appear throughout the selection.

If you click and hold the Edit Pitch tool, two sub-tools appear beneath it, these
being the Pitch Modulation and Pitch Drift tools.

: | o feor| e 0 oa - & i
= 2 | "i\‘

e 4
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The Pitch Modulation tool can be used to augment or diminish the amount of
vibrato applied to the selected note or notes. The amplitude of the vibrato applied
to this note, for example, ...
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' ... can be reduced to
__%gg@;‘_{_ nothing with a simple drag
| . 3 of the mouse.

If you carry on dragging in a
downward direction, you
can even phase-reverse the
vibrato.

To increase the amplitude of the vibrato of a selection, click on any note within it
and drag the pointer upwards.

The Pitch Modulation tool provides an interesting way of modifying one crucial
aspect of the musical expression of a performance; not only can you tone down
the vibrato throughout the entire track (or wherever it descends into a tasteless
warble), but you can also add it in areas where a performance perhaps lacks lustre
or seems thin. Double-clicking a note using the Pitch Modulation tool toggles
between the original vibrato and no vibrato. You can read the existing vibrato
intensity from the box next to the tool bar or enter a new value if you wish.

The second tool down is the Pitch Drift tool. ‘Pitch drift’, you will remember, is the
term reserved for divagations in pitch other than vibrato, the difference being
primarily that vibrato is faster. The Pitch Drift tool works like the same parameter
in the Correct Pitch panel with the added possibility of increasing or reversing the
pitch drift. This makes it a more powerful tool for redrawing the pitch envelope of
a note. Double-clicking a note using the Pitch Drift tool toggles between the
original drift and no drift. You can read the existing drift intensity from the box
next to the tool bar or enter a new value if you wish.

Note: Whenever you select one of the Pitch tools from the toolbar, the pitch curve
will be superimposed on the note blobs, even though you may have unchecked
Always Show Pitch Curve in the View menu.

The context-sensitive Pitch Transitions tool is also available with the tools for
Pitch Drift and Vibrato.

Tip: It can happen — as a result of drift or vibrato editing, the cutting up of notes
and transposition of the parts — that discontinuities appear in the Pitch Curve,
introducing a harshness or jerkiness to the transitions. That may be the effect you
intend, but in the event that it is not, you can use the Pitch Transition tool to
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smooth the transitions. What this does is to introduce a portamento (the intensity
of which you can control) between adjacent notes.

___,' Melodyne File d Definition View Navigation MIDI Window Help

ene | Undo Changing Pitch Drift E74 Untitlec
Redo 0¥Z B
O Plain O polyjperdg  Undo History >
@ Processed @ Melodic Revert to Audio File >
- — Cut 8;X
NSO i oo
Paste ’Y

v

Delete — -
Paste Special »
Select

Reset Pitch Center to Original

Edit Formant

=
B
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b
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%; > Reset Pitch Modulation to Original
e Edit Amplitude > Reset Pitch Drift to Original
JEb Edit Notes Time > Reset Pitch Transition to Original
(A Edit Note Separations > Reset All Pitch Related Changes to Original
b Add Random Offset To Pitch Center
B Change Tempo (Autostretch) »
&b Define Tempo >
EF Variable Tempo Editing Mode (&)
!é Correct Pitch X¥P
Ip Quantize Time BT
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In the Edit > Edit Pitch cascading submenu, you will find a number of other
functions. The majority, you will observe, are designed to help you reverse
whatever changes you have just made to the selected notes, by allowing you to
reset the pitch center, pitch modulation, pitch drift or pitch transition to their
original state; they are more flexible, however, than the Undo tool because they
allow you, for example, to reverse the first of a series of four editing steps without
reversing the second, third and fourth. You could, for example, by selecting Edit >
Edit Pitch > Reset Pitch Modulation to Original, restore the original vibrato of the
recording without sacrificing whatever other editing you may have done
subsequently. Reset all Pitch-related Changes to Original can be used when
needed to reset the pitch, modulation and drift in one go to the original, saving
you having to use the corresponding individual commands.

The command at the bottom of the Edit > Edit Pitch submenu, Add Random
Offset to Pitch Center, is of a different kind: this can be used to create a chorus-
like effect; by copying the same part several times and adding random offsets to
the notes of each file (except the first), you can simulate the effect of several
musicians singing or playing in unison.

04-02 The Edit Formant tool
The next tool in the toolbar is dedicated to the editing of formants. Formants are
groups of emphasized harmonics arising, in the case of the human voice, from
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resonances in the vocal column; they are the same whatever the pitch of the
fundamental. Crude transposition tools, such as samplers, when they transpose
the fundamental, transpose the formants along with it, creating — in the case of a
transposition upwards — an unnatural timbre, as though the speaker or singer had
just inhaled helium; this is known as the ‘Chipmunk effect’ and the converse
(produced by transposing formants downwards), as the ‘Darth Vader effect’. No
disrespect to either gentleman, but something better than this is called for in a
musical context.

That is why Melodyne, as a rule, leaves
the formants in place when transposing
audio files, yielding considerably more
natural results. You may wish on
occasion, however, to make minor or (for
special effects) even major adjustments
to the formant structure manually, and
this is where the Edit Formant tool comes
in.

When you select the Edit Formant tool, a horizontal beam appears in the middle of
each blob. If you drag the beam upwards, you transpose the formants upwards,
giving the voice a more feminine sound; do the same to a musical instrument and
it is equivalent to giving it a smaller resonating chamber, turning a guitar into a
ukulele or a viola into a violin. Transposing the formants downwards is equivalent
to giving an instrument a more voluminous resonating chamber. Again, you can
apply the same changes to all, or only selected, notes and type in the desired
value in cents for the latter, if you prefer that to using the mouse. If you wish to
restore the original formants of a note, simply double-click on it with the Edit
Formant tool.

The Edit Formant tool is context sensitive: when you hold it over the last part of a
note, it governs formant transitions.

This tool works in much the same way as the tool for pitch transitions. With the
formants, transitions are created automatically whenever you shift the formants of
a note. Here, too, the blue lines appear representing a transition. As with the pitch
transition tool, by dragging the mouse pointer upwards or downwards (level with
the end of a note), you can set the speed of the formant transition to the next
note, with the blue line between the two notes becoming correspondingly
shallower or steeper.
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" @ Melodyne File X[ Definition View Navigation MIDI Window Help
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The Edit > Edit Formant cascading submenu offers two options, Reset Formants
to Original and Reset Formant Transition to Default that are useful because they
are independent of the normal Undo function.

04-03 The Amplitude Tool

Dynamics, obviously, play a vital part in musical expression, so Melodyne offers
powerful functions to help you edit this aspect of a performance. They are
implemented with the help of the Amplitude tool.

e L

If you click on a note with the Amplitude tool and drag upwards, it becomes
louder; downwards, softer; the amount of change in decibels being indicated in
each case in the Inspector area.
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Dragging upwards increases the
amplitude of the note ...

... whilst dragging downwards has
the opposite effect

As usual: one note, selected notes, or all notes, can be edited with a single
movement of the mouse, or else, if preferred, by entering the desired value in the
edit box near the Toolbar.

As with pitch and formants, you can edit the amplitude transition between notes
to introduce subtle variations into the dynamics of a performance. When, after
dragging to alter the amplitude of a note, you later move the Amplitude tool to the
latter part of the note, blue lines appear indicating the steepness of the amplitude
transition to the next note. This, too, can be modified by dragging the lines in the
normal way.

When you double-click with the Amplitude tool on one or a selection of blobs, the
note or notes in question are temporarily muted and their blobs replaced by a
straight line. Double-clicking a second time, unmutes the notes in question.

The selected notes
| have been muted
here with a double
] click ... —
... but it is still
possible to select
l and edit them
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& @ Melodyne File =5 Definition View Navigation MIDI Window Help

Undo Muting Note ®»Z

Redo i 4

Undo History »

Reset to Original

Cut ®X

Copy ®BC

Paste ®Bv

Delete

Paste Special >

Select >

Edit Pitch >

Edit Formant > L

Edit Amplitude » Reset Amplitudes to Original
Edit Note Separations > Reset Amplitude Transitions to Default
Edit Notes Time > Mute Notes

Change Tempo (Autostretch) > Reset Mute State

Define Tempo >

Variable Tempo Editing Mode 3]

Correct Pitch P

Quantize Time NEHT

The Edit > Edit Amplitude cascading submenu contains the items you would
expect: commands for resetting the amplitude to the original, the amplitude
transitions to the default and the mute state of the selected notes.

04-04 The tools for editing the position and

length of notes
The next tool in the toolbar is the Move Notes tool. This works in exactly the same
way as the Main tool when positioned at the beginning or end of a note.

In this case, however, outlines in little blue frames indicate the positions that
Melodyne's analysis has identified as the ‘ideal’ rhythmic positions for the blobs
and that are represented by the notation. The blue frames also indicate the target
positions for quantization that can be carried out using the Quantize Time macro.
Important: these positions will only make sense if the tempo has been correctly
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identified and the grid properly aligned (how to adjust the tempo to the material
and realign the background where necessary is explained in §03-05 Any Tempo
you Like and §05-07 Variable Tempo Editing mode).

The following experiment will help you to understand the blue frames. Select the
Time tool and make the notation visible. From the Quantization drop-down menu
to the right of the Bar/Time ruler select a smaller or triplet quantization factor.
Then select all notes and choose Edit > Define Arrangement Tempo > Reassign
Notes to Beats. This will cause the blue frames to jump to new positions in line
with the newly selected quantization factor. The little blue frames and the
notation jump to new positions representing the new target positions for
quantization.

The little blue frames
represent the target
positions of the notes for
quantization

These positions of the notes can be changed by dragging a note and moving it in a
horizontal direction — the exact distance being dependent upon the current
quantization factor; the notes in this case are always moved by the current
quantization factor (the horizontal difference between gridlines), not onto the grid.
Double-clicking on a note, or selecting multiple notes and double-clicking any one
of them, will cause the selected note or notes to snap to the nearest grid line and
be stretched or compressed if necessary.

If you click the Move Notes tool in the toolbar and hold the mouse button, you can
select the Edit Time Handle sub-tool from the drop-down menu. This tool can be
used to speed up or slow down the attack of individual notes. When the tool is
active, small blue levers appear within the blobs.

If you drag the blue point at
the end of the lever upwards,
you give the note a faster
attack; if you drag it
downwards, it has the
opposite effect. If you stretch
the lever itself, you increase
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the range upon which this time alteration takes effect. If you alter the global
playback tempo, this happens automatically, so that plucking or breath noise as
well as consonants in vocal parts retain their character despite tempo changes.
Another way of altering the attack is to enter a new attack speed in the box beside
the toolbar; whereby 100% represents the fastest, and -100% the slowest,
possible attack.

From the Edit > Edit Notes Time cascading submenu, you can reset the various
Time parameters of selected notes to their original values.

" @ Melodyne File [JZ[Y Definition View Navigation MIDI Window Help

Undo Changing Note Attack #Z
Redo 8z
Undo History >
Revert to Audio File >
Cut X
Copy #C
Paste 2BV
Delete

Paste Special
Select

Edit Pitch

Edit Formant

Edit Amplitude

Edit Notes Time

Edit Note Separations

Reset relative Time Course to Original
Reset Time and Duration to Original
Reset Note Time Handles to Original
Add Random Offset to Time Course

Change Tempo (Autostretch)
Define Tempo

Variable Tempo Editing Mode (28] Adapt all Notes of Track to Arrangement Tempo
Set all Notes of Track to half Tempo
Set all Notes of Track to double Tempo

YVY VRAVYY VY

Correct Pitch %P
Quantize Time XET

— Reset Relative Time Course to Original re-establishes the original time
relationship between notes, leaving their total length unchanged in the event
that the area has been stretched or compressed

— Reset Time Course and Duration to Original restores both the position and the
length, though the original length of notes that have been compressed can only
be restored if enough space exists behind them to allow them to expand without
invading the space occupied by another note.

— Reset Note Time Handles to Original to the original, whatever changes were
made with the tool in question are undone and the original values are restored.
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— Add Random Offset to Time Course is the companion to Add Random Offset to
Pitch Center (which we met in the Edit > Edit Pitch cascading submenu; both
serve the same purpose: to introduce minor variations to one or multiple copies
of a part, so that when these are played back together, the effect is of a choir (or
‘chorus’) rather than a single voice, or of two or more instruments playing in
unison (like the first violins in an orchestra, for example), rather than a single
violin.

04-05 Note separation tool
Has the same function as the Note separation tool in the context-sensitive Main
tool.

You can use this to move the boundary between notes freely to the right or left; by
‘freely’, | mean ‘independently of the current quantization factor’. If you double-
click, the note will be split at that point and a new note separator created. If you
double-click an existing note separator (without holding the [Alt] key), it will
disappear. If you hold the [Alt] key and move the pointer to a note separator, it will
become the Segment Separation tool; in this case, if you double-click on the note
separator, it will become a segment separator. The Segment separation toll is also
available as a sub-tool of the Note separation tool.

In the Edit > Edit Note Separations cascading submenu, you will find the
following commands:

Separate Note as Trill reinterprets a note containing a strong vibrato as being in
fact a trill and accordingly what was displayed previously as a single note...
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2 J\L\f\ﬂﬁﬂ/\/\

f i e e

T ELCoE

... is broken down into a succession of individual notes alternating in pitch and
capable of being edited individually. Without more, however, the command has no
influence upon the sound.

The command Separate Note as Slide is designed to separate notes created, for
example, when a guitarist or bass player slides the finger stopping the string up or
down the string — in other words, it breaks a rising or descending glissando into a
series of discrete semitone steps. Where the potential for a glissando exists, a
continuous rising or falling pitch curve is displayed which, with fretted
instruments, may take on a step-like appearance; for it to be recognized as such
by Melodyne, a slide must cover at least three semitones, with the first and last
notes defining the range of the slide.

The note range that you wish to treat and separate as a slide should initially be
separated from any preceding or following ‘main note’ and consist of only one
note. Select this slide note followed by the command Separate Note as Slide. The
slide will then be broken down into its constituent notes.

YaXa) Preferences If the option Preferences >
~{Other %) Other > Make Group on Trill

or Slide Separation is
checked, the resulting scale
tones are automatically
defined as a note group

Master Fader Default: | -6 db

Language: | English

= @ @

Undo: |50 Levels

¥ Manitor Note Pitch on Editing

] Always use maximum processing quality
# Consider Original Scale Notes on Scale Snap (Compound note).
& Make Group on Trill or Slide Separation

[l Double Click in Melody Manager opens File in MDD Editor
[ Update MDDs on Saving Arrangement

[l Auto-Update MDOs In Melody Manager

[l Enable Spot to ProTools

/i
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The Separate Selected Notes to Beats command

This command in the Edit Note Separations sub-menu of the Edit menu separates
the selected notes in equal notes; the size of the notes is entered using the
current grid setting (top right of the window).

Edit Pitch

Edit Formant

Edit Amplitude

Edit Notes Time

Edit Note Separations

Y Y VYY

Separate Note as Trill
Separate Note as Slide
Separate Selected Notes to Beats

Change Tempo (Autostretch)

Define Tempo

Variable Tempo Editing Mode (38}
_ I —— ———

vy

Use Compound Notes X#G
Compound/De-Compound Notes 3G

The Separate Selected Notes to Beats command

04-06 The Revert and Revert and reset Position
commands

These two commands in the Revert to Audio files sub-menu of the Edit menu are

used to undo all editing of pitch, formants, amplitude etc. of a segment, restoring

it in other words to its original (unedited) state.

File [ Definition View Navigation MIDI Window Help
Undo w7 WholeArrangement.mar
Redo +8Z

B E E

Revert
Revert and Reset Position

Undo History
Revert to Audio File

Whilst the first of the two commands does not restore the segment to its original
position in the arrangement (in the event that this has been changed), the second
returns the segment to the exact position in which it was originally recorded (or
else the position defined as its original position in the MDD file). In this way, if
you wish, you can restore the original time relationship with other recorded tracks.
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05 Other editing functions
and options

05-01 The Melody Manager

The Melody Manager is a file browser optimized for audio files. It allows you to
navigate swiftly through your library and is at the same time a very useful
arranging tool. Unlike the standard Open File dialog, the Melody Manager is
capable of displaying the musical contents of your audio files, allowing you to
audition and select parts of individual files and drag them to the desired position
in your arrangement. Open the Melody Manager from the File menu.

000 Melody Manager
Show: | Notes ﬁ Play: | Plain ﬁ @)
Anselms HD. Est M| Brass [ FirstSax.snd
music_film ExperienceTour 01 [ 2 Flutes —f—14
files_backups mmnems P Guitar 1
ANSELMS SHU Tutorial b MultiSamples
Ueberschall-Demo-Sarr B |  Other

Percussion

Plucked

Saxes

Speech

Strings

Vocals

Woodwinds
[[+] saxsolo02_8.5nd

[ [TR—

(] saxSolo03_8.snd
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At the top left, you will see all the hard disks, partitions and CDs that are
available. When you click on one of them, in the next column to the right, you will
see the audio files or sub folders, through which you can then navigate further.
The lower area on the left is where you store your Favorites by dragging them from
the tree on the right. This will allow you to access them more rapidly.

The audio files in a folder are represented by a Play button. When you click on
this, you can listen to the file. You can also see the contents of the file, dragging
the edges of the window, if need be, so that you can see more of it. Using the
second list box from the right, you can select between various display modes for
the audio files. You can display

(v | saxSolo01_B.snd only the title

(v ) saxSolo01_B.snd i

*H“ =>4 l' [ ] ' ”.. only the waveform

((» | saxSolo01_B.snd

only the notes

the notes and the waveform

((» ] saxSolo01_B.snd

If an audio file has not yet been analyzed, only the waveform can be displayed.
Whatever display mode you have selected, as the file plays back, a pointer
indicates the playback position. You can select parts of the melody with the
mouse. When notes are displayed, your selection is always set on the note borders,
and you will also hear exactly the notes selected. For easy arranging, you can drag
selections or even the entire melody into your Melodyne arrangement, with or
without tempo adjustment (depending upon whether or not Autostretch is
activated) and scale adjustment, when the Scale Snap function is activated.

Melodyne blobs
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To play back the current audio file, either click the play button beside its name or
double click (Stop with a single click) anywhere in the display. When you use a
double click, playback begins from where you clicked, unless you have made a
selection, in which case playback will start from the beginning of the selection
provided you double click somewhere within it.

The next list box is used to select the playback mode. ‘Plain’ plays only the
currently active audio file. ‘Cycle’ causes the selected audio file to loop, which is
useful if you want to hear how a drum loop sounds when looped. ‘Sequence’ plays
back all the audio files in the current folder in sequence. Note the volume control
to the right of the list box.

The Path drop-down menu in the top left allows you to return quickly to a
particular folder in the current tree. The Action drop-down offers a selection of
commands relating to the currently selected file. These are:

— Open in New Arrangement (works like the Open command in the Main menu)

— Add to the Current Arrangement (adds the selected file to a new track in the
current arrangement at position ‘O’ without tempo adjustment — works like
‘Import audio file’ in the main menu)

— Open in the MDD editor (use this to edit the results of the analysis if this is
necessary)

— Update MDD file (if it was created with an older version of Melodyne)

— Batch Detection (triggers the analysis of the entire folder including any sub-
folders)

— Rescan Directory (causes Melody Manager to update its display of the file
structure in the light of changes made using Finder/Explorer)

— Unregister Archives (relates to the use of Liquid Sound banks - see below)
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Working with the “Melodyne Sound Library” and
Ueberschall “Liquid” sound banks

With Melodyne cre8/studio, you can integrate titles from the Melodyne Sound
Library (MSL) as well as Liquid sound banks from Ueberschall into your work.
These libraries offer you high-quality phrases tailor-made for use with Melodyne;
they are extremely flexible and easy to manipulate, and you can insert them into
your own arrangements.

First copy the library files from the CD/DVD to your hard disk. The procedure for
activating MSL tiles and Liquid sound banks is described in Chapter 1.

Once you have activated a Melodyne Sound Library or a Liquid sound bank,
double-clicking on its entry on the status page of the activation assistant has one
of two possible effects:

- if Melodyne does not know where the sound bank is stored, a file select box will
open allowing you to locate it;

- if Melodyne does already know the location of the sound bank, double-clicking
opens the Melody Manager window through which you can access the samples in
the sound bank.

From the Melody Manager window, you can work with the material in the normal
way, dragging phrases, segments or even individual notes into your arrangements.

Note: certain Melodyne Sound Library titles also offer multi-voice material such as

vocal or wind ensembles. The multiple voices here are achieved through the
combination of individual ones, so you retain access at all times to the harmonies

Show: = Notes |—3—] Play:  Plain -

Andi » MiniSax.liquid P ALTO » _* | VLP_sax120alto005-d.wav
Banktest 1 BARITON » %
BossKopp | 2 SOPRAND »

CarstensSmaples |3 TENOR » _* | VLP_sax120alto008~e.wav

Elastik » —_— N che @
Instruments » ¥ A < v L0 ¢

Liquid » _* | VLP_sax120alto009-a.wav

MP3 » oy Rt

A sound bank in the Melody Manager

Melodyne cre8/studio user manual 79



05 Other editing functions and options

and their course. In the Melody Manager, you will find the samples for such
ensembles in sub-folders. You will also always find there an arrangement that you
can audition directly in the Melody Manager as though it were a sample, in order
to hear all the voices in context and with it the entire ensemble. You can only at
that time import the contained samples individually — either by selecting them in
the Melody Manager and dragging them one by one into your arrangement or by
loading the audition arrangement parallel to your own and copying the samples
from one arrangement to the other.

Files from a Melodyne Sound Library or Liquid sound bank are marked in the
Audio window and cannot be moved or copied into the audio file folder of an
arrangement. If you wish to transfer an arrangement that uses files from a
Melodyne Sound Library or Liquid sound bank to another computer, the relevant
library or sound bank must also be available and activated there (though it does
not matter where on the second computer the requisite library file is stored).

Arrangements in the Melody Manager

The Melody Manager displays not only samples but also Melodyne arrangements.
An arrangement is represented by a miniaturized image of the Arrangement
window and Mixer. Using the Playback switch, you can now audition (i.e. listen
to without loading) arrangements along with all the tracks they contain just as
though they were samples. A double-click on the title bar opens the selected
arrangement in Melodyne. When you are looking for sounds, this new option allows
you to audition a number of arrangements swiftly and easily, loading the ones that
interest you, and copying the sounds you want into the current arrangement.

¥ | SunshineDay.mar

A Melodyne arrangement in
the Melody Manager

. |

o

¥ | Warale end

05-02 Compound notes

A useful aid when editing and handling notes is the ability to form a succession of
single notes into a compound note. This is particularly useful with ornaments as
well as notes created using the commands Separate Note as Trill or Separate Note
as Slide in the Edit > Edit Note Separations submenu. The advantage is that you
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can perform the same action on all of the notes of which a compound note
consists simultaneously. If later you need to edit the notes singly, simply deselect
the Use Compound Notes option (rather than de-compounding the note itself).

These notes, which were created using the Separate Note as Trill command, have been formed into
a compound note to facilitate editing, but you can still access the notes individually.

Important: Please note that only adjacent notes (such as those in the example
above) can be fused to form a compound note.

Compound notes are displayed in the notation as a single note, running from the
beginning of the first of the notes of which it is composed to the end of the last.
The pitch displayed is that of the note defined as the compound main note.
Editing functions always affect all the notes of which the compound note is
composed.

The options relating to compound notes are to be found in the Edit Note

Separations submenu of the Edit menu. To enter compound mode, check the

option Use Compound Notes in this submenu; it is only in compound mode that

compound notes are displayed and treated as such, in which case:

— only the compound note, not the individual notes of which it composed, is
displayed in the staff (or ‘score’) beneath the Bar/Time ruler;

— selecting any of the individual notes of which the compound note is composed is
equivalent to selecting all of them;

— when stepping through the audio data using the Left and Right arrows, selecting
the compound note triggers the playback of the entire group of notes of which it
is composed.

The second command Compound / De-Compound Notes is used to create a
compound note from a succession of selected notes or undo such an action
subsequently. There is no limit to the number of compound notes that can be
created.
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The command Set Compound Main Note determines the pitch assigned to a
compound note, which is not necessarily that of the longest note of which it is
composed. If to wish to designate some other note as the main compound note, you
need first to select it individually, which is not easily done if Use Compound Notes
is checked, since selecting any one of the notes of which a compound note is
composed will select the entire group. There are two ways to get round this: either
by rubber-banding the note you wish to designate as the compound main note or by
unchecking Use Compound Notes and then selecting it in the normal way.

The command Show Compound Main Note limits the selection to the main note of
a compound note.

With certain tools, because they are concerned with the definition of individual
notes, it would make no sense for all the constituents of a compound note to be
selected automatically whenever the compound note was selected, so compound
mode is temporarily disabled when such tools (which include the tools for note
separation and pitch definition) are active. When editing pitch in the Editor, on
the other hand, compound mode remains active.

05-03 The Analysis of audio by Melodyne

As we said at the outset, for Melodyne to be able to render audio malleable and
offer such powerful editing functions, it must first analyze and interpret the file
loaded or recorded. This process, which is called ‘detection’, is usually carried out
automatically and results in the creation of a file containing the results of the
analysis and having the same filename as the original but with an additional
suffix: “.mdd’.

Detection is a complex process through which Melodyne obtains all kinds of
information about the file under analysis, including its tempo, the positions at
which each note or drum stroke begins and ends, and in the case of one-part
material, the pitch of each note as well as the prevailing tonality and mode (i.e.
the key).

Based on the information thus obtained, Melodyne takes a number of key
decisions, the most important being whether to treat the material as ‘melodic’ (i.e.
containing only one part), homo- or ‘polyphonic’ (i.e. containing two or more parts,
regardless of whether or not these are rhythmically independent) or ‘percussive’
(i.e. consisting primarily of unpitched material). This decision determines how the
blobs will be displayed in the Arrange window and Editor as well as how the
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material will be played back using Melodyne’s Local Sound Synthesis (LSS).
Unless the material is melodic, for example, there is no point in displaying a pitch
curve. Whether the material is characterized as melodic or percussive also
determines whether the frequency is taken into account in determining where one
sonic event ends and the next begins or only the amplitude, how transients should
be handled during playback and whether or not the pitch of the blobs should be
displayed in the staff.

In short, the conclusions drawn by Melodyne in the course of the analysis play an
important role in determining how your audio material is presented and which
functions are and not available when you come to edit it; and although the process
is fully automatic, you can if you wish intervene in various ways on the rare
occasions where the material is such that optimal results cannot be obtained
without such intervention. These include:

— The ability to change the default parameters governing the analysis and trigger
the process manually (as was the standard procedure with earlier version of the
program); you might wish to do this if the material is in some way intractable or
if you are batch-processing a whole set of recordings of the same singer and
want to ensure consistent results. The parameters in question are accessed from
the ‘Detection’ page of the ‘Preferences’ dialog, where you are also offered the
option of saving the newly modified parameter set for later use. The significance
of each of the individual parameters will be explained later in this section.

— Using the Definition menu, you can also force Melodyne to adopt a particular
interpretation or treat the material differently — as melodic, for example, rather
than percussive — and trigger a fresh analysis based upon the new parameters.
You have full control, in other words, over the way Melodyne displays and
handles your audio material.

— Melodyne’s automatic detection copes with very diverse material and works as a
rule very reliably without requiring any intervention by the user. Occasionally,
however, there is material with which Melodyne interprets individual notes an
octave too high or too low. As soon as you edit such a falsely detected note in
the Editor, unwanted sonic artifacts can appear. For this reason, Melodyne offers
a Correction Mode in which you can correct the automatic detection if necessary.
You reach this mode from the Editor of Melodyne, to which you return
seamlessly after a successful correction; thereafter no further artifacts appear.
You will learn more about this Correction Mode further down.
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— Melodyne allows you not only to correct possible discrepancies in the detection
but also to edit in a detailed and diverse way Melodyne’s detection results.
(Remember: the file created by Melodyne with the detection results has the file
ending “*.mdd"). This editing takes place in the MDD Editor and is as a rule not
necessary in everyday work with Melodyne. It is, however, of importance if you
wish to perfect a file for repeated use in Melodyne, for example for the building
of a sample library optimized for Melodyne. Then, in addition to the possible
correction of detection errors, it will also be of interest to examine the rhythmic
interpretation of the material and the detected scale. For such tasks, which have
nothing to do with the arrangement currently being edited but with the audio file
itself (or to be more precise: its MDD file), Melodyne provides the MDD Editor,
to which a separate chapter is devoted

As well as being able to influence manually the otherwise automatic process of
analysis, correct detection errors in the Correction mode offered by the normal
editor, and edit and perfect an audio file using the more powerful functions of the
MDD editor, which is independent of the current arrangement, you can select for
each separate segment whether or not Melodyne’s Local Sound Synthesis should
control the playback of the audio material and, if so, whether the algorithm for
melodic material or that for polyphonic and percussive material should be
employed — of which, more later.

The introduction over, we would like to go into each of these areas in greater
detail, beginning with the detection parameters.

Detection parameters

Melodyne 3 adapts automatically to the material at hand: there is generally no
need to modify any of the defaults; simply load the file and Melodyne itself will
decide whether it is melodic or polyphonic/percussive and act accordingly. It may
be, however, that in certain situations (for example, when batch-processing
multiple recordings by the same singer) more consistent results can be obtained
through the use of detection templates, which you can create, save and reload for
subsequent use. This involves overriding the default, Auto-detect, and entering,
storing and reloading new parameters.
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CXeXa) Preferences |
o (o)
® Auoderect The Detection parameters in the
0 miosich i Preferences dialog

Detection Parameter

Title: New Parameter Set

Highest Mote: C8 4186 Hz
P Tempo: ) Automatic Detection
Lowest Note: CO 16 Hz 1
T O Given Tempo: 120
Separation Sensitivity: 100 % O From Name at Digi. =~ 1 |

STy From File Durati
silence Note Limit: 34 db © From File Duration

Notation: () Rhythmic Separation: @ Melodic
® Tonal O Percussive
O Polyphonic

Portamento: () Treat Notes Separately ) No Separation

@ Track Portamento

Play Algorithm: @ Melodic
(O Poly / Percussive

To create a new parameter set, select Add from the Options list box at the top
right of the dialog. A window opens offering various options, which become the
currently selected options as soon as you close the window. The following options
are available:

Highest Note / Lowest Note: this determines the range to which Melodyne will
confine its search for notes (fundamentals). If you know the highest and lowest
notes of a melody, entering them here obviates the risk of Melodyne confusing the
first harmonic with the fundamental or confusing a note with the note an octave
lower because (say) the singer had a frog in his throat at that instant, but, as
we've said, such errors are rare, so this is seldom necessary. If there is crosstalk
on the recording, such as the (faint) sound of the bass spilling into the flute
microphone, you can ensure that Melodyne concentrates on the flute and
disregards the grumbling of the bass in the background (and any stray squeaks) by
entering here the lowest and highest notes the flute is capable of producing.

Separation Sensitivity determines whether more or fewer segments of the audio
file are detected as separate notes. This parameter is also available after the
detection in Correction mode and in the MDD editor, allowing you to adjust the
note separation without having to re-detect the entire file.

Silence Note Limit: this determines the level beneath which the audio is deemed
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to be silent; if the threshold is so low that the audio level never falls below it (due
perhaps to the self-noise of the microphone), each note will be deemed to last
until the next note sounds, even where, to the listener, it may appear to have
ended, and no rests will appear in the score. This parameter can also be modified
in Correction mode (from the normal editor) as well as using the MDD editor and
allows you to adjust note boundaries without triggering a fresh analysis of the
entire file.

For tempo recognition, there are four options:

1. Automatic Detection (the default)

2. Given Tempo (you enter the tempo manually in the box provided)

3. From Name at Digit (in fact, Melodyne will take the tempo from the first string
of digits following n, so if the tempo is 160 BPM and the filename
“git_160_clean.wav”, you can just enter ‘1’. It is only where the first digit in
the filename relates to something other than the tempo (e.g.
“003_git_160_clean.wav”) that you need to tell Melodyne to skip the ‘003’
and begin reading at char 9.

4. From File Duration (the tempo is derived from the length of the file)

In the lower part of the window, there are a number of parameters which, whilst
they have no influence upon the process of analysis itself, do affect the way the
audio material is handled at the editing stage and during playback:

Notation: tonal / rhythmic. This determines whether the notes will all be displayed
on the same line in the score (like a snare drum part, for example) or like a normal
melody, where the position of each note depends upon its pitch. This parameter,
too, is accessible from the Definition menu, so you can change your selection after
the analysis is complete.

Portamento: Treat notes separately / Track portamento: In the course of its own
analysis of the audio data, Melodyne always takes account of any portamentos
(sliding from one note to another), but after dragging either or both notes to a
different pitch in the course of your own editing, you may feel that a portamento is
no longer appropriate. This parameter determines the global default: whether the
notes should in such cases be separated or the portamento retained, though you
can, of course, override it in individual cases using the Note Transitions tool in the
Editor.
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Play Algorithm: here, too, you are simply setting the default. The playback
algorithm can be changed at any time (the options are described below) without
requiring a fresh analysis of the audio file.

Separation: these options determine the basis upon which Melodyne decides
whether to interpret a sonic event as a single note or as two or more individual
notes. In the case of melodic material, a change of pitch is taken as indicative of
a change of note, but in the case of polyphonic and percussive material this is
largely ignored. Instead, the presence of a fresh attack is determinative.

Note that even if you leave the defaults unaltered in the Detection panel of the
Preferences dialog, the program will still behave differently from the way it
behaves when automatic detection is selected; for example, if under Separation
you select Percussive, Melodyne will observe the criteria chosen whether the
material is really percussive in nature or not.

Custom detection parameters should only be used in rare cases, such as when you
are processing a set of audio files of the same type for a sound library and know
exactly which settings are most appropriate. Under other circumstances, Melodyne
will almost certainly do a better job if left to its own devices. For this reason, if
any custom detection parameters are active when you next launch Melodyne, you
will be asked to confirm that you still wish to use them. This is to prevent you
carrying on for weeks using non-standard settings (and in all probability obtaining
inferior results) without realizing it.

Reset or repeat detection

The Definition menu allows you the option of resetting or repeating the detection
with fresh parameters, as well as offering a shortcut to the Detection page of the
Preferences dialog, the contents of which we have just been describing.

" @ Melodyne File Edit [EINITTH Vview Navigation MIDI Window Help
—_—

Correct Detection {+#0D
Save MDD from Current Edit State X#S

Reset Detection to Melodic Mode
Reset Detection to Percussive Mode
Reset Detection to Polyphonic Mode

The Definition menu Redetect Audio File
Select Detection Parameter Set...

Apply Arrangement Tempo and Tone Scale to all MDDs

Open MDD Editor... X{#D
T —
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Using the Reset Detection to ... commands, you can tell Melodyne to treat a
recording as ‘melodic’, for example, when its own analysis of the material may
have concluded that it was ‘polyphonic’, or ‘rhythmic’ where its own analysis may
have concluded that it was ‘melodic’. As a result, Melodyne adopts a whole swathe
of different parameters or options — relating to things such as the type of note
separation, the type of notation, the interpretation of note transitions, the choice
of playback algorithm and the parameters thereof ... — which is obviously far
faster than altering the same parameters or options manually one by one. The
Reset Detection to ... commands are therefore macros that impose new settings
for the interpretation of the analysis results and the playback algorithm with a
definite purpose and in a single go.

The command Redetect Audio File triggers a fresh analysis of the material based
upon the current settings, the default being ‘automatic detection’. If, for example,
you wish to see what happens if you change one of the detection parameters,
select Detection > Select Definition > Select Detection Parameter Set, make the
desired changes, and select Definition > Redetect Audio File for them to take
effect.

NB: the commands in the Definition menu that we have just discussed are also
available from context menus in correction mode (see below) and the MDD editor.

Correcting the automatic detection

Melodyne's analysis (or ‘detection’) of an audio file when it is first loaded is the
basis for all subsequent editing. It involves a determination as to whether the
material is tonal, polyphonic (Melodyne studio only) or percussive, as to where
each note ends and the next begins, and as to the pitch and amplitude of the
signal at any point in time. Usually, the results are highly accurate, but with
certain types of material, things can occasionally go wrong:

— It can happen that the fundamental does not sound with sufficient clarity,
causing Melodyne to mistake the first harmonic for the fundamental itself (with
the result that the note appears in the score as well as in the Editor an octave
higher than you expect); the exact opposite can also happen: you have a frog in
your throat, perhaps, and Melodyne thinks you were singing Middle C when you
thought you were singing the C an octave above. Errors of intervals other than an
octave, incidentally, are very rare.

— Sometimes notes are not cleanly separated — i.e. two notes appear as a single
note
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— Melodyne sometimes confuses tonal material with rhythmic and vice versa: one
could think of certain passages of scat (jazz singers imitating instruments),
where different people could have a legitimate difference of opinion as to
whether it was tonal or rhythmic. The significance of the decision is this: when
material is interpreted as ‘rhythmic’: all the notes are displayed at the same
pitch; when it is transposed, the formants are also transposed; and no manual
editing of formants is possible.

Such errors can be corrected manually. For this purpose, Melodyne offers a special
edit mode, which you enter by checking the option Correct Detection in the
Definition menu and which causes the blobs to turn yellow and the pitch curve to
appear in bold red.

ana Unuizied = Vocalsd

W] o ] [ecai 4] seowwon 2n | Shewe -a60on | [Meeds eprsion )

The Editor in Correct
Detection mode

In Correct Detection mode, the mouse pointer is again context sensitive: when you
move it to the center of a blob, it becomes the Pitch Correction tool, though the
effect of dragging a note here to a new location is not to alter its pitch (as would
be the case in the normal Editor) but to trigger a fresh search at the new position;
it's a hint, in other words; the equivalent of saying: “try looking here”. |f Melodyne
is successful, the pitch curve will be redrawn to take account of the newly
detected note. If, however, the redrawn pitch curve seems implausible, by double-
clicking the blob, you can trigger a fresh search at the designated location.

In Correct Detection mode, the blobs do not necessarily move by an integral
number of semitones, and the results of your editing are stored in the *.mdd file
that accompanies the audio file, so your corrections are never lost; when the audio
file is next loaded, notes will be displayed at their corrected locations.

When you move the pointer to a position above or below (or to the beginning or
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end of) a note, it changes to the Note Separation tool, which you can use to split
(or move the boundaries between) notes as in the ordinary Editor. The difference
between this and altering the note separations in the normal editor is that here the
new separations go into the definition of the melody and are automatically stored
in the .mdd file, as soon as you leave the mode for the correction of the detection,
whilst the alteration of the separations in the normal Editor only relate to the
melody in the current arrangement.

Untitled

—— Pitch Detection: Sempl:l Separation: i
roug

The Emphasize Pitch and Consider Roughness options can
now he accessed through check hoxes

Check Emphasize Pitch at Dragged Note Position for Detection whenever you feel
that it is noise in the recording that is preventing Melodyne detecting a note you
yourself can hear at the pitch to which you have dragged the corresponding blob
and Consider Sound Roughness for Detection whenever Melodyne is placing blobs
an octave too low, as sometimes happens when the singer has a cold or a gravelly,
growling voice.

Note that these options only affect the detection of those notes that you drag or
double-click with the Correct Pitch tool in Correct Detection mode; they have no
affect upon the detection of other notes.

Increasing the value in the ‘Separation’ field in the Inspector area in Correct
Detection mode increases the likelihood (in cases of doubt) that Melodyne will
divide a sonic event into two or more notes rather than a single longer one.

The ‘Silence’ parameter (still in the Inspector area in Correct Detection mode)
determines the level beneath which the audio will be interpreted as silent; if the
threshold selected is very low, each note will be deemed to last until the next note
sounds, even where, to the listener, it may appear to have ended, and no rests will
appear in the score. This parameter also influences note separation but has
nothing to do with a noise gate or the ‘Strip Silence’ function offered by other
sequencers.
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Silence: | -26.0dp | Melodic Separation From the drop-down list on the right of the
Percussive Separation
| E:c'v:hu";ﬁmw Inspector area, you can select whether the
E = lo Note Separations
-~ Reset Detection: - note separation should be based upon the
Reset Detection to Melodic Mode . . ) .
Reset Detection to Percussive Mode assumption that the material is melodic,
Reset Detection to Polyphonic Mode . .
==~ Redetect: ---------- percussive or polyphonic or else opt to
Redetect Audio File . . . .
Select Detection Parameter Set... dispense with automatic note separation
altogether. Experiment with these options
= if you are not satisfied with the results of
the automatically selected system of note
separation.

The next group of commands (the Reset Detection set), which can also be
accessed from the Definition menu, are useful if the detection errors go beyond
the incorrect positioning of note boundaries; if, for example, a recording
containing staccato pitched notes is wrongly interpreted as percussive, selecting
Reset Detection to Melodic Mode remedies the error. This and the similar
commands Reset Detection to Polyphonic Mode and Reset Detection to Percussive
Mode allow you to determine manually how Melodyne interprets the material and
influence the playback algorithm, the blob and note display, the type of note
separation and the pitch connections between the notes.

The command Redetect Audio File triggers a fresh analysis of the material based
on the current parameters; if you wish to modify these beforehand, the command
Select Detection Parameter Set opens the Detection page of the Preferences
dialog so that you can make the necessary changes. These commands, too, are
also available from the Definition menu.

To leave Correct Detection mode, either uncheck the menu item Definition >
Correct Detection or select any tool from the Toolbar.

NB: When you correct the note separations in Correct Detection mode, your
corrections are stored in the *.mdd (analysis) file and will therefore be displayed
and acted upon when the audio file is next loaded. Secondly, you can only edit
note separations in Correct Detection mode if the audio file is ‘undamaged’, in the
sense that no copy and paste operations have been performed on it and no new
segments created.

The Definition menu

The Definition menu brings together those functions relating to editing the *.mdd
files of audio files. You can use this menu, for example, to activate Correction
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mode from the Editor, to access the Reset and Redetect commands (see the
description above) and open the MDD Editor in order to make far-reaching
changes to an MDD file. You will also find two new commands:

With “Save MDD from current Edit State” you can apply the current state of the
editing to the *.mdd file of the audio file, which saves you switching to Correction
Mode or opening the MDD Editor for small corrections. When this command is
used, the current state of the melody in the Editor (note separations and tempo
definition) is saved for the current audio file in its *.mdd file; alterations to the
pitch and formants settings, however, are ignored. This command can only be
used when the audio file in the Editor has not yet been broken into small pieces
and rearranged using the copy and paste functions or distorted in terms of time.

The ‘Apply Arrangement Tempo and Tone Scale to all MDDs’ command does what you
would expect and also makes these the standard settings for the audio files affected.

05-04 Melodyne’s playback algorithms

Local Sound Synthesis, a technology specially developed for Melodyne, makes it
possible to treat pitch and tempo as wholly separate entities. You can, for
example, bring the music to a halt without it falling silent as well as slowing down
or speeding up the tempo without this having any effect upon the pitch or even
creating unnatural artifacts. Furthermore, when notes are stretched or
compressed, they retain their essential character, by which | mean that the
starting transients that are characteristic of the instrument or singer in question
remain unmodified; the acceleration or slowing down of the material is performed
by stretching or compressing the sustain or 'steady state' phase of notes, and as a
result it really does sound as though the instrument or vocalist in question is
simply performing the same piece at a different tempo. Melodyne offers a number
of options and parameters that allow you to tailor Local Sound Synthesis to the
musical context. These are displayed in a separate pane above the toolbar when
you select View > Show Play Algorithm Parameters.

The parameters displayed relate to the selected segment (for more on segments,
see §03-09 The behavior of contiguous notes and note segments).

Plain or Processed: This determines whether or not processing is applied to the
sound during playback. When Melodyne completes its 'detection' of the audio
material, the parameter 'Processed' is selected. If, however, you only wish to edit
certain notes and would prefer the rest of the recording to be played back
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normally, you can divide the recording into a number of segments, selecting
'Processed' for those you have edited and 'Plain’ for the rest.

| ® plain @& original

() Processed () Sampler

The parameters for Plain

When 'Plain’ is selected, you have two further choices that become important if
you have altered the tempo: if you select 'Original’, the tempo changes will be
ignored and the audio will play back exactly as recorded. If, on the other hand,
you select 'Sampler', the pitch of the playback becomes tempo-dependent, as is
the case with a sampler or a tape recorder when you alter the speed at which the
tape passes the playback head. With the 'Sampler' setting, variable pitch courses
within single notes also result from a variable time course in the notes. The time
course within the notes can be set with the Edit Time Handle tool in the Editor
(see Editor tools). This allows you to create interesting effects above all with
percussive material.

The algorithm options in Melodyne studio

"Melodic" or "Poly/percussive": Melodic mode is the algorithm of choice for any
monophonic material, like vocals, all members of the woodwind and brass
families, solo guitar or bass lines, etc. Also speech ist best reproduced with the
Melodic mode. The voice's formants will be preserved on pitch changes and can
also be altered at will.

Poly/Percussive mode is the algorithm of choice for any other material, such as
percussion, drums, noises, but also any sounds consisting of multiple voices, like
guitar or piano chords, polyphonic voicings, choirs, and up to full mixes of
arbitrary sources. The automatic detection will set this algorithm if it finds the
material to be either polyphonic or percussive, but will adjust the other parameters
(descibed below) slightly different depending upon the material being more
percussive or more polyphonic.

Please note that the initial setting is just the best guess the program makes. You
can always set the algorithm to different values if it fits the material better. For
example, if you have a funky slap bass line, this can be considered somewhere
half way between melodic and percussive, and if it is more important for your
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purpose to preserve a very clear attack on pitch changes, you would choose the
Poly/percussive mode.

Both Poly/Percussive mode and Melodic mode offer the following additional
options and parameters.

Crisp or Smooth: The terms 'Crisp' and 'Smooth' are used here to describe two
varieties of internal sound processing, the precise nature of which depends upon
whether Melodic or Poly/Percussive has been chosen. If in doubt, try both to see
which works best.

When the algorithm for melodic material has been selected, the option 'Crisp' is
usually the better choice, as it gives the sound greater presence and there is less
loss; besides which, it makes more modest demands upon the capacity of the
CPU, allowing you to play back a greater number of tracks simultaneously. There
are, however, cases in which the 'Smooth' algorithm delivers superior results;
these include cases where extreme stretching is applied to a sound as well as well
as those where there are sudden percussion-like changes or clicks within
individual notes; the tendency is for the 'Crisp' algorithm to render such
irregularities even more obtrusive, whereas the '‘Smooth' algorithm applies a gentle
airbrush.

When the algorithm for polyphonic or percussive material is selected: the 'Smooth'
setting delivers cleaner and smoother results with held polyphonic sounds, such
as sustained guitar chords; the 'Crisp' setting is more useful with staccato sounds
and gives percussive sounds greater incisiveness. If the analysis has revealed the
material to be polyphonic, this parameter is generally set to 'Smooth', whereas for
percussive material the 'Crisp' parameter is generally preferred.

O Plain ® Poly/Percussive () Smooth Transients  Formant Tuning
® processed () Melodic ® Crisp o “y

The parameters for Poly/Percussive mode in Melodyne studio

Poly/Percussive mode also offers a parameter called 'Transients' that determines
the intensity of the attack phase of the notes in the audio file: move the slider to
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the left and the transients are less pronounced, making the sound softer; move the
slider to the right and the sound becomes more percussive. The standard setting
for material identified as percussive is all the way to the right, whilst for
polyphonic material it is in the center.

If ever the algorithm for polyphonic material fails to deliver the expected results, it
is a good idea to begin by experimenting with this slider and checking the note
separations. With the other algorithms, the note separations and with them the
blobs represent only 'editing units' and are of practically no acoustic relevance.
However with the polyphonic algorithm, it is worth checking the note separations
if you want to transpose or stretch an entire file, as the separations determine how
the transients in the audio material will be handled. Add separations or move
existing ones to better preserve the transients; remove them if they lead to
unwanted 'muttering' during long sustained chords.

Melodyne studio's Polyphonic algorithm offers an option for the preservation or
editing of formants. This means you can modify the pitch of the formants of
individual notes using the Formant tool — just as you can with the Melodic
algorithm. The "Formant Tuning" parameter determines the way formants are
affected when the Polyphonic algorithm is used. With it, you can determine the
degree of formant correction (range: left to middle) as well as its sound and
character (range: middle to right). Or, to be more precise:

— if the slider is at the left-hand extreme, no formant correction takes place; i.e.
when the fundamentals are transposed, the formants are transposed along with
them. With the slider in this position, the load on the CPU is around 20% less
than when formant correction is activated;

— as the slider is moved to the right, for the first third of the way there is a
gradual increase in the degree of formant correction; the formants are no longer
transposed to the same extent as the fundamentals;

— the central third of the range serves primarily to adapt the sound to the
material. In the case of sensitive material — an a cappella quartet, for example —
the sound of the formant correction can be adjusted. The balance lies between
"too little formant correction" (further to the left) and the creation of "false
harmonic tones" (further to the right). As a rule of thumb, when the pitch of the
dominant voice is higher, the position of the slider is further to the left; at lower
pitches, the slider is somewhat further to the right;
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— the right-hand third of the slider range is reserved more for effects. Here
additional overtones are brought out. The effect could be anything from a slight
change in the character of a grand piano, for example, to the radical
transformation of a drum loop. A precondition for this is that a fairly strong
formant adjustment (and/or transposition) is also effective, for example with the
real-time parameters. Here, extreme intervention in the character of the sound is
possible.

In the case of newly detected polyphonic material, the "Formant Tuning" slider is
by default in the middle position; in other words, the formant correction function
is activated and set at a level that has been determined empirically to be suitable
for most material.

- \.

) Plain () Poly/Percussive () Smooth  Formant Corr.  Period

@ Processed @ Melodic @ cCrisp — 1

The parameters for Melodic mode

Formant Correction, 0% - 100%: When you alter the pitch of notes, this
parameter determines whether the formants should move en bloc with the
fundamental - in which case there is no formant correction (0%) - or whether the
formants should remain in place - in which case it is their relationship to the
(transposed) fundamental that is being 'corrected'. The standard setting is 100%,
which means that the formant frequencies remain unchanged regardless of the
pitch of the fundamental, as they do, for example, when you sing (or play on the
violin) a high note followed by a low one - or vice versa. Obviously, unless have
transposed at least one note of your audio file, the value assigned to this
parameter is irrelevant.

Transposing a note a fifth (say) with Formant Correction set to 0% is the same as
transposing it a fifth with Formant Correction set to 100% and then moving the
formants a fifth in the same direction, however in the former case, the formant bar
will be superimposed on the note, whilst in the latter case, it will be displayed
hovering a fifth above the note. In either case, dragging the bar upwards or
downwards by a given interval will result in the formants being moved by the same
interval from their current position.

Period, 1 - 6: The normal value for this parameter is "1". Other values result in the
algorithm behaving as though the recording had been detected with 2, 3... times
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the period (i.e. an octave, twelfth ... deeper). This can improve the sound of
things like very high flute and string parts, particularly when elements of the
octave below are present, as is often the case when flutes are overblown or when a
vocalist has a particularly gravelly voice. It is worth experimenting with this
parameter when dealing with problematic material. If the aim is realism, however,
you are seldom going to need a value higher than "2" and even then, the Formant
Correction parameter should be set to 0%. Period values greater than 2, or greater
than 1 where formant correction is applied, lead to unnatural results and are only
useful for the creation of special effects. If only the tempo of the recording has
been altered and the Period parameter has been modified, the setting of the
Formant Correction slider is ignored.

The algorithm options offered by Melodyne cre8

"Melodic" or "Percussive": Melodic mode is the algorithm of choice for any
monophonic material, like vocals, all members of the woodwind and brass
families, solo guitar or bass lines, etc. Also speech ist best reproduced with the
Melodic mode. With Melodic mode, the voice's formants will be preserved on pitch
changes and can also be altered at will.

Percussive mode is the algorithm of choice for any other material, such as
percussion or drums, but also for plucked sounds, which have a very sharp attack
followed by a rapid decay phase. With Percussive mode, the formants or sound
character will change if the sound is altered in pitch and cannot be adjusted
independently from the pitch. The automatic detection will set this algorithm if it
finds the material to be percussive. Polyphonic material, like chords or full mixes,
can only be processed with the algorithm provided in Melodyne studio.

Please note that the initial setting is just the best guess the program makes. You
can always set the algorithm to different values if it fits the material better. For
example, if you have a funky slap bass line, this can be considered somewhere
half way between melodic and percussive, and if it is more important for your
purpose to preserve a very clear attack on pitch changes, you would choose the
Percussive mode. Or, on the other hand, if it is more important to preserve the
formant on pitch changes, you would choose the Melodic mode.
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) Pplain ® Percussive
@ pProcessed () Melodic

cre8's Percussive algorithm has no editable parameters

) Plain () Percussive () Smooth  Formant Corr.  Period

@ Processed @ Melodic @ Crisp —8 1

The parameters for Melodic mode

Crisp or Smooth: The terms 'Crisp' and 'Smooth' are used here to describe two
varieties of internal sound processing. If in doubt, try both to see which works
best. The option 'Crisp' is usually the better choice, as it gives the sound greater
presence and there is less loss; besides which, it makes more modest demands
upon the capacity of the CPU allowing you to play back a greater number of tracks
simultaneously. There are, however, cases in which the 'Smooth' algorithm delivers
superior results; these include cases where extreme stretching is applied to a
sound as well as well as those where there are sudden percussion-like changes or
clicks within individual notes; the tendency is for the 'Crisp' algorithm to render
such irregularities even more obtrusive, whereas the 'Smooth' algorithm applies a
gentle airbrush.

Formant Correction, 0% - 100%: When you alter the pitch of notes, this
parameter determines whether the formants should move en bloc with the
fundamental - in which case there is no formant correction (0%) - or whether the
formants should remain in place - in which case it is their relationship to the
(transposed) fundamental that is being 'corrected'. The standard setting is 100%,
which means that the formant frequencies remain unchanged regardless of the
pitch of the fundamental, as they do, for example, when you sing (or play on the
violin) a high note followed by a low one - or vice versa. Obviously, unless have
transposed at least one note of your audio file, the value assigned to this
parameter is irrelevant.

Transposing a note a fifth (say) with Formant Correction set to 0% is the same as
transposing it a fifth with Forman Correction set to 100% and then moving the
formants a fifth in the same direction, however in the former case, the formant bar
will be superimposed on the note, whilst in the latter case, it will be displayed
hovering a fifth above the note. In either case, dragging the bar upwards or
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downwards by a given interval will result in the formants being moved by the same
interval from their current position.

Period, 1 - 6: The normal value for this parameter is "1". Other values result in the
algorithm behaving as though the recording had been detected with 2, 3... times
the period (i.e. an octave, twelfth ... deeper). This can improve the sound of
things like very high flute and string parts, particularly when elements of the
octave below are present, as is often the case when flutes are overblown or when a
vocalist has a particularly gravelly voice. It is worth experimenting with this
parameter when dealing with problematic material. If the aim is realism, however,
you are seldom going to need a value higher than "2" and even then, the Formant
Correction parameter should be set to 0%. Period values greater than 2, or greater
than 1 where formant correction is applied, lead to unnatural results and are only
useful for the creation of special effects. If only the tempo of the recording has
been altered and the Period parameter has been modified, the setting of the
Formant Correction slider is ignored.

05-05 Defining the Tone Scale and Tuning

In Melodyne, you can work with any scale or tuning you like. The scale defines
which tonal positions of a scale can be used. The tuning defines the exact pitch
that the different tonal positions have relative to each other. It also defines the
tuning pitch of the key note.

— Scales are used by Melodyne to define to which tonal snap-to positions notes
can be moved by the pitch change tool in the Editor Window when “Scale Snap”

is activated.

— Tuning is used by Melodyne to define the exact pitch of the individual tonal
positions, if the intonation of notes is to be corrected.

Scale and tuning are always defined for an entire arrangement. The panel to
define and edit the scale can be opened from the menu Windows ->Tone Scale.
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— At the bottom there is a text field which is labeled
“Offset” - this field allows you to enter the deviation from
“standard” tuning (A=440 Hz) in cents. If you enter a

05 Other editing functions and options

The tone scale panel always first appears in the form in
which it is displayed in the picture to the left. For most
applications, the editing functions that are at your disposal
here will be sufficient.

— To the left, you will find the buttons for the selection of
the key note of the scale, i. e the key - by clicking on a
button the key note for the arrangement is defined. With a
mouse click with the “Shift” key pressed you toggle
between major and minor modes.

— To the right, you find text fields in which the frequency of
each key of the scale is displayed. Here, you can enter the
tuning of a reference note (in Hertz). All other fields will
change according to the tuning chosen in a text field.
Thus you cannot enter different frequencies for different
notes of the scale here - the chosen tuning sets the
relation between the tones. For example, if a piece has
been recorded in a tuning with A=415 Hz, you should
enter “415” into the text field defining A, and all other
frequencies will change
accordingly.

Major

Minor (natural}
Minor (harmaonic)
Minor (melodic)
lonian (Major)

frequency in the note fields, this field will always also ;’:”“f'
lan
show the deviation from standard pitch in cents. [ L,.;::,,
Mixolydian
— At the top left of the Tone Scale window, there is a drop- ':::::: it ML)

down list from which you can select from a large number
of different scale structures. These include not only the

Major Pentatonic
Minor Pentatonic

Blues
harmonic and melodic ascending forms of the minor Bop
mode but the church modes, major and minor Augmented

. L Diminished
pentatonic, whole tone and diminished scales as well as b

scale structures employed in the music of Asia and the

Middle East.

Hungarian Major
Hungarian Minor
Neapolitan Major
Neapolitan Minor
Spanish

Arabian

Persian

|| Hindu

‘. Oriental

| Japanese

100 Melodyne cre8/studio user manual

[ A __Tona Srala -



05-05 Defining the Tone Scale and Tuning

Editing Tone scales

The “Edit” button opens the extended tone scale panel as displayed to the right.
Here, you can define any tuning that you want to apply to the arrangement. (If you
do not intend to work with historical, ethnic, or experimental tunings, you can skip
the following sections.)

For a better comprehension of working with tone scales, we must distinguish
between relative and absolute tone positions. In Melodyne, the relative positions
are called Do, Re, Mi..., the absolute positions are called C, D, E... (in most
“Latin” countries, the names Do, Re, Mi... are used as having the same meaning
as C, D, E... we will not do this here since we would lose the difference between
relative and absolute positions. It would have been best to use the Hindu names
Sa, Re, Ga..., as these only intend relative positions). This discrimination would
be irrelevant for equal temperament, since in this (and only in this) temperament
the intervals of all tonal positions are exactly equal to each other. This means that
a C major scale on a piano, which is tuned in equal temperament, has the same
intervals as an E major scale. All other tunings do not share this characteristic.

The relative intervals (Do, Re, Mi...) are used at first as a construction plan to
specify a tuning relative to the imagined key note or tonic (Do). The second step is
to specify where this tonic is located in an absolute system, i.e. like on a piano
key (C, D, E...).

(&) Tone Scale
[Ma]or i [Equli Temgeramﬂ E Tuning only
Finish Edit Equal Temperament __ Used Tonal Positions
B 494 B 1100 1100
------- — = ———— |_~Proportions of the relative Tonal
466 1000 1000 "
l:l Positions
A w0 [ AT w
o a1s [ ] 0 | |~ Assign relative to absolute
[c | =02 58 700 v Absolute Tonal Positions
F# 370 [ ] s00
Proportions of the absolute Tonal
349 500 e
e ! Positions
E 330 i <00
D# 311 |:| 300
o 294 PR 200
c# 277 [ ] 100
a2 B o
Offse. 0 [ New ] [ Open ] [ Save ]
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— The buttons “Used Tonal Positions” define, which tonal positions (of 12
possibilities) appear in the scale. (These then become the positions that notes
can snap to if “Scale Snap” is activated.)

The text fields “Proportions of the relative Tonal Positions” define the actual
tuning. The values are entered in cents. They always relate to the virtual tonic
“Do”. (If the Editor Window is opened when you make these changes, you can
see how the background of tonal positions changes relative to the other tonal
positions.) This procedure defines the relative tuning.

— The buttons “Assign relative to absolute” specify which absolute tone is set to
be the actual key note of the relative tuning. If you press a button for the
assignment, you can see that the displayed cent value beside the absolute tone
is set to 0. All other text fields now display values relative to that key note. This
procedure defines the absolute tuning of each key.

— If you press the “Absolute Tonal Positions” buttons, you can see which tonal
relations result for each tone by the respective assignments in the “Proportions
of the absolute Tonal Positions” text fields. These buttons only have a display
function and will not change the tuning.

— If you changed the values in the “Proportions of the absolute Tonal Positions”
text fields, you would change the relative tonal positions at the same time; only
that here, they would be changed from the point of view of absolute tonal
positions. This is just an alternative to editing the “Proportions of the relative
Tonal Positions” first.

— Now, the actual tuning definition is complete - we can still specify which
absolute frequency the tuning is based on using “Frequency of the Keys” text
fields. This process is comparable to “tuning a piano as a whole” higher or lower
in pitch without changing the tonal intervals in relation to each other.

— Finally, you can specify with the “Select Base Key” buttons which key is
supposed to be the base key for the used scale steps defined before by “Used
Tonal Positions”.

Saving, loading and using tuning system

If you have defined a new scale or tuning system, you can give it a name by typing
it into the text box provided (second from the top at the right) and Save it. When
you do so, both the scale structure and the note currently defined as the key note
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will be saved along with any changes you have made to the tuning system. If when
you wish to open the file during a later session or reselect it from the list box
during the same session you are working in a different key and are only interested
in loading the new tuning structure, check the ‘Tuning only’ box before selecting
the tuning system from the list box or loading it from the hard disk. Melodyne
Tone Scale files have the ending *.mts. Whatever tone scale files you have created
should be displayed automatically when you click the ‘Open’ button at the bottom
of the Tone Scale dialog.

The panel to define tuning and scale is also available in the Melody Definition
Window. There, however, you only define the tuning of a melody, not the tuning of
the entire arrangement. If the melody is the first one loaded into an arrangement,
the melody automatically determines the scale of the arrangement. You can of
course still change the scale of the arrangement, at all times.

The defining of a scale does not change the musical content of the recorded
material contained in the arrangement - the scale only becomes effective when
editing notes with the note- or scale snap option active.

Importing “Scala” tuning systems

You can also import tuning systems in ‘scala’ format. Scala files have file ending
*.scl. The Scala Home Page (http://www.xs4all.nl/~huygensf/scala/index.html )
offers a library of over 3000 scales in *.scl format, which you can import into
Melodyne for your own use. Certain of these scales have more than 12 notes;
these are not currently supported by Melodyne. With the others, the Scala format
defines neither the scale degrees used nor their absolute pitch. For this reason,
Melodyne uses the following system when importing them: if a Scala file contains
exactly 12 notes, these are assigned to the existing 12 notes of the chromatic
scale and the scale itself (the 7 degrees that are used) are set to the 7 tones of
the major scale. If, on the other hand, a Scala file contains fewer than 12
degrees, these are assigned to the nearest degrees to them in the even-
temperament scale and the other degrees left as multiples of a 100. At the same
time, the notes defined by the file automatically become the scale degrees used.

05-06 MIDI Out options

You can use Melodyne as a flexible audio-to-MIDI converter and play back the
detected (or edited) melodies using an external MIDI synthesizer or a software
instrument loaded into Melodyne. Pitch bend and controller data are used to
permit the continuous variation in pitch and amplitude of the audio to be
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reproduced precisely by MIDI instruments. As an alternative to the realtime
transmission of the MIDI data, Melodyne can export it as a file that you can then
load into a variety of other MIDI programs for further editing.

To activate the output of MIDI data, select View > Show Audio-to-MIDI Parameters
or MIDI > Show Audio-to-MIDI Parameters and these will then be displayed

beneath the Menu bar in the Editor or Arranger window. All the settings relate to
the currently selected track.

Velocity r I Pitch Bend I Envelope r I . I Realtime Midi Send I
| (oo | fc=

The audio-to-MIDI parameters

When Realtime MIDI Send is checked in the rightmost pane of the Audio-to-MIDI
parameter set, the list box below can be used to select the MIDI port to be used
and the edit box to the right of it to determine the MIDI channel. If you have
loaded software instruments into Melodyne’s mixer, the names of the instrument
tracks of the mixer will also appear in the MIDI Ports list box.

By clicking and dragging in the Velocity box on the left, you can vary the shape of
the Note On velocity curve; it is also possible to determine the minimum and
maximum values by dragging the horizontal lines located initially at the bottom
and top of the rectangle.

If you wish Pitch Bend messages to be included in the transmitted MIDI data,
check the Pitch Bend box; the edit box directly below is used to determine the
Pitch Bend Range in semitones and should correspond with the same parameter
of the MIDI instrument being controlled. (Any difference in the settings will lead
to either a reduction or an intensification of the effect). A problem that arises with
MIDI when you have to use a Pitch Bend controller (or in this case: Pitch Bend
messages) to realize a portamento between two notes is that the controller is
inevitably out of position at the instant the first note ends, since in the course of
the first note it moves further and further from the neutral position it needs to be
in the instant the second note begins. Even when the messages are generated by
software rather than a physical controller, the result is often a noticeable
discontinuity.
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Melodyne therefore offers three different algorithms (Each Note, Central Note and
Alternating Channel) for implementing passages in which the pitch glides
smoothly rather than moving stepwise from note to note. If the default, Each Note,
in which Note On and Note Off messages are sent for each blob in the display (i.e.
each note) results in discontinuities of the type described — which is often the
case if the sound selected has an audible release phase — the other two
algorithms are designed to address the problem, either by sending the same Note
On message each time throughout the portamento passage and implementing the
variations in pitch within the passage using Pitch Bend data and nothing else
(Central Note) — in which case if the melody has a compass of an octave, the
Pitch Bend range needs to be +/- 6 semitones and the Pitch Bend resolution of
the MIDI tone generator receiving the messages needs to be high — or else by
distributing the notes alternately between two neighboring MIDI channels, which
gives each of them time to recover and ensures that as each Note On message is
sent, the Pitch Bend status of the channel sending it is neutral.

If you use this third mode, make sure that the same sound program is selected on
both channels and that the second channel is not being used for a different
channel. If for example, you have assigned Channel 1 to a particular track, in
Alternating Channel mode Channels 1 and 2 will now be used. Remember that
Pitch Bend data invariably applies to an entire MIDI channel, so you will need at
least one MIDI channel for each of the tracks of your arrangement from which you
intend to generate pitch bend data.

Not only the pitch but also the amplitude of the original melody can be used to
modulate parameters such as the corner frequency of filters as well obviously as
the volume itself, the result being a far more vibrant and realistic performance. To
take advantage of this option, check the Envelope box and select, from the edit
box below, the number of the MIDI controller you wish to be governed by the
amplitude; the default is Controller 11 (Expression Pedal) but you can select
Controller 7 (Volume) or indeed any other controller you like, if you wish the
amplitude of the audio to govern the timbre of the sound generated by the MIDI
instrument rather than simply its volume. The rectangular box to the right of the
Envelope checkbox operates in the same way as the Velocity box described a few
paragraphs back: to alter the shape of the curve, click within the box and drag the
pointer upwards or downwards, and click and drag the upper and lower extent of
the rectangle to define the range. Note that if both key velocity and Controller 7
are being used to control the volume of the receiving instrument, quiet notes are
in danger of becoming inaudible unless either the velocity curve is programmed to
ensure that only values at or near the top of the available range are sent or the
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receiving instrument is programmed in such a way that velocity data is diverted
from its usual task (controlling the volume) and is used instead to govern the tone
color.

The small rotary control to the right of the Envelope box governs the type of
influence exercised by the envelope upon the beginning of each note. When the
knob is turned fully anticlockwise, the original envelope of the melody determines
the amplitude of the attack phase, which is generally realistic except that the
attack of the receiving instrument can sometimes be lost. When the knob is
rotated fully to the right, the sound of the receiving instrument dominates the
attack. Not all MIDI instruments are capable of implementing gradual crescendos
and generate what is known as ‘zipper noise’, where the change is heard as a
succession of discrete steps rather than continuous change. It's a question of
resolution, of course, since only analogue technology is capable of smooth
transitions. You may therefore need to try various synthesizers (or synthesizer plug-
ins) before you find one capable of delivering convincing results. Bear in mind
that MIDI controller messages, like Pitch Bend data, apply to an entire MIDI
channel, so — again — you will need at least one MIDI channel for each of the
tracks of your arrangement from which you intend to generate MIDI controller
data.

Tip: if you are outputting a track to a MIDI instrument, you may wish to edit the
audio in Melodyne first in order to obtain optimal MIDI results; depending upon
which system you are using to implement portamento, for example, you might
want to fuse adjacent notes or split single notes in two; you may also wish to
optimize the amplitude transitions or the rhythm for the destination instrument; of
course, if you intend to carry on using the audio file as an audio file as well, you
should copy it to a separate track beforehand, which will give you two versions:
one optimized for MIDI and the other for audio. If you are using Melodyne in order
to edit MIDI in this way, it makes sense to copy the audio file onto an additional
track and switch off the audio for the track upon which you are editing the melody
as MIDI. In this way you can edit audio and MIDI completely independently from
one another.

Melodyne and plug-in instruments

As well as external MIDI instruments, it is possible to load and use software
instruments (in the form of VST or AudioUnit plug-ins). To do this, select
Preferences > Plug-ins and activate the software instrument you plan to use;
select, Window > Mixer > and from the ‘Configure’ list box in the top right-hand
corner of the mixer Instrument Tracks > Add Instrument Track; {a new channel,
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named ‘Inst 1’ appears at the right-hand extreme of the mixer}; click in the name
field and give the instrument a more descriptive name; from the second list box
from the top in the channel strip, select the desired instrument; {the user
interface of the selected instrument opens allowing you to adjust the parameters
as desired — if, after closing this, you need to make further adjustments, click the
same list box as before}; finally select MIDI > Show audio-to-MIDI parameters
followed by the new mixer channel you have just created, which you will find
displayed in the Port list box (below the word ‘Real-time MIDI Send’).

Saving MIDI data

If you wish to save the MIDI data, rather than using it to control (i.e. play) a MIDI
instrument in real time, after setting the audio-to-MIDI parameters as described
above, select File > Save Audio to MIDI.

Save MIDI
Format: | As Specified in Tracks F
Range; | Entire Arrangement i
Channels: @ All () Save each track as a single file
Tracks: ® Vocalso [ Track 4 CTrack 7
() Track 2 I Track 5 I Track 8
(O Track 3 Track &
Y

The Save MIDI dialog

Format: | As Specified in Tracks
Depending upon what you plan to do next — print out e LQ"““”-"‘ LD E
the score (in which case the notes need to be quantized
but you don’t need the Pitch Bend, Velocity Scaling and Controller data) or edit
the file in a MIDI sequencer — choose either Quantized for Notation or As
Specified in Tracks from the Format list box in the Save MIDI dialog that opens.

The options in the Range list box are

for the most part self-explanatory. Format: (As Specifed in Tracks 4
Range: | Entire Arrangement
Between Locators

— If you select Entire Arrangement, Chanrnels: | ag Reference Track

everything from the beginning of Tearka: From Start of Reference Track until End of Arrangement

. Individual Range for each Track
the first note of the arrangement to individiial Fila for sach Marker Region
the end of the last will be saved. [ Track 3 BTt
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— If you select Between Locators, the length will be determined by the current
position of the left and right locators.

— If you select As Reference Track, a new list box opens to the right of the Range
box from which you are invited to select a reference track, the beginning and
end of which will then serve the same purpose as the left and right markers in
the previous option; in other words, MIDI data will be saved from all the active
channels, but only where it coincides with the reference track.

— If you select From the Start of the Reference Track to the End of the
Arrangement, the beginning of the range will be as per the previous option but
tracks continuing beyond the end of the reference track will not in this case be
truncated.

— If you select Individual Range for Each Track, each track will be saved with a
separate starting point and length.

— If you select Individual File for Each Marker Region (see Navigating with
Markers), the files will derive their names from the markers. This option is only
available when you are saving MIDI data from a single (usually long) track.

In the next line, you can stipulate whether the active tracks of the arrangement
should be saved to a single file or whether each track should be assigned to a
separate file. Depending upon your selection, either a single multichannel MIDI
file or a separate MIDI file for each track will be created. It is possible to set the
Velocity Scaling, Pitch Bend and Envelope curves independently for each track; if
you wish this data to be saved along with the other MIDI messages, select As
Specified in Tracks.

The Channels radio buttons allow you to elect either to save all the active channels
in a single MIDI file (to which you will be invited to supply a name in the normal
way) or as so many individual files (in which case the name you enter will be
assigned to the folder in which the files are stored and the files themselves will
take their names from the tracks from which they are derived). Finally, using the
check boxes at the bottom of the dialog, select the tracks from which you wish to
save MIDI data and exit with Save As.... By default all active unmuted tracks are
selected but you are free to vary this selection.
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05-07 Saving audio

Usually, you will want to save your entire arrangement, which may be derived
many different audio files; these, needless to say, will remain untouched, since
Melodyne edits non-destructively, implementing in real time whatever changes you
have made in the course of editing. An ‘arrangement’ in Melodyne is therefore
equivalent to a ‘session’ or ‘song’ in other sequencers and encapsulates an entire
multi-track production in a single file.

Sometimes — if, say, you wish to export to a different sequencer vocal tracks
edited, or vocal harmonies generated, using Melodyne— you may prefer to save
audio tracks individually. If so, select File > Save Audio. The Save Audio dialog
that opens, you will note, bears a striking resemblance to the Save MIDI dialog we
have just described.

Save Audio
Format: [WAVE 5) (44100khz ) (16 biclinear pcM i3 (interleaved i3
Range: [As Reference Track ) Track: [Voealso B
Channels: (J)Stereo Mix @ Save each track as a single file [l write MDDs The Save Audio dialog
Tracks: #Vocalso Crack 4 I Track 7
Track 2 O Track 5 OTrack 8
Track 3 Orack 6

From the list boxes in the first line, you can select the audio format, sampling
rate, audio resolution (‘wordlength’) and between interleaved and split stereo
formats; an interleaved file contains both the left and right channels, whereas in
split stereo format a separate file is assigned to each. Note that if you are using
plug-ins in the mixer, you cannot select a sampling rate other than the one
selected in the Preferences dialog.

Entire Arrangement
Berween Locators

Format:

=]

The options in the Range list box are for Range: | As Reference Track ce
From Start of Reference Track until End of Arrangement
the most part self-explanatory. Channels: | individual Range for each Track

Individual File for each Marker Region
Tracks:

— If you select Entire Arrangement,
everything from the beginning of the first note of the arrangement to the end of
the last will be saved.

— If you select Between Locators, the length will be determined by the current
position of the left and right locators.
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— If you select As Reference Track, a new list box opens to the right of the Range
box from which you are invited to select a reference track, the beginning and
end of which will then serve the same function as the left and right markers in
the previous option; in other words, data will be saved from all the active
channels, but only where it coincides with the reference track. This is useful
when you are working in another application and wish to export a passage for
editing by Melodyne and then restore it to exactly the same slot.

— If you select From the Start of the Reference Track to the End of the
Arrangement, the beginning of the range will be as per the previous option but
tracks continuing beyond the end of the reference track will not in this case be
truncated.

— If you select Individual Range for Each Track, each track will be exported with a
separate starting point and length. This is useful when you are editing samples
of different lengths within the same arrangement.

— If you select Individual Audio File for Each Marker Region (see Navigating with
Markers), the files will derive their names from the markers. This option is only
available when you are exporting audio data from a single (usually long) track.

— Melodyne's Audio Export window also offers the option of exporting the audio
material of a track blobwise; for each detected or manually produced note,
Melodyne creates a separate audio file on the disk. Provided this is one-part
melodic material and one extract defined as a note does not contain more than
one pitch, a MIDI root key is automatically written to the files produced. This
makes it possible to map the audio files automatically to the correct keys when
they are used in a sampler. When exporting, give a name to the folder, and the
names of the individual files will then consist of the name of that folder followed
by a number (which is incremented with each successive file).

Save Audio

Format: | AIFF [3) (s4200khz |5 (32 bit floating Pcfig) [interleaved 4

The option Range:
permitting the
creation of an

Entire Arrangement
Between Locators
As Reference Track

Channels:

Lo . v From Start of Reference Track until End of Arrangement g‘[rumpet
individual file for " | Individual Range for each Track
each note Individual File for each Marker Region E[)umhak
Individual File for each Note
Sample rate is limited by active plug ins. ( Cancel ) G—hm-—;
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The Channels radio buttons allow you to elect either to save all the active channels
in a single audio file (to which you will be invited to supply a name) or as so many
individual files (in which case these will take their names from the tracks
themselves). Finally, using the check boxes at the bottom of the dialog, select the
tracks from which you wish to save data and exit with Save As....

If you are exporting individual files, the settings of each track (the volume, EQ and
insert effects settings) will be exported but not those of the Master section or aux
effects. If you select Save each track as a single file, every active track will be
saved as a separate audio file — either mono or stereo depending upon whether
the mixer channel assigned to the track in question is defined there as mono or
stereo. You have the additional option of writing or not saving an MDD file at the
same time and in the same folder as each of the exported audio files, which will
allow you to edit the file at a later date without waiting for it to be analyzed a
second time. If you have compiled group tracks or ReWire tracks, these will also
be exported at the same time. If ReWire or instrument tracks are being used or
MIDI transmitted in real time, the export process will also be performed in real
time.

When you first open the Save Audio dialog, you will see from the check boxes at
the bottom that all active tracks that are currently unmuted are initially selected,
but of course you can deselect any of these and select others if you wish. If you
have selected Save each track as a single file, after clicking Save As... you can
select a folder: the files will automatically be given the same names as the tracks
from which they are derived.

[Cmd]+[A] selects all tracks in the Save Audio window whenever at least one track
remains unselected and deselects all whenever all are selected.

If in the course of an audio export operation the level is too high, the error will be
reported at the end and you will be advised to adjust the mixer settings to prevent
a recurrence when the material is exported a second time.

A separate section is devoted in Chapter 7 to the Spot to Pro Tools option that

appears under certain circumstances in the Save Audio dialog, so we will not deal
with it here.
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05-08 Variable Tempo Editing mode

When there are no tempo changes within an audio file or arrangement, the tempo
is determined by the value in the top right-hand corner of the Transport bar. The
effect of altering this depends upon whether Autostretch is checked (in which
case the audio material is stretched or compressed to correspond with the new
tempo) or unchecked (in which case only the grid that forms the background in
the Editor expands or contracts, whilst the notes themselves remain fixed).

If, however, there are tempo changes within the audio file (either because it was
played rubato or because the time signature changes at some point in the score)
or you wish to introduce tempo changes to your arrangement, select Edit >
Variable Tempo Editing Mode.

When this mode is active, whenever the mouse pointer passes over the gridline
separating two crotchets (or ‘quarter notes’) in the Arrangement window or Editor,
it changes its appearance to become the Time tool. You will notice that when you
drag a gridline to the right using the Time tool, the entire grid expands
horizontally, whereas when the gridline is dragged to the right, the grid contracts
horizontally. Whether the tempo of the audio is reduced or increased when you do
this depends upon whether or not the Autostretch box in the Transport Bar is
checked: If so, it is; if not, all you are doing is adjusting the grid to fit the notes.

If you double-click at the beginning of a bar, a blue line will appear. You can set a
different tempo each side of the line.

Between the blue lines, different tempo settings are possible
Above each blue line, in the Bar/Time ruler, you will see a time signature and
tempo indication. To change any of the values displayed, double-click on it and

type in something different.
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By typing in the desired values in the Bar/Time ruler,
you define a different tempo and/or time signature
for each segment

You can activate Variable Tempo Editing mode separately for the Arrangement and
Editor. When it is active, you can enter values at any time in the Bar/Time ruler.
Dragging the grid in the Editor is only possible when the Main tool (the Arrow) is
selected.

The Change and Define Tempo submenus

Further options for altering or redefining the tempo within a recording are provided
by the Change Tempo (auto-stretch) and Define Tempo submenus accessed from
the Edit menu. When you redefine the tempo, all that happens is that the gridlines
move; the tempo of the audio itself is unchanged. As you will have noticed, the
two sub-menus have many commands in common:

— Double Tempo and Half Tempo are self-explanatory

— Equal Tempo is an Undo function: it removes all the tempo changes you have
introduced in the course of editing so that the same tempo obtains throughout
the arrangement

— Same Tempo for Following Bars has the same effect, except that tempo changes
prior to the current bar are preserved

— Same Signature for Following Bars preserves all time signatures prior to the
current bar but deletes any that follow

— Equal Beats in Current Bar and Equal Beats in Following Bars are also Undo
functions and self-explanatory

— Smooth Tempo Changes is used to implement an accelerando or rallentando; in
other words, the tempo increases or decreases gradually between the two tempo
indications instead of changing suddenly.

— Set Tempo Zero to Sound Zero is used to synchronize the first beat with the
beginning of the audio. For obvious reasons, this command only appears in the
Define Tempo sub menu.

— Derive Tempo from Audio File Duration. This command in the Define Tempo sub-
menu of the Edit menu sets the tempo of the arrangement to ensure that the

audio file lasts an integral number of bars. The time signature currently selected
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is adopted. This command is useful, for example, when you know the recording
lasts an integral number of bars but this is not the case with the tempo currently
detected.

— Set Bar Duration to Current Selection. This command in the Define Tempo sub-
menu of the Edit menu sets the tempo and the beginning of the bar in such a
way that the currently selected notes comprise one bar exactly. The time
signature currently selected is adopted. This command is useful, for example, to
establish at the beginning of a recording as accurate a starting value for the
tempo-tapping as possible.

— Tempo from MDD applies the tempo detected for the selected audio file to the
entire arrangement

You can also import tempos:
— If you select Tempo from MIDI File, the Open dialog appears and you can select
the file containing the desired tempo definitions.

— The Tempo from MIDI Clock option will be greyed out unless Melodyne is
running in slave mode for MIDI clock (i.e. when a MIDI port has been selected
from the MIDI Clock In list box of the MIDI Ports page of the Preferences dialog
and Receive MIDI Sync option is selected in the Sync list box in the bottom left-
hand corner of the Transport Bar). When you select Tempo from MIDI Clock, the
recording of the tempo progression will be activated and Melodyne will wait for
playback to commence in the host application. Once playback has finished, the
recorded tempo progression will be used for the current arrangement until such
time as the process is repeated.

05-09 Tempo-tapping function
Melodyne lets you define the tempo background in the absence of a strict tempo
by tapping.

The command Enable Tempo Recording from Tempo Tapping in the Define Tempo
sub-menu of the Edit menu switches the Tempo track to record mode; the Time
ruler turns red. The Time ruler also turns red (to indicate record mode) when you
select Enable Tempo Recording from MIDI Clock. In each case, you can exit
record mode by clearing the checkmark before the menu entry concerned.

After "Play", the playback runs at the original speed and the tapping serves to
define the tempo. After "Stop", the new tempo is adopted. Even uneven beats
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within a bar - indicated by the thin blue lines by each beat - can be created. If
need be, the progression of recorded beats can be made smoother by selecting
Edit > Define Tempo > Smooth Tempo Changes.

The commands for tempo tapping can be assigned in the preferences to keys on
the computer keyboard but the implementation via MIDI is more exact. The
assignment via MIDI takes place in the MIDI Remote Control settings.
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06 Working with multiple tracks

In the first chapters of this manual, we laid the emphasis upon Melodyne’s Editor,
which allows you to edit audio material in a highly flexible way using a variety of
tools. Whilst the correction and creative editing performed in the Editor are among
the most important uses for Melodyne, they are by no means the only ones.
Melodyne is at its most versatile and powerful when you have loaded multiple
tracks into the Arranger, which offers you the degree of control you associate with
a MIDI sequencer: you can reshape melodies, change the mode, modify the
timing, alter the rhythm, stretch or compress the material and even effect a global
transposition of the entire arrangement as well as tweaking any of the other
parameters offered by Melodyne for the editing of audio.

The Arrangement window and the Editor are of equal status: both represent an
‘Arrangement’, though they display different views of it: in the Arrangement
window, the tracks are displayed one on top of the other, whereas in the Editor,
they are in a sense behind one another with the one in the foreground being the
edited track, which you can edit using the various tools.

Opening am arrangement or creating a new arrangement causes the Arrangement
window to open, whereas opening an audio file results in the Editor opening. This
is simply because if you open an audio file, you will normally wish to edit it first
before entering the arranger. The Arrangement window and the Editor are, as we
have said, of equal status. An arrangement is closed when the last arrangement or
editing window is closed.

Please note that all audio editing in Melodyne is performed in real time and non-
destructively. As with most sequencers, the file type usually saved is an
arrangement (file ending: “.mar”). If you are editing an individual audio file, as
you would in a sample editor, and wish to save the edited version as a new audio
file, select File > Save Audio. (For more on saving audio, see section 05-06 Audio
above)
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Tracks in Melodyne’s Arrangement window

The functions of the Track list

The left-hand margin in the Arrangement window is occupied by the Track list,

within which each track is assigned a control panel containing its name and a

number of buttons:

— To select a track, click on its control panel in the Track list or (if it already
contains audio data) on one of its notes; the bold outline of the panel in the
Track list and the fact that the notes are red (rather than yellow) indicates that
this is the currently selected track.

— To select all the notes of the currently selected track, click the panel a second
time.

— To open a track in the Editor, double-click on its control panel in the Track list.

— To increase or decrease the height of a track in the Arrangement window, drag
the dividing lines in the Track list.

— To increase the width of the Track list (in order to display longer names), drag
the dividing line between the Track list and the track display.

— You can rearrange the order of the tracks in the Track list by dragging and
dropping their control panels to new positions: to promote a track, click on its
control panel and drag it upwards; to demote a track, drag its panel downwards.

— To rename a track, double-click on its name and enter a new one; the name
initially given to a track is that of the audio file from which it is derived.

— Click the button marked ‘M’ to mute a track.

— Click the button marked ‘S’ to solo a track. You can ‘solo’ multiple tracks by
Shift-clicking their solo buttons; this is equivalent to, but often faster than,
muting the tracks you do not wish to hear.
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— Click the button marked ‘R’ to record-enable a track. Doing this whilst the
recording is already in progress is equivalent to punching in; deselecting it is
equivalent to punching out.

Editing multiple tracks

In the Editor, you can have single or multiple files. At any one time, only one of
these tracks (the track currently selected) can be edited and the others are
displayed more palely in the background. Tracks are transferred to the Editor
either by double-clicking in the Arrangement window or by selecting them from
the list box just above the quantization menu in the Editor. As in the Arrangement
window, you can display the currently selected track in notation form by clicking
the staff symbol at the left-hand edge of the Time/Bar ruler.

iF'll'Il' visible ” | ARANEN You can select from the list box
: 2. Track 2 which tracks to display in the
E & K Track 3 Editor
Track 4

Track 5
Track 6
Track 7 i
Track &

Nothing in Editor | “

06-01 Importing audio files

You can either load an audio file into a new arrangement or add it to an existing
one. If you know the tempo of the file, select File > New Arrangement followed by
Window > Transport Bar and enter the tempo in the edit box in the top right-hand
corner of the Transport bar; this will now be applied by Melodyne’s detection
algorithms to every audio file imported into this arrangement. If you are working
with melodic material the key of which you already know, select Window > Tone
Scale and click in the left hand column to define the tonality, using the Shift key
to toggle between the major and minor modes (see Tone Scale Window above).
Now that you have prepared the arrangement, it is time to import the first audio
file (File > Import Audio File). Once the tempo of the arrangement has been
defined, it will be adopted in the course of the detection by all files loaded
subsequently into the arrangement. Alternatively, you can choose how the tempo
of a newly loaded file should be detected in the manually selectable detection
parameters in the preferences.

BNM AW
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If you don’t know the tempo of the audio file you are about to edit, select File >
Open followed by the file and Melodyne will create a new arrangement as well as
detecting and setting the tempo and (if this is the first file in the arrangement to
be opened that contains melodic material) also the key automatically; if you
disagree with Melodyne’s analysis, you are, of course, free to redefine either the
tempo (see 05-07 Variable Tempo Editing Mode) or the key (as outlined in the
previous paragraph) manually.

If audio files contain information about the tempo (as do Apple Loops and Acid
files), this is automatically adopted by Melodyne.

File- and note-based importation

You can also drag and drop audio files directly from the Finder (Mac)/Explorer
(Windows) or - easier still - the Melody Manager (see 05-01 The Melody Manager)
into Melodyne’s Arrange window or Editor. Where exactly they end up depends
upon whether you are conducting a file- or a note-based import.

When you conduct a file-based import, the contents of the file are ignored:
Melodyne simply drops the beginning of the file down in the place indicated like a
conventional sequencer, even if the file begins with 20 bars of silence.

If, however, Melodyne has already analyzed (in the jargon: ‘detected’) the file and
therefore knows its tempo and time signature and where in the bar each note falls,
it is capable of performing a note-based import, adjusting the tempo of the file to
that of the arrangement (even if the latter is irregular) and positioning the notes
‘intelligently’.

When you drag an audio file over one of Melodyne’s windows, a transparent
rectangle appears indicating where the file would be placed if you were to release
the mouse button at that moment. In the top left-hand corner of the rectangle are
two lines of text that indicate whether or not the original tempo and pitch will be
retained or whether they will be adjusted to those of the arrangement.

If an audio file has not yet been detected by Melodyne, the insert point invariably
coincides with the start of the file; the precise insert point, of course, depends upon
whether or not quantization is active and, if so, the quantization factor; this is
displayed to the right of the Bar/Time ruler at the top of the Arrangement window.

If an audio file has already been detected by Melodyne, you can determine using
the Autostretch option whether the position and tempo of the file should be
adjusted to suit the arrangement (Autostretch On) or whether it should simply be
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positioned at the insert point without any tempo adjustment (Autostretch Off).
When the Autostretch function is active, all the notes snap to the correct beat of
the bar relative to their original position: if, for example, you have selected ‘Bar’
as the quantization factor, the notes will be inserted on the same beats of the bar
as in the original recording.

If you wish to insert a previously detected audio file in such a way that the
beginning of the file coincides with that of the arrangement, instead of the drag
and drop method, select File > Import Audio File.

A similar logic to that governing tempo adjustment applies to the adjustment of pitch:
If the Scale Snap function is selected (in which case the Note ruler in the Editor will
be white rather than gray; click the Snap button at the bottom to toggle the function
on and off), a detected audio file will adjust automatically to the key of the current
arrangement, sparing you the effort of performing the adjustment manually.

06-02 Real-time parameters

It is possible to change the pitch, the formants and the tempo of the entire
arrangement globally, which is useful if you want to hear how it would sound in a
different key or at a different tempo. To do this, select Window > Realtime Play

Offsets.
o Reslime Fiay Offcers These parameters can be edited
(cotal 9 independently (e.g. slowing down the
Pitch: 0.0 cent tempo does not lower the pitch) either by
Formant: 0.0 cent Reset typing in a new value or by clicking in the
Tempe: 1200 bpm Reset box and dragging the pointer upwards (to

« to Arrangement increment) or downwards (to decrement);
this can even be done during playback.

The Realtime Play Offsets dialog

The values in the Pitch and Formant fields are expressed in cents (hundredths of a
semitone in equal temperament), so to transpose up a perfect fifth, the Pitch
parameter should be set to +700. The formants are corrected automatically as you
transpose, so you don’t need in this case to enter +700 in the Formant field,
unless you intend to alter not only the pitch but also the character of the sound.
Assuming that you want it to sound like the same vocalist singing, or the same
instrument playing, a fifth higher, leave the Formant parameter set to 0. Note that
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if a playback algorithm other than that for melodic material has been selected for
the track in question, changing the Formant parameter has no effect.

The tempo displayed is always that of the first bar of the arrangement but altering
the displayed value affects all the tempos within the arrangement proportionally.

Note that since for Melodyne’s Local Sound Synthesis preserving the transients is
of paramount importance — these are neither stretched nor compressed when you
alter the tempo — an error message will appear if ever you seek to affect such an
exaggerated acceleration of the playback that unless the transients of adjacent
notes were compressed, they would be forced to overlap.

If you have modified the Pitch, Formant or Tempo parameters in the Realtime Play
Offsets dialog, you can restore the original values by clicking the appropriate
Reset buttons.

Changing any of these parameters does not of itself change your arrangement; it
only changes the way Melodyne plays it back. If, for example, your song is in C
minor and you enter 100 in the Pitch field of the Realtime Play Offsets dialog,
Melodyne will play back the song in B minor but the notes displayed in the Editor
will still be in C minor. It is only when you click the Fix to Arrangement button at
the bottom of the dialog that the arrangement itself will be transposed; then and
only then will what you see be what you hear. The same goes for the tempo and
formant offsets; initially, the arrangement itself is unaffected; only if you click Fix
to Arrangement will the arrangement itself be modified.

When you click Fix to Arrangement, the Fix Play Offsets dialog appears, inviting
you to select the range within which the offsets should be applied: to the whole
arrangement, only to that part of the arrangement that is encompassed by the
right and left locators, or to none of the arrangement at all (‘No’ here is equivalent
to Cancel). If you wanted to transpose up a tone the trio section (only) of a minuet
and trio or the last verse (only) of a song, simply place the left and right markers
at the beginning and end of the passage you wish to transpose, select Window >
Realtime Play Offsets and enter +200 in the Pitch field. Then click Fix to
Arrangement followed by Change between Locators and the job is done.

You can, if you prefer, apply the realtime play offsets for Pitch and Formant to
individual tracks instead of to the entire arrangement. To do this: choose Selected
Track in place of Global from the list box at the top of the Realtime Play Offsets
dialog; set the Pitch and Formant parameters to the desired values; and replace
Selected Track with Global using the same list box; only then can you exit with Fix
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to Arrangement. When you do this, not only whatever Global offsets you have
selected but also the offsets you have chosen for the Selected Track will be
applied to the arrangement and track respectively.

It is also possible to exclude individual tracks from the global changes — so as to
exclude the drum track, for example, from a global transposition. In this case,
select the drum track; open the Realtime Play Offsets window; choose Selected
Track from the list box at the top; and clear the Globals checkbox (which is
checked by default). When you do this, the selected track will no longer react to
global changes in the Pitch or Formant realtime play offsets.

You can also modify the playback parameters via MIDI, either by transposing
semitone-wise by playing variations with the MIDI keyboard or continuously via
MIDI controller (see §06-05 MIDI In options and §07-05 Remote control using a
MIDI controller).

Note: You can now enter percentage values (e.g. 50 %) in the Tempo fields of the
Transport bar and of the window with the real-time parameters as well as in the
Time ruler (if Variable Tempo Editing Mode is selected). The percentage is in each
case that of the last applicable value; for example, if the tempo set is 100 BPM,
typing in "50 %" will reduce it to 50 BPM. If you want to double it (so that it
returns to 100 BPM), enter "200 %" (not 100 %).

06-03 Navigating with markers

By creating markers each time at the current locator positions, you can divide the
file into regions either to facilitate navigation or with a view to saving parts only of
a selected audio file as described in Section 05-06 Saving Audio - Individual
Audio File for Each Marker Region above.

z @ Melodyne File Edit Definition View WLEULLE MIDI Window Help
-— Create Marker  XC
Scroll to >
Zoom to >
Delete Marker >
R

To create and name a region, select Navigation > Create Marker and enter the
name in the edit box that appears in the Bar/Time ruler.

A marker region in the
Bar/Time ruler
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You can move the cursor and left locator instantly to the start, and the right

locator to the end, of any defined region in either of two ways and delete Markers:

— Navigation > Scroll to > opens a drop-down menu from which you can select the
region. moves the playback cursor to the start of the selected region, scrolling
the display if necessary to reveal as much of it as possible without altering the
horizontal resolution.

— Navigation > Zoom to goes one further, increasing or decreasing the horizontal
resolution to ensure that only the selected region is displayed.

— Navigation > Delete Marker deletes the left and right markers and with it not the
contents of the region but the region itself. In other words, if you have defined a
region called ‘Chorus’ running from bar 17 to bar 26 and you select Navigation
> Delete Marker > Chorus, the word ‘Chorus’ will disappear from the Bar/Time
ruler and the region ‘Chorus’ will no longer be available for selection from the
Zoom to or Scroll to drop-down menus, but bars 17-26 themselves will not be
deleted or changed in any other way.

Once a region has been defined, the only way to move, extend or truncate it is to
delete it and start again. If, in the previous example, your chorus only in fact
extends to the beginning of bar 25 and you have made a mistake, select
Navigation > Scroll to > Chorus, which will move the left locator to the beginning
of bar 17 (right) and the right locator to the beginning of bar 26 (wrong); then
select Navigation > Delete Marker > Chorus; move the right locator to the
beginning of bar 25 (which is where it ought to have been in the first place) and
define the region a second time by selecting Navigation > Create Marker and
typing in the name ‘Chorus’ as before.

You can also define and use keyboard shortcuts for navigating swiftly between
regions (see §07-06 Preferences - Customizing shortcut key assignments below).

06-04 Arranging by copying and pasting

Melodyne offers you numerous interesting possibilities for the creative editing and
reshaping of melodies and rhythms. In the following section, we would like to look
at these in greater detail. The main techniques include the selecting, deleting,
copying, cutting and pasting of note blobs and the most used shortcuts
[Command]+[A] (Select All), [Command]+[X] (Cut), [Command]+[C] (Copy) and
[Command]+[V] (Paste).
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To create vocal harmonies from a single part, for example, all you need to do is
copy the melody into one or more new tracks and edit the pitch of the notes on
the new tracks until the desired results are achieved. You could equally well select
the notes you wish to copy and drag them to a new track whilst holding the Shift
and Alt keys.

If, rather than generating harmonies, you wish simply to double a part to make it
sound as though two people rather than one are performing, it is more convincing
(and produces rich, chorus-like effects) if slight variations in intonation and timing
are introduced in the course of, or subsequent to, the copying. If you are working
in the Editor and copy a part by [Shift]+[Alt]-dragging, this is done automatically.
Otherwise, select the part followed by Edit > Edit Pitch > Add Random Offset to
Pitch Center and/or Edit > Edit Notes Time > Add Random Offset to Time Course
from the Edit menu.

You can also rearrange the structure of a composition on a single track using
commands like Cut, Copy and Paste.

In addition to the usual Select All, the Edit > Select sub-menu offers you a variety
of other options.

E @ Melodyne File IZT8 Definition View Navigation MIDI Window Help

=
Undo Create Marker ®Z
Redo 08z
Undo History >
Reset to Original
Cut ®8X
Copy #8C
Paste v
Delete
Paste Special [

Select Al %A
Select following Notes
Edit Pitch » | Select same Notes
Edit Formant » Select same Notes in all Octaves
Edit Amplitude » | Select same Beats
Edit Nots Separations » 1 Select Notes between Locators
Edit Notes Time >
Invert Note Selection

Change Tempo (Autostretch) >
Define Tempo >
Variable Tempo Editing Mode (2
Correct Pitch NP
Quantize Time BT

— Select All selects all the notes of the current audio file. In the Arrange window,
this can also be done by clicking on the Control panel of the track in question in
the Track list.
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— Select following Notes adds all the notes following the currently selected note to
the selection. This is useful, for example, when you have divided off a segment
and wish to move it further to the right to allow space for the insertion of other
notes.

— Select same Notes selects all notes occupying the same semitone as the
selected note. This is useful if, for example, you wish to replace all the Middle
C’s in the piece with the note above (C#).

— Select same Notes in all Octaves is the same except that it allows you to select
all C’s (or all F sharps, for that matter) regardless of their octave.

— Select same Beats allows you to select all the notes in an audio file that occur
on the same beat of the bar as the note selected. This is useful, for example, if
you wish to alter the rhythm of a percussion track by making all the notes on the
first beat sound slightly earlier. By [Shift]-clicking multiple notes before
selecting Edit > Select > Select same Beats you can define and pick out a
rhythmic pattern wherever it occurs in the audio file.

— Select Notes between Locators is self-explanatory. Conversely, you can move the
locators to encompass the selected notes by double-clicking in the lower deck of
the Bar/Time ruler.

— Invert Note Selection selects all the notes that are currently unselected and
deselects those that are.

The standard shortcut, [Command]+[A], is assigned to Select All. You can, of
course, assign your own shortcuts to any or all of the other options as explained in
§07-06 Preferences - Customizing shortcut key assignments below.

The intelligent clipboard

The pasting of notes from the clipboard is implemented rather differently by
Melodyne than by other sequencers, because a ‘note’ to Melodyne is a note in the
true sense of the word — a musical event with a specific place in the melodic and
rhythmic scheme of things — rather than simply a snippet of audio.

This means that when you copy a phrase or even an entire melody from one
arrangement to another or from one part of an arrangement to another, not only
the first note but all the notes fall automatically on the correct beats of the bar,
even if the tempo of the source and that of the destination are different —
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provided, of course, the Autostretch box is checked in the Transport bar of the
destination arrangement; otherwise Melodyne will preserve the tempo of the
original just like any other sequencer. Where, for example, a song has been
recorded without using a metronome and the tempo of the third verse is slightly
higher than that of the first, provided the tempo has been correctly detected (or
that any detection errors have been corrected manually), Melodyne will have no
difficulty in pasting a lick or a vocal harmony taken from the first verse into the
last in such a way that all the notes fall on the correct beats of the bar. Needless
to say, intelligent pasting is only possible if both the source and the target
arrangements have at some stage been detected (i.e. analyzed) by Melodyne.

The clipboard is intelligent but not inflexible: it is up to you to choose the
principle that determines where the pasted notes will end up, one of the key
parameters being the quantization factor, which you select using the drop-down
menu at the right-hand end of the Bar/Time ruler. Normally you will want a phrase
that begins on the fourth beat of a bar and runs until the third beat of the second
following bar in the verse or arrangement from which it is taken to do the same in
the verse or arrangement into which it is being pasted; in that case, select ‘Bar’ as
the quantization factor. If, on the other hand, you want it to start this time on the
second beat (and run to the first beat of the second following bar), select 1/4 as
the quantization factor. In the latter case, of course, you will need to be careful to
position the cursor closer to the second beat than to either the first or the third (so
that it ‘snaps’ to the correct beat); whereas in the former case (when ‘Bar’ is
selected as the quantization factor), provided you place the cursor somewhere
within the right bar, Melodyne will do the rest.

Of course, if the rhythm of the material you are working with is of no consequence
— if it's speech, for example — you should uncheck the Autostretch box in the
Transport bar prior to pasting, as there is no need in such cases for Melodyne to
do anything clever. A simple copy-and-paste will suffice.

Pasting notes

You can paste notes to any part of the arrangement where there is sufficient room;
where, in other words, there is a rest of sufficient length in the score. If, therefore,
the desired insert point falls in the middle of an unbroken sequence of notes,
before you can perform the paste, you have to split the sequence of notes in two
at the desired insert point and move everything that follows to the right. Suppose,
for example, you wish to insert a new line four bars in length that begins on the
fourth beat of the bar. Set the quantization factor to ‘Bar’ and select the first of
the notes following the desired insert point followed by Edit > Select > Select
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following notes and drag the entire selection four bars to the right using the Move
Notes tool. Now you have room to insert a new line.

The statement above that the rest must be of sufficient length to accommodate
the material to be inserted needs to be qualified in one respect: if the last of the
inserted notes overruns the start of the following material, that’s no problem;
Melodyne simply truncates it. If, on the other hand, the beginning of the last note
falls outside the paste area, you will see the error message: “Not enough space
after paste position!” With single notes, therefore, you are allowed to paste a note
lasting three beats into a rest lasting only two. Melodyne simply truncates the
note, making it a minim (half note) instead of a dotted minim.

Replacing notes

The same is true when you are replacing one note with another: the two notes
don’t have to be the same length; if the new note is too long, Melodyne simply
truncates it. Where, for example, a vocalist has made a hash of a high note on the
second repetition of the chorus but got it right in the first, you simply select the
note that was correctly sung followed by [Command]+[C] (or Edit > Copy); then
select the botched note followed by [Command]+[V] (or Edit > Paste) and
Melodyne will replace the botched note with the correctly sung one, truncating the
latter in the event that it overruns the start of the next note.

Melodyne’s Edit > Paste Special menu contains a number of unusual, but very
useful, functions:

’ " Melodyne File Q3+ Definition View Navigation MIDI Window Help
Undo ®Z
Redo 08z
Undo History

Reset to Original

Cut 8X
Copy 3#C
Paste Ay
Delete -

Paste Special Paste Pitches 3V

Select Replace Keeping Target Pitches N8V

v

Edit Pitch

Edit Formant

Edit Amplitude

Edit Note Separations

Edit Notes Time

Change Tempo (Autostretch)
Define Tempo

Copy and Paste Selection to Parallel Track ©3C
Cut and Paste Selection to Parallel Track 38X

VVVVYVYYY v

Variable Tempo Editing Mode 3]

Correct Pitch X#P
Quantize Time N8BT
T —
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Pasting pitches

Paste Pitches solves the problem that you cannot simply copy a correctly sung line
from one verse to another unless the lyrics are the same. Provided the rhythm is,
and that the only real problem is intonation, all you need to do is make the pitch
of the notes in the second verse conform to the pitch of the equivalent notes in
the first. Similarly, if you are generating four-part harmonies from a single vocal
part and you intend to use the same harmonies in all three verses, all you need to
do is copy the original recording to four separate tracks; create vocal harmonies for
the first verse only, by moving the notes of the three harmony tracks up and down
in pitch; and, finally, taking each of the harmony parts in turn, and pasting the
pitches of the first verse to the two following verses.

Taking the alto part as an example, pasting the pitches involves nothing more than
selecting the notes of the first verse followed by Edit > Copy; then selecting the
notes of the second verse (which at this stage are those of the melody) followed by
Edit > Paste Special > Paste Pitches and, in place of the melody, you will have the
alto part created for the first verse, except that the words will be those of the
second verse not those of the first.

The Paste Pitches function is also intelligent in the sense that it does not just take
the first 8 notes, say, of the destination and apply to them the pitches of the first
8 notes of the source; if it did, it would make a nonsense whenever there was a
slight difference in the number of syllables in the source and destination lines.
Quite often in a song, a minim in one verse is replaced by two crotchets (or a
dotted crotchet and a quaver) to accommodate an extra syllable in the second
verse; in such cases, Melodyne retains the rhythm of the second verse but applies
the same pitch (that of the minim in the first verse) to both notes. It may be that
you would prefer to introduce some melodic variation at this point, but in that
case, you must decide for yourself what notes you would prefer and make the
adjustments manually. Melodyne’s intelligent but it can’t read minds!

Replace Keeping Target Pitches does the exact opposite of Paste Pitches. Take the
song: “For he’s a jolly good fellow”. The rhythm and the words of the first and
second lines are the same; it's only the pitches that are different. Suppose the
subject of the eulogy were a woman, and you started off “For she’s a jolly good
fellow” but then forgot and sang “For he’s a jolly good fellow” in the second line.
Now the pitch is right both times; you've just got the wrong word in the second
line, so you select the word “she’s” (OK, it's two words...) in the first line; copy;
select “he’s” in the second followed by Edit > Paste Special > Replace Keeping
Target Pitches; and the “he’s” will be replaced by “she’s” in both lines, but the
pitches will be different. This is useful, too, for instrumental parts, where the note
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you have played is fine but the tone color leaves something to be desired; when
you're playing tirando on the guitar, for example, and the string gets caught under
the nail making a ‘thunk’ sound, even though the two notes may be of different
pitches you can simply apply the timbre of the note before (which you played well)
to the note you botched.

The last two commands in the Edit > Paste Special submenu are self-explanatory
assuming you know the difference between cutting and copying, which is perhaps
not obvious from the words themselves. Copy and Paste Selection to Parallel Track
creates a new track and copies the selected notes to it - without removing them
from the source. Cut and Paste Selection to Parallel Track does the same thing
except that this time the selected notes are removed from the source.

The first of these commands is useful for doubling — a classic technique used to
give more body and vibrancy to a vocal or instrumental part. Here, as we said
earlier, it is useful to introduce random but slight variations in pitch and timing to
suggest two different performances rather than two copies of the same one; this
can be done using Edit > Edit Pitch > Add Random Offset to Pitch Center and/or
Edit > Edit Notes Time > Add Random Offset to Time Course from the Edit menu.
If the purpose of making the copy is two generate two-part harmonies from a
single part, a faster way of doing this is to begin by selecting the notes in the
Editor and dragging them up a third, say, whilst holding the Shift and Alt keys, as
Melodyne then copies them to a new track as well as introducing the desired
discrepancies without waiting to be asked. Further editing, of course, will be
necessary to obtain a musically satisfying second part but a copy with random
offsets represents a promising start.

The second of the two commands, Cut and Paste Selection to Parallel Track, is
useful in cases where you wish to add separate processing to elements within a
track; you could select all the kick-drum notes from a drum loop, for example, and
move them to a different track with this in mind. Incidentally, both of these
actions can be performed in the Arrangement window without recourse to the Edit
> Paste Special submenu, simply by selecting the notes and dragging them to a
new track. If you hold down the Shift and Alt keys as you do so, it is equivalent to
Copy and Paste Selection to a Parallel Track. Otherwise, the effect is the same as
Cut and Paste Selection to a Parallel Track.
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06-05 MIDI In options

It is possible to edit an arrangement using your MIDI keyboard as well as using
Melodyne as though it were an instrument and playing it in real time via MIDI. To
activate MIDI, you must first select a standard MIDI input under MIDI Ports.

E @ Melodyne File Edit Definition View Navigation o8 Window Help

- No MIDI In to Tracks

v MIDI In Plays Notes
MIDI In Edits Notes
MIDI In Transposes All from C3 =0
MIDI In Transposes Track from C3 =0

All MIDI Channels to Selected Track

MIDI Channels to Track Numbers
MIDI Portamento Time »
From the MIDI menu, you can determine Show Audio-to-MIDI Parameters  C3M
. . Show MIDI Ports Preferences
how Melodyne handles incoming MIDI Show MIDI Remote Control Preferences
notes: T ——————

— When MIDI In Plays Notes is selected, you can play the blobs in the
arrangement using a MIDI keyboard. If the playback is not running, you can
move in Step mode from one note to the next. (You can also move notewise
forwards or backwards using the arrow keys on the computer keyboard). When
the playback of the arrangement is running, you hear the blobs with the pitches
you enter with the MIDI keyboard. The playback is always in mono; that means
you hear always the pitch of the key last pressed. When you release the last key,
the pitch returns to its original in the arrangement. In MIDI In Plays Notes
mode, all changes are only temporary realtime events; they do not, in other
words, alter the notes in the arrangement.

— When MIDI In Edits Notes is selected, you can use the MIDI keyboard to edit
the notes; in other words, the notes in the arrangement are moved to the
positions played and remain there. As in MIDI In Plays Notes mode, you can edit
the sequence of notes in step mode if playback is not running. If playback is
running, you can move notes in real time. When editing in real time, the actual
movement of notes is rather different to what you hear as you play: admittedly
you hear the altered pitches at precisely the moment that you play a note, but
the actual movement of the notes is governed by the note separations defined in
the audio file. In this way, more natural transitions between notes are obtained.
If you play a few shorter notes over a long original note, the note is not
separated; if you want a separation, cut the long note in the desired places with
the Note Separation tool prior to playing.
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— When either MIDI In Transposes All from C3=0 or MIDI In Transposes Track from
C3=0 is selected, the entire arrangement or track is transposed through an
interval calculated by subtracting Middle C from the key pressed; up a tone, in
other words, if you play the D above Middle C; down a semitone if you play the B
below Middle C, and so on. Unlike in MIDI In Plays Notes mode, releasing the
key has no effect: the original pitch of the arrangement or track is not restored.
If you wish this to happen, press Middle C. The effect of these functions is the
same as that of transposing the arrangement or selected track using Window >
Realtime Play Offsets and Global or Selected Track respectively from the list box
at the top of the window, where you enter the transposition interval in cents in
the Pitch edit box immediately below; and, in fact, if the Realtime Play Offsets
window is open when you transpose the arrangement or track using the keyboard
(i.e. as described in the present paragraph), you will see the changes reflected
there in real time in the Pitch edit box. As well as transposing through an
integral number of semitones, you can use MIDI input to detune the instrument
by hundredths of a semitone: by 50 cents (half a semitone), for example, or 150
(a tone and a half). How to do this is explained in $07-05 Remote control using
a MIDI controller below.

— When All MIDI Channels to Selected Track is selected, regardless of the channel
of the MIDI input, only the current Melodyne track is affected. When MIDI
Channels to Track Numbers is selected on the other hand, messages transmitted
on MIDI Channel 1 are assigned to Melodyne Track 1, those transmitted on
Channel 2 to Track 2, and so on. By splitting the MIDI keyboard into two zones
and assigning each zone to a different MIDI channel, you can therefore control
two Melodyne tracks at the same time. You could also copy the same melody to
several tracks and control these simultaneously using the same number of tracks
of an external MIDI sequencer.

— The MIDI Portamento Time parameter determines the speed of pitch changes
during MIDI control. This parameter only influences the changes that you hear
directly when playing. It has no effect upon the arrangement itself, unlike the
tool for the editing of pitch transitions in the Editor.

The remaining three commands in the MIDI menu cause the Audio-to-MIDI
parameters, and MIDI Ports and Remote Control preferences, to be displayed (in
the former case) above the toolbar and (in the latter two cases) in separate
windows.
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06-06 Recording with Melodyne

Within an arrangement, you can record on a single track or several tracks
simultaneously, the exact number depending upon the audio driver and number of
input channels available. Melodyne can only record using ASIO, Direct 1/0 and
Core Audio drivers; with DirectX and Sound Manager only playback is supported.
The driver is determined using the Hardware page of the Preferences dialog, whilst
the file format you wish to be used when your recording is stored on the hard disk
is selected from the Recording page of the same dialog (see also §07-06
Preferences).

When you record in an arrangement that has already been saved — e.g. under the
name ‘MySong’ — the audio files are automatically saved to a folder called
‘MySong Audio’ created parallel to the arrangement ; if the arrangement has not
yet been saved, the audio files are stored in the temporary folder of your choice
(Preferences > Recording > Audio Folder for unsaved Arrangements) but copied to
a new folder (named according to the convention just described) as soon as you
save the arrangement.

To record, proceed as follows:
— In the Track List of the Arrangement window, click the ‘R’ button in the Control
Panel of the track upon which you wish to record to record-enable (or ‘arm’) it.

@ <0> <0>
0 db 0 db

You can arm a track for
recording from either the
Arrange window or the Mixer

G0._ado

Track 1  Track 2

— Click the Record button in the Transport Bar (having first armed one or more
tracks for recording — both steps are necessary).

— If the Mixer is open, you will see a meter for each of the active tracks; to control
the level of the input signals use your external mixer or microphone preamp.
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— If the Rec Monitor box in the Mixer is checked, you will hear the incoming signal
with all the effects active in the signal chain; the degree of latency (delay) is
partly determined by the buffer size (Preferences > Hardware > Buffer Size)

— While you are recording, you can also hear the tracks already recorded. To obtain
a metronome, check the Click box in the Transport Bar.

— Finally, to commence recording, click the Play button in the Transport Bar.

When the recording is complete, the newly created audio files will be detected
(i.e. analyzed) and their notes displayed in the appropriate tracks.

You can record ‘on the fly’ by clicking the Record button in the Transport Window
during playback (in which case, recording will only proceed on the tracks currently
armed). Conversely, if recording is already underway on other tracks, you can
extend it to new ones (i.e. ‘punch in’) by record-enabling them on the fly.

Punch In/Out

You can program recording to commence and/or end (&) Transport Bar
automatically at the current left and right locator o Cycle 0001.01.01.000

e / . ) & O Punchin  poo3.01.01.000 0001.01.
positions respectively by checking the Punch In and/or ey, e
Punch Out boxes in the Transport Bar. In other words, [Sme ™~ [K' W l ”’—I W ] [ [""'—l

if you want recording to commence at the left locator

and continue until you click the Stop button, check the Punch In box only; if you
wish recording to commence at the current cursor position and end at the right
locator, click the Punch Out box only; if you wish both the beginning and the end
of the recording to be determined by the locator positions, check both boxes.

Melodyne offers a very useful way of replacing a sequence of notes on a given

track by punching in and out, because it knows where each note begins and ends.

— Select the notes you wish to replace.

— Hold the Alt key and double click the Locator (lower) deck of the Bar/Time ruler
to place the left locator at the exact (unquantized) beginning of the first note of
the group and the right locator at the exact end of the last.

— Check the Punch In and Punch Out boxes in the Transport Bar.

— Commence recording as described above.
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If the singer or instrumentalist begins to soon or holds the last note for too long,
Melodyne makes the necessary adjustments. If he begins too soon, it shortens
(which in Melodyne is not the same thing as truncating!) the preceding note —
i.e. the (previously recorded) note to the left of the left locator. If he holds the last
note for too long (i.e. it overlaps the right locator), Melodyne shortens it rather
than making room for it by moving the notes to the right of the Right locator to the
right. In other words, the rules are exactly the same as those that apply when you
are editing an audio file using Copy and Paste.

06-07 The Mixer

The Mixer of the current arrangement, which opens when you select Window >
Mixer or ((Command]+[Shift]+[M]), offers a channel strip for each track of the
arrangement — plus additional strips for group, ReWire and instrument tracks, if
any are included in the arrangement. The order of the channels is always the same
as that of the corresponding tracks in the Arrange window, so if you sort (i.e.
change the order of) the latter, you sort the former automatically as well. Since the
layout of the Mixer is tailored to the current arrangement, its appearance is likely
to alter each time you switch to a new arrangement.

8n00n Mixer
i ﬁ ﬁ 1 ﬁ ﬁ ﬁ i 1 ﬁ Configure -
caracd e gty Natip Se e S g e NG E)
OO EiT) @inl Zi 0o 00 &inl ) &
| | | .| m— | — | — | a—
3 T = ] =] =

Ll
O

s
(i

O

5 O One Ouna Oune O a4
S | | S S | S [N [
Maln ﬁ Main ﬁ[Man ﬁ[Maln ﬁ[Main ﬁ[Main ﬁ[Maln ﬁ[Maln i Out:{ 1-2 ﬁ
[c ﬁ[o ﬁ[c ﬁ i[c ﬁ[o n[" ﬁ[o i EllecMonimr
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Note: Command-clicking any of the controls on the Mixer resets it to its default
value. To fine-tune a parameter, hold the Alt key whilst dragging the relevant
control.

(800

— The top pane of each of the channel strips is devoted to the Equalizer. High Shelf | 7o
Each time you add a band to the equalizer, a new band appears just = Q?:
below it. Bands are added by selecting their type: High Shelf, Peak or |
Low Shelf from the list box at the top. The controls marked ‘G’ (Gain), - -

‘F’ (Frequency) and ‘Q’ govern the amplitude (or ‘magnitude’), the

center or roll-off frequency (depending upon whether Peak or one of the other
types is selected) and the quality (or ‘selectivity’) factor of the filter respectively.
If you prefer, you can also program the equalizers using a graphic interface as is
described under Master Section below. To bypass the equalizer, clear the

checkbox beneath the frequency (F) control.

The list boxes directly below the equalizer section are used for the selection of
insert effects such as VST plug-ins or Audio Units (Mac only). You can use as
many as you like; each time you use one list box, another appears. As soon as
you have selected an effect from the cascading menu — the contents of which
vary depending upon your settings on the Preferences > Plug-ins page and
whether the track is mono or stereo — the user interface for the selected plug-in
or Audio Unit opens in a new window.

— The knob marked ‘Ax’ determines how much of the channel signal is routed to
any auxiliary effect selected from the ‘Aux’ drop-down in the Master Section to
the right of the channel strips (See Master Section below). The checkbox beside
the control allows you to deactivate the aux send, without altering the setting of
the Ax control. The aux sends are switched post-fader.

— The next list box down is used for selecting the input channels, the choice being
dependent upon your audio hardware. If the channel in question was created by
selecting Configure > Instrument Tracks > Add Instrument Track using the
cascading list at the top of the Master section, this is the list box you use to
assign a software instrument to it; available choice depending upon your settings
on the Plug-ins page of the Preferences dialog.

The list box below is used for selecting the output channels. If you select Main,
the signal will be routed to the output channels of the Master Section. If you
select one of the numerical values, it will be routed to the selected channel(s) of
your audio hardware. If you have created any group tracks by selecting Configure
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> Group Tracks > Add Group Track using the cascading list at the top of the
Master section, these, too, will be listed as alternative targets for the output of
the channel in question.

— From the bottommost list box, you can select whether the track should be
processed in mono or stereo. If the audio file is in stereo, Stereo will be selected
here by default, though you can always switch to mono if you prefer. The setting
of this switch affects the choice of available insert effects; if you wish to use a
stereo insert effect in a track with a mono source, you must first select Stereo
from this list box.

— The pan pot, which is only active if a stereo output has been selected, sits just
above the fader with the current value is displayed to the right of it.

— The channel fader is located to the right of the meter, the current value being
displayed above the slider.

— The three switches marked ‘S’, ‘M’ and ‘R’ beneath the channel fader and level
display are the Solo, Mute and Record buttons, the functions of which are
identical to those of the equivalent buttons in the Track list: clicking the Solo
button in a channel, for example, mutes all the other channels; whilst Shift-
clicking it mutes all the other channels except those already soloed. If the
Record button in the Transport bar is selected, you can punch in and out on the
fly by clicking the Record buttons of the desired channels during playback.

— At the bottom of each channel strip, there is an edit box displaying the name of
the track assigned to the channel. Changing the name here produces a
corresponding change in the name displayed in the Arrange window, and vice
versa.

The Master Section

To the right of the channel strips, you will see the Master Section, where the level
of the Main L/R output, the auxiliary effects to be used, and various other global
settings are determined.

— To the right of the channel faders, you will see the meters and faders of the
Master (L/R) output. If at any stage in the playback, the output level of either
the left or right channel goes above O dB, this fact is indicated by the presence
of a red rectangle at the top of the meter of the offending channel; this
rectangle remains visible until either the playback stops or you click the meter.
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If the Sync Faders box at the bottom of the Master Section
is cleared, you can move the left and right master faders
independently; otherwise they are yoked together.

If the Rec Monitor box is checked, you will hear the

incoming signal with all the effects active in the signal

L chain; the degree of latency (delay) is partly determined by
the buffer size (Pref Hard Buffer Size).

ow(FZ W) e buffer size (Preferences > Hardware > Buffer Size)

E Rec Monitor

Above this is a list box, marked ‘Out’, displaying the audio
-6db  -6db hardware channels of the main output. The output channels
available are dependent upon your audio hardware.

From the Aux list box(es), you can select from among the
available VST plug-ins or Audio Units (Mac only) one or
more Aux effects — the choice, again, being dependent
B S upon the settings on the Plug-ins page of the Preferences
- dialog. Each time you select an effect, a new list box
— appears to permit the selection of another. At the same
time, a second row of rotary controls (marked ‘Ax’) appears
in the channel strips. Clicking the name of the selected
effect in the Aux window of the Master Section opens a new
window in which the parameters of the selected effect are
displayed and can be adjusted. After selecting a new effect,
this window opens automatically.

Master Out

The box at the top, displaying the word Configure, is a cascading
list box that combines the functions of a View menu with o

commands for adding and deleting group and instrument tracks: Hide EQs
Hide Inserts
Hide Aux Sends

— By checking and unchecking the first three items, you can
toggle the display of the EQ, Insert and Aux sections on and off.

Group Tracks »
Instrument Tracks »

Show EQ Graph |
— Group tracks, which you can create and delete using the next

item in the list, are useful when you are happy with the balance

between a group of instruments or voices (such as the components of a drum
set; or the sopranos, altos, tenors and basses of a choir) but wish to make the
entire group quieter or louder relative to the rest of the channels. Obviously if
you had to move each of the faders in turn, you would be in danger of mucking
up the balance you had perhaps gone to some pains to establish; so you begin
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by creating a group track and routing the outputs of the member channels to it;
only then do you begin the difficult task of establishing the balance between
members of the group, which you only need to do once; thereafter, if you need to
make the entire drum set or the entire choir louder without disturbing the level
ratios between members of the group, you will move the group fader, leaving the
channel faders untouched.

The inputs of a group track are not selected in the group channel; instead, the
various channels that comprise the group select that group as their output,
which (obviously) comes to the same thing. The nesting of groups is also
supported: all you do is route the output of one or more groups to a higher
group; you might, for example, wish to route the output of the group comprising
the three backing vocalists to a higher group that included the lead vocals; or
unite the components of the drum set in one group, the other percussion
instruments in a second group, and then create a third group uniting both drums
and percussion). By default, newly created group tracks are stereo; if you wish to
use them mono, select Mono from the list box above the Pan pot.

— Instrument tracks, which are created and deleted in the same way, serve as
containers for VST- or Audio Unit- (Mac only) instruments. These are ‘played’ by
audio tracks using Melodyne'’s Audio-to-MIDI function as described in §05-05
MIDI Out Options.

— The final command in the Configure drop-down is Show EQ Graph. This displays
the combined effect of all the equalizer bands in the channel the EQ parameters
of which were last modified; i.e. the frequency response of the EQ section as a
whole. By selecting a point and dragging it vertically or horizontally you can set
the Gain and Frequency parameters of the selected band. The Q factor, however,
can only be controlled using the rotary control in the channel strip.

|nN0n EQ: Track 1

The EQ Graph
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07 Integration and global functions

07-01 Melodyne Bridge

The Melodyne Bridge is a small effect plug-in that establishes a link to Melodyne.
The Melodyne Bridge enables another application to integrate Melodyne and use it
as though it were a plug-in, even though both programs in fact remain

independent.

LA Ohne Namen : MelodyneBr

|. | @® Transfer

e

e
—. -

mm_bridm Audio Unit 3.0.1.4

O—

Bridge E

Connect to

=
L O Playback

L

GCoing to send audio

System Load

The interface of the
Melodyne Bridge
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The concept
In your sequencing and recording application you have one or more audio tracks
that are linked to one of its mixer channels:

Host Application

12 |z |a s |8

Mixer

To edit this audio track using the functions of Melodyne, the Melodyne Bridge
plug-in must be inserted into the signal chain as the first insert effect.

Host Application

1z s |« |5 |s Malcdyne
e e S—— Bridge

Mixer

As soon as the first Melodyne Bridge plug-in is inserted, Melodyne launches and
creates a new, empty arrangement.

If Melodyne isn't running, the Melodyne Bridge is simply an empty loop. If

Melodyne is active, the Melodyne Bridge serves two purposes:

— In Transfer mode, it transfers the audio signal from the recording program to
Melodyne

— In Playback mode, it is used to return the edited audio signal from Melodyne to
the host mixer

In Transfer mode, the Melodyne Bridge copies the audio data during playback by
the host to the Melodyne track selected from the drop-down menu of the plug-in.
If, for example, in Transfer mode, you transfer Bars 3 to 5, the result is this:

Host Application Melodyne

O EX EX ER E 1| M;T:'"g:“
e S l \ J

Arrangment

Mixer
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Now you can edit the recorded material in Melodyne. The Melodyne Bridge plug-in
switches automatically to playback mode after the data transfer; if you now play
back Bars 1 to 6, the Melodyne Bridge takes over the signal from Melodyne and
routes it to the mixer of the host. Where in Melodyne no audio material is present,
the original signal of the host program is looped right back to it.

Host Application Melodyne
vz s |8 |5 s e 1 |2 |3 jal[sills
wem e S | —
Song Amangment
Mixer
Host Application Melodyne
t 2 o |+ s e | tJ2 Ja Ja |5 s
Song Amangment
Mixer

In Bars 5 and 6, you again hear the original signal.

Host Application Melodyne
tJ2 s 4 s s ey 1 J2 Js Ja s s
e R - - —
Song Amangment
Mixer

If you are using the transport functions of the host application, the two programs
will run in sync. If, on the other hand, you start the playback in Melodyne, whilst
you will hear Melodyne’s signal via the mixer of the host application, the transport
functions of the host application will be sidelined. Thus, depending upon which
Transport Bar you use, you have the choice of either listening in isolation to the
signal from Melodyne, as you will often need to do whilst editing, or hearing the
synchronized output of the two applications.

Note: this only applies to host applications such as Cubase or Pro Tools that
continuously render their plug-ins. With programs such as Logic or Digital
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Performer, this is not the case. If with applications such as these you wish to hear
the signal from Melodyne in isolation, Melodyne can route the audio output to the
first two channels of the audio hardware as soon as it is moved to the foreground.
This only works with hardware accessed via Core Audio (and therefore only on the
Mac) and also not with all types of driver — you just have to try it out to discover
whether or not it works with a concrete configuration. You can switch this feature
on and off on the audio page of the preferences dialog when Melodyne is operated
with the Bridge; the option is named Use Audio Hardware for Non-Synchronous
Playback.

The Melodyne Bridge plug-in reports by means of lines of text in the bottom left-
hand corner whether or not a connection with Melodyne is active as well as its
current status. Transfer and Playback modes are displayed in a graphic of the
signal-flow. In the rectangular field on the right, the name of the Melodyne
arrangement being used for the editing is displayed at the top. If you have saved
the arrangement and later open the song in the host, you can open the Melodyne
arrangement in Melodyne using the drop-down menu next to the arrangement
name (and should it also be necessary launch Melodyne) or else localize the
arrangement on your hard disk.

Working with the Melodyne Bridge

Start your audio sequencer (e.g. Cubase SX) and load a file containing a vocal
track. In the signal path of this track, load the Melodyne Bridge as the first insert
effect. If Melodyne is not already running it should launch automatically and
create an empty arrangement. It is advisable to save this arrangement at once, in
the project folder of your Cubase song, for example. Now return to the Melodyne
Bridge in Cubase. The Bridge will now display the names of the tracks of the
Melodyne arrangement in the Connect To drop-down menu.

T E Select Track 1 from the drop-down menu. Now the vocal
: track on “CH 1” in Cubase (the channel in which the
Melodyne Bridge is loaded as an insert) is linked with
Connectto

— Track 1 in Melodyne. Place the playback cursor in

~ Cubase at the bar from which you wish to begin
transferring the vocals to Melodyne. Activate, if
necessary, Transfer mode using the switch in the signal
flow graphic. Start playback in Cubase, allow 2 bars to elapse and stop playback.
Note the way the mode switches automatically from Transfer to Playback. In
Melodyne, the audio material that has been transferred is now detected
automatically and displayed on Track 1.
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Return to Cubase and create a loop encompassing the region that has been
transferred but including also material that has not. Commence playback in
Cubase. Now return to Melodyne and open Track 1 in the Editor. Move a few notes
around in the usual way, varying their pitch or position. In this way, you can edit
your material in real time, with the signal all the time transmitted to the mixer of
your host application.

Tip: for the creation of choirs, for example, it can make sense to route several
tracks from Melodyne on one Bridge, so as to bounce the material mixed in
Melodyne directly onto a track in the host. This is very easy to do — you just
select several tracks using the drop-down menu of the Melodyne Bridge — but it
only makes sense if you have already transferred all the audio tracks to Melodyne
and are only working in Playback mode.

When you have done all the editing you mean to do, it makes sense to bounce the
track(s) in the host, thereby saving the changes you have made in a new audio
file. You can then deactivate the Melodyne Bridge plug-in or remove it from the
affected tracks and reduce the load on the CPU. A point to note here is that the
Melodyne Bridge requires two audio applications to run simultaneously on the
same computer and — to add to the gaiety — communicate with one another at
the same time. It is therefore unrealistic to imagine that you can transfer an
unlimited number of tracks — especially if the host computer is already under
pressure. Unlike other plug-ins, the Melodyne Bridge does not provoke stuttering,
drop outs or crashing in the event of overload; the only symptom is that
communication between Melodyne and the host is broken off, and the latter
therefore behaves as though Melodyne were not even running. In the worst case,
however, at the threshold of overload, the link between Melodyne and the host can
flicker on and off producing strange sonic effects.

The load on the processor generated by the Melodyne Bridge is usually not taken
into account by the CPU load display of the host. For this reason, the Melodyne
Bridge has its own System Load display, that shows the additional load on the
host processor — the part not reflected in the readout of the host application —
produced by the Melodyne Bridge plug-in; if the two figures added together come
to more than 100%, you can expect dropouts of the type just described. The
Melodyne Bridge, like the ReWire implementation, takes full advantage of
multiprocessing architecture (if present) and therefore runs more smoothly on
computers with dual processors than those that have to make do with one.
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Depending upon the host, the Melodyne Bridge can either always transfer audio
back from Melodyne (i.e. even if the Melodyne Bridge plug-in is on an empty track
of the host) or only if audio is to be found in the corresponding part of the track in
the host. The first category covers the case of Pro Tools and Cubase inter alia and
the second that of Logic, since the Bridge functions as an insert effect and Logic
(along with a number of other host applications that work on the same principle)
assumes that an insert effect does not require processing if no audio signal is
being sent to it — the program has no way of knowing that the audio signal is not
being supplied by the track but by Melodyne via the Bridge plug-in. The Bridge
represents such a situation by greying out all the signal paths. What can help here
is to fill the ‘empty’ sections in the Logic arrangement with muted audio parts.

Another possibility is:

— to save the Melodyne arrangement once all the tracks have been transferred;
—to quit Melodyne;

— to remove the Melodyne Bridge plug-in;

—to activate Melodyne’s ReWire channels in the host;

— to start Melodyne again and establish a ReWire connection with the host;
—to reload the arrangement that you have just saved.

In Bridge mode, on the Bridge (8606 Preferences \
page of the Preferences dialog, R |

you can find two Melodyne # Fast Playback Start (loads audio file into RAM)

Bridge-specific options. The first Sl hardwate when plaving bk axynchmmoi.

is: Use Audio Hardware for Non-
Synchronous Playback, the
purpose of which has already been explained; and the second Faster Playback
Start. With this option, you can ensure that Melodyne synchronizes with the host
after a delay that is constant and as small as possible. Of course, considerably
more RAM is required to implement this option as it involves reading the file from
the hard disk and loading it in its entirety into RAM. If your computer has a less
than abundant supply of RAM, it may be obliged to use virtual memory, which
involves using ‘page’ (or ‘swap’) files to swap pages of data out of physical
memory when necessary; the upshot being that instead of the hoped-for
acceleration in performance, there is a marked braking. If this occurs, it is better
to deactivate the Faster Playback Start option.

You can find more information concerning the Melodyne Bridge, current
compatibility lists and configuration tips at http://www.celemony.com/support.
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07-02 ReWire
Like a number of other applications, Melodyne supports communication via
ReWire and can be used as either a ReWire host or a ReWire client.

Melodyne as ReWire host

Launch Melodyne and open a new or existing arrangement. Select Window >
ReWire Devices followed by the ReWire client from the drop-down list at the top of
the dialog box and launch it either by clicking the Start Application button or in
the normal way. Select the channels to be used using the switches in front of the
channel names in the ReWire Devices window. For each ReWire channel,
Melodyne adds a channel strip in the Mixer the input of which is fed by the output
of the respective channel of the client. The first two channels can be combined to
make a stereo channel. Commence playback and work with both programs. It is
also possible to combine multiple programs with Melodyne. Always quit the client
program before quitting Melodyne!

Melodyne as ReWire client

Start the host program and activate Melodyne’s ReWire channels in the mixer of
the host application. Start Melodyne; it will recognize the running host program
and ask how you wish to link it with Melodyne. Select ReWire.

— — — = Open a new or existing

T arrangement. Open the

How would you like to connect Melodyne to the running host M iXEI’ the OUtpUtS Of Wh |Ch
;QG application.

| are now connected to the

((Don'tcomnect ) ((ReWire ) (MelodyneBridge’) corresponding ReWire
channels in the host
application. The inputs are
not available when Melodyne is connected to a program as a ReWire client. Unlike
other ReWire programs, it does not matter in which order you quit the
applications. If, for example, you relaunch ‘Live’ without quitting Melodyne, the
connection between the two programs will generally be re-established.

In the Sync drop-down list in the Transport Bar, you will

find the option Link Transport to ReWire host, which is e Transport Bar_
normally selected and ensures that the host application |~ mei wor oo 0001.01.01
. [ Punch Out
st.arts and stop§ whenever Meloc!yne FIoes, under thgse | G 4| « [ » [p || O r
circumstances it is normally of little importance which - %:nﬂ M‘z‘l;\lﬂﬂ; —_—
| eceive ync
program'’s transport bar you use. If you deselect this | Open Port Settings

| « Link Transport to ReWire Host |

option, however, you can start and stop Melodyne
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independently of the ReWire host, which allows you to listen to the edited material
in Melodyne without hearing the arrangement in the ReWire host at the same time.

ReWire-related preferences
In the ReWire Preferences, which are only accessible in ReWire mode, you will find
two options: Fast Playback Start and Opening Files takes Tempo from ReWire host.

. . eanon Preferences
With the former option, you can
: |
ensure that Melodyne synchronizes AT T
with the ReWire host after a ! Gpening files takes tempo from ReWire host.
constant and considerably shorter i i =6 om

delay than in earlier versions. Of Y
course, considerably more RAM is

required to implement this option as it involves reading the file from the hard disk
and loading it in its entirety into RAM. If your computer has a less than abundant
supply of RAM, it may be obliged to use virtual memory, which involves using
‘page’ (or ‘swap’) files to swap pages of data out of physical memory when
necessary; the upshot being that instead of the hoped-for acceleration, there is a
marked slowdown in performance. If this occurs, it is better to deactivate the Fast
Playback Start option.

The option Opening Files takes Tempo from ReWire host causes Melodyne to
adopt the current tempo of the ReWire master when defining the tempo (Bar/Time
Ruler setting) of newly opened files (see below).

Latency matching in ReWire mode: In ReWire mode, Melodyne supports latency
matching with the ReWire host, if needed. What this means is that in the event
that the position of the song cursor in Melodyne does not correspond with the
heard signal, you can correct the problem. As a starting point, set the audio
latency displayed in your host, or else just experiment until the position of the
cursor corresponds with what you are hearing. Please note, however: this
parameter merely compensates for a possible discrepancy between what you see
and what you hear; the audible signal transmitted to the host is always in sync!

Tempo setting and synchronization

The tempo in beats per minute (BPM) displayed in Melodyne’s Transport Bar
ought, in principle, to be that of the audio file loaded; (if the file was recorded at
100 BPM, the tempo displayed should be 100 BPM, and so on). When Melodyne
opens a new file, Melodyne analyses the tempo of the material and ‘suggests’ a
tempo setting. If this is not, in fact, the tempo of the file, the user should enter
the correct tempo (with the Autostretch function deactivated!) and, if need be,

146 Melodyne cre8/studio user manual



07-03 Synchronization via MIDI Clock and MTC

drag the first beat to the beginning of a bar, so as to ensure that the Bar/Time
Ruler is correctly aligned with the audio — a sine qua non of correct timing
editing in Melodyne. Doing all this, it should be understood, only affects the
tempo definition — the spacing and alignment of the gridlines or ‘columns’ in the
background display — and not the audio file itself. It may be necessary to move the
beginning of the first bar to the desired position by dragging the little grey ‘1’
marker in the Bar/Time Ruler, (again: with the Timestretch function deactivated!).
Double-click the small grey ‘1" and type in a value if you need to move the ‘1’ by
two or more bars.

As far as the tempo in ReWire client mode is concerned, two situations have to be

distinguished:

a) the file to be opened is derived from the ReWire master, where it has just been
recorded: in this case, in all probability, the file will already have the same
tempo as the host, which has already been detected, and it is unnecessary (and
may even be counterproductive) to let Melodyne determine the tempo; instead,
you need Melodyne to adopt the tempo of the master as the tempo definition,
so select Newly Opened Files Adopt the Tempo of the ReWire Master;

b) the file to be opened does not have the same tempo as the master; in this case
Melodyne should be allowed to analyse the material and suggest a tempo
setting; though, again, it may be necessary to correct this manually. Once the
tempo has been correctly defined, Melodyne is able (using a process that could
be described as ‘realtime time-stretching’) to play back the audio file in time
with the ReWire master. During playback, Melodyne’s Tempo box is deactivated
and simply displays the tempo of the master, so you cannot enter a new value
manually. Note that when Melodyne adjusts the playback tempo of the audio
file to match that of the host, it is not altering the audio file itself; if you do
want to change the tempo of the audio file, you have to halt the playback,
check the Autostretch box, enter the desired tempo manually, and save the file.

You can find more information concerning Melodyne and ReWire, current
compatibility lists and configuration tips at http://www.celemony.com/support.

07-03 Synchronization via MIDI Clock and MTC

Melodyne can be synchronized with other programs via MIDI, using either MIDI
Clock or MIDI Time Code. Melodyne can also transmit these synchronization codes
and act as the master. Melodyne is also capable of adjusting to variable tempos in
real time, but if you wish to take advantage of this capability, it generally makes
sense to use MIDI Clock, as MIDI Clock — unlike MIDI Time Code — is based on
musical beats.
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To employ synchronization, first select which MIDI ports should be used to send or
receive the signals (and whether the MIDI Time Code or the MIDI Clock protocol
should be used) using the list boxes provided on the MIDI Ports page of the
Preferences dialog, which you can open either in the normal way (Preferences >
MIDI Ports) or by selecting Open Port Settings from the Sync drop-down list in the
Transport Bar. When you have finished in the Preferences dialog, return to the
Sync list box in the Transport Bar and select Send MIDI Sync or Receive MIDI
Sync as appropriate.

E " Melodyne File Edit Definition e Navigation MIDI Window Help
¥ Autoscrolling NEF
¥ Always Show Pitch Curve X#C
Always Show Note Separations XEE
Show Play Algorithm Parameters HEL
Show Audio-to-MIDI Parameters N#EM
Show Pitched Notation on selected Track
Show Score Notes BN
24 =
25
29.97 drop
v 30

+ Ignore Hours

To select the type of SMPTE used for the transmission of MIDI Time Code, choose
View > SMPTE Type followed by ‘24’, '25’, ‘29.97 drop’ or ‘30’ from the sub-
menu.

If Melodyne is synchronized using MIDI Clock and the Cycle box in the Transport
Bar is checked, Melodyne will cycle between the locators in sync with the MIDI
Clock; if you would prefer it to follow the position of the MIDI Clock master, clear
the Cycle box.

07-04 The function ‘Spot to Pro Tools’

The function Spot to Pro Tools has an important role to play in streamlining the
workflow when Melodyne is used in combination with Pro Tools — especially when
Melodyne is used as a ReWire client with Pro Tools — but is otherwise irrelevant.

Note: whilst the option Spot to Pro Tools is shown automatically when a file

containing Pro Tools regions is first opened, it is hidden by default; to show it,
select Edit > Preferences > Other > Enable Spot to Pro Tools.
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Explanation: ‘regions’ is the term used to describe sections of an audio file within
Pro Tools. Technically, they consist of pointers to the beginning and end of all or
part of the file. For every take, Pro Tools defines at least one region encompassing
the entire sound file. The order in which the regions that comprise each track are
played back is determined by a ‘playlist’. When a region is created, it is given an
Original Time Stamp and a User Time Stamp, which are initially identical and
reflect the SMPTE time at which the audio was recorded. The User Time Stamp
can later be redefined with the Time Stamp Selected command in the Regions List
pop-up menu. If you open a time-stamped region in Melodyne while it is linked to
Pro Tools via ReWire, the data will be placed in exactly the same ruler position in
Melodyne as in the host application. Once the file has been saved, it can therefore
be reinserted with sample accuracy into the host application at exactly the right
place.

How to use Spot to Pro Tools when you are running Melodyne as a ReWire client

with Pro Tools

— In Pro Tools, select the audio file or region that you wish to edit using Melodyne.
Choose Export Region Definitions from the Audio Regions List pop-up menu or
in the case of audio files Time Stamp Selected from the Audio menu. Now open
Melodyne as the first insert effect on the track; the program should launch
automatically.

— If no ReWire channel is selected, please select one. This should happen
automatically in the case of stereo files but has to be done manually when

working with mono files.

— Inside Melodyne select Open from the File menu and navigate to the audio file
to be edited or else to the audio file containing the region to be edited.

— When the file to be opened contains a region, Melodyne opens a dialog window
from which you can elect to edit the entire file or only one region.

Open Region

The shec!ed soundfile contains regions

O Open entire file This is the window that appears when you open an
® Open region: audio file containing one or more regions
Mitte.L )

Start: 0:4.000000
End: 0:12.000000
User Time: 60:5.996395

#4
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— Open the file or region selected and edit it using Melodyne.

— Select Save Audio from the File menu. In the top right hand corner of the
window that appears, there is a menu from which you can select either
Interleaved or Split Stereo format. If spotting from stereo files, you should select
Split Stereo. At the bottom left, you will find a checkbox marked Spot to Pro
Tools. If you check this box, the audio files once saved will be loaded back into
Pro Tools at the current cursor position. If several tracks or stereo tracks are
exported in this way, the first will be inserted into the selected track and the
others one after the other into the tracks that follow.

NB: You will only see the Spot to Pro Tools checkbox if you have selected Enable
Spot to Pro Tools (either automatically or manually), which you cannot do if you
have selected Individual Range for Each Track or Individual Sound File for each
Marker Region under Range.

The Save Audio window with the
Spot to Pro Tools checkbhox

= g Spot To ProTools

When saving audio files, Melodyne generates suggested names automatically by
inserting the characters “.melo” before the file ending or channel index (if
present).
Examples: Hallo.aif -> Hallo. melo.aif

Hallo.L.aif -> Hallo. melo.L.aif

If this name already exists, “.melo.1” is used, and so on. If you don’t mind
overwriting the original file, of course, you can simply use the same name again.

NB: When Melodyne saves a file that contained regions when it was opened, it
saves a time stamp with it. This will ensure that if you import it manually into a
Pro Tools session, it will automatically be put in the right place.

Editing audio files in split stereo format

From version 3 onwards, Melodyne supports audio files in split stereo format, i.e.
files in which the data for the left and right channels are stored in separate files,
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with the suffixes ‘L’ and ‘R’ respectively. Like the Spot to Pro Tools function, this
audio file format is almost exclusively of importance when working with Pro Tools.

Opening split stereo files: If you open a file that is part of a split stereo file,
Melodyne will look for and open automatically the companion file (i.e. the file for
the other channel), if it is available. If, for example, one file is called
“Audio.L.wav” and the other “Audio.R.wav”, whichever one you open, Melodyne
will open the other at the same time. In either case, the reference of the file
names will be based on the left channel, so whichever you open, “Audio.L.wav”
will appear in the title bar of the window.

When saving audio files, you can decide whether you wish split stereo or
interleaved files to be created. When you save in split stereo format and the name
does not already make the fact that it is a split stereo file clear, Melodyne adds
the letters ‘L’ and ‘R’ to the files containing the data for the left and right
channels respectively. If on the other hand, the name chosen already ends with an
‘L’ or an ‘R’, Melodyne uses this name for the corresponding channel, and a
similar name (substituting only an ‘R’ for the ‘L’ or the other way around) for other
channel.

.mdd files Even split stereo files only require one mdd analysis file. This contains
the information for both channels, even though it only bears the name of the file
for the left channel. In other words, if you open the audio files “Audio.L.wav” and
“Audio.R.wav”, Melodyne will create an analysis file called “Audio.L.wav.mdd”
containing the analysis data for both channels.

07-05 Remote control using a MIDI controller

You can control most of the functions in Melodyne — including the Transport Bar,
the Mixer and even Melodyne-typical functions such as transposing the
fundamentals or formants of individual tracks or the entire arrangement — using
an external MIDI controller, either by assigning the various knobs, switches and
faders to Melodyne functions yourself (which is not difficult) or by choosing a
controller already supported by Melodyne (such as MackieControl, LogicControl
and Radical SAC), in which case the work has already been done.

To assign functions to the controls of an external device not already supported by

Melodyne, choose Preferences > MIDI Remote Control followed by Add > Generic
Controller from the Options list.
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enn Preferences |

.~ MIDI Remote Control Options .

XTI Generic Controller |
Remove Mackie Control

Edit Legic Control

Radikal SAC Control

) Generischer Controller 1

Import
Export

The MIDI Remote Control page of
the Preferences dialog showing
the cascading Options list

:4

By ‘generic controller’ is meant simply any MIDI controller other than those
specifically named below (for which the assignments have already been defined).
It is also possible to import or export predefined controller assignments.

Once a controller has been registered with Melodyne in this way, you can activate
it using the checkbox to the left of its name on the MIDI Remote Control page of
the Preferences dialog. If you double-click the name (or select Edit from the
Options drop-down list), you open a window in which you can define your
controller assignments. These can be organized into several banks, so that you can
assign to elements of your MIDI hardware controller in each bank a different
function for the operation of Melodyne. When a controller is first added, it has an
empty bank without assignments (or ‘mappings’). First click the Title field and
name the new controller before selecting from the MIDI In list box the MIDI In
port to which your controller is connected.

With the Mapping Add key, you can add as many assignments as necessary. Each
assignment is displayed as a line in a table. In the first column, you can give to
each of your control elements (such as faders, buttons and so on) a name of your
choosing. The next three columns show the MIDI value that the control element in
question sends. You can enter the type, MIDI channel and number either manually
or directly via MIDI. When the MIDI connection is active (in which case the box
beside its name in the Preferences dialog is checked), the values of the selected
controller mappings are determined by the incoming MIDI events. These could be
either controller, Note On/Off, program change or pitch bend messages. The first
four columns remain the same for all banks, since they represent the hardware
device itself.
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enn New Window
Title: Midi In: Bank: Mapping:
Generischer Contr [Nm! ﬂ [Bank 1 m [ Add ] [ Remove ] [ Add J [ Remove ]
Title [Event [cr [num Jaction N [inx i max
|Controller  # (1 [0 |MasterGain - \ oo 13
Mixer 2
Windows 3
File Commands >
Melody Manager Commands »
Edit Commands 3
Tools Commands »
Transport and Navigation »
Change Global Tempo
Various Options » Change Global Pitch
MIDI Remote Control » Change Global Formant
Change Track Pitch
Change Track Formant
Reset Global Tempo
Reset Global Pitch
Reset Global Formant

— Reset Track Pitch

| Reset Track Formant

The window for mapping the control elements of a MIDI remote controller to Melodyne functions

In the next column, each cell contains a hierarchically structured drop-down menu
with the actions that are available. The entries in the last four columns —
channel, index, minimum and maximum value — are dependent upon the action
that you select. If it is a simple action without a programmable value. such as
‘Playback’, ‘Save’ etc., there will be no entries here. For ‘Master Gain’, for
example, there will be a Min and Max value but no channel or index. For ‘Track
Gain’ on the other hand, you can enter the channel to which this controller is
assigned in the mixer. For ‘Equalizer Gain’ you can additionally enter an index,
since there can be several equalizer bands per channel. The Min and Max
parameters are generally preset to sensible values, but you can change these
values as you wish. For example for the action ‘Track Pitch Change’, the Min and
Max parameters are set to -24 to +24 (semitones), but if you only want to use this
action for fine-tuning, you can also set the values e.g. to -0.5 to +0.5.

If you add a new bank for other mappings, the current one is always copied, so
that you do not have to enter all the mappings again in the event that you only
wish to change some of them in the new bank. If you are working with several
banks, you should always assign one of the actions “Select Bank by Index”,
“Select Bank by Value”, or “Select Next Bank” and “Select Previous Bank” to a
definite control element of your hardware, so that you can select between banks
using your MIDI hardware.
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As long as the window for the controller definition is open, the assignment to the
selected mapping is determined by incoming MIDI events. As soon as the window
is closed or moved to the background, the MIDI events produce the defined
effects.

MIDI keyboard keys or controllers that are assigned to an action can no longer be
used for normal playing; in other words, if the lowest keys of your keyboard have
been assigned to the actions ‘Start’ and ‘Stop’, for example, they can no longer
used to play notes.

The specific control devices, such as Mackie Control, have their own definition
window, in which normally only the MIDI port and certain actions for user-
definable keys can be entered.

07-06 Preferences

Here we would like quickly to familiarize you with Melodyne’s Preferences. Open
the Preferences window from the menu.

The Preferences dialog contains several pages; you choose between them using
the drop-down list at the top. In ReWire mode — as in Bridge mode — a special
page appears with additional preference options; the ReWire preferences are
discussed in the ReWire section of this manual; the Bridge settings in the section
dealing with the Melodyne Bridge.

é (&) E) - ~ Preferences

.~ Hardware B

Device Driver: | CoreAudio: MOTU Traveler

Sample Rate: | 44.100 kHz

Buffer Size: | 512 Samples

On the Hardware page, you
will find the following

[ lgnore buffer underruns

=)
B
= Hardware
B

File Cache: | 10 sec

—/A paramEterS:

— Device Driver: This is used to select the audio driver. On the Mac, this is usually
the Core Audio driver for the integrated or optional audio hardware; under
Windows, a DirectX or preferably an ASIO driver for the audio hardware in use.

— Sample Rate: If the audio driver permits such a choice, you can set the sample
rate to be used for recording and playback with this parameter. This value must
not necessarily be the same as the sample rate of the audio files used. The best
audio quality, however, is obtained if the sample rates are the same.
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— Buffer Size: This parameter shows the size in bytes of the buffer used to
communicate with the audio hardware. Small values result in low latency times;
large values in correspondingly greater ones. Please note that short latency times
can result in a higher CPU load and the user interface responding more slowly or
in dropouts during playback. With DirectX, 2048 is a sensible value for the
buffer size, whilst for all other drivers, a value of 512 is recommended. The
amount of latency also depends upon the hardware and the sample rate
selected: high sample rates result in faster latency times and vice versa.

The Ignore buffer underruns checkbox: With this switch, you can order Melodyne
when running on very slow computers to tolerate a click during the playback
rather than producing dropouts as a result of lack of power. The reason for this
parameter is that many audio cards react sensitively to such dropouts and can
even cause the computer to crash. Activate this switch if you have the feeling
that that is happening; as a rule, however, you will not need this parameter and
can safely ignore it.

File Cache: This parameter determines how much sample time Melodyne keeps
in main memory during playback. If you are using processor-intensive functions
(such as altering the pitch of all notes at the same time during playback or
permanently altering the tempo of the entire arrangement), small file cache
values can lead to a “buffer underrun” producing dropouts in the audio stream.
High values, on the other hand, can impose heavy storage demands. In most
cases, 5 or 10 seconds will be a good setting for this parameter.

| S_O O_ b ~ Preferences - |

.,_J Recording E

File Format: | AIFF

Recording

i Folder fov inswved Adraiigements: The Recording page of the
(Al Preferences dialog is
concerned with the preferred
audio file format for
recording. Loaded and edited files are always saved in Melodyne in their original
format. With these parameters you choose the format of files recorded or created
in Melodyne:

16 bit linear PCM

— File Format: Here you have the choice between the same formats as those that
Melodyne can also load: AIFF, WAV, SND and Sound Designer Il (this last on the
Mac only).
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— Resolution The wordlength of the audio file in bits: 8, 16 or 24 bits; in
Melodyne studio, if desired, 32 bits is also possible

In the lowest line, after clicking the Set button, you can select a folder for
recordings that are created in an arrangement that has not yet been saved. As
soon as you save the arrangement, the recorded files are moved from this folder to
a newly created folder that has the same name as the arrangement and is stored
in the same place.

800 Preferances Appearance
fovence - | The Appearance page brings together a
- [ Classie . .
sacka “: T = number of options concerning the appearance
= and behavior of Melodyne.
oae Baeder: !_ - Style: from this menu, you can now select
= = 2 between two preset styles ("Gray" and "Blue")
Aunoseraling: [Page wer Page ] for the user interface or a user-defined colour
Med C 252) i {4 L] scheme. The default is "Gray". If you select
Temoo Display Format: | 123.4 ) . .
Bitow sl oe either of the preset styles, the following four
88 Show Siider Valves while Editing fields have no significance. If, on the other

hand, you decide in favor of a ‘Custom’ look,
you can choose new Background, Note and Note Border colors. Play around with
the settings until you find the appearance you like best. From the Unselected list
box, you can determine the brightness of the notes of unselected tracks with both
the ‘Classic’ and the ‘Custom’ settings.

— Autoscrolling: Here you can decide how the display follows the position of the
cursor during playback. If the first option, ‘Smooth’, is selected, the display
scrolls smoothly; if you choose Page per Page, the display moves to the next
page as soon as the cursor runs off the page.

— Mid C (262) Name. Here you can choose whether Middle C (262 Hz) should be
given the name C3, C4 or C5, as there are various naming conventions in
common use for the various octaves.

— Tempo Display Format: determines how many decimal places should be used
when displaying the tempo. The setting affects the Transport window, the Real-
time Play Offsets, and the Time Ruler, but in that case, of course, only when the
input field is active.
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— The Show Tool Tips and Show Slider Values while Editing checkboxes allow you
to decide whether tool tips should always be displayed and whether the values
you are currently modifying should be displayed next to the mouse pointer.

New Arrangements

The Preferences property sheet contains a page that allows you to select certain
options for newly created arrangements. These include Time Background (the
choices being: Bars & Beats, Seconds, and SMPTE) as well as whether or not the
Beat Snap, Pitch Snap and Cycle should be active. The default value for the
master fader in the mixer is also determined here.

800 Preferences ] First Recording determines
- —— Tempo: When you begin recording
‘ Master Fader Default: (-6 db = | in an empty arrangement, you may
‘ = =) wish the first recording to
s:;zpp:; determine the tempo (in the
| Hcycle acive | absence of an active click or

S G :/ external synchronization) or you

/

may prefer the tempo of the
arrangement invariably to be taken
as correct. The option is off by default; if you wish to activate it, check the box.

Plug-ins

enn Preferences | The Plug-ins page of the
A ) Preferences dialog is concerned
| © Audiolnits Efects & VT Effecs with the plug-ins that can be
| [ e =[Manufacturer = valid = [version used in Melodyne as instruments
| ¥ AuBandpass Apple oK 1.4.0 . .
| AuDeiay Aaple oK 140 and insert or auxiliary effects.
f %ﬁﬂmﬁ"‘i""’”““"' s = - You will find more detailed
| |8 Aucrsticea Poolt o 140 information about the use of
| # AuHighshelfFilter Apple oK 1.4.0 . . . .
| ® Autipass Apple oK 140 s plug-ins in the sections dealing
THETT — o0 I with the MIDI Out options and
| [ Rescan selected Plugins | | show Log ) .
{ ) the Mixer.

/

Under Mac OS X, you can choose whether you wish to work with Audio Units, with
VST plug-ins, with both, or with neither. If you activate Audio Units or VSTs with
the switches at the top of the window, Melodyne searches in your system for
corresponding plug-ins and tries to load them. If one of the plug-in options has
been activated, when it launches, Melodyne looks for plug-ins that have been
added or updated recently. With the two buttons at the bottom of the page, you
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07 Integration and global functions

rescan the selected plug-ins in the event of problems or show a log file with the
results of the scan. The ‘Selected plug-ins’ are those the names of which have

been clicked on and are as a result displayed against the background selection
color; to select two or more plug-ins, Shift-click their names in the normal way.
Whether or not the plug-ins have been activated (checked) here is irrelevant.

As a rule, not all the plug-ins that are installed on the computer are used in
Melodyne either because you simply do not need them in Melodyne or because they
are incompatible and could (in the worst case) crash. For this reason, you can
choose in the Preferences dialog which of the available plug-ins should appear in the
Mixer by checking the box to the left of their names. If the checkbox in front of the
name of a plug-in is cleared (i.e. empty), it will not appear in the Mixer. When
scanning, Melodyne attempts to discover whether there are any incompatibilities and
de/activates the plug-ins at first automatically — you can however change this
setting at any time manually. The latest information on (in)compatible plug-ins can
be obtained from the Support section of the Celemony web site.

Under Windows, you can select the folder for the VST plug-ins used by Melodyne.
The standard folder is the “Vstplugins” folder in the Melodyne program directory
but you can choose any folder you like. Under both systems, activate a plug-in
using the switch in front of its name. It will then appear at once in the menus for
plug-in selection in the Mixer.

@00  Preferences — MIDI Ports
Aworres 1) From this page, you can choose

Defaut Input: [All the default MIDI ports to be used
for the MIDI In and MIDI Out
options in Melodyne (see the
relevant sections of §5 and §6).
You can also select the input and
| output ports for the MIDI Clock or
= MIDI Time Code synchronization

(see the section on Synchronization earlier in this chapter).

Default Output: (Al

MIDI Time Code In: [All

MIDI Time Code Out: | Al

MIDI Clock In: [All

IPEEE®

MIDI Clock Out: [All

MIDI Remote Control

(800 Bisfarences | Here you can select the various
{01 Remte Contl [#)———————————{osie___} | MIDI remote control options for
B Generischer Cantraller 1 Melodyne. These were described

in detail earlier in this chapter.
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Preferences

(6006

o S T

@ Autodetect

| [0 melogic
| 1O percussive
| 1O polyphonic

07-06 Preferences

Detection

From this page, you can switch
between Autodetect and your
own settings as well as adding
and managing your own

parameter sets. The options on this page were discussed in detail in §05-03 The

Detection and Playback of Audio in Melodyne

» Melody Manager Commands
» Edit Commands
» Tools Commands

» Transport and Navigation
P Realtime Play Offsets

» Various Cptions

8nn Preferences "
(o1 |
- Import ...
Action I Key Export ...
¥ Windows Clear Selected Short Cut
» File Commands Reset to Factory Defaults |

Shortcuts

From the Shortcuts page of the
Preferences dialog, you can
assign keyboard shortcuts to
many different actions. This is
done by selecting the action
with the mouse and then
entering at the keyboard the key
combination you wish to use as
a shortcut. From the Options
drop-down list, you can export

or import entire sets of keyboard shortcuts, clear (i.e. delete) the selected shortcut
or reset to the factory defaults. Most of these actions are self-explanatory; some
can only be carried out by means of these keyboard shortcuts.

806

Preferences

~{other B =

Language: |English

Undo: [50 Levels

| ¥ Monitor Note Pitch on Editing
| [ Always use maximum processing quality

| [ Process Stereo Channels Separately

| ™ Consider Original Scale Notes on Scale Shap

¥ Make Group on Trill or Slide Separation

[ Double Click in Melody Manager opens File in MDD Editor
| ) Update MDDs on Saving Arrangement

[J] Auto-Update MDDs in Melody Manager

| [ Enable Spot to ProToals

e

/J

Other

The Other page of the
Preferences dialog brings
together a number of additional
settings.

— The Language list box is used to select the language of the user interface.

— The Undo list box is used to select the number of working steps that can be
undone or redone; if Melodyne begins to react more and more slowly as editing
progresses, reduce the number of undo levels.
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— When the Monitor Note Pitch on Editing checkbox is selected, the local sound of
the note is played (this is called ‘scrubbing’) when you drag blobs upwards or
downwards in the Editor — i.e. edit their pitch.

— Always use maximum processing quality: When saving audio files, Melodyne
uses a sound processing algorithm that increases the sound quality still further,
but which requires more time to process. If you also wish to use this process
during normal playback, activate this option. If you are working with
arrangements with very many tracks or many plug-in effects — and you have
very little processing capacity left — do not activate this option.

— Consider Original Scale Notes on Scale Snap: When converting melody notes to
a different key, Melodyne distinguishes between notes found in the original scale
and notes foreign to it. Notes that were not part of the original scale are not
forced to snap to the degrees of the new scale and can when moved take any
semitone positions. By preserving such notes, the character of the melody is
retained. This is most noticeable when melodies are dragged from the Melody
Manager into the Editor with the Scale Snap function active. The described
behavior also affects changing the key of selected notes when Scale Snap is
active. If you wish to force all the notes of an imported melody to snap to scale
notes, clear the Consider Original Scale Notes on Scale Snap checkbox.

Make Group on Trill or Slide Separation. When this option is activated,
compound notes are formed automatically from the separated notes that were
generated with the “Separate as Trill” or “Separate as Slide” commands; this
makes them easier to work with. See also §05-02 Compound Notes.

Double-click in Melody Manager opens File in MDD Editor: This option is useful
when you are perfecting your Melodyne sample library. It streamlines the process
of sifting through files and editing their properties in the MDD Editor.

Update MDDs on Saving Arrangement: The format of the MDD files (in which
Melodyne stores the detection data relating to audio files) varies depending
upon the version of Melodyne used. If you activate this option, Melodyne will
always save the files in the latest format when an arrangement is saved.

Auto-Update MDDs in Melody Manager: With this option, you can decide
whether or not the Melody Manager should automatically update any MDDs it
finds that are not in the latest format. The MDD files of very early versions of
Melodyne did not contain the information that now makes it possible to display
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their notes in the Melody Manager. When the Melody Manager finds such MDD
files, it can either generate the note information without altering the existing
MDD file or rewrite the MDD file in the latest format to speed up the note
display in the future. By default, this option is not selected so that MDD files are
not overwritten unintentionally. It is not a case here of the general updating of
MDD files; only of the updating of those without information for the note display.

— Enable Spot to Pro Tools: With this option, you can manually activate or
deactivate the Spot to Pro Tools function, which is described in a separate
section of this chapter.

07-07 Audio file management

Melodyne's Audio Files window now distinguishes (through the use of separate
panes) between files that are found in the audio files folder and those that are
merely referenced. Selected referenced files can be moved or copied to the audio
folder and selected unused files deleted from it.

These commands make it easy to track down unused audio files and delete them
from the folder of an arrangement or prepare an arrangement for transfer to
another computer by copying all the referenced files into the audio folder.

enn Audio Files
Referred Files Files in Audio Folder o
Copy Selected Referred Files to Audio Folder
ciskisa YEEESHR P il .
Drumloopl30.wav | 1users jugh_allg...in/ Desktop/ Tour Delete Selected Unused Files from Audio Folder ¥
Bass_S_Chorus.aif fUsers/ugh_allg...in/Desktop/Tour
Bass_13_Verse.aif fUsers fugh_allg...in/Desktop,Tour
Bass_44_Solo.aif fUsers/ugh_allg...in/Desktop,/ Tour
GuitarOffbeat.aif fUsers/ugh_allg...in/Desktop/Tour
Vocals_5_Chorus.aif fUsers/ugh_allg...in/Desktop/Tour
Vocals_13_Verse.aif fUsers/ugh_allg...in/Desktop/Tour
Vocals_20_Verse.aif fUsers/ugh_allg...in/Desktop/Tour
iTrumpel_l.wav fUsers fugh_allg...in/Desktop/Tour 1
Name: Rate: Path:
Duration: Samples:
Format: Size:
A

The Audio Files window with the new file management functions
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08 The MDD Editor

08 The MDD Editor

Melodyne permits not only the correction of possible discrepancies in the
detection but also the detailed and varied fine-tuning of its detection results (you
remember: the file with the file ending “.MDD" created by Melodyne to store the
results of the detection). This process takes place in the MDD Editor, which you
can open with the entry Open MDD Editor in the Definition menu or from the
action menu of the Melody Manager.

eoe Vocals0.mdd "

DF4  310Hz | Special: ~ Separation: 200 % Silence: | -26.0db | Melodic Separation B

AN A A AN
WWA Ty Y

The MDD Editor is used for perfecting the detection results and is distinguished by its red
background

The MDD Editor has a similar structure to the normal editor but is used not for the
modification of audio files but when necessary for fine-tuning the results of the

analysis Melodyne performed when it detected the file. If all you want to do is edit
the tempo of an audio file or correct its intonation, you will only very seldom need
the MDD Editor. If on the other hand you want to work with a recording intensively
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and perhaps use it later again in other arrangements, you should examine its
detection in the MDD editor and if need be fine-tune it.

NB: An audio file is never musically or sonically altered in the MDD Editor; all that
happens is that the assignment of the audio material to musical parameters is
examined and if necessary modified.

08-01 The tools in the MDD Editor

Definition in the MDD Editor should follow a set procedure. First the pitch of any
wrongly detected notes should be corrected and the note separations checked
before the tempo is defined. The order of tools in the MDD Editor corresponds to
the sequence in which the working steps are best performed. It can in certain
cases also be necessary to switch back and forth between the tools.

08-02 The Main multi-function tool

As is the case in the normal editor, the first tool in the MDD Editor is a multi-
function tool and serves for the correction of any falsely detected pitches and the
correction of note separations. The occasional pitch errors are almost always cases
where the note has simply been placed in the wrong octave. You can find these
easily by playing through the melody with the function “Play detected pitch”
(assigned to “p” on the keyboard), before dragging wrongly positioned notes to the
correct pitch using this tool.

You will find more on this subject in §05-03 The detection and playback of audio
in Melodyne, where we introduce the Correction mode for the detection. In this
mode, you can remove this type of detection error more quickly and simply than in
the MDD Editor when working on an arrangement. There you will also find
explanations as to the options in the two drop-down list boxes.

.

1| ' The three tools for the editing of pitch detection
e - === errors or note separations

The next two tools have the same functions as the sub-tools of the first multi-
function tool. Use these tools when you can do without the multi-functionality of
the multi-function tool.
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08-03 Correcting the pitch

The detected pitch of a selected note is displayed in the text fields of the
Inspector; the name of the note (and any deviation in cents) as well as the
frequency in hertz is displayed. To reset the detected pitch, drag the note in
question — or, if necessary, the group of notes in question — near to the probably
correct position. Melodyne will then attempt in the area of the new pitch to
ascertain again the pitch curve it contains. Sometimes notes the pitch content of
which is unclear are attached to a neighboring note as unrecognized parts. These
can be separated off using the next tool and then dragged to the likely pitch.

As a result of the new detection, the neighboring notes may possibly also be
altered in their pitch course. If the result of the displayed pitch course does not
seem entirely correct, you can also double-click a note without moving it.
Melodyne will then re-ascertain the pitch course.

Tip: to check whether the found pitch is the expected one, it is useful to compare
the found pitch with the original using the neighboring keys [O] (which plays the
original) and [P] (which plays the found pitch).

08-04 Correcting the note separations

Often it is a matter of opinion whether an ornament is regarded musically as a
separate note or integrated into the main note; and naturally Melodyne does not
always recognize the intended separation of the notes either. With the tool for
altering the note separations, the dividing up of the notes can be adjusted
correspondingly. Between the notes, you can see vertical lines that show the note
separations. If you wish to move the separation between two notes, drag the
dividing line with the mouse.

If you want to divide a note, as in the Editor double-click on the desired position
within the note and a new separation will be introduced. At the same time, both
parts of the note will ascertain their own pitch centers. Melodyne attempts to
ascertain which is the best place in the note to make the division. For this reason,
it can happen that the dividing line does not appear exactly where you have
clicked within the note. You can however drag the dividing line and move it to the
place where you want it. If you press [Alt]l+[Space] on the computer keyboard, the
selected note will be played exactly in the area between its separations, so you
can easily check whether or not the separation occurs in the desired place.

If you wish to remove the separation and unite two notes, double click the dividing
line between them. If you wish to unite more than two notes, select them with a
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selection rectangle and double-click one of them. These will then unite to form a
single note.

Tip: a convenient way of examining and editing the note separations quickly is to
step through them with the arrow keys on the computer. Position the playback
cursor before the first note and press the right arrow key. You will hear the first
note right up to its separation position. You can go through the notes one by one
in either direction using the arrow keys, listening to each one in turn. When you
hear two notes that ought to be separated, press the down arrow key, and
Melodyne will separate the note heard most recently in the position it considers
most likely. If the separation does not occur in the correct place, drag the dividing
line with the mouse and move it to the correct place. If when you are going
through the material you hear two separated notes that actually should be united
to form one note, press the up arrow and the two notes last listened to will be
united.

310 Hz | Separation: 200 % Silence: -26.0db | Melodic Separation B

PR

The Inspector area for the Pitch/Note

il Separation tool

The Separation parameter determines the sensitivity of the note separation; i.e.
whether a greater or lesser number of sections of the audio file should be
recognized as separate notes. When you select a new value, the process of note
separation will be repeated throughout the audio file.

The parameter for the sensitivity of the silence detection (“Silence”) determines
the threshold beneath which sections of the audio should be considered silent. If
the value ‘Off’ is selected, no silence will be defined and any silence following the
dying out of a note will be added to this note. This parameter also has a general
influence upon note separation. If you select a new value, the process of note
separation will be repeated throughout the audio file.

First find the values for these two parameters and the note separation mode that

are best suited to the material, and only then perform the manual note separation,
since manual separations are lost as a result of the general note separation!
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Tip: With the tool for altering the note separations, you can if need be alter the
beginning of the first note or the end of the last note. It may be that before the
first note identified by Melodyne in a vocal line there is an intake of breath that
you wish to include or Melodyne has set the end of the last note too early, where
in the recording there is a quiet but audible dying away of the note that you would
prefer to keep. In this case, drag the first or last segment borders of the audio file,
and the part that was previously inaudible will be restored.

08-05 The Define Score Time tool

The assignment of notes to time and measure (bar) is performed with the Define
Score Time tool. Melodyne attempts during the detection to determine the tempo
automatically. With markedly rhythmic material with a constant tempo, the
detected tempo will probably be right. If the course of the tempo is in principle
constant, but individual notes are constantly falling slightly before or after the
intended beat, Melodyne will position the bar background in such a way as to find
the best fit with the material played. If the tempo detection is correct, you will
only need occasionally to adjust the position of the beginning of the bar, because
the position of the first beat of the bar is not always clearly recognized. You can do
this most easily by selecting 1/4 from the Quantization menu and moving the
small gray ‘I’ in the Bar/Time ruler to the position where the first beat of the bar is
found.

If the tempo has been correctly identified but you feel that where Melodyne has
written crotchets (quarter notes) it should have written quavers (eighth notes) or
vice versa, you can put matters right by selecting Edit > Define Tempo > Half
Tempo or Edit > Define Tempo > Double Tempo respectively.

If the tempo follows an uneven course, it will usually need further editing. For the
work that follows, activate the metronome click. Then select the Define Score
Time tool.

69.0
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First enter the time signature in the Inspector area, unless the piece is in 4/4
time, which is the default. As soon as you select the Define Score Time tool, a red
line appears at the beginning of the first bar. This is the ‘“Time Anchor’: if you drag
it, the entire bar background moves with it. (Moving the small gray ‘I in the
Bar/Time ruler has the same effect but its movement is subject to the selected
quantization factor). If, on the other hand, you position the Define Score Time tool
in another part of the background at the very beginning of a beat and then drag,
the result will be an alteration of the tempo; the Time Anchor will remain in place.
With a recording that has been played or sung in a very free tempo with a great
deal of variation, you can and should define a separate tempo for each bar, if you
wish notes to be assigned to their ‘ideal’ positions such as those displayed in the
score. This is essential, too, if you are going to want later to adapt the recording to
an arrangement with a different tempo. For this purpose, click on any quarter note
dividing line in the grid, hold the mouse key and drag the mouse to the left or the
right and the grid will be stretched or compressed accordingly. By double-clicking
in the grid at the beginning of a bar, you can fix the set tempo there; a vertical red
line will appear at this position. If you double-click on the line again, you can
remove the tempo fixation at the place in question. The procedure here is exactly
the same as the one described in §05-07 Variable Tempo Editing mode in the
context of the editing of variable tempo in the Arrangement window or Editor.

It is possible not only to set a different tempo but also a different time signature
for each bar; both can be done by typing in new values in the Inspector area or by
double-clicking the values displayed in the Bar/Time ruler.

k[ Edr] 4 1 e 69.0

You can set the tempo and time signature for each bar separately in
the Inspector or Bar ruler

If you wish to remove all tempo changes, you can do this by selecting Edit >

Define Tempo > Equal Tempo. The Define Tempo sub-menu contains a number of

other useful commands:

— If you wish to delete all tempo definitions after a given bar, select Same tempo
for following bars.

— If you wish to remove all time signature changes after a given bar, select Same
time signature for following bars
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— If you have defined irregular beats within a bar and you want to make them
uniform again, select Equal beats in Current bar or Equal beats in Following bars

— If you have defined an irregular tempo by setting a separate tempo for each bar,
the tempo changes normally only occur at the bar lines. If, however, you select
Smooth tempo changes, the tempo will speed up or slow down in the course of
the bar, which means of course that the beats will be of different lengths.

— Set Tempo Zero to Sound Zero places the beginning of the tempo definition
exactly at the beginning of the audio file.

08-06 The Define Beat Assignment tool

If the tempo has been correctly defined, the notation view of the recording at the
top of the window should already be easier to read and more accurate; but there
may still be discrepancies between what is displayed there and what was
displayed in the sheet music from which the performer was reading or was
‘intended’ musically. If the performer did not play with metronomic precision, so
much the better from a musical point of view; that is not something that needs to
be changed. (We are in Definition mode here and are not in any case seeking to
change the performance in any way!). What we are seeking to do is to assign
correctly the notes played to the notes ‘intended’, which when we do come to
reshape the performance later will make working with the notes more intuitive and
flexible.

(AnH el mde

NIFFEMAT

— - The Define Beat Assignment tool

= NEE5S P
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When you select the Define Beat Assignment tool, the notes played are
temporarily moved to the exact positions shown in the notation at the top of the
window. These assigned positions are represented as small blue frames containing
an outline of the note, whilst the actual position of the notes is shown in the
background. You can now listen to the audio file in this quantized form and decide
whether what was ‘meant’ is that which is indicated by the notation. If the
notation does not correspond to the material, you can drag the little frames to
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their correct positions. This can be done either by dragging the notes in the staff
at the top or by dragging the outlines in the display beneath. They will then sound
different from a rhythmic point of view. If you then select another tool, the
temporary quantization will be nullified, since we are in Definition mode and
nothing in the recording itself is being changed; we are only editing the detection.

Note that in the Quantization menu to the right of the Bar/Time ruler you decide
what is the smallest note unit by which you can move the note assignment. If a
note was set by its automatic assignment on a beat the unit of which is smaller
than that set in the quantization menu, when it is moved it will initially be moved
to the nearest defined unit.

The Quantization menu also determines how finely the beats are assigned in
general. The option that permits you to set triplet values here is important. If, for
example, some notes are understood or noted as triplets, select these notes and
double-click with this tool or else select Edit > Define Tempo > Reassign Notes to
Beats.

08-07 The Define Pitch Assignment tool

If the pitch of a note does not lie clearly enough on a degree of the scale, its
assignment to a semitone can be fixed using the Define Pitch Assignment tool.
The assignments appear as blue backgrounds on the semitone degrees; these blue
rectangles can be moved.

anA vesa e
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d_—,lr——_———_— ST TRE The Define Pitch Assignment tool
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Immediately after the pitch detection, all there is a section of the pitch curve
representing a note. Melodyne then attempts to ascertain the ‘pitch center’ (which
the hearer perceives as the pitch of the note) of that curve. Naturally this pitch
center does not necessarily lie directly upon a degree given by a tone scale. For
this reason, in a further step, Melodyne assigns this pitch center to a degree of the
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given tone scale. This is the pitch to which the note would move, if it were
corrected to the tone scale. These degrees are represented by the blue rectangles
beneath the notes and necessarily coincide exactly with a ‘key position’, whilst the
pitch center of the notes found could also lie somewhere between the keys.

The Define Pitch Assignment tool serves to correct the assignment to a key of the
pitch center found if the center lies too unclearly between the keys. For this, move
the blue rectangle behind the note to the intended key position. When this tool is
active, the notes are temporarily quantized to the pitches to which they are
assigned, and now by listening you can decide whether the ascertainment of the
pitch center seems right.

08-08 Assignment to tone scales

The Define Pitch Assignment tool is also used for the detection and establishing
of the tonality and scale of the melody. The scale set here has important
implications among other things for the handling of chromatic notes foreign to the
key or scale. This is useful as it allows chromatic passing notes (and therefore the
integrity of the melody or phrase) to be preserved during transposition when the
Scale Snap function is active.

Although advanced functions like these are of more benefit to those with a
grounding in musical theory, other users, too, can profit from experimenting with
different scale definitions even if they have no notion of the theory of harmony;
indeed the new display and adjustment possibilities may even offer a more
intuitive approach to what might otherwise seem a rather dry subject.

The notes of the scale are indicated by gray beams making it easy to discover
whether or not important melody notes form part of the scale: if they do, they will
coincide with the gray beams; if not, they will fall between.

A number of commands are provided to make the various functions of the Tone
Scale window available also in the MDD Editor.

— In the left-hand margin of the window, the switches for selecting the tonality and
mode are active, as in Scale Snap mode in the Editor. The name of the note (in
upper case) accompanied by an ‘m’ (in lower case) represents the minor mode
(or some other mode, such as the Dorian, in which the third degree of the scale
is a minor third above the tonic).
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— Another way of defining the tonality and mode is to use the drop-down list boxes
in the Inspector. Here any of the church modes as well as other scales not
forming part of the Major/Minor system can be selected. The tonalities are
arranged in accordance with the circle of fifths to make it easier to switch
between closely related keys.

— To use anything other than concert pitch (A=440Hz), enter the desired offset in
cents.

— Double-clicking on any of the gray beams redefines that note as the tonal center
without altering the key signature. If the key were C major, clicking on the note
‘E” would select the Phrygian mode with E as the new tonal center. In the pop-
up windows at the top, ‘E’ would be displayed as the tonality and ‘Phrygian’ as
the mode.

— Clicking on the Key Buttons in the left margin of the window also changes the
tonality but this time the mode remains unchanged e.g. C lonian to E lonian.

— If you perform the same action with the Shift key held, not only does the tonality
change but also the mode, the effect (depending upon which mode you start
from) being to toggle between major and minor. An analogous changes takes
place if the original scales is neither major nor minor. In this case the steps of
the current scale move a minor third upwards or downwards if the current scale
has the requisite third.

Vocals0.mdd
The actions in the Define Tone Scale drop- Define Tone Scale | 40% | (Ab ) [Winor (natural)
. . Find Scale with Standard Tuning considering Tuning Offset
down list next to the toolbar on the right of the Find Scale with Standard Tuning E
screen help you locate the most probable key e Tl Ofbe e e D

Find Note Assignments for Current Tuning

automatically. Unclear note assignments in = Reset all Manual Note Assignments
relation to the scale can be improved. = Tone Scale Panel...

==

— Find Scale with Standard Tuning considering Tuning Offset ascertains the tonality or
mode and corrects the note assignments. Here any deviation from standard tuning
[i.e. concert pitch (A=440Hz)] is detected and used to improve the assignment of
notes to a scale. The scale and note assignments actually used, however, still relate
to concert pitch. The same happens implicitly during the automatic detection of the
melody. Redefining the pitch is nonetheless useful, as otherwise notes may be
divided erroneously or assigned to the wrong degrees of the scale in the course of
later manual editing. After conducting this type of rationalization of note divisions
and note assignments, Melodyne can often find a more suitable scale.
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— Find Scale with Standard Tuning works like Find Scale with Standard Tuning
considering Tuning Offset except that concert pitch alone is used to determine
the scale and note assignments within it. Melodyne does not look to see whether
a better match might be found by reinterpreting the melody in the light of a
different pitch (i.e. where the frequency of A is higher or lower than 440 Hz and
that of all other notes similarly offset). Use this function, when you are confident
that the instrument was correctly tuned (i.e. to concert pitch) and played in
tune.

— Find Tuning Offset from Standard Tuning works like Find Scale with Standard
Tuning considering Tuning Offset except that the deviation from concert pitch is
stored in the melody definition. This function should only be used when the
deviation is significant. The point of storing this information is that otherwise
when you first load a melody for which an offset has been defined, the new
tuning might be adopted by the newly created arrangement. To prevent this
happening without your being aware of it, a dialog box appears asking you
whether you wish the detected offset to be used for the definition of the scale.

— Find Note Assignments for Current Tuning. When you have already defined the
scale and pitch, this function will ensure that notes are correctly assigned.

— Reset all Manual Note Assignments. Whenever an existing note assignment has
been modified by the user, the default behaviour is for such an assignment to be
retained throughout any subsequent automatic note assignment operations.
Whilst no reassignments occur immediately when this command is used, any
subsequent automatic note assignment operations will begin by wiping the slate
clean and the manual assignments will therefore be lost.

— Tone Scale Panel. The Tone Scale Panel can be used for the more precise
definition of the tuning system (or ‘temperament’). The temperament you define
here will apply to the melody but not the entire arrangement. Please note that
the Scale Panel is context-sensitive. The tuning system displayed here will be
that of whichever edit, definition or arrangement window is currently in the
foreground.

When any of the first four functions are used, you can tell Melodyne that notes
falling between the notes of the scale as defined should ‘snap’ to the nearest
member of the scale. You can specify the catchment area (Diatonic Snap Range
for Note Assignment) for the snap function as a percentage. If the value is set to
100%, all notes will snap to the nearest member of the defined diatonic scale. If
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the value is set to 50%, a note will be assigned to the next diatonic scale degree if
its exact pitch is more than halfway in the direction of the neighboring note. If the
value is set to 0%, no snapping will occur and notes lying between members of
the scale will be left alone. The default value is 40%.

Note that when you change the scale using either the key buttons on the left or
the drop-down lists at the top of the screen or the Tone Scale window, notes will
not automatically be reassigned to degrees of the new scale. To reassign them, you
must then use function (Find Note Assignments for Current Tuning). When the
first three commands are used, on the other hand, notes are automatically
reassigned to the newly defined scale.

Further recommendations regarding key definition and scale assignments:

— the main object of defining the tonality and mode is that it makes it possible to
distinguish between notes forming part of the scale (diatonic notes) and others
(chromatic notes), which are handled differently by the Scale Snap function as
well as when melodies are dragged and dropped into the Edit Window and their
tonality is automatically matched to that of the arrangement.

— before defining the tonality, mode and note assignments, the results of the pitch
recognition and note separation functions should be checked carefully and if
necessary corrected. Only then should you begin with the Define Pitch
Assignment tool. Otherwise, if you were to split a note after having assigned it
manually to one of the degrees of the scale, you might have to do so a second
time, as corrected notes are automatically reassigned.

— if you already know the tonality and mode of the melody, enter it manually and
then invoke function (Find Note Assignments for Current Tuning)

— if you wish the tonality to be analysed automatically, use function (Find Scale
with Standard Tuning considering Tuning Offset)

— after using “Find Tuning Offset from Standard Tuning” or “Find Note
Assignments for Current Tuning”, listen to the melody again. The notes in these
modes are quantized to the assigned pitches. Correct any false assignments
manually.

08-09 Define Pitch Transition

Melodyne can recognize whether a gradual transition in pitch exists between two
notes or whether the following note represents in this respect a new start.
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Depending upon which is the case, the phrasing and legato of a melody can be
developed in a musical way. Whether a gradual pitch transition between two notes
exists can also be decided in the normal Editor after the detection with the Pitch
Transitions tool. However, these changes only apply to the current instance of the
melody in a specific arrangement and are not be included in the definition of the
melody for general use. The Define Pitch Transition tool offers the same
functionality as the equivalent tool in the Editor except that the changes here are
stored in the MDD file and therefore affect every new use of the audio file in an

arrangement.
(ann Wecal) mds
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The Define Pitch Transition tool

fc}:::'!_ k ‘% + % G "J [Change Notes J [ Reset Motes J E Transition

After choosing the last tool in the MDD Editor you can remove or add pitch

transitions

— If you double-click on a note, a pitch transition to the following note will be
added. A further double-click will delete the transition again.

— If several notes are marked, a transition will be placed after each of the marked
notes. Deleting works in an analogous way to the single note. Of course the pitch
transitions are only deleted if and when all the marked notes have pitch
transitions. Otherwise the pitch transitions not yet set will be added.

— As an alternative to double-clicking on a note, pitch transitions can be set or
deleted by checking the Transition box in the Inspector

— The Change Notes button in the Inspector assigns a new pitch randomly to each
note without changing the expression. This is helpful since you can only assess
the effect of the transitions when the intervals between notes have been

changed. Clicking Change Notes a second time produces a further test shift.

— Reset Notes restores the notes to their starting positions.
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