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26.1 水晶报表 

� 选择数据库连接或批量数据库连接: 

� 执行<制作报表格式>: 

 

� 执行<新建>按钮,选择 Crystal(水晶星)报表格式: 

 

执行 Cancel,直接取消; 



                                                                 26.数据库报表 

26-3 

� 执行菜单 File->New: 

 

� 执行<Standard>按钮: 

 

� 执行<SQL/ODBC>按钮,选择 ODBC 数据源: 

 

� 执行<Ok>按钮,继续选择报表使用的数据表或视图: 
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� 执行<Add>按钮,再执行<Done>按钮: 

 

� 执行<Next>按钮,选择参与报表字段: 

 

� 执行<Preview Report>按钮,完成报表初始化参数设置; 
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� 执行<Design>选项,继续设计基本报表格式: 

 

[1].设计模式,即使报表内容有多条记录,也只设计一行; 

[2].报表格式内容,通过对象表示,通过修改对象属性改变报表格式; 

  [3].改变字体,选中某对象,点击右键,执行弹出菜单<Change Font>; 

[4].改变标题及文本内容,选中某标题对象,点击右键,执行从弹出菜单<Edit Text Field>; 

[5].记录序号,执行菜单<Insert->Special Field->Record Number Field>命令; 

[6].画表格线,执行菜单<Insert->Line>; 

[7].添加图片,执行菜单<Insert->Picture>; 

[8].添加字段,执行菜单<Insert->Database Field>; 

[9].刷新数据库结构, 执行菜单<database->Verify Database>; 

报表建立后,数据表结构发生变化,需通知报表格式; 

[A].多选字段,执行菜单<Edit->Select Fields>,再选择字段并编辑; 

[B].刷新报表内容,执行菜单<Report->Refresh Report Data>; 

制作报表时,数据表记录内容发生变化,为浏览正常需通知报表格式; 

� 基本报表格式设计完成: 
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� 公式字段,显示几个字段的计算结果; 

[1].执行菜单<Insert->Formula Field>,插入公式: 

     

[2].输入公式名称,执行<Ok>: 

     

[3].从<Fields>选择参与计算字段到<Formula text>中,形成计算公式; 

[4].执行<Check>按钮,检查公式是否正确: 

[5].执行<Accept>按钮,添加公式到报表: 
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� 字段统计值,显示某个字段统计结果:累加、平均、最大、最小...; 

[1].选择某数值字段; 

[2].执行菜单<Insert->Grand Total>: 

     

[3].选择统计方式: 累加(sum)、平均(average)、最大(maximum)、最小(minimum)... 

     

� 浏览报表结果: 
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� 报表排序,报表记录根据某字段进行排序; 

[1].执行菜单<Report->Sort Report>: 

     

[2].选择排序字段及排序方式(升序、降序); 

[3].输出报表过程中排序速度较慢,建议数据表建立索引进行排序; 

� 隐藏报表内容: 

[1].整个报表由 Title、Page Header、Details、Grand Total、Page Footer 组成; 

[2].鼠标右键点击某部分前部灰色区域,执行菜单<Hide Section>,可以隐藏相应内容: 

     

[3].恢复显示隐藏内容,进行反向操作即可: 
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� 设置时间格式: 

[1].有时日期/时间字段只显示日期,而不显示时间: 

     

[2].执行菜单<File->Report Options>: 

         

[3].确信未选择<Convert Date-Time to Date>: 

     



                                                                 26.数据库报表 

26-10 

� 设置浏览页格式: 

[1].浏览报表时,为了使浏览页尺寸与窗口匹配; 

[2].执行菜单<File->Report Options>,选择<Fit Page>: 

         

� 编辑完成,报表预览: 

 

� 保存报表格式到 ReportFile 目录; 

� 保存报表时,确信未选择〈Save Data with Report>,否则输出报表内容不被更新: 
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26.2 Excel 报表 

� 计算机必须安装微软 Excel,支持 Office 2000/2003/2007/2010/2012 等; 

� 选择数据库连接或批量数据库连接,执行<制作报表格式>: 

 

� 执行<新建>按钮,选择 Excel 报表格式: 

 

� 输入报表文件名称: 

 

� 执行<确定>按钮,自动建立缺省格式的 Excel 报表格式文件: 

 



                                                                 26.数据库报表 

26-12 

� 打开 Excel 报表格式文件,由两个工作表组成:Param、Report; 

 

� 选择 Param 工作薄,设置报表参数： 

� 数据源,必选项,提供报表内容的数据库名称,支持 ODBC 数据源或 DSN 描述型名称: 

 

� 数据表,必选项,提供报表内容的数据表或视图名称; 

� 排序分组字段,可选项,报表内容根据某字段进行排序,并根据某字段的变化进行分组统计; 

例如,设定"字段 1"作为排序分组字段,报表样式为: 

 

� 记录开始行号,必选项,设定报表记录输出到 Report 数据表的开始行号: 

 

� 自动执行宏,可选项,报表输出结束时执行某宏命令; 
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� 附加过滤条件,可选项,报表内容是数据表某段时间内过滤后的记录: 

 

� 记录排序字段,可选项,报表内容根据一个或多个字段进行排序; 

缺省升序,字段后附加 desc 降序: 

 

� 报表字段,必选项,设定参与报表的字段; 

 

[1].字段数量,取值 1-1024,缺省 30 个; 

[2].序号,记录编号,通过<列号>定义序号输出位置,缺省在第 2列(B),列号为 0不填写序号; 

      

[3].字段名称,正确填写数据表存在的字段,通过<列号>定义字段输出位置,例如 3(C)、4(D).. 

      

     如果字段名称为"()",则指示对应输出列内容为计算公式; 

      

 [4].列名 

如果字段名称为"()",即公式字段,则需要填写列号对应的列名,如 G(7)、H(8) 

如果某字段在输出报表结束时进行统计运算,则需要填写列号对应的列名,如 E(5)、F(6) 

[5].列统计,对某些字段内容进行统计运算; 

统计类型 最大值 最小值 累加值 平均值 增加值 减少值 差 值 

统计公式 MAX MIN SUM AVERAGE DIFF FDIFF MDIFF 

需要做统计运算的字段,相应列统计中填写统计公式; 

可以在不需要做统计运算的列后面填写统计描述; 

      [6].统计格式,即统计数据值得显示格式:  

"#0.00" – 浮点数保留两位小数, "0.00%" - 百分数保留两位小数; 
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[7].报表字段设置举例: 

      

      

[8].报表界面参数: 

      

    工作簿标签(Y/N),是否显示左下角的工作簿标签; 

       

    附加工作簿,缺省显示 Report 工作簿,可附加某工作簿并缺省显示; 

    隐藏 Report(Y/N),附加工作簿时,可隐藏 Report 工作簿,缺省显示附加工作簿; 

    插入方式(Y/N),Y=插入方式,N=追加方式,插入方式速度较快; 

    最大行数,报表记录最大行数(1-65000); 

    水平滚动(Y/N),是否显示水平滚动条; 

    垂直滚动(Y/N),是否显示垂直滚动条; 

    行号列标(Y/N),是否显示 Excel 表左侧行号和上方列标; 

       

    网格线(Y/N),是否显示报表背景网格线; 

    公式栏(Y/N),常用工具(Y/N),格式工具(Y/N),定制工具栏; 

    全屏显示(Y/N),是否全屏显示,不显示菜单、标题等; 

    保护报表(Y/N),是否保护报表内容不被修改; 

    隐藏细节(Y/N),是否隐藏报表数据内容,只显示统计数值; 
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� 选择 Report 工作薄,设计报表格式; 

 

[1].预先填写两行报表数据内容,并设置字体、单元格格式等; 

[2].保证列内容与字段对应关系正确; 

� 保存 Excel 报表格式; 

 

26.3 报表打印按钮 

� 画面提供"报表打印"组件: 

 

� 组件属性对话框: 
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� 按钮标题: 

    

� 执行<格式文件>按钮,选择 Crystal(水晶星)或 Excel 报表格式文件: 

 

Excel 报表文件后加参数/HideInfoWnd,避免显示打印过程信息; 

 

� 时间字段,输入查询报表数据所使用的时间字段; 

执行<时间字段>按钮,分别选择数据源、数据表,最后选择时间字段; 

如果时间字段名称后附加"/T",则输出报表时支持时间间隔查询: 

 

 

时间格式,数据库查询时间格式,除 Access 外,其余数据库类型均选择 SQL 即可; 

� 报表类型:班报表、日报表、周报表、月报表、季度报表、年度报表、自由报表、选择报表; 

� 使用班报表类型时,需预选设置班报表: 

[1].填写班次名称,并定义班次对应的时间范围; 

[2].每天最多分 24 班,开始时间早于结束时间; 
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[3].如果开始班次的开始时间晚于结束时间,则认为此班次是从昨天某时间到今天某时间; 

例如:20:00:00-06:00:00,表示班次时间从昨天晚 20 点至今天早 6点; 

如果最后班次的结束时间早于开始时间,则认为此班次是从今天某时间到明天某时间; 

例如:20:00:00-06:00:00,表示班次时间从今天晚 20 点至明天早 6点; 

� 过滤条件,预先设置 256 条报表查询过滤条件: 

      

     鼠标双击表格分别输入查询描述及查询命令,按照 SQL 语言格式输入查询命令: 

      

     执行报表时允许使用预设过滤条件: 

 

 

� 报表窗口位置,设置报表相关窗口的显示位置,(x,y)用屏幕像素坐标表示,(0,0)时居中显示; 
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� 运行状态,执行报表按钮,提供各种报表查询方式; 

[1].选择报表: 

  

[2].班报表: 

     

[3].日报表: 

     

[4].周报表 
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[5].月报表 

     

[6].季度报表 

     

[7].年度报表 

     

[8].自由报表 
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[9].条件报表 

     

[A].时刻报表 

          

� 相关脚本函数 

1 
设置水晶报表数据库连接登录参数,连接远程数据库时必须使用 

ReportBtnObj.SetConnect objName,odbcName,userName,password 

2 
设置水晶报表公式(Formula)字段内容 

ReportBtnObj.SetFormulaValue objName,name,type,value 

3 
操纵报表打印按钮,使其打开操作界面窗口 

ReportBtnObj.ShowWindow objName 

4 
激活报表打印按钮,重新设定报表内容,并打开操作界面窗口 

ReportBtnObj.ActiveReport objName,fileName,reportType,dbType,1,timeField 

5 
设置水晶报表预览窗口的位置和尺寸 

ReportBtnObj.SetPreviewWindowPos objName,x,y,w,h 

6 
重新为水晶报表格式设置查询表 

ReportBtnObj.SetSQLQuery objName,s 

7 
自定义报表起始时间 

ReportBtnObj.SetBeginTime objName,n1,n2,n3,n4 

8 
设置打印机名称 

ReportBtnObj.SetPrinterName objName,prnName,prnPort,prnDriver 

9 
设置附加的过滤条件 

ReportBtnObj.SetAddonFilter objName,addonFilter 

10 
设置缺省的工作方式,并选择所支持的工作方式 

ReportBtnObj.SetDefaultMode objName,m,n 
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26.4 用户报表 

� 画面提供脚本函数,输出水晶报表和 Excel 报表: 

 

� 函数功能: 

1 
设定远程报表数据库连接登录参数,使用远程数据库进行报表时必须使用 

UserReport.SetConnect odbcname,user,password 

2 
设定报表参数 

UserReport.SetCrystalReport filename,dbType,timeFiled,filterText 

3 
设置报表文件中公式(Formula)字段内容,最多支持 300 个公式字段 

UserReport.SetFormulaValue name,type,value 

4 
打印报表 

UserReport.PrintCrystalReport y,m,d,H,M,S,type,LD,LH,LM,LS 

5 
预览报表 

UserReport.PreviewCrystalReport y,m,d,H,M,S,type,LD,LH,LM,LS 

6 
设置报表预览窗口的位置和尺寸 

UserReport.SetPreviewWindowPos x,y,w,h 

7 
重新为报表格式设置查询条件 

UserReport.SetSQLQuery s 

8 
自定义报表起始时间 

UserReport.SetBeginTime n1,n2,n3,n4 

9 
重新定义报表打印机 

UserReport.SetPrinterName prnName,prnPort,prnDriver 

� 举例: 

    UserReport.SetConnect "FameView UserData Source","sa","123456" 

UserReport.SetCrystalReport "水晶报表.rpt",2,"dt","f1=1 and f2=2" 

UserReport.PreviewCrystalReport -1,-1,-1,-1,-1,-1,1,0,0,0,0 
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26.5 分钟报表生成小时和日报表 

� 假设分钟、小时、日数据表格式如下: 

      

� 分钟表建立触发器,某小时最后 1次追加记录时,把最近 1 小时统计结果插入小时数据表; 

选择分钟数据表,点击右键,执行"所有任务->管理触发器",编写触发器 P1: 

 

� 小时表建立触发器,某天最后 1次追加记录时,把最近 1天统计结果插入日数据表; 

选择小时数据表,点击右键,执行"所有任务->管理触发器",编写触发器 P2: 
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26.6 水晶报表某字段有效数值统计 

� 假设: 对符合"1<f3<10"条件的数值,进行平均统计;f3 为数值字段名称; 

� 增加公式 V1: 

 

� 增加公式 V2: 

 

� 显示公式 V2 的内容; 
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26.7 水晶报表根据某字段有效性对其他字段进行统计 

� 需求: 剔除 f1≠0 的查询记录并进行统计; 

� 增加公式 V1: 

 
� 增加公式 V2: 

 
� 显示公式 V2 内容; 
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26.8 水晶报表连接远程数据库 

� 水晶报表关联数据源为远程数据库时,如不能正常打印浏览,可能是没有登陆远程数据库; 

� 报表按钮组件,使用脚本函数,打印/浏览前登陆远程数据库: 

     ReportBtnObj.SetConnect objName,odbcName,userName,password 

     objName, 报表按钮组件的对象名称; 

odbcName,水晶报表关联ODBC数据源名称; 

userName,password,远程登录用户名称和口令; 

  例:ReportBtnObj.SetConnect "AAA","FameView UserData Source","sa","1211" 

� 用户报表,使用脚本函数,打印/浏览前登陆远程数据库: 

UserReport.SetConnect odbcname,user,password 

     Odbcname,水晶报表关联 ODBC 数据源名称; 

     user 用户名称,password 为登录口令; 

     例:UserReport.SetConnect "FameView UserData Source","sa","123456" 

 

26.9 水晶报表不支持太多 nvarchar 类型字段 

� 水晶报表格式,添加 10 个以上 nvarchar/nchar 类型字段时,出现异常现象; 

� 建议不使用 nvarchar 或 nchar 类型字段,而使用 varchar 或 char 字段类型; 

 

26.10 Excel 报表执行宏函数 

� Excel报表输出结束时,执行自定义的函数(mysub),并把报表最后行号(curRow)传递给函数: 

� 报表格式param工作簿,自定义脚本.脚本1,输入参数: 

ExcelObj.Application.Run "mysub",CInt(curRow) 
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� 执行工具->宏->Visual Basic编辑器: 

 

� 插入模块: 

 

� 编写函数mysub,保存报表格式; 
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26.11 水晶报表导出 Excel 文件失败 

� 水晶报表记录内容多于 13000 行时,导出 Excel 文件格式,出现以下错误: 

 

� 是由于水晶报表对导出 Excel 有限制所致; 

� 建议直接制作 Excel 报表格式,最多可输出 60000 行记录; 

 

26.12 动态改变水晶报表标题 

� 制作水晶报表时,在标题栏中添加几个公式字段: 

[1].执行Insert->Formula Field菜单命令: 

 

[2].输入公式字段名称(如title1),执行ok按钮; 

[3].输入标题缺省内容,下图分别为文本和数值字段类型的缺省内容格式: 
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� 调用脚本控制报表打印按钮,打印/预览前,把动态值传递给报表,例如: 

ReportBtnObj.SetFormulaValue "AAA","title1",0,"1#配方记录" 

x=RunSys.GetVarValue(VA,"%RAND",-1) 

ReportBtnObj.SetFormulaValue "AAA","title2",12,x 

ReportBtnObj.ShowWindow "AAA" 

 

26.13 后台打印报表为 PDF 文件 

� 以 Bullzip PDF Printer 为例: 
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� 假设每小时打印一次报表,首先编写全局脚本文件如下: 

 

'打印报表,当前时间为结束时间，往前退移1小时为开始时间 

UserReport.SetCrystalReport "q1.rpt",2,"dt","" 

UserReport.PrintCrystalReport -1,-1,-1,-1,-1,-1,5,0,1,0,0 

'5秒钟内应该出现PDF打印机窗口,根据窗口标题得到窗口控制权 

n=WindowObj.FindWindowFromTitleEx("Bullzip PDF Printer",5000) 

If n>0 Then 

   WindowObj.BringWindowToTop 

'在PDF打印窗口中,根据缺省PDF文件,寻找要求输入PDF目标文件的子窗口 

   n=WindowObj.FindSubWindowFromTitle("Crystal Reports") 

   If n>0 Then 

      '重新输入PDF文件名称 

      s=CurrentTime.GetFormatTime("C:\TEMP\TEST_%Y%m%d%H%M%S.pdf") 

      WindowObj.SetSubWindowTitle s 

   End If 

   '再找到<生成后打开文档>选项按钮,并设置为0 

   n=WindowObj.FindSubWindowFromTitle("生成后打开文档") 

   If n>0 Then 

      WindowObj.SetSubButtonCheckState 0 

   End If 

   '向PDF打印机窗口发送回车命令 

   WindowObj.SendKeyDown &H0D  

End If 
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26.14 脚本控制 Bullzip 打印机实现报表打印 

� 须安装Bullzip PDF打印机,本实例使用BullzipPDFPrinter V7.1.0.1136版本测试; 

� Bullzip PDF打印机支持COM组件访问,组态软件方便使用VBScript脚本控制其打印参数; 

     

� 脚本实例: 

'得到格式化的PDF文件名称 

s=CurrentTime.GetFormatTime("c:\temp\日报_%Y%m%d_%H%M%S.pdf") 

'打开Bullzip组件 

Set obj=CreateObject("Bullzip.PDFPrinterSettings")  

obj.LoadSettings False                        '装载预设置设置参数 

obj.SetValue "Output",s                       '设置输出文件路径和名称 

obj.SetValue "ShowPDF", "no"                  '打印完成后不显示PDF文档  

obj.SetValue "RememberLastFileName", "no"     '不需要记住上次文件名 

obj.SetValue "RememberLastFolderName", "no"   '不需要记住上次文件路径 

obj.SetValue "ConfirmOverwrite", "no"         '不显示覆盖确认 

obj.SetValue "ShowSaveAS", "never"            '不显示另存对话框 

obj.SetValue "ShowSettings", "never"          '不显示设置对话框 

obj.WriteSettings True                        '确认设置 

Set obj=Nothing 

'打印某个水晶报表 

UserReport.SetCrystalReport "q1.rpt",2,"dt","" 

UserReport.PrintCrystalReport -1,-1,-1,-1,-1,-1,1,0,0,0,0 
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26.15 定义日报表的开始时间 

日报表缺省开始时间是 00:00:00,有时需要改变开始时间,如昨天 20:00:00 作为开始时间; 

报表按扭控件和用户报表都提供脚本函数,可以自定义开始时间: 

□ ReportBtnObj.SetBeginTime objName,n1,n2,n3,n4 

     n1=起始月,n2=起始日,n3=起始小时,n4=起始分钟; 

     n1/n2/n3/n4缺省值均为0,以默认方式运行; 

     n1/n2/n3/n4值大于0,起始时间晚于报表时间; 

     n1/n2/n3/n4值小于0,起始时间早于报表时间; 

    例1(日报表,以某日8点30分作为起始时间): ReportBtnObj.SetBeginTime "AAA", 0, 0, 8, 30 

    例2(日报表,以前日8点30分作为起始时间): ReportBtnObj.SetBeginTime "AAA", 0, 0,-8,-30 

    例3(月报表,以某月9日8点作为起始时间):  ReportBtnObj.SetBeginTime "AAA", 0, 9, 8, 0 

    例4(月报表,以前月9日8点作为起始时间):  ReportBtnObj.SetBeginTime "AAA", 0,-9,-8, 0 

    例5(年报表,以某年9月8日作为起始时间):  ReportBtnObj.SetBeginTime "AAA", 9, 8, 0, 0 

    例6(年报表,以前年9月8日作为起始时间):  ReportBtnObj.SetBeginTime "AAA",-9,-8, 0, 0 

□  UserReport.SetBeginTime n1,n2,n3,n4 

     n1=起始月,n2=起始日,n3=起始小时,n4=起始分钟; 

     n1/n2/n3/n4缺省值均为0,以默认方式运行; 

     n1/n2/n3/n4值大于0,起始时间晚于报表时间; 

     n1/n2/n3/n4值小于0,起始时间早于报表时间; 

    例1(日报表,以某日8点30分作为起始时间): UserReport.SetBeginTime  0, 0, 8, 30 

    例2(日报表,以前日8点30分作为起始时间): UserReport.SetBeginTime  0, 0,-8,-30 

    例3(月报表,以某月9日8点作为起始时间):  UserReport.SetBeginTime  0, 9, 8, 0 

    例4(月报表,以前月9日8点作为起始时间):  UserReport.SetBeginTime  0,-9,-8, 0 

    例5(年报表,以某年9月8日作为起始时间):  UserReport.SetBeginTime  9, 8, 0, 0 

    例6(年报表,以前年9月8日作为起始时间):  UserReport.SetBeginTime -9,-8, 0, 0 

 

26.16 控制水晶报表输出打印机 

水晶报表缺省打印到缺省打印机,如HP打印机,在特殊情况下,需要打印到PDF打印机; 

� 安装HP打印机,设置为缺省打印机,安装PDF打印机,如Bullzip PDF打印机,不设置为缺省打印机; 

� 制作水晶报表,并选用缺省打印机: 
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� 画面使用报表打印控件,并为控件命名,如AAA,通过两个按钮中的脚本分别输出到HP和FDF打印机: 

 

� 增加按钮,编写脚本输出到PDF打印机: 

'得到格式化的PDF文件名称 

s=CurrentTime.GetFormatTime("c:\temp\日报_%Y%m%d_%H%M%S.pdf") 

'打开Bullzip组件 

Set obj=CreateObject("Bullzip.PDFPrinterSettings") 

obj.LoadSettings False '装载预设置设置参数 

obj.SetValue "Output",s '设置输出文件路径和名称 

obj.SetValue "ShowPDF", "no" '打印完成后不显示PDF文档 

obj.SetValue "RememberLastFileName", "no" '不需要记住上次文件名 

obj.SetValue "RememberLastFolderName", "no" '不需要记住上次文件路径 

obj.SetValue "ConfirmOverwrite", "no" '不显示覆盖确认 

obj.SetValue "ShowSaveAS", "never" '不显示另存对话框 

obj.SetValue "ShowSettings", "never" '不显示设置对话框 

obj.WriteSettings True '确认设置 

Set obj=Nothing 

ReportBtnObj.SetPrinterName "AAA","Bullzip PDF Printer","BULLZIP","Bullzip PDF Printer" 

ReportBtnObj.ShowWindow "AAA" 
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� 增加按钮,编写脚本输出到HP打印机: 

ReportBtnObj.SetPrinterName "AAA","HP LaserJet P1505n","HPLaserJetP1505n","HP LaserJet 

P1505n" 

ReportBtnObj.ShowWindow "AAA" 
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26.17 水晶报表计算某字段最大值与最小值的差值 

� 假设有以下报表格式,要得到f2字段的最大值与最小值的差值: 

 

� 选择f2字段,点击右键,执行<Insert Grand Total>命令,选择最小值(Minimum): 

 

� 选择f2字段,点击右键,执行<Insert Grand Total>命令,选择最大值(Maximum): 

 

� 此时报表如下: 
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� 执行<Insert>菜单下<Formula Field>命令: 

 

� 输入公式字段名称并确定: 

 

� 输入计算公式,使最大值减去最小值,执行<Accept>,此时报表如下: 
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� 删除最大值最小值字段,此时报表界面如下: 

 

� 报表预览结果: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



                                                                 26.数据库报表 

26-37 

26.18 显示水晶报表首尾记录时间差 

� 数据表(demo)中增加计算字段(f5),其内容为当前记录存储时间距2013-1-1日的秒间隔值: 

 

� 使用数据表demo制作水晶报表: 
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� 选择f5字段,执行菜单Insert->Grand Total,插入f5的最大值与最小值: 

 

 

 

� 执行菜单Insert->Formula Field...,插入公式字段deltaSecond: 

公式字段deltaSecond内容为字段f5的最大值与最小值的差值: 
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� 可删除f5字段及其最大最小值,只保留deltaSecond: 

     

 

� 可以再增加公式字段对deltaSecond处理,得到天、小时、分钟、秒,以天-小时:分钟:秒的方式显示: 

从时间差值中得到天数: 

@dayValue=Round({@deltaSecond}/86400-0.5) 

或@dayValue=Truncate({@deltaSecond}/86400) 
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从时间差值中得到小时数: 

@dayValue=Round(({@deltaSecond}-{@dayValue}*86400)/3600-0.5) 

或@dayValue=Truncate({@deltaSecond}-{@dayValue}*86400)/3600) 

 

从时间差值中得到分钟数: 

@dayValue= Round(({@deltaSecond}-{@dayValue}*86400-{@hourValue}*3600)/60-0.5) 

或@dayValue=Truncate({@deltaSecond}-{@dayValue}*86400-{@hourValue}*3600)/60) 

 

从时间差值中得到秒数: 

@dayValue={@deltaSecond}-{@dayValue}*86400-{@hourValue}*3600-{@minuteValue}*60 
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� 最后预览结果: 

 

 

26.19 水晶报表统计同类记录 

�  数据表demo,对f4字段内容相同的记录进行统计,统计显示f1的累加值,f2的平均值,f3的最大值; 

    

� 用常规方法制作水晶报表: 
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� 选中f1字段值点击右键,执行菜单Insert Summary,显示统计对话框,并设置如下: 

 

� 选中f2字段值点击右键,执行菜单Insert Summary,显示统计对话框,并设置如下: 
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� 选中f3字段值点击右键,执行菜单Insert Summary,显示统计对话框,并设置如下: 

 

� 选择时间字段dt,制作时间字段的最小最大值: 
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� 编辑使报表样式为: 

 

 

� 如果不希望显示详细清单,在Deltails处点击右键,执行Hide Section: 
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� 此时报表样式为: 

 

� 进一步编辑报表格式为: 
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26.20 使用视图在报表中显示多个数据表数据 

� 假设有两个数据表t1和t2: 

   

� 制作视图,把两个表中时间一样的字段合并为一个字段: 

 

� 假设两个数据表的内容为: 

   

� 视图内容为: 

 

� 使用视图制作水晶或Excel报表: 
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26.21 通过视图实现分项平均统计 

� 某数据表（Table1）内容如下: 

 

� 根据表Table1建立试图View1,通过站号字段分组(1/2/3),统计每天变量1、变量2、变量3平均值: 
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26.22 Excel报表数值枚举文本 

� 假设 Excel 报表格式为: 

 

� 需要把第 6列的数值内容{1,2,3,…},在第 7列中对应显示为文本内容{"AAA","BBB","CCC",….} 

 

� 实现方法,在第 7列中输入下面公式并拉动到第二行: 

=CHOOSE(F4,"AAA","BBB","CCC") 或 

=CHOOSE(MATCH(F4,{1,2,3}),"AAA","BBB","CCC") 

 

� 如不希望显示第6列,隐藏第6列即可; 
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26.23 根据日统计数据生成月报表 

� 假设有以下数据表(DataTable),字段dataDay为记录日期: 

     

� 根据数据表,建立最基本水晶报表格式: 

 

� 选择[数据1]内容,弹出右键菜单: 
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� 执行右键菜单[Insert Summary],根据日期生成分组统计累加值: 

 

� 选择[数据2]内容,弹出右键菜单: 

 

� 执行右键菜单[Insert Summary],根据日期生成分组统计累加值: 
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� 把日期字段下移一行,并缩小列宽只显示日期: 

 

� 此时报表预览为:    

    

� 鼠标移动到[Details]处,执行菜单[Hide Section],隐藏数据记录: 

 

� 此时预览结果为: 
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� 选择[数据1]内容,弹出右键菜单: 

 

� 执行右键菜单[Insert Grand Total],生成全部查询记录的总统计累加值: 

 

� 用同样方法,为[数据2]生成全部查询记录的总统计累加值 

 

� 此时预览结果为: 
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� 对报表格式进行加工: 

 
� 最后预览结果为: 

 

� 在画面中制作报表按钮,进行月报表查询: 
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26.24 水晶报表统计符合某条件的记录数量 

� 根据某数据表制作水晶报表, 统计 f1 字段符合条件的记录数量,条件 1000<f1<5000: 

 

� 增加公式字段: 
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� 根据公式字段求和: 

 

� 预览报表: 

 

 

  


