
SyncThru™Admin 6
▌ Admin Guide



Copyright_ 1

Copyright
© 2011 - 2012 Samsung Electronics Co., Ltd. All rights reserved.
This admin guide is provided for information purposes only. All information included herein is subject to change without any 
notice.
Samsung Electronics is not responsible for any direct or indirect damages, arising from or related to use of this admin 
guide.

• SyncThru™ is a trademark of Samsung Electronics Co., Ltd.
• Samsung and Samsung logo are trademarks of Samsung Electronics Co., Ltd.
• Microsoft, Windows, Internet Explorer and Windows Vista are either registered trademarks or trademarks of Microsoft 

Corporation in the United States and other countries.
• All other brand, product and company names herein may be the trademarks of their respective owners.

REV. 2.3



Contents
COPYRIGHT/1

HOW TO USE THIS GUIDE
Intended audience . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5
Terminology used in this guide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  5
Reference material  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  6
Product support information  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  6

GETTING STARTED
Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  7
Installation requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  7
Installing SyncThru™ Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  8
Uninstalling SyncThru™ . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9
Starting SyncThru™ 6 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9
Stopping SyncThru™ 6 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  9
Layout of SyncThru™ 6  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  10

DASHBOARD
Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13
Understanding Widgets  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  13
Adding a Dashboard Widget  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14
Configuring Dashboard Widgets . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  14

DEVICES
Device Management  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  16
Device Toolbox Functions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  20
Management History . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  33

USER
User Group & List  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  37
User Role Assignment  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  38

MOBILE DASHBOARD
Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39
Viewing Widgets  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39

FILE
Plug-ins  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40
Device Applications  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41
SNMP Agent . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41
Font/Form/Macro . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  43
Firmware  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  44
Driver File Management  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  45

REPORTS
Contents_ 2



Contents
Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  48
Report . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  50
Analysis  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  50

RULE
Adding/Editing a New Rule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51
Deleting a Rule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51
Modifying a Rule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  51
Events . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52

PLUG-IN
Plug-in Management . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  54

ACCOUNTING
Setting Accounting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  55
Setting Permissions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  55
Viewing the Management History  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  56

SETTINGS
Overview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  57
Network  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  57
Log  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  59
System  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  60
Notification . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  62
Tasks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  65
Device . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  65
Accounting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  69

BACKUP & RESTORE
Getting Started  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71
Backup . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71
Restore . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  71

DATA REFERENCE
MIB reference . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  73
Data matrix . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  73
Role reference   . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  74

TROUBLESHOOTING
Common errors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  76

FREQUENTLY ASKED QUESTIONS
FAQ . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  80

SECURITY REFERENCE
Contents_ 3



Contents
SSL communication (HTTPS) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  82
User authentication . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  82
SNMPv3  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  82
User credentials  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  82

OPEN SOURCE INFORMATION
zlib/png License  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  83
OpenSSL License  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  83
Apache License, Version 2.0  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  83
BSD . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  85
Boost Software License 1.0 (BSL1.0)  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  85
GNU LESSER GENERAL PUBLIC LICENSE . . . . . . . . . . . . . . . . . . . . . . . . . . . .  86
MIT  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  91
Eclipse Public License  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  91
Mozilla Public License  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  93
Common Development and Distribution License, Version 1.0 (CDDL-1.0)  . . .  97
Contents_ 4



1.How to use this guide
The SyncThru™ 6 Admin Guide is intended to be used to install and setup SyncThru™ 6 on a 
network server and client systems. To assist you in acclimating to the SyncThru™ 6 environment, 
this guide provides instructional screen images, situational examples, easy-to-read tables of 
features, and step-by-step instructions. The chapters of this guide are arranged according to the 
page view, moving from left to right. Each tab’s and sub-menu’s functionality and screen layout is 
described in detail to ensure a complete understanding of the environment.

Intended audience
The expected user for this guide is a network administrator with an understanding of
• The network printing environment
• Network protocols – subnets, security features, addresses
• Windows operating systems on server and client computers
• SNMP and SNMPv3 monitoring
• LDAP

Terminology used in this guide
The following terms are used throughout this guide in examples, instructions, and descriptions:

Acronyms 
The following acronyms are used throughout this guide in examples, instructions, and descriptions:

Glossary
(See "Glossary" on page 101).

ACRONYMS MEANING

DBMS Database Management System

IP Internet Protocol

JAC Job Accounting

HTTP Hypertext Transfer Protocol

HTTPS Secure Hypertext Transfer Protocol

LDAP Lightweight Directory Access Protocol

mDNS Multicast Domain Name System

MFP Multi-Functional Peripheral/Multi-Functional Printer

MSSQL Microsoft SQL

NTLM NT LAN Manager

OS Operating System

RFC Request for Comment

SLP Service Location Protocol

S/N Serial Number

SMTP Simple Mail Transfer Protocol

SNMP Simple Network Management Protocol

SSL Secure Socket Layers

SWS SyncThru Web Service

TCP Transmission Control Protocol

UDP User Datagram Protocol

WMI Windows Management Instrumentation

XOA eXtensible Open Architecture
How to use this guide_ 5



Reference material
SyncThru™ 6 software
http://www.samsungprinter.com

Updates and Plug-ins
http://www.samsungprinter.com

Help
Click the Help in site navigation bar at the top right corner of the SyncThru™ 6 page.

Product support information
Contact Samsung’s printer service
http://www.samsungprinter.com
How to use this guide_ 6
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2.Getting started
This chapter gives you instructions for installing SyncThru™ 6.

Overview
SyncThru™ 6 is a web-based managing and monitoring application which helps you to discover, configure, manage, 
monitor and report on any type of SNMP-compliant printing and imaging devices without leaving your desk. There are nine 
main menus that will help you manage your devices: Dashboard, Plug-in, Device, File, Accounting, User, Report, Rule, 
and Settings. For easy management, you can add device status related items to the Dashboard and see them all on one 
page. The Device menu has sub-menus to support all the device-related operations, discovery, file storage management, 
access control management, and configuration. The Plug-in menu provides options to install, stop, start, and uninstall 
plug-ins that are installed on the server. The File menu supports all the file-related operations such as application 
installation file, driver installation file, and files to store on the server. The Accounting menu supports basic accounting 
functionality to track all jobs within your imaging and printing environments, and helps to save costs and reduce overuse. 
The User menu supports all the user-related operations such as user and user group management. The Report menu 
provides reporting capabilities for devices. The Rule menu allows the administrator to create rules and manage tasks 
according to the rule’s conditions and actions. All of the menus and features in SyncThru™ 6 operate based on the settings 
set in the Settings menu. You can improve your organization’s device management system with these menus and 
features.

Installation requirements
System requirements

ITEMS SERVER SYSTEM REQUIREMENTS CLIENT SYSTEM REQUIREMENTS

Hardware • For less than 1000 devices:
- Pentium 4 processor, 2GHz or faster
- 2 GB RAM or more
- 2 GB free disk space is recommended.

• For more than 1000 devices:
- Dual core processor, 2GHz or faster
- 2 GB RAM or more
- A server with SQL server installed are 

highly recommended.
- 50 GB free disk space is recommended 

for SQL Server.
SyncThru™ 6 can manage 5000 devices.

Client computers do not require any software to 
be installed. To work with SyncThru™ 6, a web 
browser that SyncThru™ 6 supports must be 
installed on the client computers.

Operating 
system

• Windows XP Professional (32/64-bit)
• Windows 7 Professional (32/64-bit)
• Windows Server 2003 (32/64-bit)
• Windows Server 2008 (32/64-bit)

Any operating system with a supported browser 
installed.

Database • PostgreSQL 8 included in application 
installation

• MS SQL Server 2005 Workgroup
• MS SQL Server 2008 Workgroup
• MS SQL Server 2005 Enterprise
• MS SQL Server 2008 Enterprise
• MS SQL Server 2005 Standard
• MS SQL Server 2008 Standard

N/A

Resolution N/A • 1280 x 1024 or higher resolution is highly 
recommended.

• 1400 x 900 or higher resolution (wide screen) 
is highly recommended.

Browsers • Microsoft Internet Explorer 8.x or 9.x
• Mozilla Firefox 3.6.8 or higher
• Safari 5.x
• Chrome 15.x
• Browser needs Adobe Flash Player 10.x or 11.x
Getting started_ 7



Ports
SyncThru™ 6 listens on several ports and opens some ports for specific features. The following table shows you the port 
information used by SyncThru™ 6:

Installing SyncThru™ Server
Follow these steps to install SyncThru™ Server:
1. Go to the local or network location where you downloaded the Samsung SyncThru™ 6 Setup file.

 

You can also download it at http://www.samsungprinter.com.

2. Run the EXE file.
3. Select the language you want to use.
4. Read the setup guide and click Next to continue installation. 
5. Read the license information and click I Agree to continue installation. 
6. Choose the destination path for installation and click Next. 

If the latest version of SyncThru™ 5 (version 5.5.2.3013) has already been installed, data can be migrated from 
SyncThru™ 5 to SyncThru™ 6.
a. Select the Import data from SyncThru 5.0 checkbox.
b. Click Next.

7. Select the Database server type you are using and click Next.

 

If you migrated data from SyncThru™ 5, the database server type can’t be changed.

 

• If you select Microsoft SQL Server, you need to enter in the server information. Fill in the information and 
click Next. 

- Server address and Port. This is your SQL Server address and port number. Microsoft SQL Server uses 
port 1433 as a default.

- Database name. This is your database name.
- User name and Password. This is your account for the existing SQL Server. This account must have 

system administrative rights.
- Create database. If you want to create a database, check this option. This is enabled once the connection 

has been successfully tested.
- Test Connection button. You can check to see if the settings are correct by clicking this button. 

8. Type in the port number for the web server and, if necessary, check the options below then click Next.

 

• Windows Firewall is a personal firewall, included in Microsoft Windows XP or higher OS versions. If your 
firewall is enabled, you need to add the ports SyncThru™ 6 uses to Windows Firewall Exceptions. 
Otherwise, you cannot use SyncThru™ 6 properly. Check Add exception rule to the Windows firewall 
option to add the ports SyncThru™ 6 uses to Firewall Exceptions automatically (see "Is Window XP 
Service Pack 2 supported by SyncThru™ 6?" on page 80).

• You need to configure a password for the admin account.
9. Confirm the summary then click Next. 
10. Click Install. 
11. When the installation is finished, click Close. 

If you selected to migrate data from SyncThru™ 5, the migration will begin now. The migration results will be displayed 
when it is finished.

Network • Network interface:
- Ethernet 10/100 Base-TX

• Network protocols:
- TCP/IP (compatible with IPv6)
- Device communication : SNMP, SNMPv3, HTTP, WMI
- SyncThru™ 6 server & client communication : HTTP, HTTPS

PORT TYPE DESCRIPTION

162 UDP Traps listening port

8080 TCP HTTP default port

8081 TCP HTTPS default port

427 UDP SLP multicast discovery 

5353 UDP mDNS discovery

5432 TCP PostgreSQL port

ITEMS SERVER SYSTEM REQUIREMENTS CLIENT SYSTEM REQUIREMENTS
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Uninstalling SyncThru™
1. From the Windows Start menu, select Control Panel > Add/Remove Programs.
2. Select SyncThru 6.x.xxx and click Remove.

If you want to remove the SyncThru local database file including device information, select Yes for ‘Do you want to 
delete database files from the local machine?’ window.

 

Or, you can use SyncThru™ 6’s included uninstaller. 
From the Windows Start menu, click Program > Samsung Network Printer Utilities > SyncThru™ Admin 6 > 
Uninstall.

Starting SyncThru™ 6
SyncThru™ 6 starts automatically every time the computer you installed SyncThru™ 6 onto boots up. The application can 
also be started immediately after installation by selecting the “Run SyncThru” option. If you want to start SyncThru™ 6 
manually, follow the steps below:

Starting the SyncThru™ 6 Server

 

• If the database is MSSQL, make sure the database server is started.
• If the database is PostgreSQL, then there will be one more service (SyncThru™ Database) that needs to be 

stopped/started.
1. From the Windows Start menu, click Control Panel > Administrative Tools > Services.
2. Select SyncThru™ Server application from the list
3. Click Start.

Opening the SyncThru™ 6 Browser
Enter one of the following addresses: 
• http://server_name.domain:port_number

"server_name.domain" is the hostname of the SyncThru™ host machine
"port_number" is the web server port number that you entered during the installation

• http://ip_address:port_number
"ip_address" is the IP address of the machine where SyncThru™ is installed
"port_number" is the web server port number that you entered during the installation

 

There is another way to open SyncThru™. From the Start menu, select Program > SyncThru > Website.

Stopping SyncThru™ 6
SyncThru™ 6 starts automatically every time the computer you installed SyncThru™ 6 onto boots up. If you want to stop 
SyncThru™ 6 manually, follow the steps below:
1. From the Windows Start menu, click Control Panel > Administrative Tools > Services.
2. Select the SyncThru™ Server application from the list
3. Click Stop.
Getting started_ 9



Layout of SyncThru™ 6
Page Overview

NO. ITEM DESCRIPTION

1 ID/Logout If a user is logged in, the user ID is displayed here along with 
Logout.

2 About Information about this software.

3 Active Tasks You can see the details for all the active tasks in SyncThru™ 6. 
With the active task list, you can
• view all the active tasks, including detailed information such 

as Type, Name, Schedule, Status, Start Time, and the 
requesting User,

• resume a specific task(s) by clicking the Resume button on 
the top left,

• pause a specific task(s) by clicking the Pause button on the 
top left, and

• stop a specific task(s) by clicking the Stop button on the top 
left.

4 Help If you click this link, a help window pops up and you can find 
information by typing in the keyword. 

5 Site Map Shows the structure of menus in the SyncThru™ 6.

6 Language selection Options for the application’s display language.

7 Main menus Includes nine main menus: Device, User, File, Report, Rule, 
Plug-in, Accounting, and Settings, plus the Dashboard link.

8 Sub-menus Includes sub-menus of the menus. Sub-menus vary depending 
on the menu selected. 
Getting started_ 10



 

Layout style depends on the menu selected.

Icon overview
The following table shows icons used in SyncThru™ 6 and their meanings:

Common

Dashboard

9 Toolbox The tool box under Device > Device Management, links to 
device management functions: Device Discovery, Driver 
Installation, Application Management, Device Configuration, 
and Firmware Management.
The tool box under Accounting > Accounting Management, 
links to accounting and user permission functions: Accounting 
Settings, Apply User Permissions, Import Permissions, 
Apply Group Permissions, and Job Records.
The tool box under User > User Management, links to user role 
assignment functions: Role Assignment.

ICON NAME DESCRIPTION

Dashboard Returns to the Dashboard.

Refresh Reloads the data in the information panel.

Refresh Selected 
Item

Refreshes the information for only the selected items (up to 50) by retrieving 
information directly from the devices.

Help Opens a help message.

Add Adds a new item.

Delete Deletes the menus selected.

Modify Configures the item’s options.

Import Imports a .csv file that includes the list data for the table.

Export Exports the selected item’s information to a .csv file.

Print Opens a new browser window with the device or user information in a 
printer-friendly format.

Email Sends an email with the data to the given recipient.

Statistics Opens the statistical data in chart format.

History Summary Expands task information in the history pages.

Sort
Custom

Sort the list in ascending or descending order, or opens the window for 
selecting custom columns to display.

Close Closes the window or the widget on Dashboard.

ICON NAME DESCRIPTION

Minimize/Maximize Toggles between a full-screen widget and a minimized widget on Dashboard.

NO. ITEM DESCRIPTION
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Device

Edit Opens the window to make changes to the widget’s properties.

ICON NAME DESCRIPTION

Normal Device is in a normal operational state.

Unknown The status of the device is unknown.

Warning Device is in a state where an error might occur in the future. For example, it 
might be in toner low status, which may lead to toner empty status. 

Error Device has an error.

Disconnected Device is not connected to the network.

New Device is newly discovered. 

ICON NAME DESCRIPTION
Getting started_ 12



3.Dashboard
This chapter explains what the Dashboard is and how to use it. You can monitor the devices with 
the SyncThru™ Dashboard. 

Overview
The SyncThru™ Dashboard will help you manage your printing environment better than before. 
Each widget gives you detailed information using an image, a column or pie graph, and/or a table. SyncThru™ provides 
various widget content for monitoring your printing environment. You can add the widgets with information that you need to 
check most frequently. Mousing over data in the widgets will open a bubble with more information.

Understanding Widgets
SyncThru™ 6 provides various Dashboard widgets for monitoring your printing environment. New widgets can be added 
with future versions of SyncThru™ 6.
These widgets can help you work more efficiently. For example, if you are a manager for Group A and you want to see 
consumables information for all of Group A's devices only, you can add a Toner Status widget for both criteria and check 
the information on the same page.
Additionally, each widget gives you detailed information using a link to the related report or device list. For example, you 
can add a Device Status widget to the Dashboard and see that 5 devices are in error status. You can check which device 
is in error status by clicking the Dashboard widget.

NAME DESCRIPTION

Unresolved Errors Unresolved Error Devices widget shows how many errors are on devices 
by the selected time periods. This widget is useful for checking devices which 
have not been fixed for some time and assume that those devices have been 
out of order. Options for the time period(s) are All, Less than 1 week, 1 ~ 2 
weeks, 2 weeks ~ 1 month, and More than 1 month. Selection of more 
than one time period is permitted.
This widget includes only unresolved errors for the given time period. So if 
you click any part of this Unresolved Error Devices, the related analysis will 
be shown with the error information. 

Usage Status Usage Status widget shows the device usage by the selected parameters 
(See "Viewing the Report Categories" on page 48).
Options include the following:
• Job Type : All, Print, Scan, Copy, Fax In, Fax Out, or Report.
• Paper Type : All, A3, A4, or Other
• Unit Type : Sheets or Impressions
• Color Type : All, Color, or Mono
• Type : All, Simplex, or Duplex
• Chart Type : Column Chart or Pie Chart
You can set various combinations of these options for this widget.

Usage Top / Low Devices Usage Top / Low Devices widget shows the most- and least-frequently used 
devices by the selected parameters (See "Viewing the Report Categories" on 
page 48).
Available options are the following:
• Job Type : All, Print, Scan, Copy, Fax In, Fax Out, or Report.
• Paper Type : All, A3, A4, or Other
• Unit Type : Sheets or Impressions
• Color Type : All, Color, or Mono
• Type : All, Simplex, or Duplex
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The widget order of the Dashboard may differ depending on which widget was added first.

Adding a Dashboard Widget
1. Run SyncThru™.

2. Click .

3. Click the add widget button ( ).

4. Select the type of widget.
5. Click Next.
6. Select a device group to manage and set the widget‘s options.
7. Click Finish.
8. Click Close.

Configuring Dashboard Widgets
Modifying a Dashboard Widget 
Click the modify icon  on the header of the Dashboard widget.

 

Basically, each widget has an option for selecting groups so you can customize widgets with multiple groups. 
Additionally, some of the widgets have more options, such as Periods or Type, that can help you make more 
comprehensive widgets.

Maximizing/Minimizing a Dashboard Widget
Click the maximize icon  on the header of the Dashboard widget to fill the entire dashboard with more information 

about the widget’s topic. To minimize the widget, click the icon again.

Refreshing a Dashboard Widget
Click the refresh icon  on the header of the Dashboard widget.

Disconnected Device Status Disconnected Device Status widget shows how many devices have the 
disconnected status in the selected domain and group. The information is 
grouped by time period. For example, if you click  and select “more than 1 
month”. Options for the time period(s) are All, Less than 1 week, 1 ~ 2 
weeks, 2 weeks ~ 1 month, and More than 1 month. Selection of more 
than one time period is permitted. SyncThru™ 6 lets you move to the devices 
list filtered with that period. This widget is useful for checking which devices 
have not been turned on and assume that those devices have not been in 
use or are out of order.

Device Status The Device Status widget shows the current statuses in the selected domain 
and group. The widget is connected to the Device List by the selection of a 
device group and filtered for Device Status. For example, if you click the 
portion of error, SyncThru™ 6 lets you move to the devices list with error 
status. You can check details from the Device List.

Estimate Toner Empty Estimate Toner Empty widget provides a forecast of how many devices will 
run out of their toner by the selected time period. Today, Week, Month, 3 
months, 6 months, Year or a custom period can be provided.

Toner Status Toner Status widget shows the devices toner levels by toner level. The 
status are the following: 
• Normal : enough toner.
• Low : not enough toner left.
• Empty : toner has reached its life span.

Current Error Current Error widget shows errors that are currently active on devices in the 
selected domain and group. The severity level can be customized in the 
Settings > Device > Alert List page.
Available options are Critical, Warning, and Information.

NAME DESCRIPTION
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Deleting a Dashboard Widget
Click the delete icon  on the header of the Dashboard widget.
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4.Devices
The Device menu supports all the device-related operations, discovery, map management, file 
storage management, access control management and configuration. This chapter gives you 
detailed information on the sub-menus under the Device menu that help you manage devices on 
the system.

Device Management
Viewing Device Information
The Device Management sub-menu provides a list to view the printers by group and to perform some basic updating 
functions for the printers. To view the Device List, follow these steps:
1. Select Device > Device Management.

The Device Management page opens.
The following table will describe the left panes.

The main pane displays the printers that are included in the group selected from the left side of the page. Device 
information and device maintenance options are also provided in this pane in the “toolbox.” 

 

To sort the information alphanumerically/reverse alphanumerically, click any column header to sort with that 
columns information.

The following table describes the “toolbox” functions available and the right pane:

COMPONENT DESCRIPTION

Device Groups The Device Groups section in the left pane displays the groups and sub-groups into 
which the printers have been divided.

Dynamic Groups A Dynamic Group is a dynamically populated group that organizes devices based on 
specific properties.
• Model Group : shows each device model separately.
• Color/Mono Group : shows each device’s color type separately.
• On/Off Group : shows devices in 3 status types: on, off, or unknown.
• Customized Group : You can assign specific devices in a group. Duplicated 

device assignment is allowed.

COMPONENT DESCRIPTION

Driver Installation Click Driver Installation to install drivers for the selected device (see "Uploading a 
Driver File to the Server" on page 46).

Device Configuration Click Device Configuration to manage the selected device’s settings (see "Device 
Configuration" on page 20). This button is only active when a device is selected from 
the list.

Device Discovery Click Device Discovery to manage device discovery settings (see "Device 
Discovery" on page 29).

Application Management Click the Application Management button to manage applications installed on a 
device (see "Device Applications" on page 41). This button is only active when a 
device is selected from the list.

Firmware Management Click Firmware Management to manage the selected device’s firmware (see 
"Firmware Management" on page 32).

Font/Form/Macro 
Management

Click Font/Form/Macro Management to manage files stored on the device’s storage 
unit (see "Font/Form/Macro Management" on page 32). This button is only active 
when a printer has been selected from the device list.

Connection Settings Click this button to edit a device’s connection settings (see "Connection" on page 67).

Show devices from 
subgroups

Select this option to display all printers under the parent group and subgroups. If this 
is not selected, only printers in the selected group will be displayed.

All Use the pull-down filter to limit which printers are displayed by status.
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Showing or hiding columns
Click the gray triangle icon in the table header to sort the list or customize the columns.
Select Custom to open a window with options for viewable columns. Click the arrows in the middle to add or remove 
selected items from viewing.
The following are the items available for viewing in the Device Management screen:

COMPONENT DESCRIPTION

Channel Protocols Displays the list of channel protocols representing the set of input data sources which 
can provide print data to one or more of the interpreters available on a printer

Device Displays the device’s information.
• Color : Color or monochrome information
• Contact Person : Contact information
• HDD Size
• Host Name : The host name of the device.
• IP Address
• Local : 
• Location : The physical location of the device.
• MAC Address
• Manufacturer
• Model Name
• Network Name
• New : 
• Page Count : Total printed page count for the device.
• Page Count since Power on : The number of pages printed since the last power 

cycle.
• Serial Number
• Status : The device’s current operational status: Normal, Unknown, Error, 

Warning, or Disconnected.
• Toner : The device’s toner type and their percentages remaining.

Firmware Versions Displays the device’s firmware information.
• Hardware Version : The version of the device’s engine firmware.
• Main Firmware Version : The version of the device’s firmware
• Network Firmware Version : The version of the device’s network card firmware.

Service Displays the various services that are enabled or disabled.

System Displays the system information.
• Altitude Adjustment : Displays the assigned altitude adjustment level to use for 

adjusting print quality
• Asset Number : Assigned asset number.
• Black Color Density
• Clock Mode : The clock display mode of the device’s LCD.
• Color Enable Custom : 
• Cyan Color Density
• Distributer : 
• Enable Alarm Sound
• Enable Auto Continue
• Enable Key Sound
• Firmware Update Enable : Displays that the selected device can be updated 

with the Firmware Management tool.
• Magenta Color Density
• Model Version
• Print Job Timeout : The time assigned for the print job timeout.
• System Module Version : 
• Yellow Color Density
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Viewing Device Information
Double-clicking on any item in a device’s information will drop down more information about the device as well as more 
configuration options. Double-clicking again will close the information.

Adding a Device Group
Printers can be divided into groups for easier management. Groups can only be added under the All > Grouped folder. 
There is no limit to the number of group levels that can be added and the steps for adding any group level will be the same. 
To add a group, follow these steps:
1. Select the group under which the new group is to be created.
2. Click the  button.

The Add Group window opens.
3. Enter the Group Name and Description.
4. Click Add.

Deleting a Device Group
If a group is no longer needed, it can be deleted. The groups All, Ungrouped, and Grouped cannot be deleted. To delete 
a group, follow these steps:
1. Select the group to be deleted.
2. Click the  button.

Tasks Displays the task setting information.
• Last Configuration: Displays the last time the device was configured through 

SyncThru.
• Last Xoae App Operation: Displays the date and time of the latest successful 

operation performed by Application Management upon the given device.
• Application Management: Displays whether or not the given device supports 

remote application management.
• Last Firmware Operation: Displays the last time firmware was updated on the 

device.
• Last Font/Form/Macro Operation: Displays the last time the device had a font/

form/macro task performed.

COMPONENT DESCRIPTION

Common This tab displays physical information about the device, such as image, toner status, 
and paper tray information.

Firmware This tab displays information about the device’s firmware and upgrade history. It 
shows the firmware that supports this device.

Alerts This tab displays the device’s alert history.

Configuration This tab displays the device’s current configuration and the configuration history. Click 
Configuration to make changes to the device’s settings (see "Device Configuration" 
on page 20).

Accounting This tab displays the accounting information for the device.

Assets Displays information related to the assigned assets of the device. “Assets” are 
components of the device.

Font/Form/Macro This tab displays the device’s file storage management history and the files currently 
on the device’s storage unit (see "Firmware Management" on page 32). Click 
Management to open a window where files can be viewed or removed. The user 
interface may have different information, but the process is the same.

Application This tab displays the device’s current applications (see "Device Applications" on 
page 41).

COMPONENT DESCRIPTION
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A confirmation window opens.
3. Click OK.

Editing a Device Group
If a group’s functionality or name needs to be changed, this can be done by clicking on the edit button. The groups All, 
Ungrouped, and Grouped cannot be edited. To edit a group’s information, follow these steps:
1. Select the group to be edited.

2. Click the  button.

The Edit Group window opens.
3. Enter the new Group Name and Description.
4. Click Save.

Adding a Dynamic Group
Printers can be divided into groups for easier management. Groups can only be added under the Custom Group folder. 
Only one level of groups can be added under dynamic groups. To add a group, follow these steps:
1. Select the group that the new group is to be created under.
2. Click the  button.

The Add Group window opens.
3. Enter the Group Name and Description.
4. Select a Filter Match.
5. Click the  button to add a filter to the dynamic group.

Repeat this step for as many condition as necessary.
6. Click Save to save the group and conditions.

Devices meeting the conditions will be added to the group automatically.

Deleting a Dynamic Group
If a group is no longer needed, it can be deleted. The groups Model Group, Color/Mono Group, and On/Off group 
cannot be deleted. To delete a user-created Custom Group, follow these steps:
1. Select the group to be deleted.
2. Click the  button.

A confirmation window opens.
3. Click OK.

Editing a Dynamic Group
If a group’s functionality or name needs to be changed, this can be done by clicking on the edit button. The groups All, 
Ungrouped, and Grouped cannot be edited. To edit a group’s information, follow these steps:
1. Select the group to be edited.

2. Click the  button.

The Edit Group window opens.
3. Enter the new Group Name and Description.
4. Make changes to conditions or Click Remove Condition to remove a conditions.
5. Click Save.

If devices in a group no longer meet the conditions, they will be removed from the Dynamic Group.

Exporting a Group List
To export a device list to Excel, follow these steps:
1. Select Device > Device Management.
2. Select the group to export.

3. Click the  button then CSV.
A window to open or save the Excel file opens.

4. Select to open or save the file.

Adding a Device to a Group
Devices are added to groups via drag and drop.
1. Select Device > Device Management.
2. Select the group containing the devices that need to be moved to another group.
3. Select the check boxes of the devices to be moved.
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4. Click on one of the selected devices and drag it to the group folder to which it is to be added.

Connection Settings
See "Connection" on page 67 for information on the settings that can be configured by clicking the Connection Settings 
button. Selecting the Use default checkbox will change use the default connection settings for the selected devices, and 
selecting the checkbox next to the connection type will allow changes to be made manually.
In the Device > Device Management menu, the Firmware Management tool box is used to configure the settings for 
mass firmware management of the specified devices. To upgrade device firmware, SyncThru™ Admin 6 uses the HTTP 
protocol for upgrading the firmware of Samsung devices. If credentials are enabled on the device, upgrading firmware 
results in failure. You can see the results in Firmware Management History. Here you need to configure the credentials 
with the Connection Settings button.
1. Select the device for which to set credentials.
2. Click Connection Settings.
3. Check Embedded Web Server Settings.
4. Set the SWS login, password, and port (the port number is usually 80).

Device Toolbox Functions
The “toolbox” is the list of links located above the device list. 
The following are the functions provided in the toolbox:
• Device Configuration
• Device Discovery
• Driver Installation
• Application Management
• Firmware Management
• Font/Form/Macro Management

Device Configuration
SyncThru™ 6 also provides a powerful device configuration tool. The Configuration window provides options for all of the 
devices functions and settings. Some features listed in the following sections may not apply to all devices. Multiple devices 
can be selected for configuration, but if the devices have different features available, some settings may fail to be saved. 
• To see the Configuration window, select Device > Device Management > Select the devices for which to change 

settings > Device Configuration tab.
1. Select Device > Device Management > Select the devices for which to change settings > Configuration tab.
2. Click Device Configuration.

The Device Configuration window opens.
3. Make changes to the settings (described in the following sections) or use previously saved settings.

To add features to the settings, click the Add button for each one. The feature will be moved to the table. To remove a 

feature, select the feature in the table and click the  button in the top-left corner of the Action List.
4. Click Next.
5. Adjust the scheduling for when the changes are to start.

COMPONENT DESCRIPTION

Start Now Select this option to make the changes immediately.
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6. Click Next.
The changes will be made to the device and/or saved for future changes. Results can be checked under Device > 
Management History > Device Configuration History (see "Device Configuration History" on page 34).

Configuration Settings
This section will give details on the settings available from the Configuration Settings.

System 
The following are the system settings available for changing:

Scheduling Select this option to set a later date on which the changes are to be made.

Start Date/Time Select a date and time for the changes to be made.

Time Interval Select how often the changes are to update. Options for this are Once, Daily, 
Weekly, or Monthly. The changes will be updated on the same day/date and 
at the same time as the date/time selected for Start Date/Time.

COMPONENT DESCRIPTION

Action To add any of the Action settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• System Restart : Selecting this option will set the System Restart 

command. This is used to check the device by restarting the system when 
an error is received.

• Manual image overwrite : Selecting this option will erase the hard disk 
drive.

• Document box clear : Selecting this option will empty the document box 
on the device.

General To add any of the General settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

bottom table and click the  button in the top-left corner of the table.
• Host Name : The host name of the device.
• Location : The physical location of the device.
• Contact : The contact person for the device. Any information for contact 

purposes is usable.
• Asset Number : An asset number. The Asset Number is used to 

manage devices as assets. Any number can be assigned to this value.
• Distributor Name : A distributor name. The Distributor Name is used to 

make managing devices easier. This value can be the manufacturer or a 
contact person.

• Clock Mode : Set the mode of the device’s on-screen clock. Options for 
this are 12 Hours or 24 Hours.

• Power Save Timeout : UA value (in seconds) for how long the device 
must be idle before it will enter power save mode.

• Job Timeout : A value (in seconds) for how long the system will hold a 
print job before aborting the job. A value of 15 or more is recommended 
for busy networks.

• Altitude Adjust : Select a value for the device’s altitude. Altitude affects 
print quality and toner usage. Options for this and their altitude 
assignments are the following:
- Normal : 0 - 1,000 m above sea level or 0 - 3,200 ft.
- High 1 : 1,000 - 2,000 m above sea level or 3,200 - 6,500 ft.
- High 2 : 2,000 - 3,000 m above sea level or 6,500 - 9,800 ft.
- High 3 : 3,000 - 4,000 m above sea level or 9.800 - 13,000 ft.

• Auto Continue Enabled : Select this check box to continue a job 
automatically even if there is a paper mismatch error. Do not select this 
check box if you do not want a job to continue if the paper does not 
match.

COMPONENT DESCRIPTION
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Consumables To add any of the Consumables settings to the device, click Add in the 
pop-up window. To remove a setting that has been added, select the setting 

in the table and click the  button in the top-left corner of the table.
• Toner Save Enabled : Select this option to set the toner saving policy. 

The life of the toner cartridge(s) will be extended without significant 
lessening of print quality.

Sound/Volume To add any of the Sound/Volume settings to the device, click Add in the 
pop-up window. To remove a setting that has been added, select the setting 

in the table and click the  button in the top-left corner of the table.
• Key Sound Enabled : Select this option to turn on audible sound when a 

key on the device is pressed. De-select this option to turn off key sounds.
• Alarm Sound Enabled : Select this option to turn on an audible sound 

for the system alarm. De-select this option to turn off key sounds.
• Speaker (Fax Sending) : Use the pull-down menu to set the speaker 

setting for outgoing faxes. Options for this are the following:
- Off : The speaker is turned off.
- On : The speaker is turned on throughout the entire fax transmission 

process.
- Comm. : The speaker is turned on during dialing and connection 

negotiation but turned off during data transfer. This is the typical 
modem setting.

• Ringer (Fax Receiving : Use the pull-down menu to set the speaker 
setting for incoming faxes.

COMPONENT DESCRIPTION
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Print
The following are the print settings available for changing:

Copy
The following are the copy settings available for changing:

COMPONENT DESCRIPTION

General To add any of the General settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Color Printing Enabled : Use this pull-down menu to select the default 

color mode. Options for this setting are Color, Mono, and Gray.
• USB Direct Printing Enabled : Select this option to enable direct 

printing from a USB device on the printer.
• Print Default Duplex : Use this pull-down menu to select the default 

duplex print mode. Options for this setting are the following:
- Off : The device will print on one side of the paper.
- Long Edge : The device will print on both sides of the paper with the 

paper oriented for long edge binding.
- Short Edge : The device will print on both sides of the paper with the 

paper oriented for short edge binding.
• Print Default Orientation : Use this pull-down menu to select the default 

page orientation. Options for this setting are the following:
- Portrait : The orientation will be portrait (short edge as the page top).
- Landscape : The orientation will be landscape (long edge as the 

page top).
- Short Edge : The device will print on both sides of the paper with the 

paper oriented for short edge binding.
• Print Darkness : Use this pull-down menu to select the default toner 

darkness of prints. Options for this setting are Light, Normal, Dark, 
Lightest, and Darkest.

Color To add any of the Color settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Auto Color Registration : Select this option to set the auto color 

registration process. Default color registration values will be used unless 
custom values are selected.

• Black : Use the pull-down menu to set the relative level of black toner for 
color registration.

• Cyan : Use the pull-down menu to set the relative level of cyan toner for 
color registration.

• Magenta : Use the pull-down menu to set the relative level of magenta 
toner for color registration.

• Yellow : Use the pull-down menu to set the relative level of yellow toner 
for color registration.
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Fax
The following are the fax settings available for changing:

COMPONENT DESCRIPTION

General To add any of the General settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Copier Enabled : Select this option to allow users to use the copy 

function of the device. If this is not selected, users cannot use any copy 
functions.

• Copier Darkness : Select the default darkness of copies.
• Copier Original Type : Set the default type for copies made on the 

device. Select this option to enable direct printing from a USB device on 
the printer.
- Text : The default copied original will be a text only document.
- Text and Photo : The default copied original will include text and 

images.
- Photo : The default copied original will include images
- LineArt : The default copied original will be line art.
- Color : The default copied original will be a color document.
- Gray : The default copied original will be a grayscale document.

COMPONENT DESCRIPTION

General To add any of the General settings to the device, click Add in the pop-up 
window.To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Fax Enabled : Allow users to use the fax function of the device. If this is 

not selected, users cannot use any fax functions.
• Fax Machine ID : Enter the machine’s ID that will appear in the “from” 

field of the Transmitting Terminal Identification (TTI).
• Fax Number : Enter the machine’s fax number that will appear in the 

“from” field of the Receiving Terminal identification (RTI).
• Fax Default Darkness : Select the default darkness of fax images.
• Fax Default Resolution : Set the default resolution for fax images. 

Options for this setting are the following:
- Standard : 
- Fine : 
- Super Fine : 
- Photo : 
- Color : 

Sending To add any of the Sending settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Fax Sending Redial Times : Enter the maximum number of redial 

attempts when sending a fax.
• Fax Sending Redial Interval : Enter the time (in seconds) that the 

system will wait between redial attempts.
• Fax Sending Prefix Dial : Enter a dialing prefix for outgoing fax calls.
• Fax Sending Error Correction Mode Enabled : Select this option to 

enable Error Correction Mode (ECM) for fax transmissions.
• Fax Sending Report : Set fax report printing mode for sent faxes. 

Options for this setting are the following:
- Off : A fax report will never print.
- On : A fax report will always print after a fax job.
- On Error : A fax report will only print when an error occurs during 

transmission.
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Scan
The following are the scan settings available for changing:

Receiving To add any of the Receiving settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Fax Receiving Mode : Select the default fax receiving mode. Options for 

this setting are the following:
- Tel : Faxes will not be received and the fax machine will ring until a 

user answers the call with an external phone.
- Fax : Faxes will be received automatically after the number of rings 

set in Fax Receiving Ring to Answer.
- Ans/Fax : Faxes will be received automatically after the CNG tone 

and Remote Code or after the number of rings set in Fax Receiving 
Ring to Answer.

• Fax Receiving Ring to Answer : Enter the number times the machine 
will ring before the system answers.

• Fax Receiving Start Code Enabled : Enable the usage of a Remote 
Code to start receiving a fax automatically.

• Fax Receiving Start Code : Enter a Remote Code used to start 
receiving a fax automatically.

• Fax Receiving Auto Reduction Enabled : Select this option to 
automatically reduce an incoming fax to fit on the size of paper available 
in the fax machine.

• Fax Receiving Discard Size (mm) : Enter (in millimeters) the amount of 
image to delete.

• Fax Receiving Default Duplex : Set the default duplex option for 
incoming faxes. Options for this setting are the following:
- Off : Faxes will print on one side of the paper.
- Long Edge : Faxes will print on both sides of the paper with the 

paper oriented for long edge binding.
- Short Edge : Faxes will print on both sides of the paper with the 

paper oriented for short edge binding.

COMPONENT DESCRIPTION

General To add any of the General settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Scanner Enabled : Select this option to allow users to use the scan 

function of the device. If this is not selected, users cannot use any scan 
functions.

• Scan Default Original Type : Set the default type for scans made on the 
device. Options for this setting are Text, Text/Photo, and Photo.

• Scan Default Resolution : Set the default resolution for scanned 
images.

• Scan Default Color Mode : Select the default color mode of scanned 
images from among Color, Mono, and Gray.

• Scan Default File Format : Set the default file format into which images 
will be scanned. Options for this setting are PDF, Single-Page TIFF, 
Multi-Page TIFF, and JPEG.

Scan to Email To add any of the Scan to Email settings to the device, click Add in the 
pop-up window. To remove a setting that has been added, select the setting 

in the table and click the  button in the top-left corner of the table.
• Scan to Email Enabled : Select this option to enable users to use the 

scan to email function.

COMPONENT DESCRIPTION
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Email
The following are the email settings available for changing:

Network
The following are the network settings available for changing:

Scan to FTP To add any of the Scan to FTP settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Scan to FTP Enabled : Select this option to enable users to use the 

scan to FTP function.
• Scan to FTP Server Connection Timeout (seconds) : Enter (in 

seconds) how long the system needs to be idle before the connection is 
automatically closed.

• Scan to FTP Servers : Enter a new FTP server’s information by clicking 
on the plus button.

Scan to SMB To add any of the Scan to SMB settings to the device, click Add in the 
pop-up window. To remove a setting that has been added, select the setting 

in the table and click the  button in the top-left corner of the table.
• Scan to SMB Enabled : Select this option to enable users to use the 

scan to SMB function.
• Scan to SMB Server Connection Timeout (seconds) : Enter (in 

seconds) how long the system needs to be idle before the connection is 
automatically closed.

• Scan to SMB Servers : Enter a new SMB server’s information by 
clicking on the plus button.

COMPONENT DESCRIPTION

SMTP Client To add any of the SMTP Client settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Scan to Email Default [From:] Address : Set when the speed of the 

ethernet interface. To set the speed by the system, select Automatic. 
Another options for this setting are 10 Mbps (Half Duplex), 10 Mbps 
(Full Duplex), 100 Mbps (Half Duplex), 100 Mbps (Full Duplex), 1 
Gbps (Half Duplex), and 1 Gbps (Full Duplex).

• Scan to Email Auto Send to Self : Select this option to automatically 
send the scanned image to the sender along with the recipients.

• Scan to Email Default Subject : Enter a default subject line for images 
sent using the scan to email function.

• Scan to Email Default Body Text : Enter a default message for images 
sent using the scan to email function.

• Scan to Email Print Confirmation Sheet : Set when a scan to email 
confirmation sheet will be printed:
- On Errors Only : A report will be printed only if an error occurs 

during transmission.
- Never : A report will never be printed.
- Always : A report will always be printed when a fax is forwarded.

Address Book The Address Book setting is used to distribute a list of email addresses to 
multiple devices at once. To add users to the list, click the  button and 

enter the user’s information. To remove a user from the list, click the  
button. The data can also be exported as a .csv file, or pre-existing data can 
be imported as a .csv file.
• Address Book 1.0 : Version 1.0 of the address book. This version is not 

supported by all devices.
• Address Book 1.1 : Version 1.1 of the address book. This version is not 

supported by all devices.
• Address Book 2.0 : Version 2.0 of the address book. This version is not 

supported by all devices.

COMPONENT DESCRIPTION
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COMPONENT DESCRIPTION

Ethernet To add any of the Ethernet settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Ethernet Speed Rate : Enter the default sending email address for 

images scanned using the scan to email function.

IP Filtering To add any of the IP Filtering settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• IP Filtering Enabled : Select this option to filter which IPs will have 

access to the network.

IPP To add any of the IPP settings to the device, click Add in the pop-up window. 
To remove a setting that has been added, select the setting in the table and 

click the  button in the top-left corner of the table.
• IPP Enabled : Select this option to enable Internet Printing Protocol (IPP) 

for remote printing.
• IPP Printer Name : Enter a user-friendly name for the IPP printer.
• IPP Printer URI : Enter the URI of the IPP printer.
• IPP Printer Information : Enter a description for the printer.
• IPP More Printer Information : Enter more information for the printer.
• IPP Printer Location : Enter the physical location of the printer.
• IPP Multiple Operation Timeout : Enter (in seconds) how long the 

printer will wait for additional send-document or send-URI commands 
while a multi-document job is still open before taking any recovery 
actions. This should be at least 30 seconds for busy networks.

• IPP Time to Keep Jobs in History : Enter (in seconds) how long the 
printer will keep completed IPP jobs in the job history. This should be at 
least 30 seconds for reliable job accounting and job completion 
notifications on busy networks.

• IPP Operator Message : The message delivered to the user with device 
status information.

LPD To add any of the LPD settings to the device, click Add in the pop-up window. 
To remove a setting that has been added, select the setting in the table and 

click the  button in the top-left corner of the table.
• LPR/LPD Protocol Enabled : Select this option to enable Line Printer 

Remote/Line Printer Daemon (LPR/LPD) for platform-independent 
printing.

• LPR/LPD Protocol Port : Enter the port to use for LPR/LPD printing. 515 
is set as default.

SLP To add any of the SLP settings to the device, click Add in the pop-up window. 
To remove a setting that has been added, select the setting in the table and 

click the  button in the top-left corner of the table.
• SLP Enabled : Select this option to enable Service Location Protocol 

(SLP).
• SLP Message Type : Set the User Datagram Protocol (UDP) message 

type for SLP discovery requests. Options for this setting are:
- Multicast : Sends the message to a specific set of multiple 

destinations simultaneously.
- Broadcast : Sends the message to all devices in the given range.

• SLP Multicast Radius : Enter the UPD multicast radius (TTL or hop 
count) for SLP discovery requests. 255 is set as default.

• SLP Registration Lifetime : Set the lifetime (in seconds) of SLP 
registration (how long the registration will be active).
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Security
The following are the security settings available for changing:

Job Accounting

 

Only appears if the Job Accounting plug-in is installed.

The following are the job accounting settings available for changing:

SNMP Traps To add any of the SNMP Traps settings to the device, click Add in the pop-up 
window.To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• SNMP Authentication Traps Enabled : Select this option to enable the 

system to support generation of SNMP authentication failure traps.

TCP/IP To add any of the TCP/IP settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Dynamic DNS Registration : Select this option to enable dynamic DNS 

registration.
• Domain Name : Enter the domain name of the DNS server.
• Primary DNS Server : Enter the IP address of the primary DNS server.
• Secondary DNS Server : Enter the IP address of the secondary DNS 

server.
• Primary WINS Server : Enter the IP address of the primary WINS 

server.
• Secondary WINS Server : Enter the IP address of the secondary WINS 

server.

UPnP To add any of the UPnP settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Auto IP : Enable Auto IP usage for link-local auto-configuration.
• Multicast DNS : Enable DNS usage for printer advertisement.
• SSDP : Enable Simple Service Discovery Protocol (SSDP) usage for 

printer advertisement via multicast address 239.255.255.250.
• SSDP TTL : Enter the UPD multicast radius (TTL or hop count) for SSDP 

advertising.

COMPONENT DESCRIPTION

Security To add any of the Security settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Printer Firmware Update Enabled : Enable software/firmware update 

operations.

SWS To add any of the SWS settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• SWS Password Enabled : Enable the login ID/password requirement for 

accessing SyncThru.
• SWS Login ID : Enter the administrative login ID for SyncThru.
• SWS Login Password : Enter the administrative password for 

SyncThru. Select the Show Password option to display the actual 
password instead of *s.

COMPONENT DESCRIPTION

Error Report To add any of the Error Reporting settings to the device, click Add in the 
pop-up window. To remove a setting that has been added, select the setting 

in the table and click the  button in the top-left corner of the table.
• Error Reporting Enabled : Enable error reporting for the device.

COMPONENT DESCRIPTION
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Device Discovery
SyncThru™ 6 allows you to search your network for devices. You can schedule and configure discoveries to suit your 
needs. Once devices are discovered, their information is stored on the server. To discover devices, you have to choose a 
discovery method.

Initializing New Discovery Settings
To set up new discovery settings, follow these steps:
1. Select Device > Device Management, then click on Device Discovery in the toolbox.
2. Select which search procedure(s) to use (multiple selections are allowed): Broadcast, IP range, SLP multicast, 

LDAP, and/or Enable local devices discovery (WMI). You can also use a CSV file with device information to 
import a list of specific devices. 

 

If you already have a discovery options template, load it by clicking the Load Template ( ) button.

Job Types To add any of the Job Types settings to the device, click Add in the pop-up 
window. To remove a setting that has been added, select the setting in the 

table and click the  button in the top-left corner of the table.
• Enable Copy Job : Enable copy jobs for users on this device.
• Enable Fax Job : Enable fax jobs for users on this device.
• Enable Print Job : Enable print jobs for users on this device.
• Enable Scan Job : Enable scan jobs for users on this device.

COMPONENT DESCRIPTION

Broadcast This sends a general SNMP request to all of the active devices on the local subnet 
and listens for responses from supported devices.
Broadcast method is suitable for the following:
• searching a small network with few devices.
• searching devices quickly.
• searching a single subnet.

IP range This method searches for the devices within a range of IP addresses. SyncThru™ 6 
can find devices on local or remote subnets. It can be slow on large networks because 
the system checks each IP address, including unused ones, to see if there is a device.
IP Range method is suitable for the following:
• searching devices on local and remote subnets. 
• running a discovery for specific IP Ranges with different schedules.
• limiting the scope of discovery on the network.
• searching multiple IP ranges.

SLP multicast This method sends a single SLP request over the specific multicast address, 
239.255.255.253, defined by RFC 2608. Only the devices which support the multicast 
IP address can respond to this request. SLP is similar to the Broadcast discovery 
except that it only looks for a specific device, which means that it does not generate 
as much network traffic and is less likely to lose device responses.

 

The values of the Multicast address and Scope for Samsung devices are 
embedded in SyncThru™ 6. Port number 427 is always used for SLP 
discovery. Please make sure that SLP protocol is enabled on the devices. 
Otherwise, you need to contact your network administrator.

SLP multicast method is suitable for the following:
• searching devices that support multicast broadcasts. 
• searching devices on a relatively small network.

LDAP This method requires your knowledge of LDAP and Active Directory domain. If you 
use LDAP discovery method, SyncThru™ 6 scans the Active Directory or LDAP 
server for the printers using LDAP protocol. First, you have to configure LDAP server 
information in Settings menu > Network Settings > LDAP Server.
LDAP method is suitable for the following:
• searching devices on LDAP servers including Active Directory. 

COMPONENT DESCRIPTION
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3. Click the Save Template ( ) button if you want to save the settings for future discoveries.
4. Click Next.
5. Adjust the scheduling for when device discovery is to take place.

Results of discovered devices can be found on Device > Management History > Device Discovery History and 
discovered devices will be in the Ungrouped group found at Device > Device Management.

Viewing Discovery Results
This section will explain the discovery results screen found at Device > Management History > Device Discovery 
History.

The calendar is a quick way to tell which dates have had a discovery performed and discoveries that are scheduled for 
the future. Dates that have a red triangle in the corner have discoveries: clicking on those dates will open a pop-up 
showing the name of those discoveries. Clicking on the date again will close the pop-up.

Driver Installation
The Driver Installation button provides options for installing drivers for your devices.
1. Select Device > Device Management.
2. Select a device for which the drivers will be installed.
3. Click Driver Installation.

The Driver Installation wizard opens.
4. Select to automatically find the driver file or to manually selected it from the uploaded drivers.

 

Driver files need to already be uploaded to the SyncThru server.

CSV Import This method searches the devices with the specified IP addresses. If you have a IP 
address list of your devices, you can upload CSV file for easy and efficient discovery. 
There is no unnecessary packet during discovery because SyncThru™ 6 queries only 
to the specified IP addresses.
CSV Import method is suitable for the following:
• searching devices with a specific IP addresses list. 
• running a discovery for specific IP Ranges with different schedules. 
• limiting the scope of discovery on the network. 

Discovery Options Provides options for connection types to be searched. Click on Connection Settings 
to make changes to SNMP or WMI settings (see "Connection Settings" on page 20).

COMPONENT DESCRIPTION

Start Now Select this option to make the changes immediately.

Scheduling Set a later date on which the changes are to be made.
• Date & Time : Select a date and time for the changes to be made. 
• Interval : Select how often the changes are to update. The changes will be 

updated on the same day/date and at the same time as the date/time selected for 
Date & Time. 

COMPONENT DESCRIPTION

Tasks This list shows discoveries that have been performed based on the filtering criteria. 
Clicking on an item in the list will display in the main pane the devices found by using 
the discovery’s settings.

COMPONENT DESCRIPTION

Click this button to refresh the device list.

Click this button to print the information in the device list.

Click this button to open information about the discovery. Click the button again to 
close the information.
A discovery that is in process can be paused or stopped from this window. 

Devices Information about the devices is displayed. The information can be sorted 
alphanumerically/reverse alphanumerically by clicking on a column header.

COMPONENT DESCRIPTION
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5. Click Next.
The driver download window will open.

6. Save and execute the setup file.
The driver will be automatically installed on your system.

Application Management
The Application Management button provides options for installing and managing applications on your devices.

Installing an Application
To install an application on one or more devices, follow these steps (at any time during the process, you can click 
Cancel to exit the process and close the window):
1. Select Device > Device Management.
2. Select the devices on which the application will be installed.
3. Click Application Management in the toolbox.

The Application Management wizard opens.
4. Select Application installation.
5. Click Next.
6. Select the application(s) to install.
7. Click Next.
8. Schedule the task.
9. Click Finish.

 

Only PAR files are accepted.

10. Click Close.

Uninstalling an Application
To uninstall an application from one or more devices, follow these steps (at any time during the process, you can click 
Cancel to exit the process and close the window):
1. Select Device > Device Management.
2. Select the devices from which the application will be removed.
3. Click Application Management in the toolbox.

The Application Management wizard opens.
4. Select Application uninstallation.
5. Click Next.
6. Select the application(s) to uninstall.
7. Click Next.
8. Schedule the task.
9. Click Finish.

Application Lifecycle Management
Application Lifecycle Management is used to start and stop applications running on devices. To manage 
applications, follow these steps (at any time during the process, you can click Cancel to exit the process and close the 
window):
1. Select Device > Device Management.
2. Select the devices on which the application will be installed.
3. Click Application Management in the toolbox.

The Application Management wizard opens.
4. Select Application lifecycle control.
5. Click Next.
6. Select the application(s) to control.
7. Click Next.
8. Select to either start or stop the application.
9. Click Next.
10. Schedule the task.
11. Click Finish.

License Activation
After installing an application, you will need to activate the license to allow full usage of the application. To activate the 
license, follow these steps (at any time during the process, you can click Cancel to exit the process and close the 
window):
1. Select Device > Device Management.
2. Select the devices on which the application will be installed.
3. Click Application Management in the toolbox.

The Application Management wizard opens.
4. Select Activate license.
5. Click Next.
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6. Select the application(s) to activate.
7. Click Next.
8. Enter the license number for each application.
9. Click Next.
10. Schedule the task.
11. Click Finish.

License Deactivation
After installing an application, it may become necessary to deactivate its license. To deactivate the license, follow 
these steps (at any time during the process, you can click Cancel to exit the process and close the window):
1. Select Device > Device Management.
2. Select the devices on which the application is installed.
3. Click Application Management in the toolbox.

The Application Management wizard opens.
4. Select Deactivate license.
5. Click Next.
6. Select the application(s) to deactivate.
7. Click Next.
8. Schedule the task.
9. Click Finish to start the task.

Viewing Created Task History
 Application Management history shows application tasks that have been performed using SyncThru™. See 
"Application Management History" on page 33.

Firmware Management
To upgrade one or more devices’ firmware, follow these steps:
1. Select Device > Device Management.
2. Select the group to which the devices belong.
3. Select the devices for which to upgrade firmware.
4. Click Firmware Management in the toolbox.

The Firmware Management window opens.
5. Select a file to add and click Add at the bottom of the window.

If you want to upload a file from your local directory then click File Upload at the top of the window.
a. Enter the file information and click Browse to find the firmware file.
b. Click Upload File to add the file to the list of files that can be added.

6. Click Next.
7. Schedule the task by clicking on Scheduling, or start the task immediately by clicking on Start Now.
8. Click Finish.

A confirmation message will appear.

 

Clicking on Firmware Management History will redirect you to the Firmware Management History page.

9. Click Close.

Font/Form/Macro Management
The Font/Form/Macro Management function provides options for managing files stored on a device’s storage unit. Follow 
the steps in the following sections to manage a device’s files.

Adding a File
To upload a file to a device, follow these steps:

 

This process can also be performed by double-clicking on a device to expand the device’s information and 
clicking on Management.

1. Select Device > Device Management.
2. Select the devices on which the file will be installed.
3. Click Font/Form/Macro Management in the toolbox.

The Font/Form/Macro Management wizard opens.
4. Select Install.
5. Click the checkbox(es) of the file(s) to add.

If the file does not exist, upload it by clicking  and click the checkbox(es) of the file(s).

6. Click Next.
7. Adjust the scheduling for when the setting changes are to take place.

The file will start being copied to the device’s storage unit. Results of Font/Form/Macro Management can be 
checked under Font/Form/Macro Management History (see "Font/Form/Macro Management History" on 
page 35).

8. Click Finish.
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Deleting a File
To delete a file from SyncThru, follow these steps:
1. Select Device > Device Management.
2. Double-click a device to open its information.
3. Click Font/Form/Macro.
4. Click the Management button.
5. Select the file(s) and click the  button.

6. Click OK.

Downloading a File
To download a file from SyncThru to a device, follow these steps:
1. Select Device > Device Management.
2. Double-click a device to open its information.
3. Click Font/Form/Macro.
4. Click the Management button.
5. Select the file(s) and click Download.

 

Only files whose “Persistence” field is not “Permanent” are downloadable.

Management History
The Management History sub-menu contains options for displaying the histories of firmware upgrades, file management, 
application management, and device configuration.

Application Management History
Application Management history shows application tasks that have been performed using SyncThru™. To view the 
application management history, follow these steps:
1. Select Device > Management History > Application Management.

The Application Management history page opens.

The calendar is a quick way to tell which dates have had an application management task performed or have a task 
scheduled. Dates that have a red triangle in the corner have application management tasks: clicking on those dates 
will open a pop-up showing the name of those tasks. Clicking on the date again will close the pop-up.

Firmware Management History
Firmware Management history shows firmware upgrades that have been performed using SyncThru™. To view the 
firmware upgrade history, follow these steps:

COMPONENT DESCRIPTION

Tasks This list shows application tasks that have been performed based on the filtering 
criteria.Clicking on an item in the list will display in the main pane the devices on 
which an application management task was performed.

Type Use this pull-down menu to filter which type of application tasks are displayed. 
Options for this are All, In Progress, Pause, and Finished.

Filter Use this pull-down menu to filter which type of firmware upgrade tasks are displayed. 
Options for this are All, Succeed, and Fail.

Operation The name of the performed operation. This can be one of the following values:
• EAM Install task
• EAM Start task
• EAM Stop task
• EAM Uninstall task
• EAM Application Activate task
• EAM Application Deactivate task

State The state of performed operation. This can be one of the following values:
• WAITING 
• IN_PROGRESS
• STOPPED
• FAILED
• SUCCEED

IP Address Displays the device’s IP address.

Device Serial Number Displays the device’s serial number.
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1. Select Device > Management History > Firmware Management History.
The Firmware Management History page opens.

The calendar is a quick way to tell which dates have had a firmware upgrade performed and have firmware upgrades 
scheduled. Dates that have a red triangle in the corner have firmware upgrades: clicking on those dates will open a 
pop-up showing the name of those upgrade tasks. Clicking on the date again will close the pop-up.

Progress Panel
The progress panel located at the top of the main pane displays the overall progress of the upgrade process. Click on 

 to open the progress panel. The panel shows the following information for the currently selected firmware 

management task:
• Execution Time: The date and start/end time of the upgrading task.
• Task State: The state of the selected task.

The progress bar displays the current firmware upgrade progress (100% if finished). To close the panel, click the  

button again. You can also control the firmware upgrade process by using the buttons available on the panel (pause, 
stop, and start).

Retrying a Firmware Management Task
You can also retry upgrading the firmware of specified devices by using the Retry button. The following are the 
available options:
• Retry Failed: Retry firmware management tasks for all devices that failed to upgrade.
• Retry Selected: Retry firmware management tasks for only the selected devices.
Some devices may have failed due to credentials being enabled on the device. To specify the credentials to use for 
these devices, follow these steps:
1. Select the necessary devices and click the Set Credentials button.
2. Click the Retry button at the top of the list.

The Retry menu is displayed.
3. Select the option.

A new firmware management task with the original firmware upgrade settings will be started for the devices.

Device Configuration History
Device Configuration History shows device configurations that have been performed using SyncThru™. To view the 
device configuration history, follow these steps:

COMPONENT DESCRIPTION

Tasks This list shows firmware upgrades that have been performed based on the filtering 
criteria. Clicking on an item in the list will display in the main pane the devices on 
which the firmware upgrade was performed.

Filter Use this pull-down menu to filter which type of firmware upgrade tasks are displayed. 
Options for this are All, Succeed, and Fail.
• All: All devices in the firmware upgrade task will be displayed, regardless of 

result.
• Waiting: Only devices in tasks that are waiting to begin.
• In progress: Only devices in tasks that are currently in progress.
• Stopped: Only devices that have firmware upgrading progress stopped by a user.
• Failed: Only devices that firmware upgrading has failed for will be displayed.
• Succeed: Only devices that firmware upgrading has succeeded for will be 

displayed.

Result The result of upgrading the firmware of the device. After a firmware management task 
is finished, the result value will be either Success or Failed.

IP Address Displays the device’s IP address.

Serial Number Displays the device’s serial number.

Upgrade Date Displays when the upgrading process was started.

File Name Displays the firmware file name.

Start Main Version/NIC 
Version/Engine Version

Displays the initial firmware version for the specified device. If the task failed, these 
columns are not displayed.

Finish Main Version/NIC 
Version/Engine Version

Displays the final firmware version for the specified device. If the task failed, these 
columns are not displayed.

Error Code Displays an error code if the task failed.
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1. Select Device > Management History > Device Configuration History.
The Device Configuration History page opens.

The calendar is a quick way to tell which dates have had a device configuration performed and have a device 
configuration scheduled. Dates that have a red triangle in the corner have configurations: clicking on those dates will 
open a pop-up showing the name of those tasks. Clicking on the date again will close the pop-up.

2. Select a task from the list in the left pane.

 

Double-clicking information in the list will open more information about the configured properties. This 
information will vary based on the property.

Font/Form/Macro Management History
Font/Form/Macro Management History shows when files have been moved to or from the device’s storage unit. To view 
the file storage history, follow these steps:
Select Device > Management History > Font/Form/Macro Management History.

The Font/Form/Macro Management History history page opens.
The calendar is a quick way to tell which dates have had a file storage task performed and have a file storage task 
scheduled. Dates that have a red triangle in the corner have file storage tasks: clicking on those dates will open a 
pop-up showing the name of those tasks. Clicking on the date again will close the pop-up.

3. Select a task from the list in the left pane.

COMPONENT DESCRIPTION

Task State Displays whether or not the task completed successfully.

Start Time
End Time

The times the task started and ended.

Devices Configured
Devices Not Configured

The number of devices that were able to be configured and the number not able to be 
configured.

COMPONENT DESCRIPTION

Tasks This list shows device configurations that have been performed based on the filtering 
criteria.Clicking on an item in the list will display in the main pane the devices on 
which configuration was performed.

Filter Use this pull-down menu to filter which type of configuration tasks are displayed. 
Options for this are All, Completed No Errors, Completed With Errors, Cancelled, 
and Finished.

Retry Option to retry the selected tasks or all of the tasks.

Status Displays whether or not the task completed successfully.

Device Name Displays the device’s name.

Device Model Name Displays the device’s model name.

Device Mac Address Displays the device’s MAC address.

Device Manufacturer Displays the device’s manufacturer.

COMPONENT DESCRIPTION

Tasks This list shows file storage tasks that have been performed based on the filtering 
criteria.Clicking on an item in the list will display in the main pane the devices on 
which a file storage task was performed.

Retry Tries to perform the selected task again.

Filter Use this pull-down menu to filter which type of font/form/macro tasks are displayed. 
Options for this are All, Succeed, and Fail.
• All: All devices in the font/form/macro upgrade task will be displayed, regardless 

of result.
• Waiting: Only devices in tasks that are waiting to begin.
• In progress: Only devices in tasks that are currently in progress.
• Stopped: Only devices that have font/form/macro upgrading progress stopped by 

a user.
• Failed: Only devices that font/form/macro upgrading has failed for will be 

displayed.
• Succeed: Only devices that font/form/macro upgrading has succeeded for will be 

displayed.
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Result Displays the result of the file storage task.

Information Displays the name assigned to the file storage task.

Model Name Displays the printer model affected by the task.

IP Address Displays the printer’s IP address.

Start Time Displays the time the task was started.

Name The name of the file.

File Type Displays the type of file uploaded.

File Key Displays the parsing key of the file.

Error Code If an error occurs during the task, the error code is displayed here. Clicking on the 
error code will open the help file with more information about the code.

COMPONENT DESCRIPTION
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5.User
The User menu supports all the user-related operations such as user and user group 
management. This chapter gives you detailed information on the sub-menus under the User menu 
that help you manage users on the system.

User Group & List
The User menu provides options for adding users to SyncThru and assigning user roles.

Adding a User Group
To add a user group, follow these steps (at any time during the process, you can click Cancel to exit the process and close 
the window):
1. Select User > User Management.
2. Select the main group to which the new group will belong.

3. Click the  button in the left pane.
4. Enter the group’s information.
5. Click Add.

Deleting a User Group
To delete a user group, follow these steps:
1. Select User > User Management.
2. Select the group(s) to delete.

3. Click the  button in the left pane.
A confirmation window opens.

4. Click Yes.

Editing a User Group
To edit a user group’s information, follow these steps:
1. Select User > User Management.
2. Select the group to edit.

3. Click the  button in the left pane.

A confirmation window opens.
4. Click Yes.

Adding a User
To add an user to a group, follow these steps (at any time during the process, you can click Cancel to exit the process and 
close the window):

 

To import multiple users from CSV file or LDAP server, select Import.

1. Select User > User Management.
2. Select the group to which the users will be added.

3. Click the  button in the main pane.
4. Enter the user’s information.
5. Click Add.

Deleting a User
To remove a user from a group, follow these steps:
1. Select User > User Management.
2. Select the group to which the users belong.
3. Select the user(s) to delete.

4. Click the  button in the main pane.
A confirmation window opens.

5. Click Yes.

Editing a User
To edit a user’s information, follow these steps:
1. Select User > User Management.
2. Select the group to which the users belong.
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3. Select the user(s) to edit.

4. Click the  button in the main pane.

The Edit User window opens.
5. Make changes to the user’s information.
6. Click Save.

User Role Assignment
Roles can be assigned to users to give them specific sets of permissions for devices.

Assigning a Role
To assign a role to a user, follow these steps:
1. Select User > User Management.
2. Select the group to which the users belong.
3. Select users to which assign role(s).
4. Click Role Assignment in the toolbox.

The Role Assignment window opens.
5. To add a new role, follow these substeps:

a. Click the  button.
b. Enter a name for the role and select the permissions that will be assigned to the role.
c. Click Add,

6. Select the role to assign to the users.
7. Click Execute.

Viewing User Information
To view user information, follow these steps:
1. Select User > User Management.
2. Select the group to which the user belongs.
3. Select a sorting option from among Ascending, Descending, or Custom.

When selecting Custom, you can re-create the column list to view. Move the items from Column List to Selected 
Column List.

4. Click Close.
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6.Mobile Dashboard
A new feature in SyncThru™ 6 is the ability to view widgets on your network-connected mobile 
device. Being able to monitor devices away from your desk is a useful new feature to assist in 
productivity and less down time for devices. 

Overview
The Mobile Dashboard application is one of the latest additions to SyncThru™ 6, which is developed to access networked 
devices from anywhere. Mobile Dashboard enables users to efficiently manage and monitor network connected devices 
added to SyncThru™ 6 on a network-enabled, hand-held platform. This application integrates SyncThru™ 6 Dashboard 
widgets and displays them on the mobile device.

Application Navigation
The following are used to navigate within the Mobile Dashboard application:

Viewing Widgets
To view widgets on your mobile device, follow these steps:

 

Mobile Dashboard requires an active network for the application to run. Configure the network settings on your 
mobile device to gain access to the SyncThru™ 6 server.

1. Open a web browser on your mobile device and enter <SyncThru™ 6 server’s URL>/m/index.html in the address bar.
2. Log-in to SyncThru™ 6.

3. Select the widget to display by scrolling through the widgets using the  and  buttons on the widget name bar 

at the top of the page (see "Understanding Widgets" on page 13 for information on the types of widgets).
4. Select the device group to view data for from the Group name pull-down list.
5. Pressing widget information below the group name will move to a screen with more information about the devices in 

that selection. For example, pressing Error on the Device Status widget screen will move to a page showing which 
devices belong to that data set.

a. Pressing the  next to a specific device will open a page with information about the selected device.

6. Limit which devices appear by entering a string in the filter field ( ).

ICON NAME DESCRIPTION

home Returns to the home page.

back Returns to the previous web page.

logout Logs the user out of the application.

 / 
App Navigation Navigates through the options and widgets in Mobile Dashboard.

Refresh Refreshes the information in the application.



7.File
The File menu supports all the file-related operations such as uploading application installation 
files, driver installation files, and files to store in the file storage. This chapter gives you detailed 
information on the sub-menus under the File menu that help you manage files on the system.

Plug-ins
The File > Application > Plug-in sub-menu provides options for remotely managing plug-in installation files stored in the 
SyncThru Admin 6 server's repository. These are for printing plug-ins that are installed at server level.

Uploading a Plug-in Installation File
To upload a plug-in installation file, follow these steps:
1. Select File > Application > Plug-in.

2. Click the  button.
The Upload File window opens.

3. Click Browse to find the file to upload (PAR format).
4. Click Upload to upload the file to the server.

The file will be listed in the For Plug-in list.

Removing a Plug-in Installation File
To remove a file from a server’s file repository, follow these steps (at any time during the process, you can click Cancel to 
exit the process and close the window):
1. Select File > Application > Plug-in.
2. Select the file from the list.

3. Click on the  button.
4. Confirm the removal.

The file will be removed.

Viewing Files
To view what installation files have been uploaded to the server, follow these steps:
1. Select File > Application > Plug-in.

Double-clicking on an installation file will expand the information to provide more details about the installation file. It is also 
possible to have several plug-ins included in one installation file.

ITEM DESCRIPTION

Exports the file information as a .csv file.

Prints the file information.

Name The name of the plug-in.

Plug-in ID The unique ID assigned to the plug-in.

Vender The plug-in provider.

Version The version of the plug-in.

ITEM DESCRIPTION

Version The version of the plug-in.

Type The XOA plug-in’s type: System, Platform, or Custom.

Provider The unique ID assigned to the plug-in vendor.

Description A description of the plug-in provided by the developers.

Signature Displays whether or not the PAR file is signed.

Verified by Displays whether or not the plug-in has been verified by Samsung.
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Device Applications
The File > Application > Device sub-menu provides options for remotely managing device application installation files 
stored in the SyncThru Admin 6 server's repository. These are for applications that can be installed on individual, 
compatible devices.

Uploading an Application Installation File
To upload an application installation file, follow these steps:
1. Select File > Application > Device.

2. Click the  button.
The Upload File window opens.

3. Click Browse to find the file to upload (PAR format).
4. Click Upload to upload the file to the server.

The file will be listed in the For Device Application list.

Removing an Application Installation File
To remove a file from a server’s file repository, follow these steps (at any time during the process, you can click Cancel to 
exit the process and close the window):
1. Select File > Application > Device.
2. Select the file from the list.

3. Click on the  button.
4. Confirm the removal.

The file will be removed.

Viewing Files
To view what installation files have been uploaded to the server, follow these steps:
1. Select File > Application > Device.

Double-clicking on an installation file will expand the information to provide more details about the installation file. It is also 
possible to have several applications included in one installation file.

SNMP Agent
The SNMP Agent sub-menu provides options to add devices that are locally connected to a PC through a USB 
connection. The SNMP agent is installed on local PCs and discovers and adds local devices to SyncThru 6. SNMP agent 
executable files are uploaded and stored on the SyncThru server and can be downloaded by users to install on individual 
PCs.

Viewing SNMP Agent Information
To view the uploaded SNMP Agent executable files, follow these steps:
1. Select File > Application > SNMP Agent.

The SNMP Agent Group page opens.

ITEM DESCRIPTION

Exports the file information as a .csv file.

Prints the file information.

Package Name The name of the file.

Provider The application provider.

Release The release version of the application

Description A user entered description of the installation package.

ITEM DESCRIPTION

Name The name of the application.

Application ID The unique ID assigned to the application.

Vendor ID The unique ID assigned to the application vendor.

Version The version of the application.

Verification status Displays whether or not the application has been verified by Samsung.
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The following table will describe the left pane.

The main pane displays the files that are included in the group selected from the left side of the page.

 

To sort the information alphanumerically/reverse alphanumerically, click any column header to sort with that 
columns information.

Adding an SNMP Agent Group
Groups can only be added under the Grouped folder. There is no limit to the number of group levels that can be added 
and the steps for adding any group level will be the same. To add a group, follow these steps:
1. Select the group under which the new group is to be created.
2. Click the button.

The Add Group window opens.
3. Enter the Group Name and Description.
4. Click Add.

Deleting an SNMP Agent Group
If a group is no longer needed, it can be deleted. The groups All SNMP Agents, Ungrouped, and Grouped cannot be 
deleted. To delete a group, follow these steps:
1. Select the group to be deleted.
2. Click the  button.

A confirmation window opens.
3. Click Yes.

Editing an SNMP Agent Group
If a group’s functionality or name needs to be changed, this can be done by clicking on the edit button. The groups All, 
Ungrouped, and Grouped cannot be edited. To edt a group’s information, follow these steps:
1. Select the group to be edited.

2. Click the button.

The Edit Group window opens.
3. Enter the new Group name and Description.
4. Click Add.

Uploading an SNMP Agent File to the Server
1. Select File > Application > SNMP Agent.
2. Select the group from the left pane to which the file is to be added.

3. Click the  button from the main pane.
The Upload File window appears.

4. Click Browse... to select a driver file.
Files must be in EXE format.

5. Click the Select button to set the Group name.
6. Click OK.
7. Enter the files information.

COMPONENT DESCRIPTION

All SNMP Agents The All SNMP Agents section in the left pane displays the groups and sub-groups 
into which the files have been divided.

COMPONENT DESCRIPTION

Version The version of the agent.

File Name The name of the file.

OS The operating system compatible with the agent.

OS Bit The operating system bit compatible with the agent.

Date The date the file was uploaded.

Installation Click the button in this column to download the executable file.

COMPONENT DESCRIPTION

File name The name of the file.
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8. Click Upload.

Deleting an SNMP Agent File from the Server
1. Select File > Application > SNMP Agent.
2. Select the group from the left pane to which the file belongs.
3. Select the file to delete.

4. Click the  button from the main pane.
A confirmation window opens.

5. Click Yes.

Editing an SNMP Agent File’s Information
1. Select File > Application > SNMP Agent.
2. Select the driver to be edited.

3. Click the  button from the main pane.

4. Modify the options.
5. Click Yes.

Exporting the File List
1. Select File > Application > SNMP Agent.
2. Select the files to export.

3. Click the  button. 

4. Enter the file name.
5. Click Yes.

Printing the File List
1. Select File > Application > SNMP Agent.
2. Click the  button. 

3. Select whether to print only the current page of files or the entire list.
A new window with the printable list opens.

Downloading an SNMP Agent File
1. Select File > Application > SNMP Agent.
2. Select the group from the left pane to which the file belongs.
3. Click the Download button in the Installation column to download the .exe file.

Font/Form/Macro
The Font/Form/Macro function provides options for managing files stored on a device’s storage unit. Follow these 
procedures to manage a device’s files:

Viewing Font/Form/Macro Files in SyncThru™
To view the stored files, follow these steps:
1. Select File > Font/Form/Macro.

The Font/Form/Macro List page opens.
The main pane displays the flies that are included in the group selected from the left side of the page.

Group name The group to which the file is being added.

OS The operating system compatible with the agent.

OS bit The operating system bit compatible with the agent.

Description Enter the description.

Application version The version of the agent.

COMPONENT DESCRIPTION

Font/Form/Macro Group The Font/Form/Macro Group section in the left pane displays the groups and 
sub-groups into which the files have been installed.

COMPONENT DESCRIPTION
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Adding a Font/Form/Macro Files from a Desktop to SyncThru™
To upload a file from a desktop to SyncThru, follow these steps:
1. Select File > Font/Form/Macro.

2. Click the  button above the file list. 
The Upload File window opens.

3. Click Browse... and find the file to upload.

 

Only the given file types and ZIP files can be uploaded.

4. Click Upload.
The file will be uploaded.

Deleting a Font/Form/Macro File from SyncThru™
To delete a file from SyncThru, follow these steps:
1. Select File > Font/Form/Macro.
2. Select one or more files. 

3. Click the  button.
A confirmation window opens.

4. Click Yes.

Updating a File Key
1. Select File > Font/Form/Macro.
2. Select one PCL macro or PCL font file.
3. Click Set File Key.
4. Enter a number between 0 and 32767 in the File Key field.
5. Click OK to update the key.

Exporting File Information
To export file information, follow these steps:
1. Select File > Font/Form/Macro.

2. Click the  button.

3. Select a save location for the file and save the file as a .csv file.

Firmware
The File > Firmware sub-menu provides options for remotely managing firmware files stored in the SyncThru™ Admin 6 
server’s repository, including uploading the firmware files from the SyncThru™ server and downloading the files from the 
server to a computer. Firmware for multiple devices can be updated at once instead of one-by-one. If credentials are 
enabled on the device, upgrading firmware will fail. You will need to configure the credentials with the Connection 
Settings button (see "Connection Settings" on page 20).
Follow these steps to manage a device’s firmware files:

 

This feature is only supported by Samsung devices.

Viewing Firmware Files
To view the firmware files stored in the SyncThru™ database, follow these steps: 
1. Select File > Firmware.

The Firmware List page opens.

Exports the file information as a .csv file.

Prints the file information.

Set File Key This is only active when a PCL macro or PCL font file is selected. In case of selecting 
PS font and PS form, Set File Key is disabled. Click this button to modify the File Key 
of the selected file.

Name The parsing name of the file.

File Type The parsing type of the file.

File Key The parsing key of the file.

Size The size of the file.

COMPONENT DESCRIPTION
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Uploading Firmware Files
To upload a firmware file to SyncThru, follow these steps:
1. Select File > Firmware.

2. Click the  button. 
The Upload New File window opens.

 

The version can be alphanumeric, '_', or '-' (e.g. 1.0.0.0_EX, 1.0.0, 1.0 or 1) with each character separated by a 
‘.’.

3. Enter the file information and click Browse to find the firmware file.
4. Click Upload File to upload the selected file to the server.
5. Click OK.

Downloading a Firmware File
To download a firmware file from SyncThru to store locally, follow these steps:
1. Select File > Firmware.
2. Select the file to download.
3. Click the Download button in the Download Firmware column.
4. Go to the directory where the file is to be saved.
5. Click Save.

Deleting Firmware File(s)
To delete firmware files, follow these steps:
1. Select File > Firmware.
2. Select the firmware file(s) to remove.

3. Click the  button.

Modifying a Firmware File
1. Select File > Firmware.
2. Select the specific firmware file you want to modify.

3. Click the  button.

You can modify the Model, Version, and Comment information, which may work as an identifier for the file.

Driver File Management
The Driver sub-menu provides a list of printer drivers that can be installed for discovered printers.

Viewing Driver Files
To view the drivers files, follow these steps:
1. Select File > Driver.

The All Drivers page opens.
2. Select a group from the left pane to view drivers assigned to the selected group.

COMPONENT DESCRIPTION

Exports the file information as a .csv file.

Prints the file information.

File Name The name of the firmware file.

Size The size of the firmware file.

Version The firmware version.

Uploading Date The date and time the firmware was uploaded.

Model The type of device supported by the firmware.

Comment Any text comment for the file.

Download Firmware Displays the Download button to download the firmware file to your hard drive.
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Adding a Driver Group
1. Select File > Driver.

The All Drivers page opens.
2. Select the group that the new group is to be created under.

3. Click the  button in the left pane.
The Add Group window appears.

4. Enter the group name and description.
5. Click Add.

Modifying a Driver Group
1. Select File > Driver.

The All Drivers page opens.
2. Select the group to be modified.

3. Click the  button in the left pane.

The Edit Group window appears.
4. Make changes.
5. Click OK.

Deleting a Driver Group
1. Select File > Driver.
2. Select the group to be deleted.

3. Click the  button in the left pane.
A confirmation window appears.

4. Click Yes.

Uploading a Driver File to the Server
1. Select File > Driver.

2. Click the  button from the main pane.
The Upload File window appears.

3. Click Browse... to select a driver file.
Driver files must be in ZIP format. For Samsung printers, only upload "Universal Print Driver".

4. Click the Select button to set the Group name.
5. Click OK.
6. Set options.

7. Click Upload.

Deleting a Driver File from the Server
1. Select File > Driver.
2. Select the driver to delete.

3. Click the  button from the main pane.
A confirmation window opens.

4. Click Yes.

COMPONENT DESCRIPTION

OS The operating system compatible with the driver.

OS bit The operating system bit compatible with the driver.

Description Enter the description.

Driver version Enter the driver’s version.

Driver model name Enter the model name that is appropriate for the driver file.

Vendor Enter the vendor name.

Supported models Add the printer models supported by the driver, by clicking the  button. For 
Samsung drivers; select the "Samsung" check box.

Driver type Select the driver’s language type such as PCL or PS.

Default Select this to make the driver default from among multiple drivers for the same device.
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Editing a Driver File’s Information
1. Select File > Driver.
2. Select the driver to be edited.

3. Click the  button from the main pane.

4. Modify the options.
5. Click Yes.

Exporting the Driver File List
1. Select File > Driver.
2. Select the files to export.

3. Click the  button. 

4. Enter the file name.
5. Click Yes.

Printing the Driver File List
1. Select File > Driver.
2. Click the  button. 

3. Select whether to print only the current page of files or the entire list.
A new window with the printable list opens.
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8.Reports
This chapter explains the report and analysis functionality SyncThru™ 6 provides. 

Overview
SyncThru™ 6 provides reporting capabilities for devices. You can create, display, and send reports on statuses, usage, 
alerts, consumables, assets and accounting information. The data is collected in a database that can be used to generate 
reports. 
Basically, SyncThru™ 6 analyzes devices’ information with time, historical reports, current reports, and pro-active reports. 
A historical report is used to provide analysis for accumulated data and a proactive report is to provide forecasting based 
on the collected data. You can better understand your printing environment using these various reports. 

 

Please click Settings menu, then in the left pane, System > Data Management to set the report time (see "Data 
Management" on page 62).

Viewing the Report Categories
The following table describes what kinds of reports SyncThru™ 6 provides:

TYPE DESCRIPTION

SLA History Operation Rate History Shows how much time for which the device was working 
properly based on the time required to fix faults and faults 
that occur during working time.

Supply Provision Rate 
History

Shows an overview of how long it has taken for supplies to 
be delivered and the corresponding faults corrected. For 
example, supply delivery time for toner low is set to 48 hours. 
If the service person does not deliver the toner within 48 
hours, the “In Time Rate” is 0 and if it is delivered within the 
supply delivery time, the “In Time Rate” is 100.

Trouble Fix Rate History Shows the average resolution time for fixing faults and the 
total number of faults.

Supply Historical Supply Lifecycle Details Shows toner lifecycle, such as when it was installed, 
generated low toner warnings, and more. 

Supply Lifecycle Shows statistics for toner changing history including average 
time and counts.

Current Supply Current 
Information

Shows current consumables status and remaining level 
configured with supply type, toner type, and state.

Forecast Supply Forecast Shows estimation for how many toners should be bought for 
the specified period configured with supply type, toner type, 
and state.

Supply Details Forecast Shows estimation for when to replace toner for the specified 
devices configured with supply type and toner type.

Assets Current Tray Information Shows current tray information of devices.

History Assets Information History Shows asset changes history for the following asset types for 
a select time period:
• IP
• Location
• Registration
• Group changes
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Job 
Account-
ing

History Device Usage Shows accounting activity for each device and for users 
associated with it.

 User Usage Shows accounting activity for users and jobs performed by 
users along with the devices with which the user is 
associated.

User Group Usage Shows accounting activity for user groups and users in the 
group, and a list of devices with which the user group is 
associated.

User Group Summary 
Usage

Shows overall accounting activity for all user groups.

Device 
Usage

Current Device Total Usage Shows the current state of device usage count.

Device Detailed Usage Shows usage count grouped by various combinations.

 

• This report is available only for Samsung devices.
• You can see "Units" in Report Settings or 

Analysis Settings. This option is for configuring 
unit for usage data. Available options are 
"Impressions" or "Sheets". Usage data collection 
works like this: Devices send impression count to 
SyncThru™ 6 and impression based report 
includes exact count. If you select a "Sheets" 
based report, SyncThru™ 6 calculates sheet count 
using impression count collected from devices. 
Therefore Sheet count is approximate Job Type is 
also an option for generating reports.

History Device Peak Usage History Shows hourly distribution of printed pages based on total 
count information.

Device Total Usage History Shows how many pages were printed during the specified 
period. It uses total count information.

Device Detailed Usage 
History

Shows usage count grouped by various combinations. 

 

• This report is available only for Samsung devices.
• You can see "Units" in Report Settings or 

Analysis Settings. This option is for configuring 
unit for usage data. Available options are 
"Impressions" or "Sheets". Usage data collection 
works like this: Devices send impression count to 
SyncThru™ 6 and impression based report 
includes exact count. If you select "Sheets" based 
report, SyncThru™ 6 calculates sheet count using 
impression count collected from devices. 
Therefore Sheet count is approximate. Job Type 
is also an option for generating reports.

Troubles Current Current Troubles Shows current errors on devices configured by severity level 
and trouble open time.

History Trouble Status History Shows the error history for devices configured by severity 
level and trouble open time.

Device Availability History Shows the downtime history for devices.

Trouble Most Frequent 
History

Shows the errors occurring most frequently on devices.

Trouble Recovery Time 
History

Shows how long the devices where in error status before 
being resolved by error type.

Severity Recovery Time 
History

Shows how long the devices where in error status before 
being resolved by severity type.

Device Current Device List Shows the current device list.

History Device Lifecycle History Shows the history of devices in SyncThru™ 6 from discovery 
to deletion.

TYPE DESCRIPTION
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Report
Reports have a slightly different concept for analyzing devices’ data from Analysis. You can see more options like 
Schedule and Device List, which lets you generate reports with individual devices. In the case of the Report menu, 
SyncThru™ 6 generates reporting data when you configure options and select devices, which is the main difference from 
the Analysis sub-menu. You can generate a wider variety of reports with the Reports menu.
With Reports, you can 
• see the history for reports you created,
• generate various reports based on your configuration,
• schedule reports, and
• email reports.

Generating Reports
1. Select Report > Report Creation & History. 
2. Click Create Report in the toolbox.

The Create Report wizard opens.
3. Select the report type you want to generate from the Report Type.
4. Click Next.
5. Each report type will have different options over the next few screens that can be selected. Select the options and click 

Next for each screen.
6. On the Select Report Options screen, name the report, select whether or not to email the report to a recipient.
7. Click Next.
8. Schedule when the report will be generated.
9. Click Execute.

You can view the generated reports on the Report > Report Creation & History main page.

Analysis
Analysis is to provide useful information with simple options. You can quickly and easily get the analysis since 
SyncThru™ 6 aggregates the analysis every time its database is updated.
With the Analysis menu, you can
• see an analysis based on a device group (not for an individual device),
• easily see different analyses by changing settings options, such as period,
• export analysis results to a PDF or CSV file,
• print the results, and
• send the results to a recipient via email.

Analyzing 
To run an analysis, follow these steps:
1. Click Report > Analysis. 
2. From Analysis Type in the left pane, select the analysis type to be performed. 

 

See "Viewing the Report Categories" on page 48 for a list of analyses types (same as reports).

3. From Device Group in the left pane, select the group for which you want to see an analysis. 
4. If necessary, change the settings in the Settings section in the main pane.

The results can be viewed in the Analysis Results section of the main pane.
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9.Rule
Rule-based task automation allows the administrator to create rules and manage tasks according 
to the rule’s conditions and actions. Any rule created is always bound to some event. Based on the 
selected event the number of available conditions and actions will be different.
This chapter includes: 
• Adding/Editing a New Rule
• Deleting a Rule
• Events
  

Adding/Editing a New Rule
Follow these steps to add a new rule:
1. Select Rule > Rule Management.
2. Select an event from the left pane (see "Events" on page 52 for a description of the events).

3. In the main pane, click  to add a new rule (see "Conditions" on page 52 and "Actions" on page 52 for information 

on conditions and actions). To edit a rule, check a rule name and click . 

The Add Rule Wizard opens. 
4. From the Condition List, select the condition(s) that you want to be met before the rule’s action will trigger.

5. Click  to add the condition(s) to the Rule list.

 

You can add the same condition multiple times to the rule. 

Some words in the Rule may appear as an underlined link when added to the Rule list. These items need to be 
changed to a specific condition. For example, if “group” appears in blue, click on the word “group” and select a specific 
group to apply to the rule.

6. Click Next.
7. From the Action List, select the action(s) that you want to take when the specified conditions are met.

Some words in the Action List may appear as an underlined link when added to the Rule list. These items need to be 
changed to a specific condition. For example, if “group” appears in blue, click on the word “group” and select a specific 
group to apply to the rule.

8. Click  to add the action(s) to the Rule list. 

 

You can add the same action multiple times to the rule. 

9. Click Next.
10. Enter the rule’s information.
11. Click Finish.

Deleting a Rule
Follow these steps to delete a rule:
1. Select Rule > Rule Management.
2. Select the event that the rule has been applied to from the left pane.
3. Select the rule(s) to delete from the main pane. 

4. Click . 
5. Confirm the deletion.

Modifying a Rule
Follow these steps to delete a rule:
1. Select Rule > Rule Management.
2. Select the event that the rule has been applied to from the left pane.
3. Select the rule to modify from the main pane. 

4. Click .

The Modify Rule Wizard opens.
5. Make changes.
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Events
Each device event will have conditions that will need to be met before the given actions will be performed.

Events
There are currently five (5) device events that can be applied to devices. Each event will have mostly the same conditions 
to apply with very minor differences. The following are the events available in the Event List in the left pane:

Conditions
Conditions are extra items that can be set by the user to be met before an action will activate. Some conditions will have 
parameters that need to be set by the user. These parameters will appear underlined in the condition text. The following 
are possible conditions that can be selected for some or all events:

Actions 
Alerts are the actions that will be taken when all of the conditions in a rule are met. Some actions will have parameters that 
need to be set by the user. These parameters will appear underlined in the action text. The following are possible actions 
that can be selected for events:

RULE ELEMENT DESCRIPTION

Device added to group When a device has been added to a device group, it meets the rule’s primary 
requirement.

Device removed from group When a device has been removed from a device group, it meets the rule’s primary 
requirement.

Device added to system When a device has been added to the system, it meets the rule’s primary 
requirement.

Device alert detected When a device has an error that needs to be checked by an administrator, it meets 
the rule’s primary requirement.

Device state changed When a device’s state changes, it meets the rule’s primary requirement. 

CONDITION DESCRIPTION

device in list When the device in the event is in the selected device list the condition is met. Select 
a device and then click Add to add it to the list. This condition will act as a filter and 
test the device in the event against the list of selected devices. “list” is the parameter 
for this condition. Click on “list” to set the parameter.

device is manufactured not 
by Samsung Electronics, 
Ltd.

When a device is not manufactured by Samsung Electronics, the condition is met. 
This condition has no parameters.

device is manufactured by 
Samsung Electronics, Ltd.

When a device is manufactured by Samsung Electronics, the condition is met.

device property conditions When a device’s property meets the given condition for the given Property value, the 
condition is met. “conditions” is the parameter for this condition. Click on “conditions” 

to set the parameter. More than one parameter can be set by clicking on the  
button.

device belongs to group 
group

When a device belongs to the selected group, the condition is met. “group” is the 
parameter for this condition. Click on “group” to set the parameter.

device group is group When a device group is the selected group, the condition is met. “group” is the 
parameter for this condition. Click on “group” to set the parameter.

alert in list When the selected alert occurs in the selected machine, the condition is met. “list” is 
the parameter for this condition. Click on “list” to set the parameter.

RULE ELEMENT DESCRIPTION

apply connection settings This action will allow the administrator to change the device’s connection settings to 
the settings configured in the parameter. “connection settings” is the parameter for 
this action. Click on “connection settings” to set the connection settings to use.

add alert trap This action will register SyncThru as a trap receiver for the selected devices.

move device to group This action will move devices to the group specified in the parameter. “group” is the 
parameter for this action. Click on “group” to select the group.
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apply device configuration 
template

This action will allow the administrator to change the device configuration by applying 
the configuration template. “template” is the parameter for this action. Click on 
“template” to select the template to use for device configuration.

send message to Twitter This action will allow the administrator to send a message to Twitter with the selected 
information. “message” is the parameter for this action. See "Twitter Notification" on 
page 62 for information on configuring Twitter notifications. Click on “message” to set 
up the Twitter message.

send email message This action will allow the administrator to send a message to a user with the selected 
information. “email” is the parameter for this action. Click on “email” to set up the 
email message to send.

RULE ELEMENT DESCRIPTION
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10.Plug-in
The Plug-in menu provides options to install, start, stop, and uninstall plug-ins on the server. 

Plug-in Management
The Plug-in > Plug-in Management sub-menu provides options for remotely managing plug-ins of the SyncThru Admin 6 
server.

Installing a Plug-in
To install a new plug-in, follow these steps:
1. Select Plug-in > Plug-in Management.

2. Click the  button at the bottom of the left pane.
The Install New Plug-in window opens.

 

The installation file must be already uploaded to the server’s file repository.

3. Click Search to look for a specific plug-in or scroll through the list of plug-ins available and select the plug-in.
4. Click Next.
5. Accept the license agreement and click Next.
6. Click Install.
7. Click Close.

Removing a Plug-in
To uninstall a plug-in, follow these steps:
1. Select Plug-in > Plug-in Management.
2. Select the application from the Plug-in List on the left.

3. Click the  button.
4. Confirm the uninstallation.

The plug-in will be removed.

Viewing Files
To view what plug-ins have been installed on the server, follow these steps:
1. Select Plug-in > Plug-in Management.

The installed plug-ins will be on the left side under Plug-in List.
2. To view a plug-in’s information select it from the list.

The plug-in’s information will be in the main pane.

Starting a Plug-in
To start a plug-in, follow these steps:
1. Select Plug-in > Plug-in Management.
2. Select the plug-in from the Plug-in List on the left.
3. Click Start in the main pane.

Stopping a Plug-in
To stop a plug-in, follow these steps:
1. Select Plug-in > Plug-in Management.
2. Select the plug-in from the Plug-in List on the left.
3. Click Stop in the main pane.

ITEM DESCRIPTION

Version The version of the plug-in.

Plug-in ID The unique ID assigned to the plug-in.

Vendor ID The plug-in provider.

Run status Displays whether the plug-in is enabled or disabled.

Start/Stop Click to start/ stop the plug-in.

Description A description of the plug-in provided by the developers.

Device Limit No The maximum number of devices with which the plug-in can be used.



11.Accounting
Accounting supports basic accounting functionality to track all jobs within your imaging and 
printing environments, and helps to save costs and reduce overuse. To start printing, users need 
to configure user account IDs and passwords with the printer driver settings that support the 
SyncThru™ 6. For scanning, copying or faxing, users need to enter valid IDs and passwords on 
the device when starting the jobs.

Setting Accounting
Enabling the Accounting Feature
To enable accounting on devices, follow these steps:
1. Select Accounting > Accounting Management.
2. Select the group from the left pane.
3. Select the devices from the main pane.
4. Click Accounting Settings in the toolbox.
5. Select Enable job accounting. You can also set an access code that will be required by users to use the device.
6. Click Next.
7. Schedule when the changes will start.
8. Click Next.
9. Click Finish.

Disabling the Job Account Feature
To disable accounting on devices, follow these steps:
1. Select Accounting > Account Management.
2. Select the group from the left pane.
3. Select the devices from the main pane.
4. Click Accounting Settings in the toolbox.
5. Select Disable job accounting.
6. Click Next.
7. Schedule when the changes will start.
8. Click Next.
9. Click Finish.

Resetting Accounting Usage
To reset accounting usage for a device, follow these steps:
1. Select Accounting > Accounting Management.
2. Double-click a device in the main pane to expand the device information.
3. Click the Accounting tab.
4. Click Reset Accounting Usage.

Viewing Accounting Job Records
To view job records, follow these steps:
1. Select Accounting > Accounting Management.
2. Select a device from the main pane.
3. Click Job Records in the toolbox.

4. The records can also be deleted ( ), exported ( ), or printed ( ).

5. Click Close.

Collecting Accounting Job Records
To collect job records from a device, follow these steps:
1. Select Accounting > Accounting Management.
2. Double-click a device in the main pane to expand the device information.
3. Click the Accounting tab.
4. Click Collect Job Record.

Setting Permissions
Permissions are used to assign user and group usage rights to devices. Once permissions are assigned, the permissions 
can be viewed by clicking on the Modify Users button.
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Defining User or Group Permission
1. Select Accounting > Accounting Management.
2. Select the group from the left pane.
3. Select the devices from the main pane.
4. Click Apply User Permission or Apply Group Permission in the toolbox.

The Apply User Permission or Apply Group Permission window opens.
5. Select the users or group.
6. Click Next.
7. Set permissions by checking Unlimited or entering a specific number.
8. Click Next.
9. Schedule the changes.
10. Click Next.
11. Click Finish.

Viewing User or Group Permissions
1. Select Accounting > Accounting Management.
2. Select the group from the left pane.
3. Double-click a device in the main pane to expand the device information.
4. Click the Accounting tab.
5. Click Modify Users or Modify Groups to view the assigned permissions. 

Importing User or Group Permissions
1. Select Accounting > Accounting Management.
2. Select the group from the left pane.
3. Check the device(s) from the main pane.
4. Click Import Permission in the toolbox.

The Import Permission window opens.
5. Select Import user permission or Import group permission and select the file to import.

 

• The type of permissions file is CSV. The following should be column headers for a user permission file: 
UserId, CopyColor, CopyMono, PrintColor, PrintMono, Fax, Scan.

• The following should be headers for a group permissions file: GroupId, CopyColor, CopyMono, PrintColor, 
PrintMono, Fax, Scan.

6. Click Upload File.
The file will be uploaded.

7. Click Close.

Exporting User or Group Permissions
1. Select Accounting > Accounting Management.
2. Select the group from the left pane.
3. Double-click a device in the main pane to expand the device information.
4. Click the Accounting tab.
5. Click Export User Permission or Export Group Permission.
6. Select to save or open the file.

Viewing the Management History
Viewing the Accounting History
1. Select Accounting > Management History > Accounting History.

The History page opens.
2. Select the date and task from the left pane.

Information about the task will appear in the main pane.

Viewing the Group Permissions History
1. Select Accounting > Management History > Group Permission History.

The History page opens.
2. Select the date and task from the left pane.

Information about the task will appear in the main pane.

Viewing the User Permissions History
1. Select Accounting > Management History > User Permission History.

The History page opens.
2. Select the date and task from the left pane.

Information about the task will appear in the main pane.
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12.Settings
This chapter explains the Settings menu where you can configure basic settings for SyncThru™ 
6.

Overview
There are seven (7) main categories in the Settings menu.

Network
Proxy
You can configure a Proxy server for SyncThru 6's proxy and the features that use proxy settings, like Twitter notifications. 
Select Settings > Network > Proxy.

COMPONENT DESCRIPTION

Network • Proxy : Configure proxy server settings (see "Proxy" on page 57).
• LDAP : Configure LDAP server settings (see "LDAP" on page 58).
• NTLM Domains: Configure NTLM domain settings (see "NTLM Domains" on 

page 58.

Log You can see SyncThru™ 6 log messages and configure logging options (See "Log" 
on page 59).

System • HTTP Security : Configure SyncThru™ 6 web server settings, configure 
certificate, or authentication (see "HTTP Security" on page 60).

• User Role Management : (see "User Role Assignment" on page 38.)
• Large Paper Settings : Configure which paper sizes are considered large and 

which are considered small (see "Large Paper Settings" on page 61).
• SyncThru Discovery : See other SyncThru™ servers on the network (see 

"SyncThru Discovery" on page 62).
• File Management : Configure the maximum file size allowed for uploading (see 

"File Management" on page 62).
• Data Management : Configure how SyncThru™ 6 will handle old data (see "Data 

Management" on page 62).

Notification • Twitter : Set up notifications via Twitter (see "Twitter Notification" on page 62).
• SMTP : Configure SMTP server settings (see "SMTP" on page 64).

Tasks • Scheduled Tasks : Information related to tasks that are currently scheduled (see 
"Scheduled Tasks" on page 65).

• Completed Tasks : Information related to tasks that have been completed (see 
"Completed Tasks" on page 65).

Device • Alert List : See the alerts (see "Alert List" on page 65).
• Blocked Devices : See the blocked devices that have been blocked when deleted 

from the Device List (see "Blocked Devices" on page 68).
• Connection : Configure SNMP default settings (SNMPv1, SNMPv2 and 

SNMPv3), SWS credentials and Account settings for locally connected devices 
(see "Connection" on page 67).

• Device Data Collection: Add/delete or arrange the schedule to collect the device’s 
data information (see "Device Data Collection" on page 67).

• Passive Device Discovery: Configure passive discovery settings (see "Passive 
Device Discovery" on page 66).

• Device Supply Levels: Configure when alerts will be sent for supplies by device 
(see "Group Supply Levels" on page 69).

• Group Supply Levels: Configure when alerts will be sent for supplies by model 
group (see "Group Supply Levels" on page 69).

Accounting Configure accounting settings like job records collection intervals and the default 
access code (see "Accounting Settings" on page 69).
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Applying a Proxy Server
1. From SyncThru™ 6, click Settings menu > Network > Proxy. 
2. Set options.
3. Click Apply. 

LDAP
You can configure LDAP servers for the LDAP-related features, such as device discovering with LDAP or using LDAP user 
accounts.

Adding an LDAP Server
1. Click Settings.
2. In the left pane, select Network > LDAP.

3. Click the  button in the LDAP panel. 

The Add LDAP Server window appears.
4. Enter the LDAP server’s information and click Check Server to test the connection.
5. Click OK. 

Editing an LDAP Server
1. Click Settings.
2. In the left pane, select Network > LDAP.
3. Select the LDAP server to edit.

4. Click the  button in the LDAP panel. 
The Edit LDAP Server window appears.

5. Type in the configuration you want to use.
6. Click OK.

Deleting an LDAP Server
1. Click Settings.
2. In the left pane, select Network > LDAP.
3. Select the LDAP servers you want to delete.

4. Click the  button in the LDAP panel. 
After confirmation, the specified servers will be removed.

NTLM Domains
NTLM Domains (NT LAN Manager) are used for authentication where Kerberos is not being used. Other situations in 
which it is better to use NTLM instead would be the client is authenticating with a server using an IP address, the client is 
authenticating with a server that is in a different Active Directory, the client is authenticating with a server that doesn’t 
belong to any domain, there is no Active Directory, or a firewall is blocking the ports required by Kerberos.

Adding an NTLM Domain
Follow these steps to add an NTLM Domain:

COMPONENT DESCRIPTION

Direct connection to the 
internet

Select this item to connect network without any settings.

Load from system setting If you already have a proxy server setting in your system, select this item to load it.

Manual proxy configuration Select this item to enter options manually.

HTTP Proxy
Port

The HTTP proxy server’s IP address and port. Click Validate to test the connection. 
This is enabled if Manual proxy configuration is selected.

HTTPS Proxy
Port

The HTTPS proxy server’s IP address and port. Click Validate to test the connection. 
This is enabled if Manual proxy configuration is selected.

No proxy for A list of hosts that do not require a proxy server connection. To add a new host to the 
list, click the  button and enter the host name. This is enabled if Manual proxy 
configuration is selected.

Enable proxy authentication Select this option if the proxy server requires authentication to be used. Enter the 
User name and Password required. This is enabled if Manual proxy configuration 
is selected.

Test URL Enter a web site outside of the intranet and click Send Test to test the proxy server’s 
settings.
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1. Click Settings.
2. In the left pane select System > NTML Domains.
3. Click the  button.

The Add NTLM Domain window opens.

4. Enter the domain information.
5. Click Validate test the connection.
6. Click Add.

Editing an NTLM Domain
1. Click Settings.
2. In the left pane select Network > NTLM Domains.

3. Select a domain and click the ( ) button. 
The Edit NTLM Domain window opens.

4. Enter the new information.
5. Click OK.

Deleting an NTLM Domain
1. Click Settings.
2. In the left pane select Network > NTLM Domains.
3. Select the NTLM domain you want to delete.

4. Click the  button. 
After confirmation, the selected domains will be removed.

Log
Event Log
You can see the log messages SyncThru™ 6 provides. Log messages are created by SyncThru™ 6 to record user activity. 
To view the log messages, follow these steps:
1. Click Settings.
2. In the left pane, select Log > Event Log.

The Event Log window opens.

Debug Log
The Debug Log setting is used to select which logs are stored on the server. To set the debug log levels, follow these 
steps:
1. Click the Settings, then in the left pane, select Log > Debug Log to configure log messages.
2. Set an option to debug and click Apply.

COMPONENT DESCRIPTION

Domain name The name of the NTLM domain.

PDC address The address of the Primary Domain Controller (see "Glossary" on page 101 for a 
definition).

Login (Optional) The login ID for the domain.

Password (Optional) The password for the domain.

COMPONENT DESCRIPTION

Category The application from which the log message originates.

Computer The computer hosting SyncThru™ 6 from which the log message was created.

Description Description of the logged event.

Event The type of event that occurred (e.g., Login or Rule added).

Event Time Time when the event was logged.

Event Type Indicates the criticality level of the event: Information, Warning, Error, Success 
Audit, Failure Audit.

User ID The user logged in when the logged action was performed.

Log Type The type of log: Application or Security.
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System
HTTP Security
You can configure SyncThru™ 6 server settings including HTTPS connection and certification configuration.
From SyncThru™ 6, click Settings, then in the left pane, select System > HTTP Security.

Configuring web server settings
SyncThru™ 6 is a web based management server. By default, it works with HTTP port, 8080. Or if your server works 
with HTTPS, it uses HTTPS port, 8081. Set the network information on HTTP Port/HTTPS Port.
• To enable SSL:

If you want to use a secure connection, you can use HTTPS by enabling the SSL. Click the checkbox for Enable 
SSL.

 

• If you enable SSL, all the communications between SyncThru™ 6 and your web browser are sent 
encrypted by HTTPS.

• Please make sure that your SyncThru™ 6 has a certificate. If there is no certificate, you cannot enable 
SSL (see "Creating Certificates" on page 60).

SSL and Certificates
If you want to use an SSL connection for security, you need to configure a certificate, which is required for the secured 
connection. SyncThru™ 6 does not provide the default certificate.

Creating Certificates
Click the Settings menu, then in the left pane, select System > HTTP Security.
• If the status is Certificate configured, there is already a certificate installed. In this case, you can see the details 

of the installed certificate with Certificate Details button (see "Viewing Certificates" on page 60).
• If the status is Certificate Not Configured, there is no certificate installed. Click Certificate Configuration. There 

are two options for certificate settings:
- Create Self-Signed Certificate : Creates a certificate using SyncThru™ 6’s provided functionality.
- Upload Existing Certificate :  Uploads the certificate already issued by the external or internal certificate 

authority. 

Preparing a Certificate Signing Request
If there a Self-Signed Certificate which has to be signed by a Trusted Authority, it requires a CSR.
In the Certificate Configuration window, select the Self-Signed Certificate and click Prepare. This will generate a 
CSR text in a pop-up window which can be pasted in a file and sent to a Trusted Authority to verify the certificate

Viewing Certificates
If there is a certificate installed, click on Certificate Details to see the details of the installed certificate. 

Enabling SSL Connection (HTTPS)
From SyncThru™ 6, click the Settings menu, then in the left pane, select System > HTTP Security. Select the 
checkbox for Enable SSL.

 

Please make sure that you enter https://ip_address:https_port_number in your web browser address bar when 
SSL is enabled. If you type http://ip_address:https_port_number or https://ip_address in the web browser 
address bar, the page will not load.

Disabling SSL Connection (HTTPS)
From SyncThru™ 6, click the Settings menu, then in the left pane, select System > HTTP Security. Deselect the 
checkbox for Enable SSL. 

 

At any time, only one port (HTTP or HTTPS) will be available. Applications cannot be accessed over both HTTP 
HTTPS simultaneously.

Authentication
Authentication is for maintaining SyncThru™ 6 access rights. If you enable the Authentication, SyncThru™ 6 requires 
a user account when logging-in to SyncThru™ 6 via a web browser. Choose one of the Authentication types 
according to the security policy for your site. Authentication types are Local Authentication, LDAP Authentication 
and Domain Authentication.

 

• If a user using IE in Windows uses the domain account and if the user’s domain account is registered in 
SyncThru™ 6, while Domain Authentication is on, SSO (Single Sign On) is applied when the user logs in 
to the PC. So, if the user opens SyncThru™ 6 from an SSO applied PC, the user does not need to log in to 
SyncThru™ 6: the user is automatically logged in. 

• If you configure the authentication during setup, SyncThru™ 6 will use Local Authentication.
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User Role Management
SyncThru™ 6 can assign user roles to users. A role is a set of permissions for using SyncThru™ 6 features. Once a role is 
assigned to a user, the user will have access to the permissions designated by the role.
For example, if account A has only device add permission, account A can use the device add feature only. If an account 
has Admin role, which is provided as a default, that account can use all the features after logging-in to SyncThru™ 6.  
After assigning a role to an account, you need to enable authentication then log in to SyncThru™ 6 to use this feature.
With User Roles, you can:
• view user roles.
• modify permissions for user roles (see "Modifying user roles" on page 61).
• add/remove user roles (see "Adding user roles" on page 61, "Deleting user roles" on page 61).
• configure permissions for user roles.
• view the permissions assigned to the user role.

 

You can refer to “Role Model” matrix in RFC 3805 for adjusting this role function according to your site (see "Role 
reference" on page 74).

Adding user roles
1. Click Settings.
2. In the left pane select System > User Role Management.
3. Click the  button in the User Role List. 

The Add Role window appears. 
4. Enter the role name and assign permissions for the role.
5. Click Add. 

You can see the role in the list. You also can see the number of permissions in the list.

Deleting user roles
1. Click Settings.
2. In the left pane select System > User Role Management.
3. Select the role(s) you want to remove. 

4. Click the  button in the User Role List. 

 

Please make sure that the Admin role cannot be deleted. 

Modifying user roles
1. Click Settings.
2. In the left pane select System > User Role Management.
3. Select the user account you want to modify. 

4. Click the  button in the User Role List. 
The Modify Role window appears. 

5. Check or uncheck the permissions you want. 
6. You can see the configured permissions within the window.

Change permissions and click OK.

 

Please make sure that the Admin role cannot be modified. It has all the permissions and if any account has 
this Admin role, it has all the ability to do anything within SyncThru™ 6.

Large Paper Settings
Large Paper Settings allows you to determine which paper sizes are considered large and which are considered small for 
accounting purposes. To set the page settings, follow these steps:
1. Click Settings.
2. In the left pane select System > Large Paper Settings.
3. Set the paper ratio.
4. Click the arrows in the middle to move selected paper sizes from one side to the other in the Large Paper Selection.

COMPONENT DESCRIPTION

Large paper ratio over small 
paper

The ratio determines how many large-sized paper pages will be counted per every 
one small-sized paper type for accounting and reporting purposes. For example, if the 
ratio is set to 2 and Ledger-size paper is in the large paper size side, every sheet of 
Ledger printed will count as 2 pages printed on reports and for accounting.

Large paper selection Click the arrows in the middle to move selected paper sizes from one side to the 
other.

Apply Click to save changes.
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SyncThru Discovery
You may want to monitor who is managing the devices with SyncThru™ 6 or SyncThru™ 5. From SyncThru™ 6, click the 
Settings menu, then in the left pane, select System > SyncThru Discovery.
 You can see all the SyncThru™ 6 URLs running on the network.

 

SLP protocol is used for SyncThru Discovery.

Viewing SyncThru™ 6 Servers
You can open the specified SyncThru™ 6 server for checking discovery details.
From SyncThru™ 6, click the Settings menu, then in the left pane, select System > SyncThru Discovery. Click the 
Go to SyncThru button in the Link column for SyncThru™ 6.

Viewing SyncThru™ 5 Servers
You can open the specified SyncThru™ 5 server for checking discovery details.
From SyncThru™ 6, click the Settings menu, then in the left pane, select System > SyncThru Discovery. Click the 
Go to SyncThru button in the Link column for SyncThru™ 5.

File Management
Determines the maximum size of the repositories where files are stored and the maximum file size allowed for stored files.

 

This applies to the firmware, driver, font/form/macro, device, PC agent, and plug-in file repositories.

Data Management
Determines how reports and historical information will be saved on the server.

Notification
Twitter Notification
Twitter Notification is also one of the proactive features of SyncThru™ 6. If you are responsible for managing devices, 
like replacing toner, you do not have to check SyncThru™ 6 or each device when using this feature. You can receive 
Twitter notification messages for events that occur on networked printing and imaging devices. 

 

There is a limit of 250 direct messages and 1000 tweets per day (about 128 tweets/30 minutes). For more 
information, see https://support.twitter.com/articles/15364-about-twitter-limits-update-api-dm-and-following

Even if an account has been blocked due to exceeding this tweet limitation, another account can be used: simply login 
from the Twitter Notification view with another account. To check if an account is blocked, follow these steps:
1. Click Settings.
2. In the left pane select Log > Event Log.
3. Search for or locate Twitter Notification in the Category column.

COMPONENT DESCRIPTION

Max repository size(MB) The maximum size (in megabytes) of the file repository. The value can be between 10 
and 10000. 

Max file size(MB) The maximum size allowed (in megabytes) for a file stored in the repository.

Apply Click to save changes.

COMPONENT DESCRIPTION

Report Cleanup Method Options for when the system will delete reports.
• Disabled: Automatic deletion is disabled.
• Automatic: Reports will be deleted automatically after they have been stored for 

the specified period in Data retention period.
• Manual: Reports will be deleted on the date selected by the user.

Historical Data Cleanup 
Method

Options for when the system will delete saved data other than reports.
• Disabled: Automatic deletion is disabled.
• Automatic: Reports will be deleted automatically after they have been stored for 

the specified period in Data retention period.
• Manual: Reports will be deleted on the date selected by the user.

Device Group Data 
Management

Click Clean to remove groups that do not contain any devices.

Apply Click to save changes.
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4. Check if the Description of the event starts with “E0501P5014” - this is the message send fail code. If this is the error 
code, then the account is currently blocked.

With Twitter Notification, you can 
• view Twitter templates,
• register a Twitter template,
• modify a Twitter template, and
• un-register a Twitter template.

Viewing Twitter Notification Templates
Details can be viewed by double-clicking a template:
1. Click Settings.
2. In the left pane select Notification > Twitter.
3. Double-click a row in the template list.

The Follower List will drop down if the template is set up for direct messaging.
4. Double-click a row to close the information.

Registering a Twitter Notification Template
You may want to check if there is an alert on any device without opening SyncThru™ 6 or leaving your desk. 
SyncThru™ 6 can inform you if the devices have Twitter notifications set up. 
1. Click Settings.
2. In the left pane select Notification > Twitter.
3. Click  in the Twitter Notification Template List panel. 

 

If authentication is not completed, see Twitter Authentication.

4. Enter the template name.
5. Select the Twitter settings. If Direct message is selected, follow the sub-steps below.

a. Click Select Follower.
b. Select followers and move the followers to the right-side list.
c. Click OK.

6. Click Add. 

Modifying a Twitter Notification Template
To modify a Twitter notification template, follow these steps: 
1. Click Settings.
2. In the left pane select Notification > Twitter.
3. Select the template to modify.

4. Click .

5. Change the template name if necessary.
6. Update the Twitter settings. If Direct message is selected, follow the sub-steps below.

a. Click Select Follower.
b. Select followers and move the followers to the right-side list.
c. Click OK.

7. Click Save. 

Un-registering a Twitter Notification Template
To remove an alert notification if the specified alert notification is no longer needed, follow these steps:
1. Click Settings.
2. In the left pane select Notification > Twitter.
3. Select the template to remove.

4. Click .

 

If the template has a blue dot icon in the template list, the template is used by a Rule and is protected from 
deletion.

Twitter Authentication
Signing Up and Registering in Twitter
Before using Twitter notifications, user has to create an account and register SyncThru™ Admin 6 as an application. 
For more details please see the following URLs:
• Create an account: http://support.twitter.com
• Register an application: http://dev.twitter.com/apps/new

 

Web Site: IP address with the port number where SyncThru Admin 6 has been installed.
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Application Type > Access: select read and write

After completing the two steps above, users can get the consumer key and secret from Twitter.

Twitter Authentication
Before getting Twitter notifications, users have to get authentication first. Follow these steps to get authentication:
1. Click Settings.
2. In the left pane select Notification > Twitter.
3. Click  in the Twitter Notification Template List panel. 

4. Enter the Consumer key and Consumer secret.
5. Click Confirm to get authentication.

 

Make sure the authorizing account is the same as the application owner’s account.

A pop-up window will open with a pin code.
6. Enter the code in the Pin code field and click Confirm. 

Access token / Access token secret will be saved from Twitter to SyncThru automatically.
After completing authentication, new templates can be created.

 

To update the Consumer key and Consumer secret, click Edit and update the Consumer key and Consumer 
secret, then repeat steps 4 and 5.

Usage in Rule
Twitter notification is used as an Action in Rule Management.
1. In the Rule wizard’s step 2 screen, select send Twitter message and click the down arrow button.
2. Click message text
3. Set the properties’ text length like {DeviceIpAddress:10} and include customized messages if necessary (total 

message length should not be longer than 120 characters).
4. Select one template to specify how the message will be sent.
5. Click OK. 

According to the event and the conditions, the message will be sent.

SMTP
You can configure the SMTP server for the SMTP-related features, such as device discovering with SMTP or using SMTP 
user accounts.

Adding the SMTP Server
1. Click Settings.
2. In the left pane select Notification > SMTP.
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3. Enter the server’s information.
4. Test the connection by entering a recipient email address in the Email address to: field and click Send Test.
5. Click Apply.

Tasks
Scheduled Tasks
Scheduled Tasks allows you to view all scheduled tasks in this page as either a list or a calendar. Clicking on the List or 
Calendar button located at the top of the pane will toggle the views between list view and calendar view.

List View
The list view will display the tasks in a list.

Calendar View
The calendar will display a large calendar with a red triangle on dates with tasks. Mousing over these dates will open a 
bubble with task names.

Completed Tasks
Completed Tasks allows you to view all completed tasks in this page as either a list or a calendar. Clicking on the List or 
Calendar button located at the top of the pane will toggle the views between list view and calendar view.

List View
The list view will display the tasks in a list.

Calendar View
The calendar will display a large calendar with a red triangle on dates with tasks. Holding the mouse over these dates 
will open a bubble with task names.

Device
The following are the items that can be configured in the Device settings menu.

Alert List
You can see the alerts notification in the Alert List panel.

COMPONENT DESCRIPTION

SMTP server The SMTP server’s IP address.

SMTP port The server’s port number.

SMTP requires 
authentication

Check this item to use a login system to access to the SMTP server.

Email address from Enter the email address to get reply mail from users.

SMTP SSL enable Enable SSL (Secure Socket Layers) to ensure secure data transfer over the Internet.

COMPONENT DESCRIPTION

Type The source of the tasks.

Name The name of the task.

Schedule The schedule name is the same as the history name of the device’s function.

Next Execution Time The time at which the task will be executed again.

User The ID of the user that created the task.

COMPONENT DESCRIPTION

Type The type of task performed.

Name The name of the task.

Schedule The schedule name is the same as the history name of the device’s function.

Start Time The date and time at which the task started.

End Time The date and time at which the task ended.

User The ID of the user that created the task.
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Adding an Alert Category
Adding a category allows users to few specific sets of alerts. For example, you can create a category for tray alerts and 
add alerts that are related to tray or paper errors. To add an alert category, follow these steps:
1. Click Settings.
2. In the left pane select Device > Alert List.
3. Click the Alert Category button.

The Alert Category Setup window appears.

4. Click the  button.

5. Enter the Category name.
6. Select the category in the left side.
7. Move the alert items from the right-side list.
8. Click OK.

Changing Alert Information
Severity Level and Toner Level information for alerts can be changed here as well. To change alert information, 
follow these steps:
1. Click Settings.
2. In the left pane select Device > Alert List.
3. Find the alert to change.
4. Change the Severity Level or Toner Level in the respective columns by selecting the option from the pull-down 

menu or changing the toner level percentage.
5. Click Apply.

Passive Device Discovery
SyncThru™ 6 can be set up to discovery devices passively without intervention from users.
Passive discovery literally means that SyncThru™ 6 works passively. That is, devices send packets first and SyncThru™ 6 
detects the packets. Passive discovery is quiet because SyncThru™ 6 does not start sending any packet first. SyncThru™ 
6 does not propagate any network traffic unless a device announces itself. There are two types of passive discoveries.
From SyncThru™ 6, click the Settings menu, then in the left pane, select Device > Passive Device Discovery.
• Enable mDNS discovery : If you enable mDNS discovery, SyncThru™ 6 starts listening for UDP traffic via port 5353. 

Devices announce packets continuously and SyncThru™ 6 detects them. With this method, you can discovery all 
mDNS compatible devices.

• Enable SLP discovery : If you enable SLP discovery, SyncThru™ 6 starts listening for UDP traffic via port 427. When 
devices are powered on, they announce packets and SyncThru™ 6 detects. Only Samsung devices will be discovered. 
(SLP multicast address is 239.255.255.253.)

The following information is provided about the discovered devices:

COMPONENT DESCRIPTION

All categories List of user-created categories.

Alert Name The configured name of the alert notification.

Severity Displays the severity level of the alert. 

Toner Level Displays the toner level percentage required to activate the alert.

Recovery Time The recovery time of the alerts.

COMPONENT DESCRIPTION

Status The device’s status when discovered.

Result Description The detailed description for the status. For example the status Success can have 
Device Already Exists or new device details.

Algorithms The common view for discovery results.

Discovered Time The time at which the device was discovered.

Host Name The host name of the device.

IP Address The IP address of the device.

Serial No. The serial number of the device.

MAC Address The MAC address of the device.

Model Name The model of the device.
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Connection
You can configure various connection settings for communication between SyncThru™ 6 and devices. To change these 
settings, click the Settings menu, then in the left pane, select Device > Connection.

Device Data Collection
Data Collection Schedules
You can configure the schedule to collect status data from all devices registered with SyncThru™ 6.

Adding a Schedule
To add a new data collection schedule, follow these steps:
1. Click Settings.
2. In the left pane select Device > Device Data Collection.

3. Click the  button in the Data Collection Schedules section.
The Add Schedule window opens.

4. Enter a name and select the time interval for how often the schedule will run.
5. Click Configure List of Properties.
6. Move the properties you want to collect from the left side to the right side.
7. Click OK.
8. Click Add.

Deleting a Schedule
1. Click Settings.
2. In the left pane select Device > Device Data Collection.
3. Select the schedule to be removed.

4. Click the button in the Data Collection Schedules section.

COMPONENT DESCRIPTION

SNMP settings • SNMP timeout : The time the connection will remain idle (in milliseconds) before 
disconnecting.

• SNMP retry count : The number of retries when SNMP communication fails.

SNMP v1/v2 settings • SNMP Read Community : The default read community name SyncThru™ 6 uses. 
When discovering a device, if the read community name value is different from the 
one here, SyncThru™ 6 cannot bring device information nor update other 
information. Usually public is set as a default name for read community name and 
so is SyncThru™ 6. Custom communities can be specified in Connection Settings 
(see "Connection Settings" on page 20).

• SNMP Write Community : The default write community name SyncThru™ 6 
uses. When configuring a device, if the write community name value is different 
from the one here, configuration will not work properly.

SNMP v3 settings SNMPv3 provides higher security than previous versions of SNMP. If your devices 
enable only SNMPv3 and SyncThru™ 6 has no settings for SNMPv3, communication 
between devices and SyncThru™ 6 will always fail. If your devices are using 
SNMPv3, you need to configure the following options to be the same as what the 
devices have.
• Context name: A collection of management information accessible by an SNMP 

entity.
• User name: The user name used to access the SNMP server.
• Security mode: Options for this are None, Auth or Auth and Privacy. Selecting 

Auth specifies that only user authentication is performed; Auth and Privacy 
specifies that user authentication and user privacy are being performed.

• Authentication protocol: Select what algorithm is used during user 
authentication. Options for this are HMAC-MD5 or HMAC-SHA.

• Authentication password: The authentication key used for HMAC.
• Privacy protocol: Select what type of encryption to use for the Privacy Key: AES 

or DES. This is active only if Auth and Privacy is selected for Security mode.
• Privacy password: The string used to encrypt the privacy key in the privacy 

algorithm.

Embedded web server 
settings

• EWS Login ID : Enter the EWS login ID.
• EWS Login Password : Enter the EWS login password.
• EWS port : Enter the EWS port number.

Local device settings • Windows account login : Enter the Windows account login ID.
• Windows account password : Enter the Windows account login password.
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Confirm the deletion.

Modifying a Schedule
1. Click Settings.
2. In the left pane select Device > Device Data Collection.
3. Select the schedule you want to modify. 

4. Click the  button. 
The editing window opens. 

5. Change the properties and click Modify schedule. 

Starting a Data Collection Task
1. Click Settings.
2. In the left pane select Device > Device Data Collection.
3. Select a schedule to start.
4. Click Start Instance Now.
5. Click Yes.

Data Collection History
You can view data collection tasks that have been completed.

Viewing a Task
1. Click Settings.
2. In the left pane select Device > Device Data Collection.
3. Select a task from the Data Collection History section.
4. Click List of Properties.

The List of Properties window opens with the information collected by the data collection task.
5. Click Close.

Deleting a Schedule
1. Click Settings.
2. In the left pane select Device > Device Data Collection.
3. Select the schedule(s) you want to remove in the Data Collection History. 
4. Click Delete.

Confirm the deletion.

Blocked Devices
You can block devices you do not need to manage via SyncThru™ 6. Devices are added to Blocked devices list when 
you delete the device from the Devices List with the Delete devices from the system and block option.
Blocked devices are not added to the Devices List when SyncThru™ 6 discovers devices. To see the blocked devices list, 
click the Settings menu, then in the left pane, select Device > Blocked devices.
If you want to manage the devices which have been blocked, delete the devices from the Block Devices. SyncThru™ 6 
will then find the devices again and add them to the Devices List.

 

Blocked devices will be grayed out in the Found Device List (see "Viewing Discovery Results" on page 30).

Device Supply Levels
Device Supply Levels is used to configure when alerts will be sent for supplies.

Adding a New Setting
To add a new Device Supply Levels setting, follow these steps:
1. Click Settings.
2. In the left pane select Device > Device Supply Levels.

3. Click the  button.
The Device Setup window opens.

COMPONENT DESCRIPTION

Toner Level Settings • No Toner: The percentage remaining at which a no toner error will be displayed.
• Low Toner: The percentage remaining at which a low toner warning will be 

displayed.
• Low Toner Early Warning: The percentage remaining at which an early warning 

will be displayed.

Device Groups
Dynamic Groups

Groups from which to select devices.

Click on this to add a new device to the list.
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4. Set the Toner Level Settings and select the devices.
5. Click OK.

Deleting a Setting
To delete a Device Supply Levels setting, follow these steps:
1. Click Settings.
2. In the left pane select Device > Device Supply Levels.
3. Select the setting(s) from the list.

4. Click the  button.
Confirm the deletion.

Group Supply Levels
Group Supply Levels is used to configure when alerts will be sent for supplies by model group.

Adding a New Setting
To add a new Group Supply Levels setting, follow these steps:
1. Click Settings.
2. In the left pane select Device > Group Supply Levels.

3. Click the  button.
The Model Group Setup window opens.

4. Set the Toner Level Settings and select the model groups.
5. Click OK.

Deleting a Setting
To delete a Group Supply Levels setting, follow these steps:
1. Click Settings.
2. In the left pane select Device > Group Supply Levels.
3. Select the setting(s) from the list.

4. Click the  button and confirm the deletion.

Accounting
Accounting Settings
Job Accounting allows you to manage job accounts for SyncThru™ 6 itself. 

Click on this to remove a device from the system. This button is only active once a 
device is selected in the list.

Connection Settings See "Connection Settings" on page 20. This button is only active once a device is 
selected in the list.

Filter Filters the devices in the list by the selected criteria.

COMPONENT DESCRIPTION

Toner Level Settings • No Toner: The percentage remaining at which a no toner error will be displayed.
• Low Toner: The percentage remaining at which a low toner warning will be 

displayed.
• Low Toner Early Warning: The percentage remaining at which an early warning 

will be displayed.

Select Device Model Group 
Settings

Model groups for which settings can be configured. This is only available for Samsung 
devices.

COMPONENT DESCRIPTION

Default access code When you enable Job Accounting for devices, SyncThru™ 6 uses this value as an 
access code unless you enter a custom access code. You can change the default 
access code here. SyncThru™ will use Default access code as a default.

COMPONENT DESCRIPTION
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Reset usage interval If you enable the Job Accounting feature, you need to reset the usage account 
periodically. For example, if your company allows employees to print 100 pages each 
month, you can set this option to every month. If you want to check the usage 
quarterly and charge bills, set this option to the end of every 3 months.

Job records collection 
interval

SyncThru™ gathers all of the job records from the devices periodically. This is for the 
interval for collecting data from the devices. You can change this interval for your own 
purposes.

Send email notification to 
user about remaining usage 
limit

If you check this option and set the remaining usage (percentage), SyncThru™ sends 
an email when the remaining usage (percentage) value is reached. A user who has 
received this email can ask the administrator to increase his/her allowed page count.

Notification interval The time interval for sending notification emails.

Send email to following also When sending a notification email you can also send it to other people, like the device 
manager, for reference.

COMPONENT DESCRIPTION
Settings_ 70



13.Backup & Restore
This chapter provides instructions for backing-up and restoring SyncThru™ 6 databases and 
settings.

Getting Started
Backing up the SyncThru™ 6 databases is an important step in ensuring your information is safe in the case of an 
unforeseeable event. The backed-up databases can be restored from the back-up files and make sure that everything is 
kept running smoothly without disruption.

Constraints
The following are the current limitations involved with creating back-up files:
• Only PostgreSQL or Microsoft SQL are supported.
• Only entire databases can be backed-up and restored.
• Backing-up and restoration can only be performed for the same database type: you can’t restore a PostgreSQL 

database with a Microsoft SQL backup file.
• Only SyncThru™ 6 databases can be backed-up and restored.

Pre-Requisites
Perform one of the following procedures before attempting to back up the SyncThru™ 6 database:
1. Install SyncThru™ 6.
2. Make sure the database has data to back up (i.e., perform some operations in SyncThru™ 6).
3. Stop SyncThru™ 6 (see "Stopping SyncThru™ 6" on page 9) and make sure no other application is using the 

database.
4. The backup/restore application will be installed under <SyncThru6 Installation Folder>\Tools\BackupRestore.
5. Install Java 5 or Java 6 and set the JAVA_HOME environment variable to point to the installed Java location (usually 

<SyncThru6 Installation Folder>\Tools\jre1.6.0_30).
or
1. Install SyncThru™ 6.
2. Edit the files backup.bat and restore.bat by replacing all occurrences of %java_home% with the Java install location 

with SyncThru™ 6 (usually <SyncThru6 Installation Folder>\Tools\jre1.6.0_30).

Backup
To back-up the SyncThru™ 6 solutions database, follow these steps:
1. Edit the file backup.properties and set the database connection settings for the database to be backed up.

 

Connection settings can be taken from the db.properties file stored under <SyncThru6 Installation 
Folder>\UniThruTarget Platform.

2. Edit the configuration_files.properties file and add any solution files that need to be backed-up.

 

The file paths must be relative to the solutions root installation folder.

3. Execute backup.bat.
4. Enter the path to the solution’s installation root folder (e.g, C:\Program Files\Samsung Network Printer 

Utilities\SyncThru Admin 6.
5. If the backup is successful, messages similar to the following will be displayed:

• Location of Database backup folder: .../BackupRestore/backup/data/
• Location of Configuration backup folder: .../BackupRestore/backup/config/
• Location of backup file: .../BackupRestore/backup_....bk

6. Delete any new files created in the folders except for the new .bk file.
7. Check that the .bk file, which is a .zip file, contains two folders: config and data.

The “config” folder contains files from the solution platform directory, and the “data folder” contains two xml files: 
db.schema-<db-server>.xml and db.data-<db-server>.xml.

Restore
To restore the SyncThru™ 6 solutions database, follow these steps:
1. Use the database client to delete and recreate the solution database.
2. Edit the restore.properties file and set the database connection settings for the database to be restored.

 

Connection settings can be taken from the db.properties file stored under <SyncThru6 Installation 
Folder>\UniThruTarget Platform.
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3. Execute restore.bat.
4. Enter the path to the solution’s installation root folder (e.g, C:\Program Files\Samsung Network Printer 

Utilities\SyncThru Admin 6.
5. Provide the backup file’s file name obtained from the backup procedure.

 

The file must be in the same directory as restore.bat.

6. After restoration is complete, two messages should be displayed: “Database Restore Completed!” and “Configuration 
Files Restore Completed!”.

7. Verify that the database data has been correctly restored.
8. Verify that the contents of the restore file are okay.
9. Start SyncThru™ 6 with the restored database.
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14.Data reference
This chapter includes:
• MIB reference
• Data matrix
• Role reference
  

MIB reference
Generic support
SyncThru™ 6 uses SNMP queries to gather information from printers. How much information is displayed and what 
functionality is provided depends on the printer’s own ability to respond to SNMP queries.

SyncThru™ 6 supported devices
Any printing and imaging device directly connected to the network that supports SNMP and the standard printer MIB (RFC 
1759) is supported. 
Network SNMP Printers and MFPs should support the following Request for Comments (RFC) standards:
• RFC 1213 (MIB-II for TCP/IP)
• RFC 1759 (Printer MIB v1)
• RFC 3805 (Printer MIB v2)
• RFC 3806 (Printer Finishing MIB)
• RFC 1514 / RFC 2790 (Host Resources MIB v1, v2)

Samsung private MIB
For Samsung devices, SyncThru™ 6 provides much more information and functionality.
• Samsung Host Resources MIB
• Samsung Service Monitor MIB
• Samsung Diagnostics MIB
• Samsung File Storage MIB
• Samsung General MIB

Data matrix
Data vs. Information
SyncThru™ 6 collects raw data from devices such as device status and generates useful information based on the 
collected data. You can see the data categories SyncThru™ 6 manages in the table below.

DATA INFORMATION

Raw data from devices • Usually for Analysis & Reports or Dashboard
• Generation based on raw data

Device • Properties such as model 
name :  You can see this data in 
the Device Management menu.

• Files : You can see the file 
repository for managing firmware 
or font/macro/form files. 

• Alerts

You can see various reports in the Report menu, 
including proactive analysis. Additionally, 
Dashboard provides useful statistics for you to 
monitor devices efficiently. Most of all, you can get 
alert notifications without accessing SyncThru™ 6. 
These features help you manage devices without 
leaving your desk.

User • User accounts and roles
• Usage and permissions if Job 

Accounting is installed.

SyncThru™ 6 provides customized UI for users. If 
Job Accounting is installed - various reports will 
be provided using raw data.

SyncThru™ 6 itself • Server configuration settings
• Help
• Log and history
• Active tasks
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Collecting data from devices
Data collection from devices is one of the most important jobs SyncThru™ 6 performs since the primary usage of 
SyncThru™ 6 is to manage devices. Devices have hundreds of properties and you cannot get all the properties in real 
time; therefore, SyncThru™ 6 categorizes the properties as follows: 

Role reference 
The following tables are based on RFC3805:

Role assignment help
The following table helps you to assign roles to users: 

CATEGORY DESCRIPTION PROPERTIES KEEP IN DB UPDATE DB
DEFAULT 
UPDATE 

INTERVAL

Identity • To use for 
identifying devices 

• No change over 
time after 
initialization

• Hardware 
address

• Serial number

Yes No N/A

Properties. 1 • To collect often for 
monitoring device 
status

• Changes are 
always there over 
time

• Device status Yes Yes 10 minutes

Properties. 2 • To collect 
periodically

• Changes are 
expected over time 
(not more frequently 
than Properties.1)

• Alerts (Troubles)
• Consumables 
• Usage counters
• Total page count
• Color page 

count
• Mono page 

count

Yes Yes 1 hour

Properties. 3 • To collect 
periodically

• Changes happen 
seldomly

• Location
• Model name
• Host name
• Storage files
•  Tray information 

and other 
properties

Yes Yes 24 hours

REQUIRED AREA DESCRIPTION SYNCTHRU™ 6 FEATURE USER ROLE

Notification of events Receive notification of the 
existence of a defined 
printer event. An event can 
be of many types, 
including warnings, errors, 
job stage completion, and 
etc.

Click Settings menu > Device > 
Alert List.

• Operator
• Technician

Printer configuration Query the current 
configuration of a printer

To see the Configuration window, 
select Device > Device 
Management > Select the devices 
for which to change settings > 
Device Configuration tab.

• System manager
• Installer

Printer consumables Determine the current 
state of any and all 
consumables within a 
printer

• Click the Dashboard menu
• Click Device > Device 

Management.

• Operator
• Capacity planner
• Accountant

Internal printer status Determine the current 
status of the printer

• Click the Dashboard menu
• Click the Devices menu > 

Device Management.

• Operator
• Technician
• System Manager
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What does the....do?
The following table explains each role: 

ROLE DESCRIPTION

User (USER) A person or application that submits print jobs to the printer: typically viewed as the "end user" within 
the overall printing environment.

Operator (OP) A person responsible for maintaining a device on a day-to-day basis, including such tasks as filling 
empty media trays, emptying full output trays, replacing toner cartridges, clearing simple paper jams, 
etc.

Technician 
(TECH)

A person responsible for repairing a malfunctioning device, performing routine preventive 
maintenance, and other tasks that typically require advanced training on the printer internals. An 
example of a "technician" would be a manufacturer's Field Service representative or other person 
formally trained by the manufacturer or similar representative.

System 
Manager 
(MGR)

A person responsible for configuration and troubleshooting of components involved in the overall 
printing environment, including printers, print queues and network connectivity issues. This person is 
typically responsible for ensuring the overall operational integrity of the device system components, 
and is typically viewed as the central point of coordination among all other roles.

Help Desk 
(HELP)

A person responsible for supporting users in their printing needs, including training users and 
troubleshooting users' printing problems.

Asset Manager 
(AM)

A person responsible for managing an organization's printing system assets (primarily printers). Such 
a person needs to be able to identify and track the location of printing assets on an ongoing basis.

Capacity 
Planner (CP)

A person responsible for tracking the usage of printing resources on an ongoing basis for the purpose 
of planning printer acquisitions and/or placement of printers based on usage trends.

Installer (INST) A person or application responsible for installing or configuring printing system components on a local 
system.

Accountant 
(ACCT)

A person responsible for tracking the usage of printing resources on an ongoing basis for the purpose 
of charging Users for resources used.
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15.Troubleshooting
This chapter gives helpful information for what to do if you face an error. 

Common errors
Cannot access SyncThru™ 6 from a browser

User actions
• Make sure that the URL and port number you type in the web browser are correct.
• Check if your browser is supported by SyncThru™ 6.
• Ask your administrator.

Administrator actions
• Check if SyncThru™ 6 is running. If the server is not running, you need to restart the service. If the service is 

running, restart the system.
• Check if you can access SyncThru™ 6 from your host machine, where SyncThru™ 6 is installed. If you can access 

SyncThru™ 6 from the host machine, but cannot access it from any remote machine, you may have a network 
issue that is preventing communication between the browser and the SyncThru™ 6 host machine.

- Ask your network administrator. You need to check your network policy, especially security issues. 
- Check the security settings, like the firewall, of the remote machine. If the port number of SyncThru™ 6‘s service is 

blocked by your network manager or firewall, you may have this problem.
- If you have unchecked the firewall configuration at the installation time, you may face this problem. Check the 

firewall settings. By default, SyncThru™ 6 will configure the firewall exceptions automatically unless you change 
the setting.

Cannot upload files to SyncThru™ 6
Using Internet Explorer
If you are using Internet Explorer as a client and SyncThru™ 6 is HTTPS enabled, you may face issues while 
uploading files to the SyncThru™ 6 server. To resolve this issue, follow these steps:
1. Go to Internet Explorer menu > Tools.
2. Click Internet Options then select the Advanced tab.
3. In the Settings section, uncheck the "Use TLS 1.0" checkbox under Security. 
4. Click OK to save the settings.

Using Firefox, Chrome, or Safari
If you are using Firefox, Chrome, or Safari as a client, uploading files to the SyncThru™ 6 server is not supported.

Cannot open context sensitive help in SyncThru™ 6 
If you are using Safari as a client and SyncThru™ 6 is HTTPS enabled, you may face issues in opening context sensitive 
help in SyncThru™ 6. To resolve this issue, do one of the following:
1. Click the Settings icon in the browser’s toolbar.
2. Uncheck Block pop-up windows.
or
1. In the Edit menu, uncheck Block pop-up windows.

Cannot find some network-connected devices
Administrator actions
• Make sure that the specified devices are turned on. 
- From the Windows Start menu, select Run and type in cmd. A window appears. Then, type in ping and the 

specified IP address to confirm network connectivity.
• The devices might have a network communication problem. Check the network configuration of the specified 

devices, such as a protocol status.
- Check SNMP community names. Verify that SNMP GET community names contain public.

• If you know the IP addresses of the devices that you want to find, you can add the devices using the  button 
located in the Device List. 

• If you used Broadcast discovery method,
- Run the discovery when there is less network traffic. If your network is busy, SyncThru™ 6 might not discover 

some devices.
- Try another discovery method, IP Range or CSV Import method. If some devices are not on the same subnet, 

Broadcast discovery might not find them.
• If you used SLP discovery method,
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- Make sure that the devices support multicast broadcasts. If the devices do not, try another discovery method.
- Check whether the router is multicast-enabled or not. If the router is not enabled, the multicast packet does not go 

out of the router. You need to ask the network administrator to enable the multicast on the router.
• If you used IP Range discovery method,
- Check if the IP Range for the discovery reflects the network that is being scanned. Your network monitoring 

system might consider the discovery as being an attack to your network. If so, contact and inform your network 
administrator when running this discovery.

- If SyncThru™ 6 still cannot find the devices, the devices might have a network communication problem. Check the 
network configuration of the specified devices, such as a protocol status.
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Unable to find locally connected devices
Device is connected to the remote computer in the local network. However, local device discovery cannot find the device.

Administrator actions
• Check if the local device account and local device password configured on the started discovery are correct. This 

account should have administrator privileges on the remote computer in order to perform discovery.
• If the operating system of the remote computer is Windows XP/Vista and non-domain configuration is used, check 

if guest user is not blocked on the remote computer. Also, the Simple File Sharing option in Windows Explorer 
should be cleared.

• WMI service uses DCOM to communicate with the remote computer. If you use a network firewall, it should be 
configured properly in order to allow DCOM connectivity. Refer to the user manual of your network firewall to 
configure it. If your system has Windows XP embedded firewall, check the Windows user manual. 

 

You can see more information on the Microsoft web site (http://www.microsoft.com) for solutions to 
problems with DCOM and WMI.

Local device discovery fails
In the latest version of Windows, local device discovery fails if SyncThru™ 6 service is started under “Local System” user.

Administrator actions
• A possible solution is to start the SyncThru™ 6 service under an administrator account.
• This issue is still being resolved.

Incorrect device status appears
User & Administrator actions
• If your network is busy or has a high level of network traffic, SyncThru™ 6 might miss some packets.
- Make sure the device is turned on.

- Refresh the devices list by clicking the  button.
- If this still happens, ask your network administrator about your network communication status.

Device status for locally connected device is not displayed
SyncThru™ 6 found locally connected device, but the status is not displayed.

Administrator actions
Local device discovery shows additional information for Samsung devices if the special WMI Provider has been 
installed on the remote computer and the locally connected device should support Samsung's USB interface. This WMI 
Provider component is automatically installed on the remote computer during local device discovery. The WMI 
Provider supports devices which are connected using USB interface only. If the device can provide additional 
information, the status will be displayed.
• Check if your network firewall allows SyncThru™ 6 to access the network.
• If the operating system of the remote computer is Microsoft Windows 2003 Server, you might need to add the MSI 

WMI Provider component using Add or Remote Programs on the Control Panel. Use the Add/Remove 
Windows Components feature.

Uploading and updating firmware is taking too long
Administrator actions
• There might be a network communication problem in your site. Ask your network administrator first.
• There might be a file size issue. It can take a longer time when uploading/updating a large file.

When a device is selected in the File Storage menu, the files list (font/ macro/ form) is not 
displayed
• Make sure the following are correct:

- Selected device is on the network.
How to check: From the Windows Start menu, select Run and type in cmd. Press enter then type in ping and the 
specified IP address to confirm network connectivity in the command window.

- Selected device supports SyncThru™ 6 File Storage feature.
- The device has at least one file. This problem can happen because the device doesn’t have any files. 
If you still have trouble with this, contact the network administrator. 

When uploading files into the specified devices, even though files are uploaded 
successfully, the result always says failed. 
• Make sure the following settings are correct:

- Check if there is any other SNMP trap server running on the computer where SyncThru™ 6 is installed. If so, that 
trap server may intercept traps via 162 port and SyncThru™ 6 cannot get any traps. Thus, the result is always 
failed as SyncThru™ 6 recognizes the connection time-out. 

- If SyncThru™ 6 is installed on the Windows XP with Service Pack 2, port 162 should be added in the Exceptions 
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list of Windows Firewall configuration in Windows Security Center. (If you have unchecked the firewall 
configuration during the installation, you need to check the firewall settings on the server.)

Configuration History always says "Failed"
• Make sure the following settings are correct:

- Check if your devices supports Samsung Private MIBs. (All the items in Configuration have dependency with MIB 
information inside the device. Only Location, Contact, and Host Name are linked to public MIB, RFC1213. See 
"MIB reference" on page 73)

- Check if your devices have SNMP Write Community name correctly. SNMP settings should be required because 
this Configuration uses SNMP SET command. 

- Check if your devices' SNMP Write Community name is same as SyncThru™ 6's SNMP Write Community 
name. Otherwise, SNMP communication between your devices and SyncThru™ 6 always fails. (See "Connection" 
on page 67 for details)

Cannot find devices using LDAP discovery
• Check the shared Windows printer port format, IP_<ip-addr> (case insensitive, e.g. IP_19.168.1.100), is the only 

supported printer port format in discovering devices. The LDAP discovery scans the shared Windows printers in 
Active Directory when it is used to find the network-connected devices. The LDAP discovery extracts IP address 
information from the printer port name of printer sharing. The port name is parsed and the IP address is used for 
communication. When a port name does not contain a valid IP address, the network device may not be discovered.

Cannot use some ports for HTTP/HTTPS configuration
• The following list of TCP ports are blocked by Flash Player. You may get an error if you try to use these ports for either 

HTTP or HTTPS configuration:

• For more information, please refer to the AS3 Developer Guide: http://help.adobe.com/en_US/as3/dev/
as3_devguide.pdf

PORT USAGE PORT USAGE PORT USAGE PORT USAGE

20 ftp data 42 name 113 auth 587 smtp

21 ftp control 43 nickname 115 sftp 601 syslog

1 tcpmux 53 domain 117 uucp-path 636 ldap+ssl

7 echo 77 priv-rjs 119 nntp 993 ldap+ssl

9 discard 79 finger 123 ntp 995 pop3+ssl

11 systat 87 ttylink 135 loc-srv/
epmap

2049 nfs

13 daytime 95 supdup 139 netbios 4045 lockd

15 netstat 101 hostriame 143 imap2 6000 x11

17 qotd 102 iso-tsap 179 bgp

19 chargen 103 gppitnp 389 ldap

22 ssh 104 acr-nema 465 smtp+ssl

23 telnet 109 pop2 512 uucp

25 smtp 110 pop3 556 remotefs

37 time 111 sunrpc 563 nntp+ssl
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16.Frequently Asked Questions
This chapter gives answers to frequently asked questions.

FAQ
How do I access SyncThru Web Admin Service after installing?

From a web browser
Type in one of the following addresses. 
• http://server_name.domain:port_number
• http://ip_address:port_number

 

• “server_name.domain” is the hostname of the SyncThru™ 6 host machine.

• “ip_address” is the IP address of the machine where SyncThru™ 6 is installed.

• “port_number” is the port number that you entered during the installation.

From the Start menu
From the Start menu, click Program > Samsung Network Printer Utilities > SyncThru™ 6 > SyncThru™ 6.

Is Window XP Service Pack 2 supported by SyncThru™ 6?
SyncThru Web Admin Service supports Windows XP Service Pack 2 if the firewall is disabled or if the following ports are 
enabled:
• 5432 :  PostgreSQL port number if you use PostgreSQL
• 8080 :  HTTP default port, or if you configure another port number for HTTP, the specified port number should be 

enabled
• 8081 :  HTTPS default port, or if you configure another port number for HTTPS, the specified port number should be 

enabled
• 427  : SLP Multicast discovery port number
• 161  :  SNMP communication port
• 162  :  Traps listening port number
• 5353 : mDNS discovery port number

Where can I get the version information for SyncThru™ 6?
After SyncThru™ 6 is installed, open SyncThru™ 6 with a supported web browser. 
Click About located in the top-right portion of the browser Version information and database information are located here.

Is there any way to speed up device discovery time?
Basically, Broadcast and SLP are the discovery methods with the highest speed while IP Range and CSV Import work 
slowly. If you have a speed problem with discovering devices, check the discovery strategy recommended in the 
Discovery section (see "Device Discovery" on page 29).
In addition, you can use another options for discovery: passive discovery settings. 
From SyncThru™ 6, click the Settings menu > Settings > Device Management > Discovery.
Passive SLP discovery or passive mDNS discovery works faster without the network traffic issue.
For IP Range, refer to the followings:
• IP Range discovery checks every IP address. If the range includes many unused IP addresses, SyncThru™ 6 will 

check those addresses, which causes the discovery time problem. If you can ask your network administrator about the 
IP addressing schemes and network environments, or if you already know them, this discovery can be faster.

• You can configure the specific range of IP addresses according to your network environments.
• If you want to use multiple, distinct IP Range settings, you can schedule your own discoveries (See"Device Discovery" 

on page 29).

 

SyncThru™ 6 recommends you to run discoveries during off-hours if possible. However, all the devices should be 
turned on in this case.

What is the purpose of group management?
Device groups make it easier to find the devices, check their statuses, and perform maintenance and other administrative 
operations. For example, if you create groups by your own physical location, you can monitor or manage them easily. 

 

 A single device can belong to an unlimited number of the groups.

Can I downgrade from current SyncThru™ 6 to a previous version with the same database?
Basically, downgrading is not supported by SyncThru™ 6 because we cannot expect any changes in the future, such as 
database schema, which means that a previous version you want to reinstall will not support updating database schema 
from current SyncThru™ 6 to previous version schema. Therefore, if you want to reinstall previous version of SyncThru™ 
6, we recommend you create a new database table. 
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How do I contact the Samsung printer service for questions about SyncThru™ 6?
You can contact Samsung at their web site: http://www.samsungprinter.com.

There are so many postgres.exe tasks in task manager even though one database is 
running. Is this normal behavior?
This is normal behavior of PostgreSQL. PostgreSQL makes around 8 to 10 tasks in task manager for a PostgreSQL 
database.

How do I encrypt the database property file (db.properties) in SyncThru™ 6 using 
Encrypting File System (EFS) in Windows?
EFS is automatically used in Windows to encrypt your confidential data when it is stored on the hard disk. The 
administrator must understand the risks of key management (i.e., if the user forgets the password or fails to back up the 
encryption key, the encrypted file cannot be restored). It is advised to encrypt the db.properties file in SyncThru to protect 
the database information from misuse by users that could represent a risk to data security.
To encrypt you data by using EFS, follow these steps:

 

EFS is not available in Windows XP Home Edition.

1. Open Windows Explorer.
2. Right-click the file or folder to encrypt and select Properties.
3. Select the General tab.
4. Click the Advanced button.
5. Select Encrypt contents to secure data.
6. Click OK.
7. Click OK.

Creating a Recovery Agent
Users can create one of the following recovery key agents based on their work environment:
• Domain-Based Recovery Agent

Allows an account to read or recover data encrypted by using EFS, you must make the account a recovery agent.
• Local Recovery Agent

In a non-domain environment, such as on a standalone computer or in a workgroup, you can create a local 
recovery agent. Creating a local recovery agent might be helpful if the computer is shared by multiple users.

See http://technet.microsoft.com/en-us/library/cc875821.aspx for more information.
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17.Security reference
This chapter explains features SyncThru™ 6 provides for security. 
This chapter includes: 
• SSL communication (HTTPS)
• User authentication
• SNMPv3
• User credentials
  

SSL communication (HTTPS)
SSL (RFC5246) stands for Secure Sockets Layer. It is cryptographic protocol that provides secure communication on the 
network. If you enable SSL, all the data from your browser to SyncThru™ 6 server is encrypted. 
Related parts are as follows: 
• From SyncThru™ 6, click Settings menu > System > HTTP Security.

User authentication
For controlling access to the SyncThru™ 6 server itself, an authentication feature is provided. If you enable authentication, 
only registered users can open SyncThru™ 6. SyncThru™ 6 requires a login ID and password. 
Additionally, registered users have different roles, which include permissions for SyncThru™ 6 operations. 
Related parts are as follows:
• From SyncThru™ 6, click Settings menu > System > User Role Management.
• From SyncThru™ 6, click Settings menu > System > HTTP Security.

SNMPv3
You can configure the security settings for the devices which support SNMPv3 security (RFC2571). These devices will not 
report any status information until you set up the security configuration. The SNMPv3 protocol encrypts the information 
being sent between SyncThru™ 6 and the devices.
Related parts are as follows:
• From SyncThru™ 6, click Device > Device Management. Select a device then click the Connection Settings button.
• From SyncThru™ 6, click Settings menu > Device > Connection.

User credentials
The embedded web servers of the Samsung devices support user credentials for security (You can see the setting in SWS, 
SyncThru Web Service: Maintenance > Security). If the security option is enabled, you need to configure user credentials 
for SyncThru™ 6 because some features of SyncThru™ 6 use HTTP protocol. That means only an Administrator of SWS 
can do the jobs from SyncThru™ 6 if device security is enabled. 
Related parts are as follows:
• From SyncThru™ 6, Device > Device Management. Select a device then click the Connection Settings button.
• From SyncThru™ 6, click Settings menu > Device > Connection.



18.Open Source Information
zlib/png License
This product uses a software program which is distributed under the zlib/png license.

OpenSSL License
This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://www.openssl.org/
)
Copyright (c) 1998-2008 The OpenSSL Project. All rights reserved. 
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following 
conditions are met:Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer.
1. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following 

dis-claimer in the documentation and/or other materials provided with the distribution.
2. All advertising materials mentioning features or use of this software must display the following acknowledgment:
3. "This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit. (http://

www.openssl.org/)"
4. The names "OpenSSL Toolkit" and "OpenSSL Project" must not be used to endorse or promote products derived from 

this software without prior written permission. For written permission, please contact openssl-core@openssl.org.
5. Products derived from this software may not be called "OpenSSL" nor may "OpenSSL" appear in their names without 

prior written permission of the OpenSSL Project.
6. Redistributions of any form whatsoever must retain the following acknowledgment:  

"This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit (http://
www.openssl.org/)"

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT ``AS IS'' AND ANY EXPRESSED OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND 
FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE OpenSSL PROJECT OR ITS 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR 
OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE.
This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product includes software 
written by Tim Hudson (tjh@cryptsoft.com).

Apache License, Version 2.0
Apache License
Version 2.0, January 2004
http://www.apache.org/licenses/
TERMS AND CONDITIONS FOR USE, REPRODUCTION, AND DISTRIBUTION 
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1. Definitions. "License" shall mean the terms and conditions for use, reproduction, and distribution as defined by 
Sections 1 through 9 of this document. "Licensor" shall mean the copyright owner or entity authorized by the copyright 
owner that is granting the License. "Legal Entity" shall mean the union of the acting entity and all other entities that 
control, are controlled by, or are under common control with that entity. For the purposes of this definition, "control" 
means (i) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or 
otherwise, or (ii) ownership of fifty percent (50%) or more of the outstanding shares, or (iii) beneficial ownership of such 
entity. "You" (or "Your") shall mean an individual or Legal Entity exercising permissions granted by this License. 
"Source" form shall mean the preferred form for making modifications, including but not limited to software source 
code, documentation source, and configuration files. "Object" form shall mean any form resulting from mechanical 
transformation or translation of a Source form, including but not limited to compiled object code, generated 
documentation, and conversions to other media types. "Work" shall mean the work of authorship, whether in Source or 
Object form, made available under the License, as indicated by a copyright notice that is included in or attached to the 
work (an example is provided in the Appendix below). 
"Derivative Works" shall mean any work, whether in Source or Object form, that is based on (or derived from) the Work 
and for which the editorial revisions, annotations, elaborations, or other modifications represent, as a whole, an original 
work of authorship. For the purposes of this License, Derivative Works shall not include works that remain separable 
from, or merely link (or bind by name) to the interfaces of, the Work and Derivative Works thereof. "Contribution" shall 
mean any work of authorship, including the original version of the Work and any modifications or additions to that Work 
or Derivative Works thereof, that is intentionally submitted to Licensor for inclusion in the Work by the copyright owner 
or by an individual or Legal Entity authorized to submit on behalf of the copyright owner. For the purposes of this 
definition, "submitted" means any form of electronic, verbal, or written communication sent to the Licensor or its 
representatives, including but not limited to communication on electronic mailing lists, source code control systems, 
and issue tracking systems that are managed by, or on behalf of, the Licensor for the purpose of discussing and 
improving the Work, but excluding communication that is conspicuously marked or otherwise designated in writing by 
the copyright owner as "Not a Contribution." "Contributor" shall mean Licensor and any individual or Legal Entity on 
behalf of whom a Contribution has been received by Licensor and subsequently incorporated within the Work.

2. Grant of Copyright License.Subject to the terms and conditions of this License, each Contributor hereby grants to 
You a perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable copyright license to reproduce, prepare 
Derivative Works of, publicly display, publicly perform, sublicense, and distribute the Work and such Derivative Works 
in Source or Object form. 

3. Grant of Patent License. Subject to the terms and conditions of this License, each Contributor hereby grants to You a 
perpetual, worldwide, non-exclusive, no-charge, royalty-free, irrevocable (except as stated in this section) patent 
license to make, have made, use, offer to sell, sell, import, and otherwise transfer the Work, where such license 
applies only to those patent claims licensable by such Contributor that are necessarily infringed by their Contribution(s) 
alone or by combination of their Contribution(s) with the Work to which such Contribution(s) was submitted. If You 
institute patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that the Work 
or a Contribution incorporated within the Work constitutes direct or contributory patent infringement, then any patent 
licenses granted to You under this License for that Work shall terminate as of the date such litigation is filed. 

4. Redistribution. You may reproduce and distribute copies of the Work or Derivative Works thereof in any medium, with 
or without modifications, and in Source or Object form, provided that You meet the following conditions: 
a. You must give any other recipients of the Work or Derivative Works a copy of this License; and 
b. You must cause any modified files to carry prominent notices stating that You changed the files; and 
c. You must retain, in the Source form of any Derivative Works that You distribute, all copyright, patent, trademark, 

and attribution notices from the Source form of the Work, excluding those notices that do not pertain to any part of 
the Derivative Works; and 

d. If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute 
must include a readable copy of the attribution notices contained within such NOTICE file, excluding those notices 
that do not pertain to any part of the Derivative Works, in at least one of the following places: within a NOTICE text 
file distributed as part of the Derivative Works; within the Source form or documentation, if provided along with the 
Derivative Works; or, within a display generated by the Derivative Works, if and wherever such third-party notices 
normally appear. The contents of the NOTICE file are for informational purposes only and do not modify the 
License. You may add Your own attribution notices within Derivative Works that You distribute, alongside or as an 
addendum to the NOTICE text from the Work, provided that such additional attribution notices cannot be construed 
as modifying the License.

You may add Your own copyright statement to Your modifications and may provide additional or different license terms 
and conditions for use, reproduction, or distribution of Your modifications, or for any such Derivative Works as a whole, 
provided Your use, reproduction, and distribution of the Work otherwise complies with the conditions stated in this 
License. 

5. Submission of Contributions. Unless You explicitly state otherwise, any Contribution intentionally submitted for 
inclusion in the Work by You to the Licensor shall be under the terms and conditions of this License, without any 
additional terms or conditions. Notwithstanding the above, nothing herein shall supersede or modify the terms of any 
separate license agreement you may have executed with Licensor regarding such Contributions.

6. Trademarks.This License does not grant permission to use the trade names, trademarks, service marks, or product 
names of the Licensor, except as required for reasonable and customary use in describing the origin of the Work and 
reproducing the content of the NOTICE file. 

7. Disclaimer of Warranty. Unless required by applicable law or agreed to in writing, Licensor provides the Work (and 
each Contributor provides its Contributions) on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF 
ANY KIND, either express or implied, including, without limitation, any warranties or conditions of TITLE, 
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NON-INFRINGEMENT, MERCHANTABILITY, or FITNESS FOR A PARTICULAR PURPOSE. You are solely 
responsible for determining the appropriateness of using or redistributing the Work and assume any risks associated 
with Your exercise of permissions under this License. 

8. Limitation of Liability. In no event and under no legal theory, whether in tort (including negligence), contract, or 
otherwise, unless required by applicable law (such as deliberate and grossly negligent acts) or agreed to in writing, 
shall any Contributor be liable to You for damages, including any direct, indirect, special, incidental, or consequential 
damages of any character arising as a result of this License or out of the use or inability to use the Work (including but 
not limited to damages for loss of goodwill, work stoppage, computer failure or malfunction, or any and all other 
commercial damages or losses), even if such Contributor has been advised of the possibility of such damages. 

9. Accepting Warranty or Additional Liability. While redistributing the Work or Derivative Works thereof, You may 
choose to offer, and charge a fee for, acceptance of support, warranty, indemnity, or other liability obligations and/or 
rights consistent with this License. However, in accepting such obligations, You may act only on Your own behalf and 
on Your sole responsibility, not on behalf of any other Contributor, and only if You agree to indemnify, defend, and hold 
each Contributor harmless for any liability incurred by, or claims asserted against, such Contributor by reason of your 
accepting any such warranty or additional liability. 

END OF TERMS AND CONDITIONS 
APPENDIX: How to apply the Apache License to your work 
To apply the Apache License to your work, attach the following boilerplate notice, with the fields enclosed by brackets "[]" 
replaced with your own identifying information. (Don't include the brackets!) The text should be enclosed in the appropriate 
comment syntax for the file format. We also recommend that a file or class name and description of purpose be included on 
the same "printed page" as the copyright notice for easier identification within third-party archives. 
Copyright [yyyy] [name of copyright owner] Licensed under the Apache License, Version 2.0 (the "License"); you may not 
use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/
licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is 
distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. 
See the License for the specific language governing permissions and limitations under the License. 

BSD
Copyright (c) 2003-2007, Terence Parr. All rights reserved.
Copyright 2001-2005 (C) MetaStuff, Ltd. All Rights Reserved. 
Copyright (c) 1998-2004, Drew Davidson and Luke Blanshard All rights reserved.
Portions Copyright (c) 1996-2008, The PostgreSQL Global Development Group.
Portions Copyright (c) 1994, The Regents of the University of California.
Redistribution and use in source and binary forms, with or without
 modification, are permitted provided that the following conditions are met:
• Redistributions of source code must retain the above copyright notice, this list of conditions and the following 

disclaimer.
• Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following 

disclaimer in the documentation and/or other materials provided with the distribution.
• Neither the name of the <organization> nor the names of its contributors may be used to endorse or promote products 

derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY <copyright holder> ''AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL <copyright holder> BE LIABLE FOR ANY DIRECT, 
INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED 
TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS 
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

Boost Software License 1.0 (BSL1.0)
Tue, 2008-02-05 16:36 — nelson 
Permission is hereby granted, free of charge, to any person or organization obtaining a copy of the software and 
accompanying documentation covered by this license (the "Software") to use, reproduce, display, distribute, execute, and 
transmit the Software, and to prepare derivative works of the Software, and to permit third-parties to whom the Software is 
furnished to do so, all subject to the following:
The copyright notices in the Software and this entire statement, including the above license grant, this restriction and the 
following disclaimer, must be included in all copies of the Software, in whole or in part, and all derivative works of the 
Software, unless such copies or derivative works are solely in the form of machine-executable object code generated by a 
source language processor.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE 
AND NON-INFRINGEMENT. IN NO EVENT SHALL THE COPYRIGHT HOLDERS OR ANYONE DISTRIBUTING THE 
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SOFTWARE BE LIABLE FOR ANY DAMAGES OR OTHER LIABILITY, WHETHER IN CONTRACT, TORT OR 
OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER 
DEALINGS IN THE SOFTWARE.

GNU LESSER GENERAL PUBLIC LICENSE
This product uses some software programs which are distributed under the LGPLv2.1/LGPLv3 license.
LGPL v2.1 Software : JaperReports, Java CSV Library, Jcommon, jCIFS, Pager Tag Library 
LGPL v3 Software : JFreeChart
Version 2.1, February 1999 
Copyright (C) 1991, 1999 Free Software Foundation, Inc. 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
Everyone is permitted to copy and distribute verbatim copies. of this license document, but changing it is not allowed.
[This is the first released version of the Lesser GPL. It also counts as the successor of the GNU Library Public License, 
version 2, hence the version number 2.1.]

Preamble
The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU 
General Public Licenses are intended to guarantee your freedom to share and change free software--to make sure the 
software is free for all its users. 
This license, the Lesser General Public License, applies to some specially designated software packages--typically 
libraries--of the Free Software Foundation and other authors who decide to use it. You can use it too, but we suggest you 
first think carefully about whether this license or the ordinary General Public License is the better strategy to use in any 
particular case, based on the explanations below. 
When we speak of free software, we are referring to freedom of use, not price. Our General Public Licenses are designed 
to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish); that 
you receive source code or can get it if you want it; that you can change the software and use pieces of it in new free 
programs; and that you are informed that you can do these things. 
To protect your rights, we need to make restrictions that forbid distributors to deny you these rights or to ask you to 
surrender these rights. These restrictions translate to certain responsibilities for you if you distribute copies of the library or 
if you modify it. 
For example, if you distribute copies of the library, whether gratis or for a fee, you must give the recipients all the rights that 
we gave you. You must make sure that they, too, receive or can get the source code. If you link other code with the library, 
you must provide complete object files to the recipients, so that they can relink them with the library after making changes 
to the library and recompiling it. And you must show them these terms so they know their rights. 
We protect your rights with a two-step method: (1) we copyright the library, and (2) we offer you this license, which gives 
you legal permission to copy, distribute and/or modify the library. 
To protect each distributor, we want to make it very clear that there is no warranty for the free library. Also, if the library is 
modified by someone else and passed on, the recipients should know that what they have is not the original version, so 
that the original author's reputation will not be affected by problems that might be introduced by others. 
Finally, software patents pose a constant threat to the existence of any free program. We wish to make sure that a 
company cannot effectively restrict the users of a free program by obtaining a restrictive license from a patent holder. 
Therefore, we insist that any patent license obtained for a version of the library must be consistent with the full freedom of 
use specified in this license. 
Most GNU software, including some libraries, is covered by the ordinary GNU General Public License. This license, the 
GNU Lesser General Public License, applies to certain designated libraries, and is quite different from the ordinary General 
Public License. We use this license for certain libraries in order to permit linking those libraries into non-free programs. 
When a program is linked with a library, whether statically or using a shared library, the combination of the two is legally 
speaking a combined work, a derivative of the original library. The ordinary General Public License therefore permits such 
linking only if the entire combination fits its criteria of freedom. The Lesser General Public License permits more lax criteria 
for linking other code with the library. 
We call this license the "Lesser" General Public License because it does Less to protect the user's freedom than the 
ordinary General Public License. It also provides other free software developers Less of an advantage over competing 
non-free programs. These disadvantages are the reason we use the ordinary General Public License for many libraries. 
However, the Lesser license provides advantages in certain special circumstances. 
For example, on rare occasions, there may be a special need to encourage the widest possible use of a certain library, so 
that it becomes a de-facto standard. To achieve this, non-free programs must be allowed to use the library. A more 
frequent case is that a free library does the same job as widely used non-free libraries. In this case, there is little to gain by 
limiting the free library to free software only, so we use the Lesser General Public License. 
In other cases, permission to use a particular library in non-free programs enables a greater number of people to use a 
large body of free software. For example, permission to use the GNU C Library in non-free programs enables many more 
people to use the whole GNU operating system, as well as its variant, the GNU/Linux operating system. 
Although the Lesser General Public License is Less protective of the users' freedom, it does ensure that the user of a 
program that is linked with the Library has the freedom and the wherewithal to run that program using a modified version of 
the Library. 
The precise terms and conditions for copying, distribution and modification follow. Pay close attention to the difference 
between a "work based on the library" and a "work that uses the library". The former contains code derived from the library, 
whereas the latter must be combined with the library in order to run. 
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TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION
0. This License Agreement applies to any software library or other program which contains a notice placed by the copyright 
holder or other authorized party saying it may be distributed under the terms of this Lesser General Public License (also 
called "this License"). Each licensee is addressed as "you". A "library" means a collection of software functions and/or data 
prepared so as to be conveniently linked with application programs (which use some of those functions and data) to form 
executables. The "Library", below, refers to any such software library or work which has been distributed under these 
terms. 
A "work based on the Library" means either the Library or any derivative work under copyright law: that is to say, a work 
containing the Library or a portion of it, either verbatim or with modifications and/or translated straightforwardly into another 
language. (Hereinafter, translation is included without limitation in the term "modification".) "Source code" for a work means 
the preferred form of the work for making modifications to it. For a library, complete source code means all the source code 
for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and 
installation of the library. Activities other than copying, distribution and modification are not covered by this License; they 
are outside its scope. 
The act of running a program using the Library is not restricted, and output from such a program is covered only if its 
contents constitute a work based on the Library (independent of the use of the Library in a tool for writing it). Whether that 
is true depends on what the Library does and what the program that uses the Library does.
1. You may copy and distribute verbatim copies of the Library's complete source code as you receive it, in any medium, 
provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of 
warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and distribute a copy of 
this License along with the Library. You may charge a fee for the physical act of transferring a copy, and you may at your 
option offer warranty protection in exchange for a fee. 
2. You may modify your copy or copies of the Library or any portion of it, thus forming a work based on the Library, and 
copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these 
conditions: 
• a) The modified work must itself be a software library.
• b) You must cause the files modified to carry prominent notices stating that you changed the files and the date of any 

change.
• c) You must cause the whole of the work to be licensed at no charge to all third parties under the terms of this License.
• d) If a facility in the modified Library refers to a function or a table of data to be supplied by an application program that 

uses the facility, other than as an argument passed when the facility is invoked, then you must make a good faith effort 
to ensure that, in the event an application does not supply such function or table, the facility still operates, and 
performs whatever part of its purpose remains meaningful. (For example, a function in a library to compute square 
roots has a purpose that is entirely well-defined independent of the application. Therefore, Subsection 2d requires that 
any application-supplied function or table used by this function must be optional: if the application does not supply it, 
the square root function must still compute square roots.) These requirements apply to the modified work as a whole. If 
identifiable sections of that work are not derived from the Library, and can be reasonably considered independent and 
separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute 
them as separate works. But when you distribute the same sections as part of a whole which is a work based on the 
Library, the distribution of the whole must be on the terms of this License, whose permissions for other licensees 
extend to the entire whole, and thus to each and every part regardless of who wrote it. Thus, it is not the intent of this 
section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to 
control the distribution of derivative or collective works based on the Library. In addition, mere aggregation of another 
work not based on the Library with the Library (or with a work based on the Library) on a volume of a storage or 
distribution medium does not bring the other work under the scope of this License. 

3. You may opt to apply the terms of the ordinary GNU General Public License instead of this License to a given copy of 
the Library. To do this, you must alter all the notices that refer to this License, so that they refer to the ordinary GNU 
General Public License, version 2, instead of to this License. (If a newer version than version 2 of the ordinary GNU 
General Public License has appeared, then you can specify that version instead if you wish.) Do not make any other 
change in these notices. Once this change is made in a given copy, it is irreversible for that copy, so the ordinary GNU 
General Public License applies to all subsequent copies and derivative works made from that copy. This option is useful 
when you wish to copy part of the code of the Library into a program that is not a library. 
4. You may copy and distribute the Library (or a portion or derivative of it, under Section 2) in object code or executable 
form under the terms of Sections 1 and 2 above provided that you accompany it with the complete corresponding 
machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium 
customarily used for software interchange. If distribution of object code is made by offering access to copy from a 
designated place, then offering equivalent access to copy the source code from the same place satisfies the requirement 
to distribute the source code, even though third parties are not compelled to copy the source along with the object code. 
5. A program that contains no derivative of any portion of the Library, but is designed to work with the Library by being 
compiled or linked with it, is called a "work that uses the Library". Such a work, in isolation, is not a derivative work of the 
Library, and therefore falls outside the scope of this License. However, linking a "work that uses the Library" with the 
Library creates an executable that is a derivative of the Library (because it contains portions of the Library), rather than a 
"work that uses the library". The executable is therefore covered by this License. Section 6 states terms for distribution of 
such executables. When a "work that uses the Library" uses material from a header file that is part of the Library, the object 
code for the work may be a derivative work of the Library even though the source code is not. Whether this is true is 
especially significant if the work can be linked without the Library, or if the work is itself a library. The threshold for this to be 
true is not precisely defined by law. If such an object file uses only numerical parameters, data structure layouts and 
accessors, and small macros and small inline functions (ten lines or less in length), then the use of the object file is 
unrestricted, regardless of whether it is legally a derivative work. (Executables containing this object code plus portions of 
the Library will still fall under Section 6.) Otherwise, if the work is a derivative of the Library, you may distribute the object 
code for the work under the terms of Section 6. Any executables containing that work also fall under Section 6, whether or 
not they are linked directly with the Library itself. 
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6. As an exception to the Sections above, you may also combine or link a "work that uses the Library" with the Library to 
produce a work containing portions of the Library, and distribute that work under terms of your choice, provided that the 
terms permit modification of the work for the customer's own use and reverse engineering for debugging such 
modifications. You must give prominent notice with each copy of the work that the Library is used in it and that the Library 
and its use are covered by this License. You must supply a copy of this License. If the work during execution displays 
copyright notices, you must include the copyright notice for the Library among them, as well as a reference directing the 
user to the copy of this License. Also, you must do one of these things: 
• a) Accompany the work with the complete corresponding machine-readable source code for the Library including 

whatever changes were used in the work (which must be distributed under Sections 1 and 2 above); and, if the work is 
an executable linked with the Library, with the complete machine-readable "work that uses the Library", as object code 
and/or source code, so that the user can modify the Library and then relink to produce a modified executable 
containing the modified Library. (It is understood that the user who changes the contents of definitions files in the 
Library will not necessarily be able to recompile the application to use the modified definitions.)

• b) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (1) uses at 
run time a copy of the library already present on the user's computer system, rather than copying library functions into 
the executable, and (2) will operate properly with a modified version of the library, if the user installs one, as long as the 
modified version is interface-compatible with the version that the work was made with.

• c) Accompany the work with a written offer, valid for at least three years, to give the same user the materials specified 
in Subsection 6a, above, for a charge no more than the cost of performing this distribution.

• d) If distribution of the work is made by offering access to copy from a designated place, offer equivalent access to 
copy the above specified materials from the same place.

• e) Verify that the user has already received a copy of these materials or that you have already sent this user a copy.For 
an executable, the required form of the "work that uses the Library" must include any data and utility programs needed 
for reproducing the executable from it. However, as a special exception, the materials to be distributed need not 
include anything that is normally distributed (in either source or binary form) with the major components (compiler, 
kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies 
the executable. It may happen that this requirement contradicts the license restrictions of other proprietary libraries that 
do not normally accompany the operating system. Such a contradiction means you cannot use both them and the 
Library together in an executable that you distribute. 

7. You may place library facilities that are a work based on the Library side-by-side in a single library together with other 
library facilities not covered by this License, and distribute such a combined library, provided that the separate distribution 
of the work based on the Library and of the other library facilities is otherwise permitted, and provided that you do these 
two things: 
• a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other 

library facilities. This must be distributed under the terms of the Sections above.
• b) Give prominent notice with the combined library of the fact that part of it is a work based on the Library, and 

explaining where to find the accompanying uncombined form of the same work.
8. You may not copy, modify, sublicense, link with, or distribute the Library except as expressly provided under this 
License. Any attempt otherwise to copy, modify, sublicense, link with, or distribute the Library is void, and will automatically 
terminate your rights under this License. However, parties who have received copies, or rights, from you under this License 
will not have their licenses terminated so long as such parties remain in full compliance. 
9. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission 
to modify or distribute the Library or its derivative works. These actions are prohibited by law if you do not accept this 
License. Therefore, by modifying or distributing the Library (or any work based on the Library), you indicate your 
acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Library or 
works based on it. 
10. Each time you redistribute the Library (or any work based on the Library), the recipient automatically receives a license 
from the original licensor to copy, distribute, link with or modify the Library subject to these terms and conditions. You may 
not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for 
enforcing compliance by third parties with this License. 
11. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to 
patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the 
conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to 
satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you 
may not distribute the Library at all. For example, if a patent license would not permit royalty-free redistribution of the 
Library by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this 
License would be to refrain entirely from distribution of the Library. If any portion of this section is held invalid or 
unenforceable under any particular circumstance, the balance of the section is intended to apply, and the section as a 
whole is intended to apply in other circumstances. It is not the purpose of this section to induce you to infringe any patents 
or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the 
integrity of the free software distribution system which is implemented by public license practices. Many people have made 
generous contributions to the wide range of software distributed through that system in reliance on consistent application of 
that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and 
a licensee cannot impose that choice. This section is intended to make thoroughly clear what is believed to be a 
consequence of the rest of this License. 
12. If the distribution and/or use of the Library is restricted in certain countries either by patents or by copyrighted 
interfaces, the original copyright holder who places the Library under this License may add an explicit geographical 
distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus 
excluded. In such case, this License incorporates the limitation as if written in the body of this License. 
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13. The Free Software Foundation may publish revised and/or new versions of the Lesser General Public License from 
time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new 
problems or concerns. Each version is given a distinguishing version number. If the Library specifies a version number of 
this License which applies to it and "any later version", you have the option of following the terms and conditions either of 
that version or of any later version published by the Free Software Foundation. If the Library does not specify a license 
version number, you may choose any version ever published by the Free Software Foundation. 
14. If you wish to incorporate parts of the Library into other free programs whose distribution conditions are incompatible 
with these, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, 
write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two 
goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software 
generally. 

NO WARRANTY 
15. BECAUSE THE LIBRARY IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE LIBRARY, TO 
THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE 
COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE LIBRARY "AS IS" WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND 
PERFORMANCE OF THE LIBRARY IS WITH YOU. SHOULD THE LIBRARY PROVE DEFECTIVE, YOU ASSUME THE 
COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION. 
16. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT 
HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE LIBRARY AS PERMITTED 
ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR 
CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE LIBRARY (INCLUDING BUT 
NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR 
THIRD PARTIES OR A FAILURE OF THE LIBRARY TO OPERATE WITH ANY OTHER SOFTWARE), EVEN IF SUCH 
HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. END OF TERMS AND 
CONDITIONS

How to Apply These Terms to Your New Libraries
If you develop a new library, and you want it to be of the greatest possible use to the public, we recommend making it free 
software that everyone can redistribute and change. You can do so by permitting redistribution under these terms (or, 
alternatively, under the terms of the ordinary General Public License). 
To apply these terms, attach the following notices to the library. It is safest to attach them to the start of each source file to 
most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to 
where the full notice is found. 
one line to give the library's name and an idea of what it does.
Copyright (C) year name of author

This library is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public
License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later 
version.

This library is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied 
warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNULesser General Public 
License for more details.

You should have received a copy of the GNU Lesser General Public License along with this library; if not, write to the Free 
Software Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
Also add information on how to contact you by electronic and paper mail. 
You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for 
the library, if necessary. Here is a sample; alter the names: 
Yoyodyne, Inc., hereby disclaims all copyright interest in the library `Frob' (a library for tweaking knobs) written
by James Random Hacker.

signature of Ty Coon, 1 April 1990
Ty Coon, President of Vice
That's all there is to it!
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GNU LESSER GENERAL PUBLIC LICENSE
Version 3, 29 June 2007
Copyright (C) 2007 Free Software Foundation, Inc. <http://fsf.org/>
Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.
This version of the GNU Lesser General Public License incorporates the terms and conditions of version 3 of the GNU 
General Public License, supplemented by the additional permissions listed below.
0. Additional Definitions
As used herein, “this License” refers to version 3 of the GNU Lesser General Public License, and the “GNU GPL” refers to 
version 3 of the GNU General Public License.
“The Library” refers to a covered work governed by this License, other than an Application or a Combined Work as defined 
below.
An “Application” is any work that makes use of an interface provided by the Library, but which is not otherwise based on 
the Library. Defining a subclass of a class defined by the Library is deemed a mode of using an interface provided by the 
Library.
A “Combined Work” is a work produced by combining or linking an Application with the Library. The particular version of 
the Library with which the Combined Work was made is also called the “Linked Version”.
The “Minimal Corresponding Source” for a Combined Work means the Corresponding Source for the Combined Work, 
excluding any source code for portions of the Combined Work that, considered in isolation, are based on the Application, 
and not on the Linked Version.
The “Corresponding Application Code” for a Combined Work means the object code and/or source code for the 
Application, including any data and utility programs needed for reproducing the Combined Work from the Application, but 
excluding the System Libraries of the Combined Work.
1. Exception to Section 3 of the GNU GPL
You may convey a covered work under sections 3 and 4 of this License without being bound by section 3 of the GNU GPL.
2. Conveying Modified Versions
If you modify a copy of the Library, and, in your modifications, a facility refers to a function or data to be supplied by an 
Application that uses the facility (other than as an argument passed when the facility is invoked), then you may convey a 
copy of the modified version:
• a) under this License, provided that you make a good faith effort to ensure that, in the event an Application does not 

supply the function or data, the facility still operates, and performs whatever part of its purpose remains meaningful, or
• b) under the GNU GPL, with none of the additional permissions of this License applicable to that copy.
3. Object Code Incorporating Material from Library Header Files
The object code form of an Application may incorporate material from a header file that is part of the Library. You may 
convey such object code under terms of your choice, provided that, if the incorporated material is not limited to numerical 
parameters, data structure layouts and accessors, or small macros, inline functions and templates (ten or fewer lines in 
length), you do both of the following:
• a) Give prominent notice with each copy of the object code that the Library is used in it and that the Library and its use 

are covered by this License.
• b) Accompany the object code with a copy of the GNU GPL and this license document.
4. Combined Works
You may convey a Combined Work under terms of your choice that, taken together, effectively do not restrict modification 
of the portions of the Library contained in the Combined Work and reverse engineering for debugging such modifications, if 
you also do each of the following:
• a) Give prominent notice with each copy of the Combined Work that the Library is used in it and that the Library and its 

use are covered by this License.
• b) Accompany the Combined Work with a copy of the GNU GPL and this license document.
• c) For a Combined Work that displays copyright notices during execution, include the copyright notice for the Library 

among these notices, as well as a reference directing the user to the copies of the GNU GPL and this license 
document.

• d) Do one of the following: 
- 0) Convey the Minimal Corresponding Source under the terms of this License, and the Corresponding Application 

Code in a form suitable for, and under terms that permit, the user to recombine or relink the Application with a 
modified version of the Linked Version to produce a modified Combined Work, in the manner specified by section 
6 of the GNU GPL for conveying Corresponding Source.

- 1) Use a suitable shared library mechanism for linking with the Library. A suitable mechanism is one that (a) uses 
at run time a copy of the Library already present on the user's computer system, and (b) will operate properly with 
a modified version of the Library that is interface-compatible with the Linked Version.

• e) Provide Installation Information, but only if you would otherwise be required to provide such information under 
section 6 of the GNU GPL, and only to the extent that such information is necessary to install and execute a modified 
version of the Combined Work produced by recombining or relinking the Application with a modified version of the 
Linked Version. (If you use option 4d0, the Installation Information must accompany the Minimal Corresponding 
Source and Corresponding Application Code. If you use option 4d1, you must provide the Installation Information in the 
manner specified by section 6 of the GNU GPL for conveying Corresponding Source.)
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5. Combined Libraries
You may place library facilities that are a work based on the Library side by side in a single library together with other 
library facilities that are not Applications and are not covered by this License, and convey such a combined library under 
terms of your choice, if you do both of the following:
• a) Accompany the combined library with a copy of the same work based on the Library, uncombined with any other 

library facilities, conveyed under the terms of this License.
• b) Give prominent notice with the combined library that part of it is a work based on the Library, and explaining where 

to find the accompanying uncombined form of the same work.
6. Revised Versions of the GNU Lesser General Public License
The Free Software Foundation may publish revised and/or new versions of the GNU Lesser General Public License from 
time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new 
problems or concerns.
Each version is given a distinguishing version number. If the Library as you received it specifies that a certain numbered 
version of the GNU Lesser General Public License “or any later version” applies to it, you have the option of following the 
terms and conditions either of that published version or of any later version published by the Free Software Foundation. If 
the Library as you received it does not specify a version number of the GNU Lesser General Public License, you may 
choose any version of the GNU Lesser General Public License ever published by the Free Software Foundation.
If the Library as you received it specifies that a proxy can decide whether future versions of the GNU Lesser General Public 
License shall apply, that proxy's public statement of acceptance of any version is permanent authorization for you to 
choose that version for the Library.

MIT
Copyright (c) 2000 - 2008 The Legion Of The Bouncy Castle (http://www.bouncycastle.org)
Copyright (c) 1999, 2006 Tanuki Software, Inc.
Copyright (c) 2007 Valerio Proietti, <http://mad4milk.net>
Permission is hereby granted, free of charge, to any person obtaining a copy of this software and associated 
documentation files (the "Software"), to deal in the Software without restriction, including without limitation the rights to use, 
copy, modify, merge, publish, distribute, sublicense, and/or sell copies of the Software, and to permit persons to whom the 
Software is furnished to do so, subject to the following conditions: 
The above copyright notice and this permission notice shall be included in all copies or substantial portions of the Software.
THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLIED, INCLUDING 
BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND 
NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY 
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, 
ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE 
SOFTWARE.

Eclipse Public License
The software included in this product contains copyrighted software that is licensed under the EPL.
You may obtain the complete Corresponding Source code from us for a period of three years after our last shipment of this 
product by sending email to: dpdopensrc@samsung.com. If you want to obtain the complete Corresponding Source code 
in the physical medium such as CD-ROM, the cost of physically performing source distribution may be charged. This offer 
is valid to anyone in receipt of this information. 
EPL software : Eclipse Project

Eclipse Public License - v 1.0
THE ACCOMPANYING PROGRAM IS PROVIDED UNDER THE TERMS OF THIS ECLIPSE PUBLIC LICENSE 
("AGREEMENT"). ANY USE, REPRODUCTION OR DISTRIBUTION OF THE PROGRAM CONSTITUTES RECIPIENT’S 
ACCEPTANCE OF THIS AGREEMENT.

1. DEFINITIONS
 "Contribution" means: 
a) in the case of the initial Contributor, the initial code and documentation distributed under this Agreement, and
b) in the case of each subsequent Contributor: 
i)changes to the Program, and
ii)additions to the Program;
where such changes and/or additions to the Program originate from and are distributed by that particular Contributor. A 
Contribution 'originates' from a Contributor if it was added to the Program by such Contributor itself or anyone acting on 
such Contributor’s behalf. Contributions do not include additions to the Program which: (i) are separate modules of 
software distributed in conjunction with the Program under their own license agreement, and (ii) are not derivative 
works of the Program. 
"Contributor" means any person or entity that distributes the Program.
"Licensed Patents " mean patent claims licensable by a Contributor which are necessarily infringed by the use or sale 
of its Contribution alone or when combined with the Program.
"Program" means the Contributions distributed in accordance with this Agreement.
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"Recipient" means anyone who receives the Program under this Agreement, including all Contributors.

2. GRANT OF RIGHTS
a) Subject to the terms of this Agreement, each Contributor hereby grants Recipient a non-exclusive, worldwide, 
royalty-free copyright license to reproduce, prepare derivative works of, publicly display, publicly perform, distribute 
and sublicense the Contribution of such Contributor, if any, and such derivative works, in source code and object code 
form.
b) Subject to the terms of this Agreement, each Contributor hereby grants Recipient a non-exclusive, worldwide, 
royalty-free patent license under Licensed Patents to make, use, sell, offer to sell, import and otherwise transfer the 
Contribution of such Contributor, if any, in source code and object code form. This patent license shall apply to the 
combination of the Contribution and the Program if, at the time the Contribution is added by the Contributor, such 
addition of the Contribution causes such combination to be covered by the Licensed Patents. The patent license shall 
not apply to any other combinations which include the Contribution. No hardware per se is licensed hereunder.
c) Recipient understands that although each Contributor grants the licenses to its Contributions set forth herein, no 
assurances are provided by any Contributor that the Program does not infringe the patent or other intellectual property 
rights of any other entity. Each Contributor disclaims any liability to Recipient for claims brought by any other entity 
based on infringement of intellectual property rights or otherwise. As a condition to exercising the rights and licenses 
granted hereunder, each Recipient hereby assumes sole responsibility to secure any other intellectual property rights 
needed, if any. For example, if a third party patent license is required to allow Recipient to distribute the Program, it is 
Recipient’s responsibility to acquire that license before distributing the Program.
d) Each Contributor represents that to its knowledge it has sufficient copyright rights in its Contribution, if any, to grant 
the copyright license set forth in this Agreement. 

3. REQUIREMENTS
A Contributor may choose to distribute the Program in object code form under its own license agreement, provided 
that: 
a) it complies with the terms and conditions of this Agreement; and
b) its license agreement:
i) effectively disclaims on behalf of all Contributors all warranties and conditions, express and implied, including 
warranties or conditions of title and non-infringement, and implied warranties or conditions of merchantability and 
fitness for a particular purpose; 
ii) effectively excludes on behalf of all Contributors all liability for damages, including direct, indirect, special, incidental 
and consequential damages, such as lost profits; 
iii) states that any provisions which differ from this Agreement are offered by that Contributor alone and not by any 
other party; and
iv) states that source code for the Program is available from such Contributor, and informs licensees how to obtain it in 
a reasonable manner on or through a medium customarily used for software exchange.
When the Program is made available in source code form:
a) it must be made available under this Agreement; and 
b) a copy of this Agreement must be included with each copy of the Program. 
Contributors may not remove or alter any copyright notices contained within the Program. 
Each Contributor must identify itself as the originator of its Contribution, if any, in a manner that reasonably allows 
subsequent Recipients to identify the originator of the Contribution. 

4. COMMERCIAL DISTRIBUTION
Commercial distributors of software may accept certain responsibilities with respect to end users, business partners 
and the like. While this license is intended to facilitate the commercial use of the Program, the Contributor who includes 
the Program in a commercial product offering should do so in a manner which does not create potential liability for 
other Contributors. Therefore, if a Contributor includes the Program in a commercial product offering, such Contributor 
("Commercial Contributor") hereby agrees to defend and indemnify every other Contributor ("Indemnified Contributor") 
against any losses, damages and costs (collectively "Losses") arising from claims, lawsuits and other legal actions 
brought by a third party against the Indemnified Contributor to the extent caused by the acts or omissions of such 
Commercial Contributor in connection with its distribution of the Program in a commercial product offering. The 
obligations in this section do not apply to any claims or Losses relating to any actual or alleged intellectual property 
infringement. In order to qualify, an Indemnified Contributor must: a) promptly notify the Commercial Contributor in 
writing of such claim, and b) allow the Commercial Contributor to control, and cooperate with the Commercial 
Contributor in, the defense and any related settlement negotiations. The Indemnified Contributor may participate in any 
such claim at its own expense.
For example, a Contributor might include the Program in a commercial product offering, Product X. That Contributor is 
then a Commercial Contributor. If that Commercial Contributor then makes performance claims, or offers warranties 
related to Product X, those performance claims and warranties are such Commercial Contributor’s responsibility alone. 
Under this section, the Commercial Contributor would have to defend claims against the other Contributors related to 
those performance claims and warranties, and if a court requires any other Contributor to pay any damages as a result, 
the Commercial Contributor must pay those damages.

5. NO WARRANTY
EXCEPT AS EXPRESSLY SET FORTH IN THIS AGREEMENT, THE PROGRAM IS PROVIDED ON AN "AS IS" 
BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, EITHER EXPRESS OR IMPLIED INCLUDING, 
WITHOUT LIMITATION, ANY WARRANTIES OR CONDITIONS OF TITLE, NON-INFRINGEMENT, 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Each Recipient is solely responsible for 
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determining the appropriateness of using and distributing the Program and assumes all risks associated with its 
exercise of rights under this Agreement , including but not limited to the risks and costs of program errors, compliance 
with applicable laws, damage to or loss of data, programs or equipment, and unavailability or interruption of operations.

6. DISCLAIMER OF LIABILITY
EXCEPT AS EXPRESSLY SET FORTH IN THIS AGREEMENT, NEITHER RECIPIENT NOR ANY CONTRIBUTORS 
SHALL HAVE ANY LIABILITY FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING WITHOUT LIMITATION LOST PROFITS), HOWEVER CAUSED AND 
ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING 
NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OR DISTRIBUTION OF THE 
PROGRAM OR THE EXERCISE OF ANY RIGHTS GRANTED HEREUNDER, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES.

7. GENERAL
If any provision of this Agreement is invalid or unenforceable under applicable law, it shall not affect the validity or 
enforceability of the remainder of the terms of this Agreement, and without further action by the parties hereto, such 
provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable. If 
Recipient institutes patent litigation against any entity (including a cross-claim or counterclaim in a lawsuit) alleging that 
the Program itself (excluding combinations of the Program with other software or hardware) infringes such Recipient’s 
patent(s), then such Recipient’s rights granted under Section 2(b) shall terminate as of the date such litigation is filed.  
All Recipient’s rights under this Agreement shall terminate if it fails to comply with any of the material terms or 
conditions of this Agreement and does not cure such failure in a reasonable period of time after becoming aware of 
such noncompliance. If all Recipient’s rights under this Agreement terminate, Recipient agrees to cease use and 
distribution of the Program as soon as reasonably practicable. However, Recipient’s obligations under this Agreement 
and any licenses granted by Recipient relating to the Program shall continue and survive.
Everyone is permitted to copy and distribute copies of this Agreement, but in order to avoid inconsistency the 
Agreement is copyrighted and may only be modified in the following manner. The Agreement Steward reserves the 
right to publish new versions (including revisions) of this Agreement from time to time. No one other than the 
Agreement Steward has the right to modify this Agreement. The Eclipse Foundation is the initial Agreement Steward. 
The Eclipse Foundation may assign the responsibility to serve as the Agreement Steward to a suitable separate entity. 
Each new version of the Agreement will be given a distinguishing version number. The Program (including 
Contributions) may always be distributed subject to the version of the Agreement under which it was received. In 
addition, after a new version of the Agreement is published, Contributor may elect to distribute the Program (including 
its Contributions) under the new version. Except as expressly stated in Sections 2(a) and 2(b) above, Recipient 
receives no rights or licenses to the intellectual property of any Contributor under this Agreement, whether expressly, 
by implication, estoppel or otherwise. All rights in the Program not expressly granted under this Agreement are 
reserved.
This Agreement is governed by the laws of the State of New York and the intellectual property laws of the United 
States of America. No party to this Agreement will bring a legal action under this Agreement more than one year after 
the cause of action arose. Each party waives its rights to a jury trial in any resulting litigation.

Mozilla Public License
The software included in this product contains copyrighted software that is licensed under the MPL.
You may obtain the complete Corresponding Source code from us for a period of three years after our last shipment of this 
product by sending email to: dpdopensrc@samsung.com.If you want to obtain the complete Corresponding Source code in 
the physical medium such as CD-ROM, the cost of physically performing source distribution may be charged.This offer is 
valid to anyone in receipt of this information.
MPL software : iText

MOZILLA PUBLIC LICENSE Version 1.1
1. Definitions.
1.0.1. "Commercial Use" means distribution or otherwise making the Covered Code available to a third party.
1.1. "Contributor" means each entity that creates or contributes to the creation of Modifications.
1.2. "Contributor Version" means the combination of the Original Code, prior Modifications used by a Contributor, and 
the Modifications made by that particular Contributor.
1.3. "Covered Code" means the Original Code or Modifications or the combination of the Original Code and 
Modifications, in each case including portions thereof.
1.4. "Electronic Distribution Mechanism" means a mechanism generally accepted in the software development 
community for the electronic transfer of data.
1.5. "Executable" means Covered Code in any form other than Source Code.
1.6. "Initial Developer" means the individual or entity identified as the Initial Developer in the Source Code notice 
required by Exhibit A.
1.7. "Larger Work" means a work which combines Covered Code or portions thereof with code not governed by the 
terms of this License.
1.8. "License" means this document.
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1.8.1. "Licensable" means having the right to grant, to the maximum extent possible, whether at the time of the initial 
grant or subsequently acquired, any and all of the rights conveyed herein.
1.9. "Modifications" means any addition to or deletion from the substance or structure of either the Original Code or any 
previous Modifications. When Covered Code is released as a series of files, a Modification is:
A. Any addition to or deletion from the contents of a file containing Original Code or previous Modifications.
B. Any new file that contains any part of the Original Code or previous Modifications.
1.10. "Original Code" means Source Code of computer software code which is described in the Source Code notice 
required by Exhibit A as Original Code, and which, at the time of its release under this License is not already Covered 
Code governed by this License.
1.10.1. "Patent Claims" means any patent claim(s), now owned or hereafter acquired, including without limitation, 
method, process, and apparatus claims, in any patent Licensable by grantor.
1.11. "Source Code" means the preferred form of the Covered Code for making modifications to it, including all 
modules it contains, plus any associated interface definition files, scripts used to control compilation and installation of 
an Executable, or source code differential comparisons against either the Original Code or another well known, 
available Covered Code of the Contributor's choice. The Source Code can be in a compressed or archival form, 
provided the appropriate decompression or de-archiving software is widely available for no charge.
1.12. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms 
of, this License or a future version of this License issued under Section 6.1. For legal entities, "You" includes any entity 
which controls, is controlled by, or is under common control with You. For purposes of this definition, "control" means 
(a) the power, direct or indirect, to cause the direction or management of such entity, whether by contract or otherwise, 
or (b) ownership of more than fifty percent (50%) of the outstanding shares or beneficial ownership of such entity.

2. Source Code License.
2.1. The Initial Developer Grant.
The Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license, subject to third party 
intellectual property claims:
(a) under intellectual property rights (other than patent or trademark) Licensable by Initial Developer to use, reproduce, 
modify, display, perform, sublicense and distribute the Original Code (or portions thereof) with or without Modifications, 
and/or as part of a Larger Work; and
(b) under Patents Claims infringed by the making, using or selling of Original Code, to make, have made, use, practice, 
sell, and offer for sale, and/or otherwise dispose of the Original Code (or portions thereof).
(c) the licenses granted in this Section 2.1(a) and (b) are effective on the date Initial Developer first distributes Original 
Code under the terms of this License.
(d) Notwithstanding Section 2.1(b) above, no patent license is granted: 1) for code that You delete from the Original 
Code; 2) separate from the Original Code; or 3) for infringements caused by: i) the modification of the Original Code or 
ii) the combination of the Original Code with other software or devices.
2.2. Contributor Grant.
Subject to third party intellectual property claims, each Contributor hereby grants You a world-wide, royalty-free, 
non-exclusive license
(a) under intellectual property rights (other than patent or trademark) Licensable by Contributor, to use, reproduce, 
modify, display, perform, sublicense and distribute the Modifications created by such Contributor (or portions thereof) 
either on an unmodified basis, with other Modifications, as Covered Code and/or as part of a Larger Work; and
(b) under Patent Claims infringed by the making, using, or selling of Modifications made by that Contributor either 
alone and/or in combination with its Contributor Version (or portions of such combination), to make, use, sell, offer for 
sale, have made, and/or otherwise dispose of: 1) Modifications made by that Contributor (or portions thereof); and 2) 
the combination of Modifications made by that Contributor with its Contributor Version (or portions of such 
combination).
(c) the licenses granted in Sections 2.2(a) and 2.2(b) are effective on the date Contributor first makes Commercial Use 
of the Covered Code.
(d) Notwithstanding Section 2.2(b) above, no patent license is granted: 1) for any code that Contributor has deleted 
from the Contributor Version; 2) separate from the Contributor Version; 3) for infringements caused by: i) third party 
modifications of Contributor Version or ii) the combination of Modifications made by that Contributor with other 
software (except as part of the Contributor Version) or other devices; or 4) under Patent Claims infringed by Covered 
Code in the absence of Modifications made by that Contributor.

3. Distribution Obligations.
3.1. Application of License.
The Modifications which You create or to which You contribute are governed by the terms of this License, including 
without limitation Section 2.2. The Source Code version of Covered Code may be distributed only under the terms of 
this License or a future version of this License released under Section 6.1, and You must include a copy of this License 
with every copy of the Source Code You distribute. You may not offer or impose any terms on any Source Code 
version that alters or restricts the applicable version of this License or the recipients' rights hereunder. However, You 
may include an additional document offering the additional rights described in Section 3.5. 
3.2. Availability of Source Code.
Any Modification which You create or to which You contribute must be made available in Source Code form under the 
terms of this License either on the same media as an Executable version or via an accepted Electronic Distribution 
Mechanism to anyone to whom you made an Executable version available; and if made available via Electronic 
Distribution Mechanism, must remain available for at least twelve (12) months after the date it initially became 
available, or at least six (6) months after a subsequent version of that particular Modification has been made available 
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to such recipients. You are responsible for ensuring that the Source Code version remains available even if the 
Electronic Distribution Mechanism is maintained by a third party.
3.3. Description of Modifications.
You must cause all Covered Code to which You contribute to contain a file documenting the changes You made to 
create that Covered Code and the date of any change. You must include a prominent statement that the Modification is 
derived, directly or indirectly, from Original Code provided by the Initial Developer and including the name of the Initial 
Developer in (a) the Source Code, and (b) in any notice in an Executable version or related documentation in which 
You describe the origin or ownership of the Covered Code.
3.4. Intellectual Property Matters
(a) Third Party Claims.
If Contributor has knowledge that a license under a third party's intellectual property rights is required to exercise the 
rights granted by such Contributor under Sections 2.1 or 2.2, Contributor must include a text file with the Source Code 
distribution titled "LEGAL" which describes the claim and the party making the claim in sufficient detail that a recipient 
will know whom to contact. If Contributor obtains such knowledge after the Modification is made available as described 
in Section 3.2, Contributor shall promptly modify the LEGAL file in all copies Contributor makes available thereafter 
and shall take other steps (such as notifying appropriate mailing lists or newsgroups) reasonably calculated to inform 
those who received the Covered Code that new knowledge has been obtained.
(b) Contributor APIs.
If Contributor's Modifications include an application programming interface and Contributor has knowledge of patent 
licenses which are reasonably necessary to implement that API, Contributor must also include this information in the 
LEGAL file.
(c) Representations.
Contributor represents that, except as disclosed pursuant to Section 3.4(a) above, Contributor believes that 
Contributor's Modifications are Contributor's original creation(s) and/or Contributor has sufficient rights to grant the 
rights conveyed by this License.
3.5. Required Notices.
You must duplicate the notice in Exhibit A in each file of the Source Code. If it is not possible to put such notice in a 
particular Source Code file due to its structure, then You must include such notice in a location (such as a relevant 
directory) where a user would be likely to look for such a notice. If You created one or more Modification(s) You may 
add your name as a Contributor to the notice described in Exhibit A. You must also duplicate this License in any 
documentation for the Source Code where You describe recipients' rights or ownership rights relating to Covered 
Code. You may choose to offer, and to charge a fee for, warranty, support, indemnity or liability obligations to one or 
more recipients of Covered Code. However, You may do so only on Your own behalf, and not on behalf of the Initial 
Developer or any Contributor. You must make it absolutely clear than any such warranty, support, indemnity or liability 
obligation is offered by You alone, and You hereby agree to indemnify the Initial Developer and every Contributor for 
any liability incurred by the Initial Developer or such Contributor as a result of warranty, support, indemnity or liability 
terms You offer.
3.6. Distribution of Executable Versions.
You may distribute Covered Code in Executable form only if the requirements of Section 3.1-3.5 have been met for that 
Covered Code, and if You include a notice stating that the Source Code version of the Covered Code is available 
under the terms of this License, including a description of how and where You have fulfilled the obligations of Section 
3.2. The notice must be conspicuously included in any notice in an Executable version, related documentation or 
collateral in which You describe recipients' rights relating to the Covered Code. You may distribute the Executable 
version of Covered Code or ownership rights under a license of Your choice, which may contain terms different from 
this License, provided that You are in compliance with the terms of this License and that the license for the Executable 
version does not attempt to limit or alter the recipient's rights in the Source Code version from the rights set forth in this 
License. If You distribute the Executable version under a different license You must make it absolutely clear that any 
terms which differ from this License are offered by You alone, not by the Initial Developer or any Contributor. You 
hereby agree to indemnify the Initial Developer and every Contributor for any liability incurred by the Initial Developer 
or such Contributor as a result of any such terms You offer.
3.7. Larger Works.
You may create a Larger Work by combining Covered Code with other code not governed by the terms of this License 
and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this 
License are fulfilled for the Covered Code.

4. Inability to Comply Due to Statute or Regulation.
If it is impossible for You to comply with any of the terms of this License with respect to some or all of the Covered 
Code due to statute, judicial order, or regulation then You must: (a) comply with the terms of this License to the 
maximum extent possible; and (b) describe the limitations and the code they affect. Such description must be included 
in the LEGAL file described in Section 3.4 and must be included with all distributions of the Source Code. Except to the 
extent prohibited by statute or regulation, such description must be sufficiently detailed for a recipient of ordinary skill to 
be able to understand it.

5. Application of this License.
This License applies to code to which the Initial Developer has attached the notice in Exhibit A and to related Covered 
Code.

6. Versions of the License.
6.1. New Versions.
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Netscape Communications Corporation ("Netscape") may publish revised and/or new versions of the License from 
time to time. Each version will be given a distinguishing version number.
6.2. Effect of New Versions.
Once Covered Code has been published under a particular version of the License, You may always continue to use it 
under the terms of that version. You may also choose to use such Covered Code under the terms of any subsequent 
version of the License published by Netscape. No one other than Netscape has the right to modify the terms applicable 
to Covered Code created under this License.
6.3. Derivative Works.
If You create or use a modified version of this License (which you may only do in order to apply it to code which is not 
already Covered Code governed by this License), You must (a) rename Your license so that the phrases "Mozilla", 
"MOZILLAPL", "MOZPL", "Netscape", "MPL", "NPL" or any confusingly similar phrase do not appear in your license 
(except to note that your license differs from this License) and (b) otherwise make it clear that Your version of the 
license contains terms which differ from the Mozilla Public License and Netscape Public License. (Filling in the name of 
the Initial Developer, Original Code or Contributor in the notice described in Exhibit A shall not of themselves be 
deemed to be modifications of this License.)
7. DISCLAIMER OF WARRANTY
COVERED CODE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE 
COVERED CODE IS FREE OF DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR 
NON-INFRINGING. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED CODE IS 
WITH YOU. SHOULD ANY COVERED CODE PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL 
DEVELOPER OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR 
OR CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. 
NO USE OF ANY COVERED CODE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

8. TERMINATION.
8.1. This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein 
and fail to cure such breach within 30 days of becoming aware of the breach. All sublicenses to the Covered Code 
which are properly granted shall survive any termination of this License. Provisions which, by their nature, must remain 
in effect beyond the termination of this License shall survive.
8.2. If You initiate litigation by asserting a patent infringement claim (excluding declatory judgment actions) against 
Initial Developer or a Contributor (the Initial Developer or Contributor against whom You file such action is referred to 
as "Participant") alleging that:
(a) such Participant's Contributor Version directly or indirectly infringes any patent, then any and all rights granted by 
such Participant to You under Sections 2.1 and/or 2.2 of this License shall, upon 60 days notice from Participant 
terminate prospectively, unless if within 60 days after receipt of notice You either: (i) agree in writing to pay Participant 
a mutually agreeable reasonable royalty for Your past and future use of Modifications made by such Participant, or (ii) 
withdraw Your litigation claim with respect to the Contributor Version against such Participant. If within 60 days of 
notice, a reasonable royalty and payment arrangement are not mutually agreed upon in writing by the parties or the 
litigation claim is not withdrawn, the rights granted by Participant to You under Sections 2.1 and/or 2.2 automatically 
terminate at the expiration of the 60 day notice period specified above. (b) any software, hardware, or device, other 
than such Participant's Contributor Version, directly or indirectly infringes any patent, then any rights granted to You by 
such Participant under Sections 2.1(b) and 2.2(b) are revoked effective as of the date You first made, used, sold, 
distributed, or had made, Modifications made by that Participant.
8.3. If You assert a patent infringement claim against Participant alleging that such Participant's Contributor Version 
directly or indirectly infringes any patent where such claim is resolved (such as by license or settlement) prior to the 
initiation of patent infringement litigation, then the reasonable value of the licenses granted by such Participant under 
Sections 2.1 or 2.2 shall be taken into account in determining the amount or value of any payment or license.
8.4. In the event of termination under Sections 8.1 or 8.2 above, all end user license agreements (excluding 
distributors and resellers) which have been validly granted by You or any distributor hereunder prior to termination 
shall survive termination.
9. LIMITATION OF LIABILITY.
UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING 
NEGLIGENCE), CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL DEVELOPER, ANY OTHER 
CONTRIBUTOR, OR ANY DISTRIBUTOR OF COVERED CODE, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, 
BE LIABLE TO ANY PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF 
ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK 
STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR 
LOSSES, EVEN IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. 
THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY 
RESULTING FROM SUCH PARTY'S NEGLIGENCE TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH 
LIMITATION. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR 
CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION AND LIMITATION MAY NOT APPLY TO YOU.

10. U.S. GOVERNMENT END USERS.
The Covered Code is a "commercial item," as that term is defined in 48 C.F.R. 2.101 (Oct. 1995), consisting of 
"commercial computer software" and "commercial computer software documentation," as such terms are used in 48 
C.F.R. 12.212 (Sept. 1995). Consistent with 48 C.F.R. 12.212 and 48 C.F.R. 227.7202-1 through 227.7202-4 (June 
1995), all U.S. Government End Users acquire Covered Code with only those rights set forth herein.
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11. MISCELLANEOUS.
This License represents the complete agreement concerning subject matter hereof. If any provision of this License is 
held to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable. This 
License shall be governed by California law provisions (except to the extent applicable law, if any, provides otherwise), 
excluding its conflict-of-law provisions. With respect to disputes in which at least one party is a citizen of, or an entity 
chartered or registered to do business in the United States of America, any litigation relating to this License shall be 
subject to the jurisdiction of the Federal Courts of the Northern District of California, with venue lying in Santa Clara 
County, California, with the losing party responsible for costs, including without limitation, court costs and reasonable 
attorneys' fees and expenses. The application of the United Nations Convention on Contracts for the International Sale 
of Goods is expressly excluded. Any law or regulation which provides that the language of a contract shall be 
construed against the drafter shall not apply to this License.

12. RESPONSIBILITY FOR CLAIMS.
As between Initial Developer and the Contributors, each party is responsible for claims and damages arising, directly 
or indirectly, out of its utilization of rights under this License and You agree to work with Initial Developer and 
Contributors to distribute such responsibility on an equitable basis. Nothing herein is intended or shall be deemed to 
constitute any admission of liability.

13. MULTIPLE-LICENSED CODE.
Initial Developer may designate portions of the Covered Code as "Multiple-Licensed". "Multiple-Licensed" means that 
the Initial Developer permits you to utilize portions of the Covered Code under Your choice of the NPL or the 
alternative licenses, if any, specified by the Initial Developer in the file described in Exhibit A.EXHIBIT A -Mozilla Public 
License. ``The contents of this file are subject to the Mozilla Public License Version 1.1 (the "License"); you may not 
use this file except in compliance with the License. You may obtain a copy of the License at http://www.mozilla.org/
MPL/ Software distributed under the License is distributed on an "AS IS" basis, WITHOUT WARRANTY OF ANY 
KIND, either express or implied. See the License for the specific language governing rights and limitations under the 
License.

The Original Code is .

The Initial Developer of the Original Code is .

Portions created by [ ] are Copyright (C) .

. All Rights Reserved.

Contributor(s): .
Alternatively, the contents of this file may be used under the terms of the [ ]license (the "[ ] License"), in which case the 
provisions of [ ] License are applicable instead of those above. If you wish to allow use of your version of this file only 
under the terms of the [ ] License and not to allow others to use your version of this file under the MPL, indicate your 
decision by deleting the provisions above and replace them with the notice and other provisions required by the [ ] 
License. If you do not delete the provisions above, a recipient may use your version of this file under either the MPL or 
the License."
[NOTE: The text of this Exhibit A may differ slightly from the text of the notices in the Source Code files of the Original 
Code. You should use the text of this Exhibit A rather than the text found in the Original Code Source Code for Your 
Modifications.

Common Development and Distribution License, Version 1.0 (CDDL-1.0)
1. Definitions.
1.1. "Contributor" means each individual or entity that creates or contributes to the creation of Modifications.
1.2. "Contributor Version" means the combination of the Original Software, prior Modifications used by a Contributor (if 
any), and the Modifications made by that particular Contributor.
1.3. "Covered Software" means (a) the Original Software, or (b) Modifications, or (c) the combination of files containing 
Original Software with files containing Modifications, in each case including portions thereof.
1.4. "Executable" means the Covered Software in any form other than Source Code. 
1.5. "Initial Developer" means the individual or entity that first makes Original Software available under this License.
1.6. "Larger Work" means a work which combines Covered Software or portions thereof with code not governed by the
terms of this License.
1.7. "License" means this document.
1.8. "Licensable" means having the right to grant, to the maximum extent possible, whether at the time of the initial grant or 
subsequently acquired, any and all of the rights conveyed herein.
1.9. "Modifications" means the Source Code and Executable form of any of the following: 

A. Any file that results from an addition to, deletion from or modification of the contents of a file containing Original 
Software or previous Modifications;
B. Any new file that contains any part of the Original Software or previous Modification; or
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C. Any new file that is contributed or otherwise made available under the terms of this License.
1.10. "Original Software" means the Source Code and Executable form of computer software code that is originally 
released under this License.
1.11. "Patent Claims" means any patent claim(s), now owned or hereafter acquired, including without limitation, method, 
process, and apparatus claims, in any patent Licensable by grantor.
1.12. "Source Code" means (a) the common form of computer software code in which modifications are made and (b) 
associated documentation included in or with such code. 
1.13. "You" (or "Your") means an individual or a legal entity exercising rights under, and complying with all of the terms of, 
this License. For legal entities, "You" includes any entity which controls, is controlled by, or is under common control with 
You. For purposes of this definition, "control" means (a) the power, direct or indirect, to cause the direction or management 
of such entity, whether by contract or otherwise, or (b) ownership of more than fifty percent (50%) of the outstanding hares
or beneficial ownership of such entity.

2. License Grants.
2.1. The Initial Developer Grant. 
Conditioned upon Your compliance with Section 3.1 below and subject to third party intellectual property claims, the
Initial Developer hereby grants You a world-wide, royalty-free, non-exclusive license: 
(a) under intellectual property rights (other than patent or trademark) Licensable by Initial Developer, to use, reproduce, 
modify, display, perform, sublicense and distribute the Original Software (or portions thereof), with or without Modifications,
and/or as part of a Larger Work; and 
(b) under Patent Claims infringed by the making, using or selling of Original Software, to make, have made, use, practice, 
sell, and offer for sale, and/or otherwise dispose of the Original Software (or portions thereof).
(c) The licenses granted in Sections 2.1(a) and (b) are effective on the date Initial Developer first distributes or otherwise 
makes the Original Software available to a third party under the terms of this License.
(d) Notwithstanding Section 2.1(b) above, no patent license is granted: (1) for code that You delete from the Original 
Software, or (2) for infringements caused by: (i) the modification of the Original Software, or (ii) the combination of the 
Original Software with other software or devices.
2.2. Contributor Grant.
Conditioned upon Your compliance with Section 3.1 below and subject to third party intellectual property claims, each
Contributor hereby grants You a world-wide, royalty-free, non-exclusive license: 
(a) under intellectual property rights (other than patent or trademark) Licensable by Contributor to use, reproduce, modify, 
display, perform, sublicense and distribute the Modifications created by such Contributor (or portions thereof), either on an
unmodified basis, with other Modifications, as Covered Software and/or as part of a Larger Work; and 
(b) under Patent Claims infringed by the making, using, or selling of Modifications made by that Contributor either alone 
and/or in combination with its Contributor Version (or portions of such combination), to make, use, sell, offer for sale, have 
made, and/or otherwise dispose of: (1) Modifications made by that Contributor (or portions thereof); and (2) the 
combination of Modifications made by that Contributor with its Contributor Version (or portions of such combination).
(c) The licenses granted in Sections 2.2(a) and 2.2(b) are effective on the date Contributor first distributes or otherwise 
makes the Modifications available to a third party. 
(d) Notwithstanding Section 2.2(b) above, no patent license is granted: (1) for any code that Contributor has deleted from 
the Contributor Version; (2) for infringements caused by: (i) third party modifications of Contributor Version, or (ii) the 
combination of Modifications made by that Contributor with other software (except as part of the Contributor Version) or 
other devices; or (3) under Patent Claims infringed by Covered Software in the absence of Modifications made by that 
Contributor. 

3. Distribution Obligations. 
3.1. Availability of Source Code. 
Any Covered Software that You distribute or otherwise make available in Executable form must also be made available in 
Source Code form and that Source Code form must be distributed only under the terms of this License. You must include a 
copy of this License with every copy of the Source Code form of the Covered Software You distribute or otherwise make 
available. You must inform recipients of any such Covered Software in Executable form as to how they can obtain such 
Covered Software in Source Code form in a reasonable manner on or through a medium customarily used for software 
exchange.
3.2. Modifications. 
The Modifications that You create or to which You contribute are governed by the terms of this License. You represent that 
You believe Your Modifications are Your original creation(s) and/or You have sufficient rights to grant the rights conveyed 
by this License.
3.3. Required Notices.
You must include a notice in each of Your Modifications that identifies You as the Contributor of the Modification. You may 
not remove or alter any copyright, patent or trademark notices contained within the Covered Software, or any notices of 
licensing or any descriptive text giving attribution to any Contributor or the Initial Developer. 
3.4. Application of Additional Terms. 
You may not offer or impose any terms on any Covered Software in Source Code form that alters or restricts the applicable 
version of this License or the recipients' rights hereunder. You may choose to offer, and to charge a fee for, warranty, 
support, indemnity or liability obligations to one or more recipients of Covered Software. However, you may do so only on 
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Your own behalf, and not on behalf of the Initial Developer or any Contributor. You must make it absolutely clear that any 
such warranty, support, indemnity or liability obligation is offered by You alone, and You hereby agree to indemnify the 
Initial Developer and every Contributor for any liability incurred by the Initial Developer or such Contributor as a result of 
warranty, support, indemnity or liability terms You offer.
3.5. Distribution of Executable Versions. 
You may distribute the Executable form of the Covered Software under the terms of this License or under the terms of a 
license of Your choice, which may contain terms different from this License, provided that You are in compliance with the 
terms of this License and that the license for the Executable form does not attempt to limit or alter the recipient's rights in 
the Source Code form from the rights set forth in this License. If You distribute the Covered Software in Executable form 
under a different license, You must make it absolutely clear that any terms which differ from this License are offered by You 
alone, not by the Initial Developer or Contributor. You hereby agree to indemnify the Initial Developer and every 
Contributor for any liability incurred by the Initial Developer or such Contributor as a result of any such terms You offer.
3.6. Larger Works.
You may create a Larger Work by combining Covered Software with other code not governed by the terms of this License 
and distribute the Larger Work as a single product. In such a case, You must make sure the requirements of this License 
are fulfilled for the Covered Software.

4. Versions of the License. 
4.1. New Versions. 
Sun Microsystems, Inc. is the initial license steward and may publish revised and/or new versions of this License from time 
to time. Each version will be given a distinguishing version number. Except as provided in Section 4.3, no one other than 
the license steward has the right to modify this License.
4.2. Effect of New Versions. 
You may always continue to use, distribute or otherwise make the Covered Software available under the terms of the 
version of the License under which You originally received the Covered Software. If the Initial Developer includes a notice 
in the Original Software prohibiting it from being distributed or otherwise made available under any subsequent version of 
the License, You must distribute and make the Covered Software available under the terms of the version of the License 
under which You originally received the Covered Software. Otherwise, You may also choose to use, distribute or otherwise 
make the Covered Software available under the terms of any subsequent version of the License published by the license 
steward. 
4.3. Modified Versions. 
When You are an Initial Developer and You want to create a new license for Your Original Software, You may create and 
use a modified version of this License if You: (a) rename the license and remove any references to the name of the license 
steward (except to note that the license differs from this License); and (b) otherwise make it clear that the license contains 
terms which differ from this License.

5. DISCLAIMER OF WARRANTY. 
COVERED SOFTWARE IS PROVIDED UNDER THIS LICENSE ON AN "AS IS" BASIS, WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, WITHOUT LIMITATION, WARRANTIES THAT THE COVERED 
SOFTWARE IS FREE OF DEFECTS, MERCHANTABLE, FIT FOR A PARTICULAR PURPOSE OR NON-INFRINGING. 
THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE COVERED SOFTWARE IS WITH YOU. 
SHOULD ANY COVERED SOFTWARE PROVE DEFECTIVE IN ANY RESPECT, YOU (NOT THE INITIAL DEVELOPER 
OR ANY OTHER CONTRIBUTOR) ASSUME THE COST OF ANY NECESSARY SERVICING, REPAIR OR 
CORRECTION. THIS DISCLAIMER OF WARRANTY CONSTITUTES AN ESSENTIAL PART OF THIS LICENSE. NO 
USE OF ANY COVERED SOFTWARE IS AUTHORIZED HEREUNDER EXCEPT UNDER THIS DISCLAIMER.

6. TERMINATION. 
6.1. This License and the rights granted hereunder will terminate automatically if You fail to comply with terms herein and 
fail to cure such breach within 30 days of becoming aware of the breach. Provisions which, by their nature, must remain in 
effect beyond the termination of this License shall survive.
6.2. If You assert a patent infringement claim (excluding declaratory judgment actions) against Initial Developer or a 
Contributor (the Initial Developer or Contributor against whom You assert such claim is referred to as "Participant") alleging 
that the Participant Software (meaning the Contributor Version where the Participant is a Contributor or the Original 
Software where the Participant is the Initial Developer) directly or indirectly infringes any patent, then any and all rights 
granted directly or indirectly to You by such Participant, the Initial Developer (if the Initial Developer is not the Participant) 
and all Contributors under Sections 2.1 and/or 2.2 of this License shall, upon 60 days notice from Participant terminate 
prospectively and automatically at the expiration of such 60 day notice period, unless if within such 60 day period You 
withdraw Your claim with respect to the Participant Software against such Participant either unilaterally or pursuant to a 
written agreement with Participant.
6.3. In the event of termination under Sections 6.1 or 6.2 above, all end user licenses that have been validly granted by 
You or any distributor hereunder prior to termination (excluding licenses granted to You by any distributor) shall survive 
termination. 

7. LIMITATION OF LIABILITY.
UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, WHETHER TORT (INCLUDING NEGLIGENCE), 
CONTRACT, OR OTHERWISE, SHALL YOU, THE INITIAL DEVELOPER, ANY OTHER CONTRIBUTOR, OR ANY 
DISTRIBUTOR OF COVERED SOFTWARE, OR ANY SUPPLIER OF ANY OF SUCH PARTIES, BE LIABLE TO ANY 
PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER 
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INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOST PROFITS, LOSS OF GOODWILL, WORK STOPPAGE, 
COMPUTER FAILURE OR MALFUNCTION, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, EVEN 
IF SUCH PARTY SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES. THIS LIMITATION OF 
LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY RESULTING FROM SUCH ARTY'S 
NEGLIGENCE TO THE EXTENT APPLICABLE LAW PROHIBITS SUCH LIMITATION. SOME JURISDICTIONS DO NOT 
ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THIS EXCLUSION 
AND LIMITATION MAY NOT APPLY TO YOU.

8. U.S. GOVERNMENT END USERS. 
The Covered Software is a "commercial item," as that term is defined in 48 C.F.R. 2.101 (Oct. 1995), consisting of 
“commercial computer software" (as that term is defined at 48 C.F.R. ¤ 252.227-7014(a)(1)) and "commercial computer 
software documentation" as such terms are used in 48 C.F.R. 12.212 (Sept. 1995). Consistent with 48 C.F.R. 12.212 and 
48 C.F.R. 227.7202-1 through 227.7202-4 (June 1995), all U.S. Government End Users acquire Covered Software with 
only those rights set forth herein. This U.S. Government Rights clause is in lieu of, and supersedes, any other FAR, DFAR, 
or other clause or provision that addresses Government rights in computer software under this License.

9. MISCELLANEOUS. 
This License represents the complete agreement concerning subject matter hereof. If any provision of this License is held 
to be unenforceable, such provision shall be reformed only to the extent necessary to make it enforceable. This License 
shall be governed by the law of the jurisdiction specified in a notice contained within the Original Software (except to the 
extent applicable law, if any, provides otherwise), excluding such jurisdiction's conflict-of-law provisions. Any litigation 
relating to this License shall be subject to the jurisdiction of the courts located in the jurisdiction and venue specified in a 
notice contained within the Original Software, with the losing party responsible for costs, including, without limitation, court 
costs and reasonable attorneys' fees and expenses. The application of the United Nations Convention on Contracts for the 
International Sale of Goods is expressly excluded. Any law or regulation which provides that the language of a contract 
shall be construed against the drafter shall not apply to this License. You agree that You alone are responsible for 
compliance with the United States export administration regulations (and the export control laws and regulation of any 
other countries) when You use, distribute or otherwise make available any Covered Software. 

10. RESPONSIBILITY FOR CLAIMS. 
As between Initial Developer and the Contributors, each party is responsible for claims and damages arising, directly or 
indirectly, out of its utilization of rights under this License and You agree to work with Initial Developer and Contributors to 
distribute such responsibility on an equitable basis. Nothing herein is intended or shall be deemed to constitute any 
admission of liability.
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Glossary

 

• The following glossary will help familiarize you with SyncThru™ 6 by understanding the terminologies commonly 
used in this admin guide.

• The definitions of the below terms are mostly cited from: 
A) http://en.wikipedia.org and B) www.ietf.org/rfc.html.

Account
In SyncThru™ 6, having an account means you have the right to access the device or system. 

Console
Console is the device’s LCD display.

CSV
Comma Separated Values (CSV) is a type of file format. CSV is used to exchange data between disparate 
applications. The file format, as it is used in Microsoft Excel, has become a pseudo standard throughout the
industry, even among non-Microsoft platforms.

DBMS
Database Management System

DNS server
Domain Name Server (DNS) is a system that stores information associated with domain names in a distributed 
database on networks, such as the Internet or an intranet.

SWS
Embedded Web Server is a web server embedded in the device. You can access it by typing in the IP address or the 
Host name on the address bar of a web browser. 

Firewall
Firewall is an integrated collection of security measures designed to prevent unauthorized electronic access to a 
networked computer system. It is also a device or set of devices configured to permit, deny, encrypt, decrypt, or proxy 
all computer traffic between different security domains based upon a set of rules and other criteria.

FTP
File Transfer Protocol (FTP) is a commonly used protocol for exchanging files over any network that supports the TCP/
IP protocol (such as the Internet or an intranet).

HTTP
Hypertext Transfer Protocol (HTTP) is a communications protocol. Its use for retrieving inter-linked text documents 
(hypertext) led to the establishment of the World Wide Web.

HTTPS
Hypertext Transfer Protocol over Secure Socket Layer or https is a URI scheme used to indicate a secure 
communication such as payment transactions and corporate information systems.

IP
Internet Protocol (IP) address is a unique number that devices use in order to identify and communicate with each 
other on a network utilizing the Internet Protocol standard.

IPv6
Internet Protocol version 6 (IPv6) is an Internet Layer protocol for packet-switched internet works. IPv4 is 
currently[update] the dominant Internet Protocol version, and was the first to receive widespread use. The Internet 
Engineering Task Force (IETF) has designated IPv6 as the successor to version 4 for general use on the Internet.
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IPP
Internet Printing Protocol (IPP) defines a standard protocol for printing as well as managing print jobs, media size, 
resolution, and so forth. IPP can be used locally or over the Internet to hundreds of printers, and also supports access 
control, authentication, and encryption, making it a much more capable and secure printing solution
than older ones.

LDAP
The Lightweight Directory Access Protocol (LDAP) is a networking protocol for querying and modifying directory 
services running over TCP/IP.

LPD
Line Printer Daemon protocol/Line Printer Remote protocol (or LPD, LPR) also known as the Berkeley printing system, 
is a set of programs that provide printer spooling and network print server functionality for Unix-like systems.

MAC
Media Access Control (MAC) data communication protocol sub-layer, also known as the Medium Access Control, is a 
sublayer of the Data Link Layer specified in the seven-layer OSI model (layer 2).

mDNS
Multicast DNS (mDNS) is a protocol that is used by Apple Inc. It uses similar APIs to the unicast DNS system but 
implemented differently.

MFP
Multi Function Printer/Peripheral (MFP) is an office machine that includes the following functionality in one physical 
body, so as to have a printer, a copier, a fax, a scanner and etc.

MIB
A management information base (MIB) stems from the OSI/ISO Network management model and is a type of database 
used to manage the devices in a communications network. It comprises a collection of objects in a (virtual) database 
used to manage entities (such as routers and switches) in a network.

OPC drum
Organic Photo Conductor (OPC) is a mechanism that makes a virtual image for print using a laser beam emitted from 
a laser printer, and it is usually green or gray colored and a cylinder shaped. An exposing unit of a drum is slowly worn 
away by its usage of the printer, and it should be replaced appropriately since it gets scratches from grits of a paper."

Primary Domain Controller (PDC)
The PDC is a server located on a Windows domain. The PDC controls access to the domain.

Plug-in
In SyncThru™ 6, plug-in is an additional feature that you can add to SyncThru™ 6.

POP3
Post Office Protocol version 3 (POP3) is an application-layer Internet standard protocol used by local email clients to 
retrieve email from a remote server over a TCP/IP connection.

PostgreSQL
PostgreSQL is an object-relational database management system (ORDBMS). It is released under a BSD-style license 
and is thus free software. 

RFC
In computer network engineering, a Request for Comments (RFC) is a memorandum published by the Internet 
Engineering Task Force (IETF) describing methods, behaviors, research, or innovations applicable to the working of 
the Internet and Internet-connected systems.

RFC 3805
Printer MIB version 2. This document provides definitions of models and manageable objects for printing 
environments. The objects included in this MIB apply to physical, as well as logical entities within a printing device.
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RSS
Really Simple Syndication (RSS 2.0) is a family of Web feed formats used to publish frequently updated works—such 
as blog entries, news headlines, audio, and video—in a standardized format. RSS feeds can be read using software 
called an "RSS reader", "feed reader", or "aggregator", which can be web-based or desktop-based. A standardized 
XML file format allows the information to be published once and viewed by many different programs. The user 
subscribes to a feed by entering the feed's URI (often referred to informally as a "URL", although technically, those two 
terms are not exactly synonymous) into the reader or by clicking an RSS icon in a browser that initiates the 
subscription process.

Site Manager
A site manager is a program running on a remote site that performs the operations related to that particular site, 
including device discovery and data collection.

SLP
Service Location Protocol (SLP, srvloc) is a service discovery protocol that allows computers and other devices to find 
services in a local area network without prior configuration. (RFC 2608)

SMB
Server Message Block (SMB) is a network protocol mainly applied to share files, printers, serial ports, and 
miscellaneous communications between nodes on a network. It also provides an authenticated Inter-process 
communication mechanism.

SMTP
Simple Mail Transfer Protocol (SMTP) is the standard for e-mail transmissions across the Internet. SMTP is a relatively 
simple, text-based protocol, where one or more recipients of a message are specified, and then the message text is 
transferred. It is a client-server protocol, where the client transmits an email message to the server.

SNMP
Simple Network Management Protocol (SNMP) is a component of the Internet Protocol Suite as defined by the Internet 
Engineering Task Force (IETF). SNMP is used in network management systems to monitor network-attached devices 
for conditions that warrant administrative attention. It consists of a set of standards for network management, including 
an Application Layer protocol, a database schema, and a set of data objects.

SSDP
SSDP is the basis of the discovery protocol of universal plug-and-play.

SSL 
Transport Layer Security (TLS) Protocol and its predecessor, Secure Sockets Layer (SSL), are cryptographic protocols 
that provide security and data integrity for communications over TCP/IP networks such as the Internet.

SSO
Single sign-on (SSO) is a method of access control that enables a user to log in once and gain access to the resources 
of multiple software systems without being prompted to log in again.

SWS
SyncThru Web Service(SWS) is a embedded web server for Samsung devices. 

TCP
Transmission Control Protocol (TCP) is one of the core protocols of the Internet Protocol Suite. TCP is so central that 
the entire suite is often referred to as "TCP/IP."

TCP/IP
The Transmission Control Protocol (TCP) and the Internet Protocol (IP); the set of communications protocols that 
implement the protocol stack on which the Internet and most commercial networks run.

Trap
Trap is used to report an alert or other asynchronous event about a managed subsystem. In SNMPv1, asynchronous 
event reports are called traps while they are called notifications in later versions of SNMP.
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UDP
User Datagram Protocol (UDP) is one of the core members of the Internet Protocol Suite, the set of network protocols 
used for the Internet. With UDP, computer applications can send messages, sometimes known as datagrams, to other 
hosts on an Internet Protocol (IP) network without requiring prior communications to set up special transmission 
channels or data paths. UDP is sometimes called the Universal Datagram Protocol. UDP uses a simple transmission 
model without implicit hand-shaking dialogues for guaranteeing reliability, ordering, or data integrity. Thus, UDP 
provides an unreliable service and datagrams may arrive out of order, appear duplicated, or go missing without notice.

UPnP
Universal Plug and Play (UPnP) is a set of computer protocols promulgated by the UPnP Forum. The goals of UPnP 
are to allow devices to connect seamlessly and to simplify the implementation of networks in the home (data sharing, 
communications, and entertainment) and in corporate environments for simplified installation of computer components. 
UPnP achieves this by defining and publishing UPnP device control protocols built upon open, Internet-based 
communication standards.

WINS server
Windows Internet Name Service (WINS) is Microsoft's implementation of NetBIOS Name Service (NBNS), a name 
server and service for NetBIOS computer names. Effectively WINS is to NetBIOS names, what DNS is to domain 
names — a central mapping of host names to network addresses. Like DNS it is broken into two parts, a Server 
Service (that manages the encoded Jet Database, server to server replication, service requests, and conflicts) and a 
TCP/IP Client component which manages the client's registration, renewal of names and takes care of queries.
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